PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:vlan-trunk-port-configuration:vlan-trunk-port-configuration

This is an old revision of the document!


VLAN Trunk Port Configuration

Home Physical Lab Topologies

ASW2

f0/1
Pi2

f0/3
Pi3

DSW2
f1/0/24
SAK
DSW2#sh vlan bri

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/8, Fa1/0/9
                                                Fa1/0/10, Fa1/0/11, Fa1/0/12
                                                Fa1/0/13, Fa1/0/14, Fa1/0/15
                                                Fa1/0/16, Fa1/0/17, Fa1/0/18
                                                Fa1/0/19, Fa1/0/20, Fa1/0/21
                                                Fa1/0/22, Fa1/0/23, Fa1/0/24
                                                Gi1/0/1, Gi1/0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ASW2#sh vlan bri

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Gi0/1
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
✘╹◡╹✘  18-03-10 13:47:59 /home/wnoguchi
% fping -f lab-net-iplist.txt
172.16.2.12 is alive
172.16.2.13 is alive
172.16.2.240 is alive
172.16.2.250 is alive
en
conf t
vlan 10
name Engineer
vlan 20
name Network
end
en
conf t
vlan 10
name Engineer
vlan 20
name Network
vlan 30
name Lab
end
DSW2#sh vlan bri

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/8, Fa1/0/9
                                                Fa1/0/10, Fa1/0/11, Fa1/0/12
                                                Fa1/0/13, Fa1/0/14, Fa1/0/15
                                                Fa1/0/16, Fa1/0/17, Fa1/0/18
                                                Fa1/0/19, Fa1/0/20, Fa1/0/21
                                                Fa1/0/22, Fa1/0/23, Fa1/0/24
                                                Gi1/0/1, Gi1/0/2
10   Engineer                         active
20   Network                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ASW2#sh vlan bri

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Gi0/1
10   Engineer                         active
20   Network                          active
30   Lab                              active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
conf t
int f1/0/24
switchport mode access
switchport access vlan 10
int f1/0/23
switchport mode access
switchport access vlan 20
int f1/0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
end
conf t
int f0/1
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20
int f0/3
switchport mode access
switchport access vlan 30
int f0/5
switchport mode access
switchport access vlan 30
int f0/8
switchport mode trunk
switchport nonegotiate
end

VLAN 10@SAK

✘╹◡╹✘  18-03-11 13:55:57 /home/wnoguchi
% ping -c1 172.16.2.240
PING 172.16.2.240 (172.16.2.240) 56(84) bytes of data.
From 172.16.2.245 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.240 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

✘╹◡╹✘  18-03-11 13:56:12 /home/wnoguchi
% ping -c1 172.16.2.11
PING 172.16.2.11 (172.16.2.11) 56(84) bytes of data.
64 bytes from 172.16.2.11: icmp_seq=1 ttl=64 time=1.44 ms

--- 172.16.2.11 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 1.449/1.449/1.449/0.000 ms
✘╹◡╹✘  18-03-11 13:56:15 /home/wnoguchi
% ping -c1 172.16.2.12
PING 172.16.2.12 (172.16.2.12) 56(84) bytes of data.
From 172.16.2.245 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.12 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

✘╹◡╹✘  18-03-11 13:56:24 /home/wnoguchi
% ping -c1 172.16.2.13
PING 172.16.2.13 (172.16.2.13) 56(84) bytes of data.
From 172.16.2.245 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.13 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

✘╹◡╹✘  18-03-11 13:56:29 /home/wnoguchi
% ping -c1 172.16.2.250
PING 172.16.2.250 (172.16.2.250) 56(84) bytes of data.
From 172.16.2.245 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.250 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

VLAN 20@Desktop

C:\Users\wnogu>ping -n 1 172.16.2.245

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.240: Destination host unreachable.

Ping statistics for 172.16.2.245:
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),

C:\Users\wnogu>ping -n 1 172.16.2.11

Pinging 172.16.2.11 with 32 bytes of data:
Reply from 172.16.2.240: Destination host unreachable.

Ping statistics for 172.16.2.11:
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),

C:\Users\wnogu>ping -n 1 172.16.2.12

Pinging 172.16.2.12 with 32 bytes of data:
Reply from 172.16.2.12: bytes=32 time<1ms TTL=64

Ping statistics for 172.16.2.12:
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\wnogu>ping -n 1 172.16.2.13

Pinging 172.16.2.13 with 32 bytes of data:
Reply from 172.16.2.1: Destination host unreachable.

Ping statistics for 172.16.2.13:
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),

C:\Users\wnogu>ping -n 1 172.16.2.250

Pinging 172.16.2.250 with 32 bytes of data:
Reply from 172.16.2.1: Destination host unreachable.

Ping statistics for 172.16.2.250:
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),

VLAN 30@Pi0

pi@raspberrypi:~ $ ping -c1 172.16.2.245
PING 172.16.2.245 (172.16.2.245) 56(84) bytes of data.
From 172.16.2.250 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.245 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

pi@raspberrypi:~ $ ping -c1 172.16.2.240
PING 172.16.2.240 (172.16.2.240) 56(84) bytes of data.
From 172.16.2.250 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.240 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

pi@raspberrypi:~ $ ping -c1 172.16.2.11
PING 172.16.2.11 (172.16.2.11) 56(84) bytes of data.
From 172.16.2.250 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.11 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

pi@raspberrypi:~ $ ping -c1 172.16.2.12
PING 172.16.2.12 (172.16.2.12) 56(84) bytes of data.
From 172.16.2.250 icmp_seq=1 Destination Host Unreachable

--- 172.16.2.12 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

pi@raspberrypi:~ $ ping -c1 172.16.2.13
PING 172.16.2.13 (172.16.2.13) 56(84) bytes of data.
64 bytes from 172.16.2.13: icmp_seq=1 ttl=64 time=1.18 ms

--- 172.16.2.13 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 1.185/1.185/1.185/0.000 ms

let's start wireshark session.

パケットキャプチャ - Catalystスイッチの設定 2(SPAN / RSPAN)

monitor session 1 source interface FastEthernet 1/0/8
monitor session 1 destination interface FastEthernet 1/0/13 encapsulation replicate
DSW2(config)#int f1/0/4
DSW2(config-if)#shut
DSW2(config-if)#shut
*Mar  1 07:29:57.433: %LINK-5-CHANGED: Interface FastEthernet1/0/4, changed state to administratively down
*Mar  1 07:29:58.440: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/4, changed state to down
DSW2(config-if)#int f1/0/6
DSW2(config-if)#shut
DSW2(config-if)#
*Mar  1 07:30:04.899: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
DSW2(config-if)#
*Mar  1 07:30:06.887: %LINK-5-CHANGED: Interface FastEthernet1/0/6, changed state to administratively down
*Mar  1 07:30:07.894: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/6, changed state to down
DSW2(config-if)#exit
ASW2(config-if)#int f0/6
ASW2(config-if)#shut
ASW2(config-if)#int
*Mar  2 15:32:53.774: %LINK-5-CHANGED: Interface FastEthernet0/6, changed state to administratively down
*Mar  2 15:32:54.781: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed state to down
ASW2(config-if)#int f0/4
ASW2(config-if)#shut
ASW2(config-if)#
*Mar  2 15:33:01.919: %LINK-5-CHANGED: Interface FastEthernet0/4, changed state to administratively down
*Mar  2 15:33:02.926: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
ASW2(config-if)#do sh int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    10         a-full  a-100 10/100BaseTX
Fa0/2                        connected    20         a-full  a-100 10/100BaseTX
Fa0/3                        connected    30         a-full  a-100 10/100BaseTX
Fa0/4                        disabled     1            auto   auto 10/100BaseTX
Fa0/5                        connected    30         a-full  a-100 10/100BaseTX
Fa0/6                        disabled     1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        connected    trunk      a-full  a-100 10/100BaseTX
Gi0/1                        notconnect   1            auto   auto Not Present

set the port native vlan id.

int f1/0/8
switchport trunk native vlan 999
end
int f0/8
switchport trunk native vlan 999
end

ping not exist host eternally from pi0 in VLAN30.

ping 172.16.2.123

or

pi@raspberrypi:~ $ ping 172.16.2.255 -b
WARNING: pinging broadcast address
PING 172.16.2.255 (172.16.2.255) 56(84) bytes of data.

VLAN 30 traffic not appeared…

int f1/0/8
switchport trunk allowed vlan 10,20
end
int f0/8
switchport trunk allowed vlan 10,20
end
DSW2#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/9, Fa1/0/10
                                                Fa1/0/11, Fa1/0/12, Fa1/0/14
                                                Fa1/0/15, Fa1/0/16, Fa1/0/17
                                                Fa1/0/18, Fa1/0/19, Fa1/0/20
                                                Fa1/0/21, Fa1/0/22, Gi1/0/1
                                                Gi1/0/2
10   Engineer                         active    Fa1/0/24
20   Network                          active    Fa1/0/23
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
DSW2#sh int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa1/0/1                      notconnect   1            auto   auto 10/100BaseTX
Fa1/0/2                      notconnect   1            auto   auto 10/100BaseTX
Fa1/0/3                      notconnect   1            auto   auto 10/100BaseTX
Fa1/0/4                      disabled     1            auto   auto 10/100BaseTX
Fa1/0/5                      notconnect   1            auto   auto 10/100BaseTX
Fa1/0/6                      disabled     1            auto   auto 10/100BaseTX
Fa1/0/7                      notconnect   1            auto   auto 10/100BaseTX
Fa1/0/8                      connected    trunk      a-full  a-100 10/100BaseTX
Fa1/0/9                      notconnect   1            auto   auto 10/100BaseTX
Fa1/0/10                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/11                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/12                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/13                     monitoring   1          a-full  a-100 10/100BaseTX
Fa1/0/14                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/15                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/16                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/17                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/18                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/19                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/20                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/21                     notconnect   1            auto   auto 10/100BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type
Fa1/0/22                     notconnect   1            auto   auto 10/100BaseTX
Fa1/0/23                     connected    20         a-full  a-100 10/100BaseTX
Fa1/0/24                     connected    10         a-full  a-100 10/100BaseTX
Gi1/0/1                      notconnect   1            auto   auto Not Present
Gi1/0/2                      notconnect   1            auto   auto Not Present
DSW2#sh int f1/0/8 trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa1/0/8     on               802.1q         trunking      999

Port        Vlans allowed on trunk
Fa1/0/8     10,20

Port        Vlans allowed and active in management domain
Fa1/0/8     10,20

Port        Vlans in spanning tree forwarding state and not pruned
Fa1/0/8     10,20
DSW2#sh int f1/0/8 switchport
Name: Fa1/0/8
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (Inactive)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 10,20
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
ASW2#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/4, Fa0/6, Fa0/7, Gi0/1
10   Engineer                         active    Fa0/1
20   Network                          active    Fa0/2
30   Lab                              active    Fa0/3, Fa0/5
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ASW2#sh int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    10         a-full  a-100 10/100BaseTX
Fa0/2                        connected    20         a-full  a-100 10/100BaseTX
Fa0/3                        connected    30         a-full  a-100 10/100BaseTX
Fa0/4                        disabled     1            auto   auto 10/100BaseTX
Fa0/5                        connected    30         a-full  a-100 10/100BaseTX
Fa0/6                        disabled     1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        connected    trunk      a-full  a-100 10/100BaseTX
Gi0/1                        notconnect   1            auto   auto Not Present
ASW2#sh int f0/8 trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/8       on               802.1q         trunking      999

Port        Vlans allowed on trunk
Fa0/8       10,20

Port        Vlans allowed and active in management domain
Fa0/8       10,20

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/8       10,20
ASW2#sh int f0/8 switchport
Name: Fa0/8
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (Inactive)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 10,20
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

configure alternatively ASW2 f0/8 to monitor.

ASW2(config)#monitor session 1 source int f0/8
*Mar  2 15:51:43.963: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
ASW2(config)#monitor session 1 source int f0/8 bo
ASW2(config)#monitor session 1 source int f0/8
ASW2(config)#monit
ASW2(config)#monitor sess
ASW2(config)#monitor session 1 des
ASW2(config)#monitor session 1 destination in
ASW2(config)#monitor session 1 destination interface f0/7 enc
ASW2(config)#monitor session 1 destination interface f0/7 encapsulation repli
ASW2(config)#$sion 1 destination interface f0/7 encapsulation replicate
ASW2(config)#
*Mar  2 15:52:20.218: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
ASW2(config)#int f0/8
ASW2(config-if)#swi
ASW2(config-if)#switchport tru
ASW2(config-if)#switchport trunk all
ASW2(config-if)#switchport trunk allowed vl
ASW2(config-if)#switchport trunk allowed vlan all
ASW2(config-if)#
*Mar  2 15:53:28.426: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

now

pi@raspberrypi:~ $ ip a s eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:1f:45:00 brd ff:ff:ff:ff:ff:ff
    inet 172.16.2.250/24 brd 172.16.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a0b2:82c4:44bb:bfd6/64 scope link
       valid_lft forever preferred_lft forever
ASW2(config-if)#switchport trunk allowed vlan 10
ASW2(config-if)#switchport trunk allowed vlan 10
*Mar  2 15:59:03.450: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
ASW2(config-if)#switchport trunk allowed vlan ad
ASW2(config-if)#switchport trunk allowed vlan add 20

stop VLAN 30 traffic.

DSW2#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/9, Fa1/0/10
                                                Fa1/0/11, Fa1/0/12, Fa1/0/14
                                                Fa1/0/15, Fa1/0/16, Fa1/0/17
                                                Fa1/0/18, Fa1/0/19, Fa1/0/20
                                                Fa1/0/21, Fa1/0/22, Gi1/0/1
                                                Gi1/0/2
10   Engineer                         active    Fa1/0/24
20   Network                          active    Fa1/0/23
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

DSW2#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/9, Fa1/0/10
                                                Fa1/0/11, Fa1/0/12, Fa1/0/14
                                                Fa1/0/15, Fa1/0/16, Fa1/0/17
                                                Fa1/0/18, Fa1/0/19, Fa1/0/20
                                                Fa1/0/21, Fa1/0/22, Gi1/0/1
                                                Gi1/0/2
10   Engineer                         active    Fa1/0/24
20   Network                          active    Fa1/0/23
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ASW2#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/4, Fa0/6, Gi0/1
10   Engineer                         active    Fa0/1
20   Network                          active    Fa0/2
30   Lab                              active    Fa0/3, Fa0/5
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

ASW2#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/4, Fa0/6, Gi0/1
10   Engineer                         active    Fa0/1
20   Network                          active    Fa0/2
30   Lab                              active    Fa0/3, Fa0/5
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ASW2#sh monitor session 1
Session 1
---------
Type                   : Local Session
Source Ports           :
    Both               : Fa0/8
Destination Ports      : Fa0/7
    Encapsulation      : Replicate
          Ingress      : Disabled

access port

DSW2#sh run int f1/0/24
Building configuration...

Current configuration : 87 bytes
!
interface FastEthernet1/0/24
 switchport access vlan 10
 switchport mode access
end

DSW2#sh int f1/0/24 switchport
Name: Fa1/0/24
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (Engineer)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

trunk port

DSW2#sh run int f1/0/8
Building configuration...

Current configuration : 191 bytes
!
interface FastEthernet1/0/8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 999
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 switchport nonegotiate
end

DSW2#sh int f1/0/8 switchport
Name: Fa1/0/8
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (Inactive)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 10,20
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

DSW2#sh int f1/0/8 trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa1/0/8     on               802.1q         trunking      999

Port        Vlans allowed on trunk
Fa1/0/8     10,20

Port        Vlans allowed and active in management domain
Fa1/0/8     10,20

Port        Vlans in spanning tree forwarding state and not pruned
Fa1/0/8     10,20

References

tech/network/vlan-trunk-port-configuration/vlan-trunk-port-configuration.1520755919.txt.gz · Last modified: 2018/03/11 17:11 by wnoguchi