PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:configure-dynamic-routing-protocol-ripv2:configure-dynamic-routing-protocol-ripv2

Configuring Dynamic Routing Protocol: RIPv2

R1#sh run int f0/0
Building configuration...

Current configuration : 95 bytes
!
interface FastEthernet0/0
 ip address 172.16.2.1 255.255.255.0
 duplex auto
 speed auto
end

R1#sh run int f0/1
Building configuration...

Current configuration : 95 bytes
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
end
R2#sh run int f0/0
Building configuration...

Current configuration : 95 bytes
!
interface FastEthernet0/0
 ip address 172.16.2.2 255.255.255.0
 duplex auto
 speed auto
end

R2#sh run int f0/1
Building configuration...

Current configuration : 95 bytes
!
interface FastEthernet0/1
 ip address 172.16.3.2 255.255.255.0
 duplex auto
 speed auto
end

Now, we check routing table.

R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.1/32 is directly connected, FastEthernet0/1
C        172.16.2.0/24 is directly connected, FastEthernet0/0
L        172.16.2.1/32 is directly connected, FastEthernet0/0
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C        172.16.2.0/24 is directly connected, FastEthernet0/0
L        172.16.2.2/32 is directly connected, FastEthernet0/0
C        172.16.3.0/24 is directly connected, FastEthernet0/1
L        172.16.3.2/32 is directly connected, FastEthernet0/1
R1(config)#router rip
R1(config-router)#netw
R1(config-router)#network 172.16.1.0 ?
  <cr>

R1(config-router)#ver
R1(config-router)#version 2
R1(config-router)#neto
R1(config-router)#netwo
R1(config-router)#network ?
  A.B.C.D  Network number

R1(config-router)#network 172.16.0.0
R1(config-router)#^Z
R1#sh ip ro
*Feb 25 10:45:12.583: %SYS-5-CONFIG_I: Configured from console by console
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.1/32 is directly connected, FastEthernet0/1
C        172.16.2.0/24 is directly connected, FastEthernet0/0
L        172.16.2.1/32 is directly connected, FastEthernet0/0
R        172.16.3.0/24 [120/1] via 172.16.2.2, 00:00:03, FastEthernet0/0
R1#ping 172.16.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R2(config)#router rip
R2(config-router)#netw
R2(config-router)#network 172.16.1.0 ?
  <cr>

R2(config-router)#ver
R2(config-router)#version 2
R2(config-router)#neto
R2(config-router)#netwo
R2(config-router)#network ?
  A.B.C.D  Network number

R2(config-router)#network 172.16.0.0
R2(config-router)#^Z
R2#sh ip r
*Feb 25 11:55:14.627: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
R        172.16.1.0/24 [120/1] via 172.16.2.1, 00:00:02, FastEthernet0/0
C        172.16.2.0/24 is directly connected, FastEthernet0/0
L        172.16.2.2/32 is directly connected, FastEthernet0/0
C        172.16.3.0/24 is directly connected, FastEthernet0/1
L        172.16.3.2/32 is directly connected, FastEthernet0/1
R2#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 172.16.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 172.16.2.1
*Feb 25 12:20:18.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

References

tech/network/configure-dynamic-routing-protocol-ripv2/configure-dynamic-routing-protocol-ripv2.txt · Last modified: 2018/02/25 21:19 by wnoguchi