User Tools

Site Tools


tech:network:cisco:wan-serial:wan-serial

Table of Contents

WAN basics

V.35 back to back connection.

R1#sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DCE V.35, clock rate 2000000
idb at 0x66C0F420, driver data structure at 0x66C16C3C
wic_info 0x66C17268
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x00030400, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00002003
SDMA Registers:
SDC=0x00002201, SDCM=0x00000000, SGC=0x0000C000
CRDP=0x161D1720, CTDP=0x161D1960, FTDB=0x161D1960
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00490013
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543210
GPP Registers:
Conf=0x430002  , Io=0x464050  , Data=0x7F57FFAB, Level=0x80004
Conf0=0x430002  , Io0=0x464050  , Data0=0x7F57FFAB, Level0=0x80004
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s0/0/0
R1(config-if)#clo
R1(config-if)#clock ra
R1(config-if)#clock rate ?
        Speed (bits per second)
  1200
  2400
  4800
  9600
  14400
  19200
  28800
  32000
  38400
  48000
  56000
  57600
  64000
  72000
  115200
  125000
  128000
  148000
  192000
  250000
  256000
  320000
  384000
  500000
  512000
  640000
  704000
  768000
  800000
  1000000
  1024000
  1200000
  1536000
  2000000
  4000000
  8000000

  <300-8000000>    Choose clockrate from list above

R1(config-if)#clock rate 64000
R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 87 bytes
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 64000
end

R1(config-if)#do sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DCE V.35, clock rate 64000
idb at 0x66C0F420, driver data structure at 0x66C16C3C
wic_info 0x66C17268
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x00030400, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00002003
SDMA Registers:
SDC=0x00002201, SDCM=0x00000000, SGC=0x0000C000
CRDP=0x161D1720, CTDP=0x161D1960, FTDB=0x161D1960
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00490013
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543210
GPP Registers:
Conf=0x430002  , Io=0x464050  , Data=0x7F57FFAB, Level=0x80004
Conf0=0x430002  , Io0=0x464050  , Data0=0x7F57FFAB, Level0=0x80004
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R1(config-if)#do sh int s0/0/0
Serial0/0/0 is administratively down, line protocol is down
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input never, output 00:21:39, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1 packets output, 24 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=down  DSR=down  DTR=down  RTS=down  CTS=down

R1(config-if)#no shut
R1(config-if)#do sh int s0/0/0
Serial0/0/0 is down, line protocol is down
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input never, output 00:22:36, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1 packets output, 24 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
 --More--
*Oct  8 01:26:04.455: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down

R1(config-if)#do sh int s0/0/0
Serial0/0/0 is down, line protocol is down
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input never, output 00:22:44, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1 packets output, 24 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions

R1(config-if)#
*Oct  8 01:28:24.755: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Oct  8 01:28:25.755: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config-if)#^Z
R1#
*Oct  8 01:29:23.783: %SYS-5-CONFIG_I: Configured from console by console
R1#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:01, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     12 packets input, 1452 bytes, 0 no buffer
     Received 12 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     11 packets output, 846 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1#sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DCE V.35, clock rate 64000
idb at 0x66C0F420, driver data structure at 0x66C16C3C
wic_info 0x66C17268
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080, SGC=0x0000C000
CRDP=0x161D17F0, CTDP=0x161D1A10, FTDB=0x161D1A10
Main Routing Register=0x0003FFF8 BRG Conf Register=0x0005023F
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543210
GPP Registers:
Conf=0x430002  , Io=0x464050  , Data=0x7F4BBFAF, Level=0x80004
Conf0=0x430002  , Io0=0x464050  , Data0=0x7F6BBFAF, Level0=0x80004
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s0/0/0
R1(config-if)#bandwi
R1(config-if)#bandwidth ?
  <1-10000000>   Bandwidth in kilobits
  inherit        Specify how bandwidth is inherited
  qos-reference  Reference bandwidth for QOS test
  receive        Specify receive-side bandwidth

R1(config-if)#bandwidth 64
R1(config-if)#^Z
R1#
*Oct  8 03:02:29.035: %SYS-5-CONFIG_I: Configured from console by console
R1#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     676 packets input, 47652 bytes, 0 no buffer
     Received 676 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     675 packets output, 47046 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
R2#sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DTE V.35 clocks stopped.
idb at 0x66C23FA0, driver data structure at 0x66C2B7BC
wic_info 0x66C2BDE8
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x00030400, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x80000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00002003
SDMA Registers:
SDC=0x00002201, SDCM=0x00000000, SGC=0x0000C000
CRDP=0x15BD2C20, CTDP=0x15BD2E60, FTDB=0x15BD2E60
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543219
GPP Registers:
Conf=0x30002   , Io=0x64050   , Data=0x7F1FFFAF, Level=0x0
Conf0=0x30002   , Io0=0x64050   , Data0=0x7F1FFFAF, Level0=0x0
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int s0/0/0
R2(config-if)#do sh int s0/0/0
Serial0/0/0 is administratively down, line protocol is down
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:23:53, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1 packets input, 24 bytes, 0 no buffer
     Received 1 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=down  RTS=down  CTS=up

R2(config-if)#do sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DTE V.35 TX and RX clocks detected.
idb at 0x66C23FA0, driver data structure at 0x66C2B7BC
wic_info 0x66C2BDE8
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x00030400, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x80000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00002000
SDMA Registers:
SDC=0x00002201, SDCM=0x00000000, SGC=0x0000C000
CRDP=0x15BD2C20, CTDP=0x15BD2E60, FTDB=0x15BD2E60
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543219
GPP Registers:
Conf=0x30002   , Io=0x64050   , Data=0x7F07FFAB, Level=0x0
Conf0=0x30002   , Io0=0x64050   , Data0=0x7F67FFAB, Level0=0x0
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R2(config-if)#no shut
R2(config-if)#
*Oct  8 01:31:34.947: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Oct  8 01:31:35.947: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#^Z
R2#
*Oct  8 01:32:37.283: %SYS-5-CONFIG_I: Configured from console by console
R2#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:02, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     11 packets input, 846 bytes, 0 no buffer
     Received 11 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     12 packets output, 1452 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2#sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DTE V.35 TX and RX clocks detected.
idb at 0x66C23FA0, driver data structure at 0x66C2B7BC
wic_info 0x66C2BDE8
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080, SGC=0x0000C000
CRDP=0x15BD2CD0, CTDP=0x15BD2F30, FTDB=0x15BD2F30
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543219
GPP Registers:
Conf=0x30002   , Io=0x64050   , Data=0x7F1BBFAB, Level=0x180000
Conf0=0x30002   , Io0=0x64050   , Data0=0x7F7BBFAB, Level0=0x180000
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int s0/0/0
R2(config-if)#bandwi
R2(config-if)#bandwidth ?
  <1-10000000>   Bandwidth in kilobits
  inherit        Specify how bandwidth is inherited
  qos-reference  Reference bandwidth for QOS test
  receive        Specify receive-side bandwidth

R2(config-if)#bandwidth 64
R2(config-if)#^Z
R2#
*Oct  8 03:05:39.263: %SYS-5-CONFIG_I: Configured from console by console
R2#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     675 packets input, 47046 bytes, 0 no buffer
     Received 675 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     676 packets output, 47652 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s0/0/0
R1(config-if)#enca
R1(config-if)#encapsulation ?
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 89 bytes
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 2000000
end

R1(config-if)#enca
R1(config-if)#encapsulation hdlc
R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 89 bytes
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 2000000
end

R1(config-if)#no encapsulation hdlc
R1(config-if)#do sh run all | i hdlc
R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 89 bytes
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 2000000
end

R1(config-if)#enca
R1(config-if)#encapsulation ppp
R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 108 bytes
!
interface Serial0/0/0
 no ip address
 encapsulation ppp
 shutdown
 no fair-queue
 clock rate 2000000
end

R1(config-if)#ppp authentication ?
  chap        Challenge Handshake Authentication Protocol (CHAP)
  eap         Extensible Authentication Protocol (EAP)
  ms-chap     Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)
  ms-chap-v2  Microsoft CHAP Version 2 (MS-CHAP-V2)
  pap         Password Authentication Protocol (PAP)

R1(config-if)#ppp authentication chap
R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 133 bytes
!
interface Serial0/0/0
 no ip address
 encapsulation ppp
 shutdown
 no fair-queue
 ppp authentication chap
 clock rate 2000000
end

R1(config-if)#ppp multilink ?
  endpoint    Configure the local Endpoint Discriminator
  fragment    Specify fragmentation parameters
  group       Put interface in a multilink bundle
  mrru        Configure multilink MRRU values
  multiclass  Configure support for Multiclass Multilink
  queue       Specify link queuing parameters
  <cr>

PPP

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#username R2 password CISCO
R1(config)#int s0/0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.252
R1(config-if)#encapsulation pp
R1(config-if)#ppp authentication cha
R1(config-if)#ppp authentication chap
R1(config-if)#no shut
R1(config-if)#
*Oct 11 22:07:14.795: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
R1(config-if)#
*Oct 11 22:07:14.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config-if)#
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#username R1 password CISCO
R2(config)#interface Serial 0/0/0
R2(config-if)#ip addr 172.16.1.2 255.255.255.252
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication chap
R2(config-if)#no shut
R2(config-if)#
*Oct 11 22:10:29.835: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
R2(config-if)#
*Oct 11 22:10:29.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config-if)#do sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.1.1/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Closed
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 00:05:37
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     58 packets input, 2161 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     60 packets output, 2825 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 162 bytes
!
interface Serial0/0/0
 ip address 172.16.1.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
 ppp multilink
 clock rate 2000000
end

R1(config-if)#do sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DCE V.35, clock rate 2000000
idb at 0x66C1E3E0, driver data structure at 0x66C25BFC
wic_info 0x66C26228
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080, SGC=0x0000C000
CRDP=0x161D7A40, CTDP=0x161D82A0, FTDB=0x161D82A0
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00490013
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543210
GPP Registers:
Conf=0x430002  , Io=0x464050  , Data=0x7F4BBFAF, Level=0x80004
Conf0=0x430002  , Io0=0x464050  , Data0=0x7F4BBFAF, Level0=0x80004
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns

R1(config-if)#do sh run | i username
username R2 password 0 CISCO
R2(config-if)#do sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.1.2/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 00:04:06
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     60 packets input, 2825 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     58 packets output, 2161 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2(config-if)#do sh run int s0/0/0
Building configuration...

Current configuration : 127 bytes
!
interface Serial0/0/0
 ip address 172.16.1.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
end

R2(config-if)#do sh controllers s0/0/0
Interface Serial0/0/0
Hardware is GT96K
DTE V.35 TX and RX clocks detected.
idb at 0x66C345A0, driver data structure at 0x66C3BDBC
wic_info 0x66C3C3E8
Physical Port 0, SCC Num 0
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000000
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080, SGC=0x0000C000
CRDP=0x15BD2CE0, CTDP=0x15BD3500, FTDB=0x15BD3500
Main Routing Register=0x0003FFF8 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543219
GPP Registers:
Conf=0x30002   , Io=0x64050   , Data=0x7F7BBFAB, Level=0x180000
Conf0=0x30002   , Io0=0x64050   , Data0=0x7F1BBFAB, Level0=0x180000
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns

R2(config-if)#do sh run | i username
username R1 password 0 CISCO
R1(config-if)#do ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Let's say wrong password.

R1(config)#username R2 password CCIE
R1(config)#do sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.1.1/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Closed
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:12:22
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     152 packets input, 6261 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     154 packets output, 6925 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops

R1(config)#ping 172.16.1.2
            ^
% Invalid input detected at '^' marker.

R1(config)#do ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1(config)#int s0/0/0
R1(config-if)#shut
R1(config-if)#
*Oct 11 22:18:32.223: %LINK-5-CHANGED: Interface Serial0/0/0, changed state to administratively down
*Oct 11 22:18:32.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#no shut
R1(config-if)#no shut
*Oct 11 22:18:37.247: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
R1(config-if)#do ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1(config-if)#
*Oct 11 22:19:02.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:19:02.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#
*Oct 11 22:19:16.755: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:19:16.763: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#
*Oct 11 22:19:24.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:19:24.859: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#no shut
*Oct 11 22:19:32.947: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:19:32.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#do ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1(config-if)#
*Oct 11 22:19:47.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:19:47.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#
R1(config-if)#do sh int s0/0/0
Serial0/0/0 is up, line protocol is down
  Hardware is GT96K Serial
  Internet address is 172.16.1.1/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP REQsent, multilink Closed, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:02, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:15:02
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     398 packets input, 11926 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     412 packets output, 13404 bytes, 0 underruns
     0 output errors, 0 collisions, 33 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     67 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Line protocol down

e
R1#debu
R1#debug pp
*Oct 11 22:21:44.787: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:21:44.795: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1#debug ppp auth
R1#debug ppp authe
R1#debug ppp authentication
PPP authentication debugging is on
R1#
*Oct 11 22:21:56.959: Se0/0/0 PPP: Using default call direction
*Oct 11 22:21:56.959: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:21:56.959: Se0/0/0 PPP: Session handle[B900003E] Session id[62]
*Oct 11 22:21:56.983: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:21:56.991: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:21:56.991: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:21:56.991: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Oct 11 22:21:56.995: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:21:56.995: Se0/0/0 CHAP: Using hostname from configured hostname
R1#
*Oct 11 22:21:56.995: Se0/0/0 CHAP: Using password from AAA
*Oct 11 22:21:56.995: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Oct 11 22:21:56.995: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:21:56.999: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:21:56.999: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R1#
*Oct 11 22:21:59.003: Se0/0/0 PPP: Using default call direction
*Oct 11 22:21:59.003: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:21:59.003: Se0/0/0 PPP: Session handle[CD00003F] Session id[63]
R1#
*Oct 11 22:22:01.047: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:22:01.047: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:22:01.047: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:22:01.047: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:22:01.047: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:22:01.047: Se0/0/0 CHAP: Using password from AAA
*Oct 11 22:22:01.047: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Oct 11 22:22:01.051: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Oct 11 22:22:01.051: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:22:01.051: Se0/0/0 PPP: Received LOGIN Response FAIL
R1#
*Oct 11 22:22:01.055: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R1#
*Oct 11 22:22:03.059: Se0/0/0 PPP: Using default call direction
*Oct 11 22:22:03.059: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:22:03.059: Se0/0/0 PPP: Session handle[C3000040] Session id[64]
*Oct 11 22:22:03.095: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:22:03.095: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:22:03.095: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:22:03.095: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:22:03.095: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:22:03.095: Se0/0/0 CHAP: Using password from AAA
R1#
*Oct 11 22:22:03.095: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Oct 11 22:22:03.099: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Oct 11 22:22:03.099: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:22:03.099: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:22:03.103: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2(config-if)#^Z
R2#debug ppp authentication
PPP authentication debugging is on
R2#
*Oct 11 22:25:13.379: %SYS-5-CONFIG_I: Configured from console by console
*Oct 11 22:25:13.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Oct 11 22:25:14.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R2#
*Oct 11 22:25:16.055: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:16.055: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:16.055: Se0/0/0 PPP: Session handle[AB00003F] Session id[63]
*Oct 11 22:25:16.067: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:16.091: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:16.091: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:16.091: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:16.091: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:16.091: Se0/0/0 CHAP: Using password from AAA
R2#
*Oct 11 22:25:16.091: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:25:16.091: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:25:16.095: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:25:16.095: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:25:16.095: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2#
*Oct 11 22:25:18.099: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:18.099: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:18.099: Se0/0/0 PPP: Session handle[11000040] Session id[64]
*Oct 11 22:25:18.115: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:18.139: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:18.139: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:18.139: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:18.139: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:18.139: Se0/0/0 CHAP: Using password from AAA
R2#
*Oct 11 22:25:18.139: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:25:18.139: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:25:18.143: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:25:18.143: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:25:18.143: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2#
*Oct 11 22:25:20.147: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:20.147: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:20.147: Se0/0/0 PPP: Session handle[A9000041] Session id[65]
*Oct 11 22:25:20.163: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:20.187: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:20.187: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:20.187: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:20.187: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:20.187: Se0/0/0 CHAP: Using password from AAA
R2#
*Oct 11 22:25:20.187: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:25:20.187: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:25:20.191: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:25:20.191: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:25:20.191: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2#
*Oct 11 22:25:22.195: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:22.195: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:22.195: Se0/0/0 PPP: Session handle[7E000042] Session id[66]
*Oct 11 22:25:22.211: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:22.235: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:22.235: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:22.235: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:22.235: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:22.235: Se0/0/0 CHAP: Using password from AAA
R2#
*Oct 11 22:25:22.235: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:25:22.235: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:25:22.239: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:25:22.239: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:25:22.239: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2#
*Oct 11 22:25:24.243: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:24.243: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:24.243: Se0/0/0 PPP: Session handle[97000043] Session id[67]
*Oct 11 22:25:24.259: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:24.283: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:24.283: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:24.283: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:24.283: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:24.283: Se0/0/0 CHAP: Using password from AAA
R2#
*Oct 11 22:25:24.283: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:25:24.283: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:25:24.287: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:25:24.287: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:25:24.287: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2#
*Oct 11 22:25:26.291: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:26.291: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:26.291: Se0/0/0 PPP: Session handle[3D000044] Session id[68]
*Oct 11 22:25:26.307: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:26.331: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:26.331: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:26.331: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:26.331: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:26.331: Se0/0/0 CHAP: Using password from AAA
R2#
*Oct 11 22:25:26.331: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:25:26.331: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:25:26.335: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:25:26.335: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:25:26.335: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2#
*Oct 11 22:25:28.339: Se0/0/0 PPP: Using default call direction
*Oct 11 22:25:28.339: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:25:28.339: Se0/0/0 PPP: Session handle[D6000045] Session id[69]
*Oct 11 22:25:28.355: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:25:28.379: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:25:28.379: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:25:28.379: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:25:28.379: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:25:28.379: Se0/0/0 CHAP: Using password from AAA
R2#
R1#sh run | i username
username R2 password 0 CCIE

Let's fix wrong password.

R1(config)#username R2 password C
*Oct 11 22:26:35.359: Se0/0/0 PPP: Using default call direction
*Oct 11 22:26:35.359: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:26:35.359: Se0/0/0 PPP: Session handle[1E0000A4] Session id[164]
*Oct 11 22:26:35.383: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:26:35.391: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:26:35.391: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:26:35.391: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:26:35.391: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:26:35.391: Se0/0/0 CHAP: Using password from AAA
R1(config)#username R2 password
*Oct 11 22:26:35.391: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Oct 11 22:26:35.395: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Oct 11 22:26:35.395: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:26:35.395: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:26:35.395: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R1(config)#username R2 password
*Oct 11 22:26:37.403: Se0/0/0 PPP: Using default call direction
*Oct 11 22:26:37.407: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:26:37.407: Se0/0/0 PPP: Session handle[570000A5] Session id[165]
*Oct 11 22:26:37.431: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:26:37.439: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:26:37.439: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:26:37.439: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:26:37.439: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:26:37.439: Se0/0/0 CHAP: Using password from AAA
R1(config)#username R2 password CISC
*Oct 11 22:26:37.439: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Oct 11 22:26:37.439: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Oct 11 22:26:37.443: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:26:37.443: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:26:37.443: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R1(config)#username R2 password CISCO
R1(config)#
*Oct 11 22:26:39.455: Se0/0/0 PPP: Using default call direction
*Oct 11 22:26:39.455: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:26:39.455: Se0/0/0 PPP: Session handle[5B0000A6] Session id[166]
*Oct 11 22:26:39.479: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:26:39.487: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:26:39.487: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:26:39.487: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:26:39.487: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:26:39.487: Se0/0/0 CHAP: Using password from AAA
*Oct 11 22:26:39.487: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Oct 11 22:26:39.491: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Oct 11 22:26:39.491: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:26:39.491: Se0/0/0 PPP: Received LOGIN Response PASS
*Oct 11 22:26:39.499: Se0/0/0 CHAP: O SUCCESS id 1 len 4
*Oct 11 22:26:39.499: Se0/0/0 CHAP: I SUCCESS id 1 len 4
R1(config)#
*Oct 11 22:26:39.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config)#^Z
R1#ping
*Oct 11 22:28:01.055: %SYS-5-CONFIG_I: Configured from console by console
R1#ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.1.1/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Closed
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 00:22:48
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1439 packets input, 33801 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1461 packets output, 37288 bytes, 0 underruns
     0 output errors, 0 collisions, 165 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     316 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1#u all
All possible debugging has been turned off
R1#
R2(config)#
*Oct 11 22:29:48.387: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:29:48.391: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:29:48.391: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:29:48.391: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:29:48.395: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2(config)#
*Oct 11 22:29:50.399: Se0/0/0 PPP: Using default call direction
*Oct 11 22:29:50.399: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:29:50.399: Se0/0/0 PPP: Session handle[BF0000A4] Session id[164]
*Oct 11 22:29:50.435: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:29:50.435: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:29:50.435: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:29:50.435: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:29:50.435: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:29:50.435: Se0/0/0 CHAP: Using password from AAA
R2(config)#
*Oct 11 22:29:50.435: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:29:50.439: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:29:50.439: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:29:50.439: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:29:50.443: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2(config)#
*Oct 11 22:29:52.455: Se0/0/0 PPP: Using default call direction
*Oct 11 22:29:52.455: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:29:52.455: Se0/0/0 PPP: Session handle[3B0000A5] Session id[165]
*Oct 11 22:29:52.483: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:29:52.483: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:29:52.483: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:29:52.483: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:29:52.483: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:29:52.483: Se0/0/0 CHAP: Using password from AAA
R2(config)#
*Oct 11 22:29:52.483: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:29:52.487: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:29:52.487: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:29:52.487: Se0/0/0 PPP: Received LOGIN Response FAIL
*Oct 11 22:29:52.491: Se0/0/0 CHAP: O FAILURE id 1 len 25 msg is "Authentication failed"
R2(config)#
*Oct 11 22:29:54.495: Se0/0/0 PPP: Using default call direction
*Oct 11 22:29:54.495: Se0/0/0 PPP: Treating connection as a dedicated line
*Oct 11 22:29:54.495: Se0/0/0 PPP: Session handle[260000A6] Session id[166]
*Oct 11 22:29:54.531: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 11 22:29:54.531: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R1"
*Oct 11 22:29:54.531: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Oct 11 22:29:54.531: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Oct 11 22:29:54.531: Se0/0/0 CHAP: Using hostname from configured hostname
*Oct 11 22:29:54.531: Se0/0/0 CHAP: Using password from AAA
*Oct 11 22:29:54.531: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R2"
*Oct 11 22:29:54.535: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R1"
*Oct 11 22:29:54.535: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Oct 11 22:29:54.535: Se0/0/0 PPP: Received LOGIN Response PASS
*Oct 11 22:29:54.543: Se0/0/0 CHAP: O SUCCESS id 1 len 4
*Oct 11 22:29:54.543: Se0/0/0 CHAP: I SUCCESS id 1 len 4
R2(config)#
*Oct 11 22:29:54.547: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config)#^Z
R2#ping 172.16.1.
*Oct 11 22:31:37.775: %SYS-5-CONFIG_I: Configured from console by console
R2#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.1.2/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:02, output 00:00:02, output hang never
  Last clearing of "show interface" counters 00:21:37
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1471 packets input, 38196 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1451 packets output, 34747 bytes, 0 underruns
     0 output errors, 0 collisions, 170 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     295 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2#undebu
R2#undebug all
All possible debugging has been turned off
R2#

Noisy debug message finished and Line protocol is up, additionally ping successful.

References

tech/network/cisco/wan-serial/wan-serial.txt · Last modified: 2018/10/14 11:12 by wnoguchi