User Tools

Site Tools


tech:network:cisco:vrrp:vrrp

VRRP

  • ASW1
en
conf t
!
vlan 10
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 10
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 10
spanning-tree portfast
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • SW1
en
conf t
!
ip routing
!
vlan 3,10
exit
!
int vlan 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
int vlan 10
ip address 172.16.10.1 255.255.255.0
vrrp 10 ip 172.16.10.1
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 10
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • SW2
en
conf t
!
ip routing
!
vlan 4,10
exit
!
int vlan 10
ip address 172.16.10.2 255.255.255.0
vrrp 10 ip 172.16.10.1
no shut
exit
int vlan 4
ip address 172.16.4.2 255.255.255.0
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 10
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 4
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.3 255.255.255.0
vrrp 2 ip 172.16.2.3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.4 255.255.255.0
vrrp 2 ip 172.16.2.3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • PC1
route delete 172.16.0.0 mask 255.255.0.0 172.16.10.254 metric 1 if 25
route add 172.16.0.0 mask 255.255.0.0 172.16.10.1 metric 1 if 25
  • PC2
sudo ip route del 172.16.0.0/16 via 172.16.2.254
sudo ip route add 172.16.0.0/16 via 172.16.2.3
SW1#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Vl10               10  255 3003   Y   Y  Master  172.16.10.1     172.16.10.1
SW1#
SW2#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Vl10               10  100 3609       Y  Backup  172.16.10.1     172.16.10.1
SW2#
R1#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Fa0/1              10  255 3003   Y   Y  Master  172.16.2.3      172.16.2.3
R1#
R2#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Fa0/1              10  100 3609       Y  Backup  172.16.2.3      172.16.2.3
R2#
C:\WINDOWS\system32>ping 172.16.2.245

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.245: bytes=32 time=8ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62

Ping statistics for 172.16.2.245:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 8ms, Average = 2ms

C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  LASTHOPE-WIN [172.16.10.1]
  2     1 ms     1 ms     1 ms  172.16.3.3
  3     1 ms    <1 ms     1 ms  172.16.2.245

Trace complete.

SW1 down

SW1(config)#int f1/0/1
SW1(config-if)#shut
SW1(config-if)#
*Mar  1 04:44:40.564: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
*Mar  1 04:44:40.564: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Master -> Init
SW1(config-if)#
*Mar  1 04:44:40.572: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.2 on Vlan10 from FULL to DOWN, Neighbor Down: Interface down or detached
SW1(config-if)#
*Mar  1 04:44:42.552: %LINK-5-CHANGED: Interface FastEthernet1/0/1, changed state to administratively down
*Mar  1 04:44:43.559: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
SW1(config-if)#
SW2#
*Mar  1 04:44:43.475: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Backup -> Master
SW2#
*Mar  1 04:45:17.012: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.1 on Vlan10 from FULL to DOWN, Neighbor Down: Dead timer expired
C:\WINDOWS\system32>ping 172.16.2.245

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.245: bytes=32 time=9ms TTL=61
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62

Ping statistics for 172.16.2.245:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 9ms, Average = 3ms

C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     2 ms     3 ms     2 ms  172.16.10.2
  2     1 ms     1 ms    <1 ms  172.16.4.4
  3     1 ms    <1 ms     1 ms  172.16.2.245

Trace complete.
SW2#show vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Vl10               10  100 3609       Y  Master  172.16.10.2     172.16.10.1

SW1 back to normal.

SW1(config)#int f1/0/1
SW1(config-if)#no shut
SW1(config-if)#
*Mar  1 04:49:42.017: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
*Mar  1 04:49:43.024: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to up
SW1(config-if)#
*Mar  1 04:50:11.855: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
SW1(config-if)#
*Mar  1 04:50:11.855: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Init -> Master
SW1(config-if)#
*Mar  1 04:50:16.519: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.2 on Vlan10 from LOADING to FULL, Loading Done
SW1(config-if)#
SW1#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Vl10               10  255 3003   Y   Y  Master  172.16.10.1     172.16.10.1

R1 goes down

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/1
R1(config-if)#shut
R1(config-if)#
*Sep 17 06:19:46.386: %VRRP-6-STATECHANGE: Fa0/1 Grp 10 state Master -> Init
R1(config-if)#
*Sep 17 06:19:46.386: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 17 06:19:48.386: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Sep 17 06:19:49.386: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#do sh vrrp bri
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Fa0/1              10  255 3003   Y   Y  Init    0.0.0.0         172.16.2.3
R1(config-if)#
R2#
*Sep 17 06:22:30.610: %VRRP-6-STATECHANGE: Fa0/1 Grp 10 state Backup -> Master
R2#sh ip ro 172.16.10.10
Routing entry for 172.16.10.0/24
  Known via "ospf 1", distance 110, metric 2, type intra area
  Last update from 172.16.4.2 on FastEthernet0/0, 00:00:10 ago
  Routing Descriptor Blocks:
  * 172.16.4.2, from 172.16.4.2, 00:00:10 ago, via FastEthernet0/0
      Route metric is 2, traffic share count is 1
R2#
*Sep 17 06:23:02.138: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Dead timer expired
R2#sh vrrp bri
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Fa0/1              10  100 3609       Y  Master  172.16.2.4      172.16.2.3

Object Tracking

SW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW1(config)#tra
SW1(config)#track 101 int
SW1(config)#track 101 interface fa1/0/2 lin
SW1(config)#track 101 interface fa1/0/2 line-protocol ?
  <cr>

SW1(config)#track 101 interface fa1/0/2 ip ro
SW1(config)#track 101 interface fa1/0/2 line
SW1(config)#track 101 interface fa1/0/2 line-protocol
SW1(config-track)#exit
SW1(config)#int f1/0/2
SW1(config-if)#tra
SW1(config-if)#vrr
SW1(config-if)#vrrp
SW1(config-if)#vrrp
SW1(config-if)#vrrp
SW1(config-if)#exit
SW1(config)#int f1/0/1
SW1(config-if)#vrr
SW1(config-if)#vrr
SW1(config-if)#vrr
SW1(config-if)#vrr?
% Unrecognized command
SW1(config-if)#int vlan10
SW1(config-if)#vrr
SW1(config-if)#vrrp 10 tra
SW1(config-if)#vrrp 10 track 101 dec
SW1(config-if)#vrrp 10 track 101 decrement 200
VRRP: Tracking not supported on IP Address owner
SW1(config-if)#vrrp 10 track 101 decrement 200
VRRP: Tracking not supported on IP Address owner
SW1(config-if)#vrrp 10 track 101
VRRP: Tracking not supported on IP Address owner
SW1(config-if)#ip addr 172.16.10.3
% Incomplete command.

SW1(config-if)#ip addr 172.16.10.3 255.255.255.0
SW1(config-if)#
*Mar  1 01:23:48.139: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.2 on Vlan10 from FULL to DOWN, Neighbor Down: Interface down or detached
SW1(config-if)#
*Mar  1 01:23:48.139: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Master -> Disable
*Mar  1 01:23:48.139: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Init -> Backup
*Mar  1 01:23:48.148: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Backup -> Disable
*Mar  1 01:23:48.148: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Init -> Backup
SW1(config-if)#ip addr
SW1(config-if)#ip address
*Mar  1 01:23:51.763: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Backup -> Master
SW1(config-if)#pri
SW1(config-if)#vrr
SW1(config-if)#vrrp 10 pri
SW1(config-if)#vrrp 10 priority 105
SW1(config-if)#vrrp
SW1(config-if)#vrrp 10 tra
SW1(config-if)#vrrp 10 track 10
*Mar  1 01:24:31.366: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.2 on Vlan10 from LOADING to FULL, Loading Done
SW1(config-if)#vrrp 10 track 101 dec
SW1(config-if)#vrrp 10 track 101 decrement 50
SW1(config-if)#

Solved: Question on configuring VRRP tracking !... - Cisco Community

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/0
R1(config-if)#shut
R1(config-if)#
*Sep 22 07:53:39.707: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 22 07:53:41.699: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Sep 22 07:53:42.699: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
SW1(config-if)#
*Mar  1 01:29:35.528: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to down
*Mar  1 01:29:35.528: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on Vlan3 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:29:36.208: %TRACKING-5-STATE: 101 interface Fa1/0/2 line-protocol Up->Down
*Mar  1 01:29:36.527: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to down
SW1(config-if)#
*Mar  1 01:29:37.525: %LINK-3-UPDOWN: Interface FastEthernet1/0/2, changed state to down
SW1(config-if)#
*Mar  1 01:29:39.136: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Master -> Backup
SW1(config-if)#do sh vrrp
Vlan10 - Group 10
  State is Backup
  Virtual IP address is 172.16.10.1
  Virtual MAC address is 0000.5e00.010a
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 55  (cfgd 105)
    Track object 101 state Down decrement 50
  Master Router is 172.16.10.2, priority is 100
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.589 sec (expires in 3.531 sec)

SW1(config-if)#

VRRP Authentication

Catalyst 3750 platform(WS-C3750V2-24TS c3750-ipservicesk9-mz.150-2.SE4) may not support md5 authentication?

SW1(config-if)#vrr
SW1(config-if)#vrrp 10 au
SW1(config-if)#vrrp 10 authentication te
SW1(config-if)#vrrp 10 authentication text pg1x
SW1(config-if)#
*Mar  1 01:35:50.961: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.10.2, group 10, type 0, expected 1
SW1(config-if)#do sh vrrp
Vlan10 - Group 10
  State is Master
  Virtual IP address is 172.16.10.1
  Virtual MAC address is 0000.5e00.010a
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 105
    Track object 101 state Up decrement 50
  Authentication is enabled
  Master Router is 172.16.10.3 (local), priority is 105
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.589 sec

SW1(config-if)#
*Mar  1 01:36:21.654: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.10.2, group 10, type 0, expected 1
SW1(config-if)#
*Mar  1 01:36:51.677: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.10.2, group 10, type 0, expected 1
SW1(config-if)#
*Mar  1 01:36:53.565: %VRRP-4-BADAUTH: Bad authentication from 172.16.10.2, group 10, type 1
SW1(config-if)#do sh vrrp
Vlan10 - Group 10
  State is Master
  Virtual IP address is 172.16.10.1
  Virtual MAC address is 0000.5e00.010a
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 105
    Track object 101 state Up decrement 50
  Authentication is enabled
  Master Router is 172.16.10.3 (local), priority is 105
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.589 sec

SW1(config-if)#vrrp 10 authentication md pg1x
SW1(config-if)#vrrp 10 authentication md5
SW1(config-if)#vrrp 10 authentication md5
SW1(config-if)#vrrp 10 authentication ?
  text  TEXT authentication

SW1(config-if)#vrrp 10 authentication te
SW1(config-if)#vrrp 10 authentication text ?
  WORD  authentication string

SW1(config-if)#vrrp 10 authentication ?
  text  TEXT authentication

SW1(config-if)#vrrp 10 authentication md5 ?
% Unrecognized command
SW1(config-if)#vrrp 10 authentication md5 ?
% Unrecognized command
SW1(config-if)#sta
SW1(config-if)#standby 10 au
SW1(config-if)#standby 10 authentication ?
  WORD  Plain text authentication string (8 chars max)
  md5   Use MD5 authentication
  text  Plain text authentication

SW1(config-if)#standby 10 authentication md
SW1(config-if)#vrrp 10 authentication ?
  text  TEXT authentication

SW1(config-if)#vrrp 10 authentication md5 key
SW1(config-if)#vrrp 10 authentication md5 key
SW1(config-if)#vrrp 10 authentication md5 key-string 111
                                      ^
% Invalid input detected at '^' marker.

SW1(config-if)#
SW2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW2(config)#int vlan10
SW2(config-if)#vrr
SW2(config-if)#vrrp 10 au
SW2(config-if)#vrrp 10 authentication te
SW2(config-if)#vrrp 10 authentication text pgg
*Mar  1 01:36:49.966: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.10.3, group 10, type 1, expected 0
SW2(config-if)#vrrp 10 authentication text pggg
SW2(config-if)#vrrp 10 authentication text pg
*Mar  1 01:36:53.783: %VRRP-4-BADAUTH: Bad authentication from 172.16.10.3, group 10, type 1
SW2(config-if)#vrrp 10 authentication text pg1x
SW2(config-if)#
*Mar  1 01:37:02.641: %VRRP-6-STATECHANGE: Vl10 Grp 10 state Master -> Backup

go to opposite side Cisco 1841 router.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/0
R1(config-if)#shut
R1(config-if)#
*Sep 22 07:53:39.707: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 22 07:53:41.699: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Sep 22 07:53:42.699: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R1(config-if)#no shut
R1(config-if)#
*Sep 22 07:55:18.859: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Sep 22 07:55:19.859: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#
*Sep 22 07:56:28.623: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R1(config-if)#int f0/1
R1(config-if)#vrr
R1(config-if)#vrrp 2 ?
  authentication  Authentication
  description     Group specific description
  ip              Enable Virtual Router Redundancy Protocol (VRRP) for IP
  preempt         Enable preemption of lower priority Master
  priority        Priority of this VRRP group
  shutdown        Disable VRRP Configuration
  timers          Set the VRRP timers
  track           Event Tracking

R1(config-if)#vrrp 2 au
R1(config-if)#vrrp 2 authentication ?
  WORD  Plain text authentication string
  md5   Use MD5 authentication
  text  Plain text authentication

R1(config-if)#vrrp 2 authentication md
R1(config-if)#vrrp 2 authentication md5 cisco
                                        ^
% Invalid input detected at '^' marker.

R1(config-if)#vrrp 2 authentication md5 key
R1(config-if)#vrrp 2 authentication md5 key-str
R1(config-if)#vrrp 2 authentication md5 key-string pg1x
R1(config-if)#
*Sep 22 08:03:51.619: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:04:22.059: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:04:52.795: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:05:23.103: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#do sh vrrp
FastEthernet0/1 - Group 2
  State is Master
  Virtual IP address is 172.16.2.3
  Virtual MAC address is 0000.5e00.0102
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 255
  Authentication MD5, key-string
  Master Router is 172.16.2.3 (local), priority is 255
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.003 sec

R1(config-if)#
*Sep 22 08:05:53.683: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:06:24.303: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#no vrrp 2 authentication md5 key-string pg1x
R1(config-if)#
*Sep 22 08:10:03.619: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 254, expected 0
R1(config-if)#exit
R1(config)#key cha
R1(config)#key chain PG1X
R1(config-keychain)#ke
R1(config-keychain)#key 1
R1(config-keychain-key)#key
R1(config-keychain-key)#key-string ine
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int vlan10
                ^
% Invalid input detected at '^' marker.

R1(config)#int vlan 10
                ^
% Invalid input detected at '^' marker.

R1(config)#int vl
R1(config)#int f0/1
R1(config-if)#int
R1(config-if)#vrrp 2 au
R1(config-if)#vrrp 2 authentication md
R1(config-if)#vrrp 2 authentication md5 key
R1(config-if)#vrrp 2 authentication md5 key-ch
R1(config-if)#vrrp 2 authentication md5 key-chain PG1X
R1(config-if)#do
*Sep 22 08:11:46.251: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#do sh vrrp
FastEthernet0/1 - Group 2
  State is Master
  Virtual IP address is 172.16.2.3
  Virtual MAC address is 0000.5e00.0102
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 255
  Authentication MD5, key-chain "PG1X"
  Master Router is 172.16.2.3 (local), priority is 255
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.003 sec

R1(config-if)#
*Sep 22 08:12:16.499: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:12:46.899: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:13:17.183: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
*Sep 22 08:13:47.343: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.4, group 2, type 0, expected 254
R1(config-if)#
2#
*Sep 22 08:06:36.611: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2#
*Sep 22 08:06:39.343: %VRRP-6-STATECHANGE: Fa0/1 Grp 2 state Backup -> Master
R2#
*Sep 22 08:07:06.767: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2#
*Sep 22 08:07:37.063: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int f0/1
R2(config-if)#vrr
R2(config-if)#vrrp 2
*Sep 22 08:08:07.603: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-if)#do sh vrrp
FastEthernet0/1 - Group 2
  State is Master
  Virtual IP address is 172.16.2.3
  Virtual MAC address is 0000.5e00.0102
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 100
  Master Router is 172.16.2.4 (local), priority is 100
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.609 sec

R2(config-if)#
*Sep 22 08:08:38.159: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-if)#vrrp 2 md
R2(config-if)#vrrp 2 auth
R2(config-if)#vrrp 2 authentication md
R2(config-if)#vrrp 2 authentication md5 ke
R2(config-if)#vrrp 2 authentication md5 key-?
key-chain  key-string

R2(config-if)#vrrp 2 authentication md5 key-
*Sep 22 08:09:08.363: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-if)#vrrp 2 authentication md5 key-str
R2(config-if)#vrrp 2 authentication md5 key-string pg1x
R2(config-if)#
*Sep 22 08:09:15.911: %VRRP-6-STATECHANGE: Fa0/1 Grp 2 state Master -> Backup
R2(config-if)#
*Sep 22 08:12:48.575: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 0, expected 254
R2(config-if)#vrrp 2 authentication md5 key-string pg1x
*Sep 22 08:12:51.343: %VRRP-6-STATECHANGE: Fa0/1 Grp 2 state Backup -> Master
R2(config-if)#no vrrp 2 authentication md5 key-string pg1x
R2(config-if)#
*Sep 22 08:12:54.839: %VRRP-6-STATECHANGE: Fa0/1 Grp 2 state Master -> Backup
R2(config-if)#
*Sep 22 08:14:31.339: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-if)#
*Sep 22 08:14:33.979: %VRRP-6-STATECHANGE: Fa0/1 Grp 2 state Backup -> Master
R2(config-if)#exit
R2(config)#keycha
R2(config)#keycha
*Sep 22 08:15:01.499: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config)#keychai
R2(config)#key cah
R2(config)#key chai
R2(config)#key chain PG1X
R2(config-keychain)#key
R2(config-keychain)#key ?
  <0-2147483647>  Key identifier

R2(config-keychain)#key 1
*Sep 22 08:15:31.779: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-keychain)#key 1
R2(config-keychain-key)#vrr
R2(config-keychain-key)#do sh vrrp
FastEthernet0/1 - Group 2
  State is Master
  Virtual IP address is 172.16.2.3
  Virtual MAC address is 0000.5e00.0102
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 100
  Master Router is 172.16.2.4 (local), priority is 100
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.609 sec

R2(config-keychain-key)#key-str
R2(config-keychain-key)#key-string md
R2(config-keychain-key)#key-string ine
*Sep 22 08:16:02.179: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-keychain-key)#key-string ine
R2(config-keychain-key)#exit
R2(config-keychain)#exit
R2(config)#int f0/1
R2(config-if)#vrr
R2(config-if)#vrrp
*Sep 22 08:16:32.215: %VRRP-4-BADAUTHTYPE: Bad authentication from 172.16.2.3, group 2, type 254, expected 0
R2(config-if)#vrrp 2 auth
R2(config-if)#vrrp 2 authentication md
R2(config-if)#vrrp 2 authentication md5 key
R2(config-if)#vrrp 2 authentication md5 key-ch
R2(config-if)#vrrp 2 authentication md5 key-chain ?
  WORD  Name of key-chain

R2(config-if)#vrrp 2 authentication md5 key-chain PG
R2(config-if)#vrrp 2 authentication md5 key-chain PG1X
R2(config-if)#
*Sep 22 08:16:53.799: %VRRP-6-STATECHANGE: Fa0/1 Grp 2 state Master -> Backup
R2(config-if)#do sh vrrp
FastEthernet0/1 - Group 2
  State is Backup
  Virtual IP address is 172.16.2.3
  Virtual MAC address is 0000.5e00.0102
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 100
  Authentication MD5, key-chain "PG1X"
  Master Router is 172.16.2.3, priority is 255
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.609 sec (expires in 3.253 sec)










References

tech/network/cisco/vrrp/vrrp.txt · Last modified: 2018/09/22 17:20 by wnoguchi