PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:vpn:tunneling:gre:gre

This is an old revision of the document!


Cisco: GRE

Topology

IP

Project name: ccna-vpn-gre-0001-gre

Static Routing

configure terminal
!
interface Tunnel 0
 ip address 10.1.1.1 255.255.255.252
 tunnel source 1.1.1.1
 tunnel destination 2.2.2.2
 no shutdown
exit
!
ip route 10.2.2.0 255.255.255.0 Tunnel 0
!
end
configure terminal
!
interface Tunnel 0
 ip address 10.1.1.2 255.255.255.252
 tunnel source 2.2.2.2
 tunnel destination 1.1.1.1
 no shutdown
exit
!
ip route 10.1.1.0 255.255.255.0 Tunnel 0
!
end

Dynamic Routing

configure terminal
!
interface Tunnel 0
 ip address 10.1.1.1 255.255.255.252
 tunnel source 1.1.1.1
 tunnel destination 2.2.2.2
 no shutdown
exit
!
router ospf 1
 network 10.1.1.1 0.0.0.0 area 0
 network 10.1.1.1 0.0.0.0 area 0
exit
!
end
configure terminal
!
interface Tunnel 0
 ip address 10.1.1.2 255.255.255.252
 tunnel source 2.2.2.2
 tunnel destination 1.1.1.1
 no shutdown
exit
!
router ospf 1
 network 10.1.1.1 0.0.0.0 area 0
 network 10.1.1.1 0.0.0.0 area 0
exit
!
end

References

tech/network/cisco/vpn/tunneling/gre/gre.1554679431.txt.gz · Last modified: 2019/04/08 08:23 by wnoguchi