User Tools

Site Tools


tech:network:cisco:verify-rip-status:verify-rip-status

Verify RIP status

GNS3 Virtual Lab.

Topology

Initial Config

  • R1
conf t
!
hostname R1
!
int gig0/0
ip addr 192.168.1.1 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.0.1 255.255.255.0
no shut
exit
!
router rip
network 192.168.1.0
network 192.168.0.1
exit
!
end
wr
  • R2
conf t
!
hostname R2
!
int gig0/0
ip addr 192.168.0.2 255.255.255.0
no shut
exit
int gig0/1
ip addr 172.16.1.2 255.255.255.0
no shut
exit
int gig0/2
ip addr 172.17.1.2 255.255.255.0
no shut
exit
!
router rip
network 192.168.0.1
network 172.16.0.0
network 172.17.0.0
exit
!
end
wr
  • PC-1
ip 192.168.1.254 255.255.255.0 192.168.1.1
save
  • PC-2
ip 172.16.1.254 255.255.255.0 172.16.1.2
save
  • PC-2
ip 172.17.1.254 255.255.255.0 172.17.1.2
save

Verification: Initial config

Verify End-to-End IP reachability.

PC-1> ping 172.16.1.254
84 bytes from 172.16.1.254 icmp_seq=1 ttl=62 time=10.623 ms
84 bytes from 172.16.1.254 icmp_seq=2 ttl=62 time=4.248 ms
84 bytes from 172.16.1.254 icmp_seq=3 ttl=62 time=4.206 ms
84 bytes from 172.16.1.254 icmp_seq=4 ttl=62 time=3.863 ms
84 bytes from 172.16.1.254 icmp_seq=5 ttl=62 time=6.883 ms

PC-1> ping 172.17.1.254
84 bytes from 172.17.1.254 icmp_seq=1 ttl=62 time=11.780 ms
84 bytes from 172.17.1.254 icmp_seq=2 ttl=62 time=3.753 ms
84 bytes from 172.17.1.254 icmp_seq=3 ttl=62 time=3.292 ms
84 bytes from 172.17.1.254 icmp_seq=4 ttl=62 time=6.989 ms
84 bytes from 172.17.1.254 icmp_seq=5 ttl=62 time=2.811 ms

Verification: RIP status

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 7 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0/0    1     1 2
    GigabitEthernet0/1    1     1 2
    Interface             Send  Recv  Triggered RIP  Key-chain
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.0.0
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.2          120      00:00:00
  Distance: (default is 120)
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.0.2, 00:00:24, GigabitEthernet0/1
R     172.17.0.0/16 [120/1] via 192.168.0.2, 00:00:24, GigabitEthernet0/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/1
L        192.168.0.1/32 is directly connected, GigabitEthernet0/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.1/32 is directly connected, GigabitEthernet0/0
R1#debug ip rip
RIP protocol debugging is on
R1#
*May 21 23:31:26.923: RIP: sending v1 update to 255.255.255.255 via GigabitEthernet0/1 (192.168.0.1)
*May 21 23:31:26.924: RIP: build update entries
*May 21 23:31:26.924:   network 192.168.1.0 metric 1
R1#
*May 21 23:31:35.334: RIP: received v1 update from 192.168.0.2 on GigabitEthernet0/1
*May 21 23:31:35.334:      172.16.0.0 in 1 hops
*May 21 23:31:35.335:      172.17.0.0 in 1 hops
R1#
*May 21 23:31:48.750: RIP: sending v1 update to 255.255.255.255 via GigabitEthernet0/0 (192.168.1.1)
*May 21 23:31:48.750: RIP: build update entries
*May 21 23:31:48.750:   network 172.16.0.0 metric 2
*May 21 23:31:48.750:   network 172.17.0.0 metric 2
*May 21 23:31:48.750:   network 192.168.0.0 metric 1
R1#
*May 21 23:31:52.842: RIP: sending v1 update to 255.255.255.255 via GigabitEthernet0/1 (192.168.0.1)
*May 21 23:31:52.843: RIP: build update entries
*May 21 23:31:52.843:   network 192.168.1.0 metric 1
R1#
*May 21 23:32:04.408: RIP: received v1 update from 192.168.0.2 on GigabitEthernet0/1
*May 21 23:32:04.409:      172.16.0.0 in 1 hops
*May 21 23:32:04.410:      172.17.0.0 in 1 hops
R1#
*May 21 23:32:18.673: RIP: sending v1 update to 255.255.255.255 via GigabitEthernet0/0 (192.168.1.1)
*May 21 23:32:18.675: RIP: build update entries
*May 21 23:32:18.677:   network 172.16.0.0 metric 2
*May 21 23:32:18.679:   network 172.17.0.0 metric 2
*May 21 23:32:18.680:   network 192.168.0.0 metric 1
R1#
*May 21 23:32:22.583: RIP: sending v1 update to 255.255.255.255 via GigabitEthernet0/1 (192.168.0.1)
*May 21 23:32:22.584: RIP: build update entries
*May 21 23:32:22.584:   network 192.168.1.0 metric 1
R1#
*May 21 23:32:31.577: RIP: received v1 update from 192.168.0.2 on GigabitEthernet0/1
*May 21 23:32:31.578:      172.16.0.0 in 1 hops
*May 21 23:32:31.579:      172.17.0.0 in 1 hops
R1#u all
All possible debugging has been turned off
R1#
*May 21 23:32:46.572: RIP: sending v1 update to 255.255.255.255 via GigabitEthernet0/0 (192.168.1.1)
*May 21 23:32:46.573: RIP: build update entries
*May 21 23:32:46.574:   network 172.16.0.0 metric 2
*May 21 23:32:46.575:   network 172.17.0.0 metric 2
*May 21 23:32:46.575:   network 192.168.0.0 metric 1

References

tech/network/cisco/verify-rip-status/verify-rip-status.txt · Last modified: 2018/05/22 08:42 by wnoguchi