PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:stp:mstp:inter-region-mstp:inter-region-mstp

Inter Region MSTP

Topology

Base Configuration

  • SW1
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 1/0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW2
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 1/0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet 1/0/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet 1/0/7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW3
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 1/0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet 1/0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW5
configure terminal
!
vlan 1-18
exit
!
interface FastEthernet 1/0/6
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW6
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
exit
!
interface FastEthernet 0/7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW7
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
exit
!
interface FastEthernet 0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW8
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
end
  • SW9
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 0/1-2
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet 0/8
switchport mode trunk
switchport nonegotiate
!
end
  • SW10
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 0/1-2
switchport mode trunk
switchport nonegotiate
!
end
  • SW11
configure terminal
!
vlan 1-18
exit
!
interface range FastEthernet 0/1-2
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet 0/7
switchport mode trunk
switchport nonegotiate
!
end
show vlan brief

MSTP 802.1s Configuration

  • SW1
configure terminal
!
spanning-tree mst configuration
 instance 1 vlan 1-3
 instance 2 vlan 4-6
 name RegionA
 revision 1
 show pending
exit
!
spanning-tree mode mst
!
spanning-tree mst 0 priority 0
spanning-tree mst 1 priority 0
spanning-tree mst 2 priority 0
!
end
  • SW2, 3
configure terminal
!
spanning-tree mst configuration
 instance 1 vlan 1-3
 instance 2 vlan 4-6
 name RegionA
 revision 1
 show pending
exit
!
spanning-tree mode mst
!
end
  • SW6
configure terminal
!
spanning-tree mst configuration
 instance 1 vlan 7-9
 instance 2 vlan 10-12
 name RegionB
 revision 1
 show pending
exit
!
spanning-tree mode mst
!
spanning-tree mst 0 priority 1
spanning-tree mst 1 priority 0
spanning-tree mst 2 priority 0
!
end
  • SW7, 8
configure terminal
!
spanning-tree mst configuration
 instance 1 vlan 7-9
 instance 2 vlan 10-12
 name RegionB
 revision 1
 show pending
exit
!
spanning-tree mode mst
!
end
  • SW9
configure terminal
!
spanning-tree mst configuration
 instance 1 vlan 13-15
 instance 2 vlan 16-18
 name RegionC
 revision 1
 show pending
exit
!
spanning-tree mode mst
!
spanning-tree mst 0 priority 2
spanning-tree mst 1 priority 0
spanning-tree mst 2 priority 0
!
end
  • SW10, 11
configure terminal
!
spanning-tree mst configuration
 instance 1 vlan 13-15
 instance 2 vlan 16-18
 name RegionC
 revision 1
 show pending
exit
!
spanning-tree mode mst
!
end
  • SW5
configure terminal
!
spanning-tree mode pvst
!
end
  • SW1-3, 6-11
clear spanning-tree detected-protocols
show spanning-tree mst
  • ASW1
ping 172.16.1.2 source 172.16.1.1 repeat 100000000
  • ASW2
ping 172.16.4.1 source 172.16.4.2 repeat 100000000
debug spanning-tree events 

External Region

Catalyst 2960 series switch say cannnot create vlans 1-180.

SW9#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW9(config)#vlan 1-18
Insufficient core memory to allocate new VLAN(s) 503 - 600
SW9(config-vlan)#exit
Proposed configuration has too many VLANs for this device's core memory
resources.  Either reduce the number of VLANs proposed or use another VTP
device to configure database.  (The latter will cause this device to enter
TRANSPARENT mode automatically if propagated to it.)
APPLY VLAN changes failed.
SW9(config)#

vlan 1 over 18 creation is successful.

SW11(config)#do sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Gi0/1
2    VLAN0002                         active    
3    VLAN0003                         active    
4    VLAN0004                         active    
5    VLAN0005                         active    
6    VLAN0006                         active    
7    VLAN0007                         active    
8    VLAN0008                         active    
9    VLAN0009                         active    
10   VLAN0010                         active    
11   VLAN0011                         active    
12   VLAN0012                         active    
13   VLAN0013                         active    
14   VLAN0014                         active    
15   VLAN0015                         active    
16   VLAN0016                         active    
17   VLAN0017                         active    
18   VLAN0018                         active    
          
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

following output is IST 0 priority misconfiguration version.

SW11#sh spanning-tree mst 

##### MST0    vlans mapped:   1-12,19-4094
Bridge        address 0026.ca6b.e980  priority      32768 (32768 sysid 0)
Root          address 0017.9549.5480  priority      0     (0 sysid 0)
              port    Fa0/7           path cost     200000   
Regional Root this switch
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6 
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 200000    128.1    P2p 
Fa0/2            Desg FWD 200000    128.2    P2p 
Fa0/7            Root FWD 200000    128.7    P2p Bound(RSTP) 

##### MST1    vlans mapped:   13-15
Bridge        address 0026.ca6b.e980  priority      32769 (32768 sysid 1)
Root          address 001a.a10c.d380  priority      1     (0 sysid 1)
              port    Fa0/1           cost          200000    rem hops 19

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Root FWD 200000    128.1    P2p 
Fa0/2            Altn BLK 200000    128.2    P2p 
Fa0/7            Mstr FWD 200000    128.7    P2p Bound(RSTP) 

##### MST2    vlans mapped:   16-18
Bridge        address 0026.ca6b.e980  priority      32770 (32768 sysid 2)
Root          address 001a.a10c.d380  priority      2     (0 sysid 2)
              port    Fa0/1           cost          200000    rem hops 19

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Root FWD 200000    128.1    P2p 
Fa0/2            Altn BLK 200000    128.2    P2p 
Fa0/7            Mstr FWD 200000    128.7    P2p Bound(RSTP) 

SW2#sh spanning-tree mst 0

##### MST0    vlans mapped:   7-4094
Bridge        address c08c.6045.5200  priority      32768 (32768 sysid 0)
Root          address 0017.9549.5480  priority      0     (0 sysid 0)
              port    Fa1/0/1         path cost     200000   
Regional Root address dc7b.948d.f700  priority      32768 (32768 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6 
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Root FWD 200000    128.3    P2p 
Fa1/0/2          Altn BLK 200000    128.4    P2p 
Fa1/0/5          Desg FWD 200000    128.7    P2p Bound(PVST) 
Fa1/0/7          Altn BLK 200000    128.9    P2p Bound(RSTP) 

SW5#sh spanning-tree 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    0
             Address     0017.9549.5480
             Cost        200019
             Port        8 (FastEthernet1/0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0064.404b.6e00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/6             Root FWD 19        128.8    P2p 


          
VLAN0002
  Spanning tree enabled protocol ieee
  Root ID    Priority    0
             Address     0017.9549.5480
             Cost        200019
             Port        8 (FastEthernet1/0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32770  (priority 32768 sys-id-ext 2)
             Address     0064.404b.6e00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/6             Root FWD 19        128.8    P2p 

SW1#sh spanning-tree mst 0

##### MST0    vlans mapped:   7-4094
Bridge        address e8ed.f315.9380  priority      0     (0 sysid 0)
Root          address 0017.9549.5480  priority      0     (0 sysid 0)
              port    Fa1/0/2         path cost     200000   
Regional Root address dc7b.948d.f700  priority      32768 (32768 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6 
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.3    P2p 
Fa1/0/2          Root FWD 200000    128.4    P2p 
Fa1/0/24         Desg FWD 200000    128.26   P2p 

SW1#
SW6#sh spanning-tree mst 0

##### MST0    vlans mapped:   1-6,13-4094
Bridge        address 0017.9549.5480  priority      0     (0 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6 
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 200000    128.3    P2p 
Fa0/2            Desg FWD 200000    128.4    P2p 
Fa0/7            Desg FWD 200000    128.9    P2p 

























































References

tech/network/cisco/stp/mstp/inter-region-mstp/inter-region-mstp.txt · Last modified: 2019/07/10 08:13 by wnoguchi