User Tools

Site Tools


tech:network:cisco:pvlan:pvlan

Cisco: Catalyst Private VLAN(PVLAN)

Abstract

  1. IOSvL2 Private VLAN do not work in GNS3, command applicable, but not works operational
  2. IOSvL2 Private VLAN may work in Cisco VIRL. I'm not tested in this environment.
  3. Following Private VLAN lab is build on Physical Lab. (Cataylst 3750 v2 series with IOS 15.x IP Services feature)

Topology

Configuration

  • PC-1 over PC-5

Raspbian on Raspberry Pi 1 or 2

  • SW1
configure terminal
!
ip routing
!
vtp mode transparent
!
vlan 10
 private-vlan primary
exit
vlan 101
 private-vlan isolated
exit
vlan 102
 private-vlan community
exit
vlan 10
 private-vlan association 101-102
exit
vlan 20
 name Office
exit
!
interface Vlan 10
 ip address 192.168.0.1 255.255.255.0
 no shutdown
exit
interface Vlan 20
 ip address 192.168.20.1 255.255.255.0
 no shutdown
exit
interface range FastEthernet 1/0/1 - 3
 switchport mode private-vlan host
 switchport private-vlan host-association 10 101
exit
interface range FastEthernet 1/0/4 - 5
 switchport mode private-vlan host
 switchport private-vlan host-association 10 102
exit
interface FastEthernet 1/0/23
 switchport access vlan 20
 switchport mode access
 switchport nonegotiate
exit
interface FastEthernet 1/0/24
 switchport mode private-vlan promiscuous
 switchport private-vlan mapping 10 101-102 
exit
!
end
  • R1
configure terminal
!
interface FastEthernet 0/0
 ip address 192.168.0.254 255.255.255.0
 no shutdown
exit
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
end
  • PC-6
route print
route add 192.168.0.0 mask 255.255.255.0 192.168.20.1 metric 1 if 26
route print

References

tech/network/cisco/pvlan/pvlan.txt · Last modified: 2019/06/01 07:29 by wnoguchi