User Tools

Site Tools


tech:network:cisco:pppoe:pppoe

PPPoE

Typical commands.

PPPoE Active Discovery x Stage

show pppoe session all

PPPoE PPP Session Stage

debug ppp authentication

negotiated

Cisco ISR 1841 Physical Lab.

This carrier assumes Japan NTT Flet's Optical Next. NGN.

R1#sh version | i bin
System image file is "flash:c1841-adventerprisek9-mz.151-4.M10.bin"

en
conf t
!
int f0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shut
exit
!
int f0/0
ip address 172.16.1.254 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414
no shut
exit
!
int Dialer 1
ip address negotiated
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 10
dialer-group 20
ppp authentication chap callin
ppp chap hostname ccie@example.com
ppp chap password cc13
no shut
exit
!
ip route 0.0.0.0 0.0.0.0 Dialer 1
!
ip nat inside source list 30 interface Dialer 1 overload
!
access-list 30 permit 172.16.1.0 0.0.0.255
dialer-list 20 protocol ip permit
!
end
  • PC1(ASW3)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.1.10 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.1.254
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 1.1.1.1
!
end
R1(config-if)#ip virtual-reassembly ?
  in   Enable VFR on Ingress
  out  Enable VFR on Egress
  <cr>
R1#cofn t
     ^
% Invalid input detected at '^' marker.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/1
R1(config-if)#no ip add
R1(config-if)#no ip address
R1(config-if)#pppoe
R1(config-if)#pppoe en
R1(config-if)#pppoe enable
R1(config-if)#
*Oct 20 07:17:11.671: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
R1(config-if)#ppp
*Oct 20 07:17:11.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
R1(config-if)#pppo
R1(config-if)#pppoe-ecli
R1(config-if)#pppoe-clie
R1(config-if)#pppoe-client dia
R1(config-if)#pppoe-client dial-pool-number ?
  <1-255>  Dialer pool number

R1(config-if)#pppoe-client dial-pool-number 10
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#
*Oct 20 07:17:47.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config)#int Dia
R1(config)#int Dialer 1
R1(config-if)#ip add
R1(config-if)#ip address negoti
R1(config-if)#ip address negotiated
R1(config-if)#ip mt
R1(config-if)#exit
R1(config)#int f0/0
R1(config-if)#ip add
R1(config-if)#ip address 172.16.1.254 255.255.255.0
R1(config-if)#ip nat insi
R1(config-if)#ip nat inside

*Oct 20 07:19:20.267: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
R1(config-if)#
R1(config-if)#ip tcp
R1(config-if)#ip tcp adu
R1(config-if)#ip tcp adj
R1(config-if)#ip tcp adjust-mss 1414]
                                    ^
% Invalid input detected at '^' marker.

R1(config-if)#ip tcp adjust-mss 1414
R1(config-if)#no shut
R1(config-if)#
*Oct 20 07:19:56.559: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#int Dia
R1(config)#int Dialer 1
R1(config-if)#ip add
R1(config-if)#ip address nego
R1(config-if)#ip address negotiated
R1(config-if)#ip mtu 1454
R1(config-if)#ip nat outsi
R1(config-if)#ip nat outside
R1(config-if)#encap
R1(config-if)#encapsulation ppp
R1(config-if)#dia
R1(config-if)#dialer po
R1(config-if)#dialer pool 10
R1(config-if)#dia
R1(config-if)#dialer-
*Oct 20 07:21:54.963: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:21:54.971: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:21:55.031: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#dialer-gr
R1(config-if)#dialer-group
*Oct 20 07:21:55.035: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#dialer-group 20
R1(config-if)#ppp au
R1(config-if)#ppp authe
R1(config-if)#ppp authentication host
R1(config-if)#ppp authentication hostn
R1(config-if)#ppp authentication cha
R1(config-if)#ppp authentication chap cal
R1(config-if)#ppp authentication chap
*Oct 20 07:22:17.219: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:22:17.223: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:22:17.267: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp authentication chap call
*Oct 20 07:22:17.271: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp authentication chap call
R1(config-if)#ppp authentication chap call?
WORD  callback  callin  callout

R1(config-if)#ppp authentication chap calli
R1(config-if)#ppp authentication chap callin
R1(config-if)#ppp
*Oct 20 07:22:39.511: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:22:39.519: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:22:39.547: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp cha
*Oct 20 07:22:39.551: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp cha
R1(config-if)#ppp chap host
R1(config-if)#ppp chap hostname
*Oct 20 07:23:01.779: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:23:01.783: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:23:01.811: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp chap hostname
*Oct 20 07:23:01.815: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp chap hostname
*Oct 20 07:23:24.034: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:23:24.038: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:23:24.082: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp chap hostname
*Oct 20 07:23:24.086: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp chap hostname
*Oct 20 07:23:46.310: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
R1(config-if)#ppp chap hostname
*Oct 20 07:23:46.314: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:23:46.354: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp chap hostname
*Oct 20 07:23:46.358: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp chap hostname
*Oct 20 07:24:08.578: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:24:08.582: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:24:08.626: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp chap hostname
*Oct 20 07:24:08.630: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp chap hostname ccie@example.com
R1(config-if)#ppp cha
R1(config-if)#ppp chap
*Oct 20 07:24:30.850: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:24:30.854: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 07:24:30.898: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#ppp chap
*Oct 20 07:24:30.902: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#ppp chap pass
R1(config-if)#ppp chap password cc13
R1(config-if)#no shut
R1(config-if)#
*Oct 20 07:24:53.134: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 07:24:53.138: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
R1(config-if)#
*Oct 20 07:24:53.302: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#exit
R1(config)#ip route
R1(config)#ip route 0.0.0.0 0.0.0.0 Dial
R1(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1
R1(config)#ip nat insi
R1(config)#ip nat inside sour
R1(config)#ip nat inside source 30 inter
R1(config)#ip nat inside source 30 Di
R1(config)#ip nat inside source lis
R1(config)#ip nat inside source list 30 inter
R1(config)#ip nat inside source list 30 interface Dia
R1(config)#ip nat inside source list 30 interface Dialer 1
R1(config)#ip nat inside source list 30 interface Dialer 1 overload
R1(config)#acce
R1(config)#access-list 30 permit 172.16.1.0 0.0.0.255
R1(config)#dialer
R1(config)#dialer-li
R1(config)#dialer-list 20 proto
R1(config)#dialer-list 20 protocol ip permi
R1(config)#dialer-list 20 protocol ip permit
R1(config)#exit
R1#e
*Oct 20 07:29:29.862: %SYS-5-CONFIG_I: Configured from console by console
R1#
ASW3#ping 172.16.1.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
ASW3#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#ping www.google.co.jp
Translating "www.google.co.jp"
% Unrecognized host or address, or protocol not running.

ASW3#sh run
Building configuration...

Current configuration : 963 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ASW3
!
!
ip subnet-zero
!
no ip domain-lookup
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 1.1.1.1
!
no setup express
!
spanning-tree mode pvst
spanning-tree portfast default

ASW3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ASW3(config)#dom
ASW3(config)#ip domain-lookup
ASW3(config)#^Z
ASW3#
6d04h: %SYS-5-CONFIG_I: Configured from console by console
ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.197.163, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/12 ms
R1(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
R1(config)#do ping www.google.co.jp
Translating "www.google.co.jp"
% Unrecognized host or address, or protocol not running.

R1(config)#ip domain-loo
R1(config)#ip domain-lookup
R1(config)#do ping www.google.co.jp
Translating "www.google.co.jp"...domain server (255.255.255.255)
% Unrecognized host or address, or protocol not running.

R1(config)#ip name
R1(config)#ip name-server 8.8.8.8 ?
  A.B.C.D     Domain server IP address (maximum of 6)
  X:X:X:X::X  Domain server IPv6 address (maximum of 6)
  <cr>

R1(config)#ip name-server 8.8.8.8 8.8.4.4 1.1.1.1
R1(config)#do ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.197.131, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/48 ms

Enhance Security

conf t
!
ip inspect name CBAC tcp
ip inspect name CBAC udp
ip inspect name CBAC ftp
ip inspect name CBAC icmp
!
int f0/1
no cdp enable
exit
!
int Dialer 1
ip access-group EX in
ip inspect CBAC out
exit
!
no ip http server
no ip http secure-server
!
ip nat translation timeout 180
!
ip access-list extended EX
deny ip any any
exit
!
line vty 0 15
access-class 1 in
exit
!
end

LAN Inbound Traffic Filtering

access-list 100 permit udp any any eq domain
access-list 100 permit tcp any any eq www
access-list 100 permit tcp any any eq 443
access-list 100 permit tcp any any eq ftp
access-list 100 permit tcp any any eq ftp-data
access-list 100 permit tcp any any eq smtp
access-list 100 permit tcp any any eq 587
access-list 100 permit tcp any any eq 143
access-list 100 permit tcp any any eq pop3
access-list 100 permit tcp any any eq 993
access-list 100 permit tcp any any eq 995
access-list 100 permit tcp any any eq 465
access-list 100 permit icmp any any
R1(config)#ip inspe
R1(config)#ip inspect na
R1(config)#ip inspect name CBAC tcp
R1(config)#ip ins
R1(config)#ip inspect na
R1(config)#ip inspect name CBAC udp
R1(config)#ip inspect name CBAC ftp
R1(config)#ip inspect name CBAC icmp
R1(config)#int f0/1
R1(config-if)#no cdp
R1(config-if)#no cdp en
R1(config-if)#no cdp enable
R1(config-if)#exit
R1(config)#int di1
R1(config-if)#ip acc
R1(config-if)#ip acce
R1(config-if)#ip access-group EX in
R1(config-if)#ip inspe
R1(config-if)#ip inspect CBAC out
R1(config-if)#exit
R1(config)#no ip http ser
R1(config)#no ip http server
R1(config)#no ip http
R1(config)#no ip http secu
R1(config)#no ip http secure-se
R1(config)#no ip http secure-server
R1(config)#ip nat trasn
R1(config)#ip nat trans
R1(config)#ip nat translation tim
R1(config)#ip nat translation timeout 180
R1(config)#ip acce
R1(config)#ip access-list exte
R1(config)#ip access-list extended EX
R1(config-ext-nacl)#deny ip any any
R1(config-ext-nacl)#exit
R1(config)#lin
R1(config)#line vyt 0 15
                 ^
% Invalid input detected at '^' marker.

R1(config)#line vty 0 15
R1(config-line)#ac
R1(config-line)#acc
R1(config-line)#access-class 1 in
R1(config-line)#exit
R1(config)#
R1(config)#
R1(config)#
R1(config)#
R1(config)#
R1(config)#ip acce
R1(config)#ip access-list 100 permi
R1(config)#ip access-list 100 permit
R1(config)#ip access-list 100 per
R1(config)#ip access-list 100 permi
R1(config)#ip access-list 100 permit
R1(config)#ip access-list 100 permi
R1(config)#ip access-list 100 ?
% Unrecognized command
R1(config)#ip access-list ?
  extended    Extended Access List
  helper      Access List acts on helper-address
  log-update  Control access list log updates
  logging     Control access list logging
  resequence  Resequence Access List
  standard    Standard Access List

R1(config)#cce
R1(config)#acces
R1(config)#access-list 100 ?
  deny     Specify packets to reject
  dynamic  Specify a DYNAMIC list of PERMITs or DENYs
  permit   Specify packets to forward
  remark   Access list entry comment

R1(config)#access-list 100 per
R1(config)#access-list 100 permit tcp any any eq www
R1(config)#int f0/0
R1(config-if)#ip acce
R1(config-if)#ip access-group 100
% Incomplete command.

R1(config-if)#ip access-group ?
  <1-199>      IP access list (standard or extended)
  <1300-2699>  IP expanded access list (standard or extended)
  WORD         Access-list name

R1(config-if)#ip access-group 100 ?
  in   inbound packets
  out  outbound packets

R1(config-if)#ip access-group 100 tcp any
R1(config-if)#ip access-group 100 in
R1(config-if)#access-list 100 permit udp any any eq domain
R1(config)#access-list 100 permit udp any any eq domain
R1(config)#access-list 100 permit tcp any any eq www
R1(config)#access-list 100 permit tcp any any eq 443
R1(config)#access-list 100 permit ftp
                                  ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit ftp-data
                                  ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit smtp
                                   ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit 587
                                    ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit imap
                                   ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit pop3
                                   ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit 993
                                    ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit 995
                                    ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit 465
                                    ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit udp any any eq domain
R1(config)#access-list 100 permit tcp any any eq www
R1(config)#access-list 100 permit tcp any any eq 443
R1(config)#access-list 100 permit tcp any any eq ftp
R1(config)#access-list 100 permit tcp any any eq ftp-data
R1(config)#access-list 100 permit tcp any any eq smtp
R1(config)#access-list 100 permit tcp any any eq 587
R1(config)#access-list 100 permit tcp any any eq imap
                                                  ^
% Invalid input detected at '^' marker.

R1(config)#access-list 100 permit tcp any any eq pop3
R1(config)#access-list 100 permit tcp any any eq 993
R1(config)#access-list 100 permit tcp any any eq 995
R1(config)#access-list 100 permit tcp any any eq 465
R1(config)#access-list 100 permit tcp any any eq ?
  <0-65535>    Port number
  bgp          Border Gateway Protocol (179)
  chargen      Character generator (19)
  cmd          Remote commands (rcmd, 514)
  daytime      Daytime (13)
  discard      Discard (9)
  domain       Domain Name Service (53)
  drip         Dynamic Routing Information Protocol (3949)
  echo         Echo (7)
  exec         Exec (rsh, 512)
  finger       Finger (79)
  ftp          File Transfer Protocol (21)
  ftp-data     FTP data connections (20)
  gopher       Gopher (70)
  hostname     NIC hostname server (101)
  ident        Ident Protocol (113)
  irc          Internet Relay Chat (194)
  klogin       Kerberos login (543)
  kshell       Kerberos shell (544)
  login        Login (rlogin, 513)
  lpd          Printer service (515)
  nntp         Network News Transport Protocol (119)

R1(config)#access-list 100 permit tcp any any eq im
R1(config)#access-list 100 permit tcp any any eq im?
% Unrecognized command
R1(config)#access-list 100 permit tcp any any eq po
R1(config)#access-list 100 permit tcp any any eq pop?
pop2  pop3

R1(config)#access-list 100 permit tcp any any eq 143
R1(config)#
ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.27.67, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#ping www.google.co.jp

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.27.67, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.197.195, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#ping www.google.co.jp

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.197.195, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
ASW3#ping www.yahoo.co.jp
Translating "www.yahoo.co.jp"...domain server (8.8.8.8) (8.8.4.4) (1.1.1.1)
% Unrecognized host or address, or protocol not running.

ASW3#ping www.yahoo.co.jp
Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 182.22.28.252, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
ASW3#ping www.yahoo.co.jp
Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 182.22.25.252, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
ASW3#access-list 100 permit ?
% Unrecognized command
ASW3#ping www.yahoo.co.jp
Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 182.22.25.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#
R1#sh ip int brief
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.254    YES manual up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Dialer1                    198.51.100.129 YES IPCP   up                    up
NVI0                       unassigned      NO  unset  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
R1#sh ip rou
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.254/32 is directly connected, FastEthernet0/0
      192.0.2.0/32 is subnetted, 1 subnets
C        192.0.2.167 is directly connected, Dialer1
      198.51.100.0/32 is subnetted, 1 subnets
C        198.51.100.129 is directly connected, Dialer1
R1#sh pppoe session
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st      Type
    N/A   4285  0012.e270.1234  Fa0/1                  Di1  Vi2        UP
                001b.2a77.5678                              UP
R1#sh pppoe session all
Total PPPoE sessions 1


session id: 4285
local MAC address: 001b.2a77.5678, remote MAC address: 0012.e270.1234
virtual access interface: Vi2, outgoing interface: Fa0/1
 VLAN Priority: 0
    1216 packets sent, 0 received
    60989 bytes sent, 0 received
R1#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 198.51.100.129:4450 172.16.1.10:4450 183.79.217.124:4450 183.79.217.124:4450
icmp 198.51.100.129:4451 172.16.1.10:4451 183.79.217.124:4451 183.79.217.124:4451
icmp 198.51.100.129:4452 172.16.1.10:4452 183.79.217.124:4452 183.79.217.124:4452
icmp 198.51.100.129:4453 172.16.1.10:4453 183.79.217.124:4453 183.79.217.124:4453
icmp 198.51.100.129:4454 172.16.1.10:4454 183.79.217.124:4454 183.79.217.124:4454
udp 198.51.100.129:51305 172.16.1.10:51305 8.8.8.8:53       8.8.8.8:53
udp 198.51.100.129:54728 172.16.1.10:54728 8.8.8.8:53       8.8.8.8:53
R1#sh ip access-lists
Standard IP access list 30
    10 permit 172.16.1.0, wildcard bits 0.0.0.255 (40 matches)
Extended IP access list 100
    10 permit tcp any any eq www
    20 permit udp any any eq domain (8 matches)
    30 permit tcp any any eq 443
    40 permit tcp any any eq ftp
    50 permit tcp any any eq ftp-data
    60 permit tcp any any eq smtp
    70 permit tcp any any eq 587
    80 permit tcp any any eq pop3
    90 permit tcp any any eq 993
    100 permit tcp any any eq 995
    110 permit tcp any any eq 465
    120 permit tcp any any eq 143
    130 permit icmp any any (10 matches)
Extended IP access list EX
    10 deny ip any any (3183 matches)
R1#clear pppoe all
R1#
*Oct 20 11:16:28.451: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Oct 20 11:16:28.463: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:16:28.467: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:16:30.443: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:16:30.447: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
R1#
*Oct 20 11:16:30.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

Virtual-Access1 verification

R1#clear pppoe all
R1#
*Oct 20 11:16:28.451: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Oct 20 11:16:28.463: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:16:28.467: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:16:30.443: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:16:30.447: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
R1#
*Oct 20 11:16:30.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int di1
R1(config-if)#ppp chap hostname ccie@example.com
R1(config-if)#ppp chap password cc13
R1(config-if)#^Z
R1#
*Oct 20 11:17:40.643: %SYS-5-CONFIG_I: Configured from console by console
R1#clea
R1#clear ppp
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
....
Success rate is 0 percent (0/4)
R1#sh pppoe sessi
R1#sh pppoe session
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st      Type
    N/A  27299  0012.e270.1234  Fa0/1                  Di1  Vi2        UP
                001b.2a77.5678                              UP
R1#sh ip int b
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.254    YES manual up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Dialer1                    198.51.100.129 YES IPCP   up                    up
NVI0                       unassigned      NO  unset  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
R1#sh ip or
          ^
% Invalid input detected at '^' marker.

R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.254/32 is directly connected, FastEthernet0/0
      192.0.2.0/32 is subnetted, 1 subnets
C        192.0.2.10 is directly connected, Dialer1
      198.51.100.0/32 is subnetted, 1 subnets
C        198.51.100.129 is directly connected, Dialer1
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int di1
R1(config-if)#ppp chap hostname abc@example.com
R1(config-if)#ppp chap password 12345
R1(config-if)#^Z
R1#ping 8.8.8.8
*Oct 20 11:20:09.699: %SYS-5-CONFIG_I: Configured from console by console
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
....
Success rate is 0 percent (0/4)
R1#sh ip ro 8.8.8.8
% Network not in table
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.254/32 is directly connected, FastEthernet0/0
      192.0.2.0/32 is subnetted, 1 subnets
C        192.0.2.10 is directly connected, Dialer1
      198.51.100.0/32 is subnetted, 1 subnets
C        198.51.100.129 is directly connected, Dialer1
R1#ping so
R1#ping sour
R1#ping 8.8.8.8 so
R1#ping 8.8.8.8 source 198.51.100.129
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 198.51.100.129
.....
Success rate is 0 percent (0/5)
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int Dialer 1
R1(config-if)#no ip inspect CBAC out
R1(config-if)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
....
Success rate is 0 percent (0/4)
R1(config-if)#no ip access-group EX in
R1(config-if)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/12 ms
R1(config-if)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
R1(config-if)#ip access-group EX in
R1(config-if)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1(config-if)#^Z
R1#
*Oct 20 11:27:10.815: %SYS-5-CONFIG_I: Configured from console by console
R1#clear pppoe all
R1#
*Oct 20 11:27:17.983: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Oct 20 11:27:17.991: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:27:17.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:27:19.803: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:27:19.807: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:27:19.887: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:27:19.887: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:27:42.083: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:27:42.087: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:27:42.155: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:27:42.159: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:28:04.343: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:28:04.347: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:28:04.427: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:28:04.431: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:28:26.615: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:28:26.619: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:28:26.735: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:28:26.739: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:28:48.887: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:28:48.895: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:28:48.983: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:28:48.987: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#


reload


Press RETURN to get started!


*Oct 20 11:33:04.779: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Initialized
*Oct 20 11:33:04.783: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled
*Oct 20 11:33:07.427: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
*Oct 20 11:33:08.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
*Oct 20 11:33:08.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
*Oct 20 11:33:08.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
*Oct 20 11:33:10.083: %SYS-5-CONFIG_I: Configured from memory by console
*Oct 20 11:33:11.555: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Oct 20 11:33:11.555: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Oct 20 11:33:12.119: %LINK-5-CHANGED: Interface Serial0/0/0, changed state to administratively down
*Oct 20 11:33:14.035: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 1841 Software (C1841-ADVENTERPRISEK9-M), Version 15.1(4)M10, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Tue 24-Mar-15 08:30 by prod_rel_team
*Oct 20 11:33:14.039: %SNMP-5-COLDSTART: SNMP agent on host R1 is undergoing a cold start
*Oct 20 11:33:14.207: %SYS-6-BOOTTIME: Time taken to reboot after reload =  161 seconds
*Oct 20 11:33:14.407: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Oct 20 11:33:14.407: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
*Oct 20 11:33:14.407: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Oct 20 11:33:14.407: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
R1>
R1>
R1>
R1>
R1>
R1>
R1>en
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#!
R1(config)#int f0/1
R1(config-if)#no ip address
R1(config-if)#pppoe enable
R1(config-if)#pppoe-client dial-pool-number 10
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#int f0/0
R1(config-if)#ip address 172.16.1.254 255.255.255.0
R1(config-if)#ip nat inside

*Oct 20 11:35:03.031: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Oct 20 11:35:03.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*Oct 20 11:35:04.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
*Oct 20 11:35:05.159: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 20 11:35:06.159: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#ip tcp adjust-mss 1414
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#int Dialer 1
R1(config-if)#ip address negotiated
R1(config-if)#ip mtu 1454
R1(config-if)#ip nat outside
R1(config-if)#encapsulation ppp
R1(config-if)#dialer pool 10
R1(config-if)#dialer-group 20
R1(config-if)#ppp authentication chap callin
R1(config-if)#ppp chap hostname ccie@example.com
R1(config-if)#ppp chap password cc13
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1
R1(config)#!
R1(config)#ip nat inside source list 30 interface Dialer 1 overload
R1(config)#!
R1(config)#access-list 30 permit 172.16.1.0 0.0.0.255
R1(config)#dialer-list 20 protocol ip permit
R1(config)#!
R1(config)#end
R1#
*Oct 20 11:35:17.243: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Oct 20 11:35:19.139: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:35:19.147: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:35:19.303: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:35:19.307: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 11:35:20.087: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1#
*Oct 20 11:35:41.411: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:35:41.415: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:35:41.503: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:35:41.507: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int di1
R1(config-if)#ppp authentication pap calli
R1(config-if)#ppp authentication pap callin
R1(config-if)#
*Oct 20 11:36:03.683: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:36:03.687: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:36:03.775: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1(config-if)#
*Oct 20 11:36:03.779: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1(config-if)#^Z
R1#
*Oct 20 11:36:13.515: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Oct 20 11:36:25.955: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:36:25.963: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 11:36:26.047: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 11:36:26.051: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#

Vi1 is not appeared.

Need's Vi1 error verification.
en
conf t
!
int f0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shut
exit
!
int f0/0
ip address 172.16.1.254 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414
no shut
exit
!
int Loopback 1
ip address 198.51.100.129 255.255.255.255
no shut
exit
!
int Dialer 1
ip unnumbered Loopback 1
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 10
dialer-group 20
ppp authentication chap callin
ppp chap hostname ccie@example.com
ppp chap password cc13
no shut
exit
!
ip route 0.0.0.0 0.0.0.0 Dialer 1
!
ip nat inside source list 30 interface Dialer 1 overload
!
access-list 30 permit 172.16.1.0 0.0.0.255
dialer-list 20 protocol ip permit
!
end
R1#
*Oct 20 11:56:52.743: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Oct 20 11:57:01.623: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 11:57:01.627: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
R1#
*Oct 20 11:57:01.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.254/32 is directly connected, FastEthernet0/0
      192.0.2.0/32 is subnetted, 1 subnets
C        192.0.2.167 is directly connected, Dialer1
      198.51.100.0/32 is subnetted, 1 subnets
C        198.51.100.129 is directly connected, Loopback1
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip domain-look
R1(config)#ip domain-lookup
R1(config)#ip name
R1(config)#ip name-server 8.8.8.8
R1(config)#^Z
R1#ping
*Oct 20 11:59:10.031: %SYS-5-CONFIG_I: Configured from console by console
R1#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.161.67, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
R1#
ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8)
6d09h: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
6d09h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up (8.8.4.4) (1.1.1.1)
% Unrecognized host or address, or protocol not running.

ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) (8.8.4.4) (1.1.1.1)
% Unrecognized host or address, or protocol not running.

ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) (8.8.4.4) (1.1.1.1)
% Unrecognized host or address, or protocol not running.

ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) (8.8.4.4) (1.1.1.1)
% Unrecognized host or address, or protocol not running.
R1#sh ip nat translations
R1#

It may be NAT configuration problem.

ip nat inside source list 30 interface Dialer 1 overload

Change to

ip nat inside source list 30 interface Loopback 1 overload
en
conf t
!
int f0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shut
exit
!
int f0/0
ip address 172.16.1.254 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414
no shut
exit
!
int Loopback 1
ip address 198.51.100.129 255.255.255.255
no shut
exit
!
int Dialer 1
ip unnumbered Loopback 1
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 10
dialer-group 20
ppp authentication chap callin
ppp chap hostname ccie@example.com
ppp chap password cc13
no shut
exit
!
ip route 0.0.0.0 0.0.0.0 Dialer 1
!
ip nat inside source list 30 interface Loopback 1 overload
!
access-list 30 permit 172.16.1.0 0.0.0.255
dialer-list 20 protocol ip permit
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip nat inside source list 30 interface Loopback 1 overload
R1(config)#^Z
R1#
*Oct 20 12:02:11.947: %SYS-5-CONFIG_I: Configured from console by console
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
R1#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.161.67, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms
R1#ping www.yahoo.co.jp
Translating "www.yahoo.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 183.79.250.123, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms
R1#
ASW3#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms
ASW3#ping www.google.co.jp
Translating "www.google.co.jp"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.197.131, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
ASW3#
R1#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 198.51.100.129:1142 172.16.1.10:1142 216.58.197.131:1142 216.58.197.131:1142
icmp 198.51.100.129:1143 172.16.1.10:1143 216.58.197.131:1143 216.58.197.131:1143
icmp 198.51.100.129:1144 172.16.1.10:1144 216.58.197.131:1144 216.58.197.131:1144
icmp 198.51.100.129:1145 172.16.1.10:1145 216.58.197.131:1145 216.58.197.131:1145
icmp 198.51.100.129:1146 172.16.1.10:1146 216.58.197.131:1146 216.58.197.131:1146
udp 198.51.100.129:55661 172.16.1.10:55661 8.8.8.8:53       8.8.8.8:53
Press RETURN to get started!


*Oct 20 22:45:22.735: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Initialized
*Oct 20 22:45:22.739: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled
*Oct 20 22:45:25.379: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
*Oct 20 22:45:26.559: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
*Oct 20 22:45:26.559: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
*Oct 20 22:45:26.563: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
*Oct 20 22:45:28.027: %SYS-5-CONFIG_I: Configured from memory by console
*Oct 20 22:45:29.491: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Oct 20 22:45:29.491: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Oct 20 22:45:30.067: %LINK-5-CHANGED: Interface Serial0/0/0, changed state to administratively down
*Oct 20 22:45:32.007: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 1841 Software (C1841-ADVENTERPRISEK9-M), Version 15.1(4)M10, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Tue 24-Mar-15 08:30 by prod_rel_team
*Oct 20 22:45:32.011: %SNMP-5-COLDSTART: SNMP agent on host R1 is undergoing a cold start
*Oct 20 22:45:32.375: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Oct 20 22:45:32.375: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
*Oct 20 22:45:32.375: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Oct 20 22:45:32.375: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
R1>en
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#!
R1(config)#int f0/1
R1(config-if)#no ip address
R1(config-if)#pppoe enable
R1(config-if)#pppoe-client dial-pool-number 10
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#int f0/0
R1(config-if)#ip address 172.16.1.254 255.255.255.0
R1(config-if)#ip nat inside

*Oct 20 22:48:50.219: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Oct 20 22:48:50.223: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*Oct 20 22:48:51.331: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
*Oct 20 22:48:52.347: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 20 22:48:53.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#ip tcp adjust-mss 1414
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#int Loopback 1
R1(config-if)#ip address 198.51.100.129 255.255.255.255
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#int Dialer 1
R1(config-if)#ip unnumbered Loopback 1
R1(config-if)#ip mtu 1454
R1(config-if)#ip nat outside
R1(config-if)#encapsulation ppp
R1(config-if)#dialer pool 10
R1(config-if)#dialer-group 20
R1(config-if)#ppp authentication chap callin
R1(config-if)#ppp chap hostname ccie@example.com
R1(config-if)#ppp chap password cc13
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1
R1(config)#!
R1(config)#ip nat inside source list 30 interface Loopback 1 overload
R1(config)#!
R1(config)#access-list 30 permit 172.16.1.0 0.0.0.255
R1(config)#dialer-list 20 protocol ip permit
R1(config)#!
R1(config)#end
R1#
*Oct 20 22:49:04.431: %SYS-5-CONFIG_I: Configured from console by console
*Oct 20 22:49:05.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1#
*Oct 20 22:49:06.279: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:49:06.283: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:49:06.391: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:49:06.395: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:49:07.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1#
*Oct 20 22:49:28.547: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:49:28.551: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:49:28.619: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:49:28.623: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:49:50.831: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:49:50.835: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:49:50.903: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:49:50.907: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:50:13.095: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:50:13.099: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:50:13.175: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:50:13.179: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:50:35.367: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:50:35.371: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:50:35.439: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:50:35.443: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:50:57.639: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:50:57.643: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:50:57.735: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:50:57.739: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:51:19.919: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 20 22:51:19.923: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 20 22:51:19.999: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
R1#
*Oct 20 22:51:20.003: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 20 22:51:42.183: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
R1#

no negotiated

LAN type PPPoE

  • R1
en
conf t
!
int f0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shut
exit
!
int f0/0
ip address 198.51.100.129 255.255.255.240
ip nat inside
ip tcp adjust-mss 1414
no shut
exit
!
int Dialer 1
ip unnumbered f0/0
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 10
dialer-group 20
ppp authentication chap callin
ppp chap hostname ccie@example.com
ppp chap password cc13
no shut
exit
!
ip route 0.0.0.0 0.0.0.0 Dialer 1
!
dialer-list 20 protocol ip permit
!
end
  • PC1(ASW3)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 198.51.100.130 255.255.255.240
no shut
exit
!
ip default-gateway 198.51.100.129
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 1.1.1.1
!
end

DMZ with Private Network PPPoE

  • R1
en
conf t
!
int f0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shut
exit
!
int f0/0
ip tcp adjust-mss 1414
no shut
exit
int f0/0.10
encapsulation dot1Q 10
ip address 172.16.1.254 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414
no shut
exit
int f0/0.20
encapsulation dot1Q 20
ip address 198.51.100.129 255.255.255.240
ip tcp adjust-mss 1414
no shut
exit
!
int Dialer 1
ip unnumbered f0/0.20
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 10
dialer-group 20
ppp authentication chap callin
ppp chap hostname ccie@example.com
ppp chap password cc13
no shut
exit
!
ip route 0.0.0.0 0.0.0.0 Dialer 1
!
ip nat inside source list 30 interface f0/0.20 overload
!
access-list 30 permit 172.16.1.0 0.0.0.255
dialer-list 20 protocol ip permit
!
ip domain-lookup
ip name-server 8.8.8.8 8.8.4.4 1.1.1.1
!
end
  • ASW1
en
conf t
!
vlan 10,20
exit
!
int f0/1
switchport mode trunk
switchport nonegotiate
exit
int f0/7
switchport access vlan 20
switchport mode access
exit
int f0/8
switchport access vlan 10
switchport mode access
exit
!
end
  • PC1(ASW3)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.1.10 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.1.254
!
ip domain-lookup
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 1.1.1.1
!
end
  • PC2(ASW2)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 198.51.100.130 255.255.255.240
no shut
exit
!
ip default-gateway 198.51.100.129
!
ip domain-lookup
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 1.1.1.1
!
end
R1#debug ppp authentication
PPP authentication debugging is on
R1#clear pppoe all
R1#
*Oct 21 04:23:52.291: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Oct 21 04:23:52.295: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
R1#
*Oct 21 04:23:52.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
*Oct 21 04:23:54.279: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 21 04:23:54.283: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
R1#
*Oct 21 04:23:54.287: Vi2 PPP: Using dialer call direction
*Oct 21 04:23:54.287: Vi2 PPP: Treating connection as a callout
*Oct 21 04:23:54.287: Vi2 PPP: Session handle[5C000003] Session id[3]
*Oct 21 04:23:54.323: Vi2 PPP: No authorization without authentication
*Oct 21 04:23:54.323: Vi2 CHAP: I CHALLENGE id 1 len 24 from "BAS"
*Oct 21 04:23:54.323: Vi2 PPP: Sent CHAP SENDAUTH Request
*Oct 21 04:23:54.323: Vi2 PPP: Received SENDAUTH Response FAIL
*Oct 21 04:23:54.323: Vi2 CHAP: Using hostname from interface CHAP
*Oct 21 04:23:54.323: Vi2 CHAP: Using password from interface CHAP
*Oct 21 04:23:54.323: Vi2 CHAP: O RESPONSE id 1 len 41 from "abc@example.com"
*Oct 21 04:23:54.451: Vi2 CHAP: I SUCCESS id 1 len 4
R1#
*Oct 21 04:23:54.459: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
  1. Permit: From LAN To Internet
  2. Permit: From LANT To DMZ
  3. Permit: From Internet To DMZ
  4. Permit: From DMZ To LAN Only Returned Traffic
  5. Permit: From Internet to LAN Only Returned Traffic
conf t
!
ip access-list extended TO_DMZ
permit ip any 198.51.100.128 0.0.0.15
permit icmp any 198.51.100.128 0.0.0.15
exit
!
ip access-list standard FROM_DMZ
deny 198.51.100.128 0.0.0.15
permit any
exit
!
ip inspect name CBAC tcp
ip inspect name CBAC udp
ip inspect name CBAC ftp
ip inspect name CBAC icmp
!
int Dialer 1
ip access-group TO_DMZ in
exit
int f0/0.10
ip access-group FROM_DMZ out
ip inspect CBAC in
exit
!
end

State-full packet inspection CBAC(Context-Based Access Control)

R1#sh ip access-lists
Standard IP access list 30
    10 permit 172.16.1.0, wildcard bits 0.0.0.255 (202 matches)
Standard IP access list FROM_DMZ
    10 deny   198.51.100.128, wildcard bits 0.0.0.15
    20 permit any
Extended IP access list TO_DMZ
    10 permit ip any 198.51.100.128 0.0.0.15 (21 matches)

??????

PPPoE

R1(config)#^Z
R1#
*Oct 27 04:20:26.507: %SYS-5-CONFIG_I: Configured from console by console
R1#debug pppo
R1#debug pppoe auth
R1#debug pppoe authe
R1#debug pppoe authe
R1#debug pppoe authe
R1#debug ppp atu
R1#debug ppp aueh
R1#debug ppp auth
R1#debug ppp authn
R1#debug pppoe authen
R1#debug pppoe ?
  data     PPPoE data packets
  elog     PPPoE elogs
  errors   PPPoE protocol errors
  events   PPPoE protocol events
  packets  PPPoE control packets
  tag      PPPoE protocol tags

R1#debug pppoe eve
R1#debug pppoe events
PPPoE protocol events debugging is on
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Oct 27 04:21:14.215:  padi timer expired
*Oct 27 04:21:14.215:  Sending PADI: Interface = FastEthernet0/1.....
Success rate is 0 percent (0/5)
R1#sh ip int bri
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.254    YES manual up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Dialer1                    unassigned      YES manual up                    up
NVI0                       unassigned      NO  unset  up                    up
R1#
*Oct 27 04:21:46.471:  padi timer expired
*Oct 27 04:21:46.471:  Sending PADI: Interface = FastEthernet0/1
R1#
*Oct 27 04:22:18.727:  padi timer expired
*Oct 27 04:22:18.727:  Sending PADI: Interface = FastEthernet0/1
R1#
*Oct 27 04:22:50.983:  padi timer expired
*Oct 27 04:22:50.983:  Sending PADI: Interface = FastEthernet0/1
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int di1
R1(config-if)#no shut
R1(config-if)#
*Oct 27 04:23:23.239:  padi timer expired
*Oct 27 04:23:23.239:  Sending PADI: Interface = FastEthernet0/1
R1(config-if)#
*Oct 27 04:23:32.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#^Z
R1#
*Oct 27 04:23:38.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1#
*Oct 27 04:23:39.923: %SYS-5-CONFIG_I: Configured from console by console
R1#debug ppp authentication
PPP authentication debugging is on
R1#
*Oct 27 04:23:55.495:  padi timer expired
*Oct 27 04:23:55.495:  Sending PADI: Interface = FastEthernet0/1
*Oct 27 04:23:55.495: PPPoE 0: I PADO  R:0012.e270.099d L:001b.2a77.5678 Fa0/1
R1#
*Oct 27 04:23:57.543:  PPPOE: we've got our pado and the pado timer went off
*Oct 27 04:23:57.543: OUT PADR from PPPoE Session
*Oct 27 04:23:57.547: PPPoE 21234: I PADS  R:0012.e270.099d L:001b.2a77.5678 Fa0/1
*Oct 27 04:23:57.547: IN PADS from PPPoE Session
*Oct 27 04:23:57.551: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Oct 27 04:23:57.555: PPPoE: Virtual Access interface obtained.
*Oct 27 04:23:57.555: PPPoE : encap string prepared
*Oct 27 04:23:57.555: [0]PPPoE 21234: data path set to PPPoE Client
*Oct 27 04:23:57.559: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
R1#
*Oct 27 04:23:57.599: Vi1 PPP: Using dialer call direction
*Oct 27 04:23:57.599: Vi1 PPP: Treating connection as a callout
*Oct 27 04:23:57.599: Vi1 PPP: Session handle[DA000001] Session id[1]
*Oct 27 04:23:57.619: Vi1 PPP: No authorization without authentication
*Oct 27 04:23:57.619: Vi1 CHAP: I CHALLENGE id 1 len 24 from "BAS"
*Oct 27 04:23:57.619: Vi1 PPP: Sent CHAP SENDAUTH Request
*Oct 27 04:23:57.623: Vi1 PPP: Received SENDAUTH Response FAIL
*Oct 27 04:23:57.623: Vi1 CHAP: Using hostname from interface CHAP
*Oct 27 04:23:57.623: Vi1 CHAP: Using password from interface CHAP
*Oct 27 04:23:57.623: Vi1 CHAP: O RESPONSE id 1 len 41 from "abc@example.com"
*Oct 27 04:23:57.735: Vi1 CHAP: I SUCCESS id 1 len 4
*Oct 27 04:23:57.747: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
R1#
*Oct 27 04:23:57.779: PPPoE : ipfib_encapstr  prepared
*Oct 27 04:23:57.783: PPPoE : ipfib_encapstr  prepared
R1#u all
All possible debugging has been turned off
R1#
R1#sh ip interface brief
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.254    YES manual up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Dialer1                    198.51.100.129  YES IPCP   up                    up
NVI0                       unassigned      NO  unset  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
R1#show pppoe session all
Total PPPoE sessions 1


session id: 21234
local MAC address: 001b.2a77.66d3, remote MAC address: 0012.e270.099d
virtual access interface: Vi1, outgoing interface: Fa0/1
 VLAN Priority: 0
    132 packets sent, 0 received
    6034 bytes sent, 0 received
R1#show pppoe session all
Total PPPoE sessions 1


session id: 21234
local MAC address: 001b.2a77.66d3, remote MAC address: 0012.e270.099d
virtual access interface: Vi1, outgoing interface: Fa0/1
 VLAN Priority: 0
    151 packets sent, 0 received
    6978 bytes sent, 0 received
R1#sh
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.254/32 is directly connected, FastEthernet0/0
      192.0.2.0/32 is subnetted, 1 subnets
C        192.0.2.137 is directly connected, Dialer1
      198.51.100.0/32 is subnetted, 1 subnets
C        198.51.100.129 is directly connected, Dialer1
R1#ping 192.0.2.137
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.0.2.137, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms

clear peer neighbor route.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int dialer 1
R1(config-if)#no peer neighbor-route ?
  <cr>

R1(config-if)#no peer neighbor-route
R1(config-if)#do clear ip ro *
R1(config-if)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.254/32 is directly connected, FastEthernet0/0
      198.51.100.0/32 is subnetted, 1 subnets
C        198.51.100.129 is directly connected, Dialer1
R1(config-if)#do ping 192.0.2.137
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.0.2.137, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
R1(config-if)#

References

tech/network/cisco/pppoe/pppoe.txt · Last modified: 2018/10/27 14:04 by wnoguchi