User Tools

Site Tools


tech:network:cisco:pppoe-server:pppoe-server

PPPoE Server Configuration

  • R1 PPPoE Client
en
conf t
!
int f0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shut
exit
!
int f0/1
ip address 172.16.1.254 255.255.255.0
!ip tcp adjust-mss 1414
no shut
exit
!
int Dialer 1
ip address negotiated
ip mtu 1454
encapsulation ppp
dialer pool 10
dialer-group 20
ppp authentication chap callin
ppp chap hostname ccie@example.com
ppp chap password cc13
no shut
exit
!
ip route 0.0.0.0 0.0.0.0 Dialer 1
!
dialer-list 20 protocol ip permit
!
end
  • R2 PPPoE Server
en
conf t
!
username ccie@example.com password cc13
!
ip local pool POOL1 10.1.1.1
!
int Loopback1
ip address 10.2.2.2 255.255.255.0
exit
!
int Virtual-Template1
mtu 1454
ip unnumbered Loopback1
peer default ip address pool POOL1
ppp authentication chap
exit
!
bba-group pppoe PPPOE-GROUP1
virtual-template 1
exit
!
int f0/1
no ip address
pppoe enable group PPPOE-GROUP1
no shut
exit
!
int f0/0
ip address 192.168.1.254 255.255.255.0
no shut
exit
!
ip route 172.16.1.0 255.255.255.0 10.1.1.1
!
end
  • PC1(ASW2)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.1.10 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.1.254
!
end
  • PC2(ASW3)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 192.168.1.10 255.255.255.0
no shut
exit
!
ip default-gateway 192.168.1.254
!
end

Input configuration by hand one by one.

don't work…

debug ppp authentication
debug pppoe events

But I'm again PPPoE Server pasted configuration works.

Compare configuration.

typo.

R1#
*Oct 28 23:10:24.019:  padi timer expired
*Oct 28 23:10:24.019:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:10:56.275:  padi timer expired
*Oct 28 23:10:56.275:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:11:28.531:  padi timer expired
*Oct 28 23:11:28.531:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:12:00.787:  padi timer expired
*Oct 28 23:12:00.787:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:12:33.063:  padi timer expired
*Oct 28 23:12:33.063:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:13:05.319:  padi timer expired
*Oct 28 23:13:05.319:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:13:37.603:  padi timer expired
*Oct 28 23:13:37.603:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:14:09.871:  padi timer expired
*Oct 28 23:14:09.871:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:14:42.127:  padi timer expired
*Oct 28 23:14:42.127:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:15:14.383:  padi timer expired
*Oct 28 23:15:14.383:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:15:46.639:  padi timer expired
*Oct 28 23:15:46.639:  Sending PADI: Interface = FastEthernet0/0
R1#clear
*Oct 28 23:16:18.895:  padi timer expired
*Oct 28 23:16:18.895:  Sending PADI: Interface = FastEthernet0/0
R1#clear ppp all
R1#
*Oct 28 23:16:51.163:  padi timer expired
*Oct 28 23:16:51.163:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:17:23.419:  padi timer expired
*Oct 28 23:17:23.419:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:17:55.675:  padi timer expired
*Oct 28 23:17:55.675:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:18:27.947:  padi timer expired
*Oct 28 23:18:27.947:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:19:00.203:  padi timer expired
*Oct 28 23:19:00.203:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:19:32.495:  padi timer expired
*Oct 28 23:19:32.495:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:20:04.767:  padi timer expired
*Oct 28 23:20:04.767:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:20:37.023:  padi timer expired
*Oct 28 23:20:37.023:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:20:40.963: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1#
*Oct 28 23:21:09.279:  padi timer expired
*Oct 28 23:21:09.279:  Sending PADI: Interface = FastEthernet0/0
R1#
R1#
R1#
R1#
R1#
*Oct 28 23:21:41.535:  padi timer expired
*Oct 28 23:21:41.535:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:22:13.791:  padi timer expired
*Oct 28 23:22:13.791:  Sending PADI: Interface = FastEthernet0/0
R1#
*Oct 28 23:22:46.047:  padi timer expired
*Oct 28 23:22:46.047:  Sending PADI: Interface = FastEthernet0/0
*Oct 28 23:22:46.047: PPPoE 0: I PADO  R:0024.c431.126f L:001b.2a77.66d2 Fa0/0
R1#
*Oct 28 23:22:48.095:  PPPOE: we've got our pado and the pado timer went off
*Oct 28 23:22:48.095: OUT PADR from PPPoE Session
*Oct 28 23:22:48.135: PPPoE 1: I PADS  R:0024.c431.126f L:001b.2a77.66d2 Fa0/0
*Oct 28 23:22:48.135: IN PADS from PPPoE Session
*Oct 28 23:22:48.139: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Oct 28 23:22:48.139: PPPoE: Virtual Access interface obtained.
*Oct 28 23:22:48.139: PPPoE : encap string prepared
*Oct 28 23:22:48.139: [0]PPPoE 1: data path set to PPPoE Client
*Oct 28 23:22:48.143: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Oct 28 23:22:48.147: Vi2 PPP: Using dialer call direction
*Oct 28 23:22:48.147: Vi2 PPP: Treating connection as a callout
*Oct 28 23:22:48.147: Vi2 PPP: Session handle[4D000002] Session id[2]
*Oct 28 23:22:48.167: Vi2 PPP: No authorization without authentication
*Oct 28 23:22:48.167: Vi2 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Oct 28 23:22:48.167: Vi2 PPP: Sent CHAP SENDAUTH Request
*Oct 28 23:22:48.167: Vi2 PPP: Received SENDAUTH Response FAIL
*Oct 28 23:22:48.167: Vi2 CHAP: Using hostname from interface CHAP
*Oct 28 23:22:48.167: Vi2 CHAP: Using password from interface CHAP
*Oct 28 23:22:48.167: Vi2 CHAP: O RESPONSE id 1 len 37 from "ccie@example.com"
*Oct 28 23:22:48.219: Vi2 CHAP: I SUCCESS id 1 len 4
R1#
*Oct 28 23:22:48.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
*Oct 28 23:22:48.263: PPPoE : ipfib_encapstr  prepared
*Oct 28 23:22:48.267: PPPoE : ipfib_encapstr  prepared
R1#
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      10.0.0.0/32 is subnetted, 2 subnets
C        10.1.1.1 is directly connected, Dialer1
C        10.2.2.2 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.254/32 is directly connected, FastEthernet0/1
R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  up                    up
FastEthernet0/1            172.16.1.254    YES manual up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Dialer1                    10.1.1.1        YES IPCP   up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
R1#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#ping 10.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2(config-if)#peer default ip address po
R2(config-if)#peer default ip address pool POOL1
R2(config-if)#ppp atuhe
R2(config-if)#ppp atuhen
R2(config-if)#ppp atuhenti
R2(config-if)#ppp authen
R2(config-if)#ppp authentication chap
R2(config-if)#exit
R2(config)#bba-gruo
R2(config)#bba-gruo
R2(config)#bba-group
R2(config)#bba-group PPPOE-GROUP1
                          ^
% Invalid input detected at '^' marker.

R2(config)#bba-group pppoe PPPOE-GROUP1
R2(config-bba-group)#
*Oct 28 23:23:38.903: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
R2(config-bba-group)#
*Oct 28 23:23:38.907: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
R2(config-bba-group)#virtu
R2(config-bba-group)#virtual-template 1
R2(config-bba-group)#exit
R2(config)#int f0/1
R2(config-if)#no ip address
R2(config-if)#pppoe
R2(config-if)#pppoe enabv
R2(config-if)#pppoe enab
R2(config-if)#pppoe enable grou
R2(config-if)#pppoe enable group PPOE-GROUP1
R2(config-if)#no shut
R2(config-if)#
*Oct 28 23:24:15.171: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 28 23:24:16.171: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip address 192.168.1.254 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#ip route 172.1
*Oct 28 23:24:41.767: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#ip route 172.16.1.10
% Incomplete command.

R2(config)#ip route 172.16.1.0 255.255.255.0 10.1.1.1
R2(config)#do debug eve
R2(config)#do debug ppp authentica
PPP authentication debugging is on
R2(config)#do debug pppoe events
PPPoE protocol events debugging is on
R2(config)#int f0/1
R2(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 105 bytes
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group PPOE-GROUP1
end

R2(config-if)#do sh run | i PPPOE
bba-group pppoe PPPOE-GROUP1
R2(config-if)#
*Oct 28 23:25:51.455: PPPoE 0: I PADI  R:001b.2a77.66d2 L:ffff.ffff.ffff Fa0/1
R2(config-if)#pppo
R2(config-if)#pppoe ena
R2(config-if)#pppoe enable grou
R2(config-if)#no pppoe enable group PPOE-GROUP1
R2(config-if)#pppoe enable group PPPOE-GROUP1
R2(config-if)#^Z
R2#
*Oct 28 23:26:21.479: %SYS-5-CONFIG_I: Configured from console by console
R2#
*Oct 28 23:26:23.711: PPPoE 0: I PADI  R:001b.2a77.66d2 L:ffff.ffff.ffff Fa0/1
*Oct 28 23:26:23.711:  Service tag: NULL Tag
*Oct 28 23:26:23.711: PPPoE 0: O PADO, R:0024.c431.126f L:001b.2a77.66d2 Fa0/1
*Oct 28 23:26:23.711:  Service tag: NULL Tag
R2#
*Oct 28 23:26:25.759: PPPoE 0: I PADR  R:001b.2a77.66d2 L:0024.c431.126f Fa0/1
*Oct 28 23:26:25.759:  Service tag: NULL Tag
*Oct 28 23:26:25.759: PPPoE : encap string prepared
*Oct 28 23:26:25.767: [1]PPPoE 1: Access IE handle allocated
*Oct 28 23:26:25.771: [1]PPPoE 1: AAA unique ID D allocated
*Oct 28 23:26:25.771: [1]PPPoE 1: No AAA accounting method list
*Oct 28 23:26:25.775: [1]PPPoE 1: Service request sent to SSS
*Oct 28 23:26:25.779: [1]PPPoE 1: Created, Service: None R:0024.c431.126f L:001b.2a77.66d2 Fa0/1
*Oct 28 23:26:25.795: [1]PPPoE 1: State NAS_PORT_POLICY_INQUIRY    Event SSS MORE KEYS
*Oct 28 23:26:25.799: [1]PPPoE 1: data path set to PPP
*Oct 28 23:26:25.799: [1]PPPoE 1: Segment (SSS class): PROVISION
*Oct 28 23:26:25.799: [1]PPPoE 1: State PROVISION_PPP    Event SSM PROVISIONED
*Oct 28 23:26:25.799: [1]PPPoE 1: O PADS  R:001b.2a77.66d2 L:0024.c431.126f Fa0/1
*Oct 28 23:26:25.799: ppp1 PPP: Using vpn set call direction
*Oct 28 23:26:25.803: ppp1 PPP: Treating connection as a callin
*Oct 28 23:26:25.803: ppp1 PPP: Session handle[BD000001] Session id[1]
*Oct 28 23:26:25.823: ppp1 CHAP: O CHALLENGE id 1 len 23 from "R2"
*Oct 28 23:26:25.831: ppp1 CHAP: I RESPONSE id 1 len 37 from "ccie@example.com"
*Oct 28 23:26:25.835: ppp1 PPP: Sent CHAP LOGIN Request
R2#
*Oct 28 23:26:25.835: ppp1 PPP: Received LOGIN Response PASS
*Oct 28 23:26:25.879: [1]PPPoE 1: State LCP_NEGOTIATION    Event SSS CONNECT LOCAL
*Oct 28 23:26:25.879: [1]PPPoE 1: Segment (SSS class): UPDATED
*Oct 28 23:26:25.883: [1]PPPoE 1: Segment (SSS class): BOUND
*Oct 28 23:26:25.883: [1]PPPoE 1: data path set to Virtual Acess
*Oct 28 23:26:25.883: [1]PPPoE 1: State LCP_NEGOTIATION    Event SSM UPDATED
*Oct 28 23:26:25.883: Vi2.1 CHAP: O SUCCESS id 1 len 4
*Oct 28 23:26:25.887: [1]PPPoE 1: State PTA_BINDING    Event STATIC BIND RESPONSE
*Oct 28 23:26:25.887: [1]PPPoE 1: Connected PTA
*Oct 28 23:26:25.919: PPPoE : ipfib_encapstr  prepared
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.1.1.1/32 is directly connected, Virtual-Access2.1
C        10.2.2.0/24 is directly connected, Loopback1
L        10.2.2.2/32 is directly connected, Loopback1
      172.16.0.0/24 is subnetted, 1 subnets
S        172.16.1.0 [1/0] via 10.1.1.1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.254/32 is directly connected, FastEthernet0/0
R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Configuration Again

ASW2#ping 192.168.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
ASW2#ping 192.168.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      10.0.0.0/32 is subnetted, 2 subnets
C        10.1.1.1 is directly connected, Dialer1
C        10.2.2.2 is directly connected, Dialer1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.254/32 is directly connected, FastEthernet0/1
R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  up                    up
FastEthernet0/1            172.16.1.254    YES manual up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Dialer1                    10.1.1.1        YES IPCP   up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
R1#ping 10.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R1#sh pppoe sess
R1#sh pppoe session all
Total PPPoE sessions 1


session id: 4
local MAC address: 001b.2a77.66d2, remote MAC address: 0024.c431.126f
virtual access interface: Vi2, outgoing interface: Fa0/0
 VLAN Priority: 0
    41 packets sent, 0 received
    1005 bytes sent, 0 received
R2#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.254   YES manual up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Loopback1                  10.2.2.2        YES manual up                    up
Virtual-Access1            unassigned      YES unset  down                  down
Virtual-Access2            unassigned      YES unset  up                    up
Virtual-Access2.1          10.2.2.2        YES unset  up                    up
Virtual-Template1          10.2.2.2        YES unset  down                  down
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.1.1.1/32 is directly connected, Virtual-Access2.1
C        10.2.2.0/24 is directly connected, Loopback1
L        10.2.2.2/32 is directly connected, Loopback1
      172.16.0.0/24 is subnetted, 1 subnets
S        172.16.1.0 [1/0] via 10.1.1.1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.254/32 is directly connected, FastEthernet0/0
R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 172.16.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#

References

tech/network/cisco/pppoe-server/pppoe-server.txt · Last modified: 2018/10/30 06:34 by wnoguchi