PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:ospf:ospf:ospf-basic:ospf-basic

OSPF Fundamental Configuration

GNS3 Virtual Lab.

Basic IP Configuration

  • R1
en
conf t
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 1.1.1.1 255.255.255.255
no shut
exit
int gig0/0
ip address 192.168.0.1 255.255.255.0
no shut
exit
int gig0/1
ip address 192.168.1.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
en
conf t
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 2.2.2.2 255.255.255.255
no shut
exit
int gig0/0
ip address 192.168.1.2 255.255.255.0
no shut
exit
int gig0/1
ip address 192.168.2.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
en
conf t
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 3.3.3.3 255.255.255.255
no shut
exit
int gig0/0
ip address 192.168.2.3 255.255.255.0
no shut
exit
int gig0/1
ip address 192.168.3.3 255.255.255.0
no shut
exit
!
end
wr
  • PC1
ip 192.168.0.101 255.255.255.0 192.168.0.1
save
  • PC2
ip 192.168.3.102 255.255.255.0 192.168.3.3
save
R1#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.0.1     YES manual up                    up
GigabitEthernet0/1         192.168.1.1     YES manual up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
Loopback0                  1.1.1.1         YES manual up                    up
R1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 3/3/4 ms
R1#192.168.1.2
Trying 192.168.1.2 ...
% Connection refused by remote host

R1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/4 ms
R2#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.2     YES manual up                    up
GigabitEthernet0/1         192.168.2.2     YES manual up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
Loopback0                  2.2.2.2         YES manual up                    up
R3#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.2.3     YES manual up                    up
GigabitEthernet0/1         192.168.3.3     YES manual up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
Loopback0                  3.3.3.3         YES manual up                    up
R3#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/4/5 ms
R3#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms

Single Area OSPF

  • R1
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.0.1 0.0.0.0 area 0
network 192.168.1.1 0.0.0.0 area 0
exit
!
end
  • R2
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.1.2 0.0.0.0 area 0
network 192.168.2.2 0.0.0.0 area 0
exit
!
end
  • R3
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.2.3 0.0.0.0 area 0
network 192.168.3.3 0.0.0.0 area 0
!
end
PC-1> ping 192.168.3.102 -t
*192.168.0.1 icmp_seq=1 ttl=255 time=2.358 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=2 ttl=255 time=2.523 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=3 ttl=255 time=2.912 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=4 ttl=255 time=2.403 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=5 ttl=255 time=2.447 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=6 ttl=255 time=2.501 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=7 ttl=255 time=2.216 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=8 ttl=255 time=2.493 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=9 ttl=255 time=2.516 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=10 ttl=255 time=2.423 ms (ICMP type:3, code:1, Destination host unreachable)
(snip)
*192.168.0.1 icmp_seq=181 ttl=255 time=4.858 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=182 ttl=255 time=2.566 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=183 ttl=255 time=3.617 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=184 ttl=255 time=2.432 ms (ICMP type:3, code:1, Destination host unreachable)
192.168.3.102 icmp_seq=185 timeout
192.168.3.102 icmp_seq=186 timeout
84 bytes from 192.168.3.102 icmp_seq=187 ttl=61 time=4.044 ms
84 bytes from 192.168.3.102 icmp_seq=188 ttl=61 time=3.752 ms
84 bytes from 192.168.3.102 icmp_seq=189 ttl=61 time=4.087 ms
84 bytes from 192.168.3.102 icmp_seq=190 ttl=61 time=3.921 ms
84 bytes from 192.168.3.102 icmp_seq=191 ttl=61 time=5.257 ms
84 bytes from 192.168.3.102 icmp_seq=192 ttl=61 time=3.963 ms
84 bytes from 192.168.3.102 icmp_seq=193 ttl=61 time=4.287 ms
84 bytes from 192.168.3.102 icmp_seq=194 ttl=61 time=3.521 ms
84 bytes from 192.168.3.102 icmp_seq=195 ttl=61 time=4.125 ms
84 bytes from 192.168.3.102 icmp_seq=196 ttl=61 time=7.499 ms
84 bytes from 192.168.3.102 icmp_seq=197 ttl=61 time=4.742 ms
84 bytes from 192.168.3.102 icmp_seq=198 ttl=61 time=4.168 ms
84 bytes from 192.168.3.102 icmp_seq=199 ttl=61 time=4.230 ms
84 bytes from 192.168.3.102 icmp_seq=200 ttl=61 time=5.549 ms
84 bytes from 192.168.3.102 icmp_seq=201 ttl=61 time=3.950 ms
84 bytes from 192.168.3.102 icmp_seq=202 ttl=61 time=5.529 ms
84 bytes from 192.168.3.102 icmp_seq=203 ttl=61 time=4.080 ms
84 bytes from 192.168.3.102 icmp_seq=204 ttl=61 time=7.923 ms
192.168.3.102 icmp_seq=205 timeout
192.168.3.102 icmp_seq=206 timeout
192.168.3.102 icmp_seq=207 timeout
192.168.3.102 icmp_seq=208 timeout
84 bytes from 192.168.3.102 icmp_seq=209 ttl=61 time=4.162 ms
84 bytes from 192.168.3.102 icmp_seq=210 ttl=61 time=5.211 ms
84 bytes from 192.168.3.102 icmp_seq=211 ttl=61 time=4.354 ms
84 bytes from 192.168.3.102 icmp_seq=212 ttl=61 time=5.367 ms
84 bytes from 192.168.3.102 icmp_seq=213 ttl=61 time=4.065 ms
84 bytes from 192.168.3.102 icmp_seq=214 ttl=61 time=4.243 ms
84 bytes from 192.168.3.102 icmp_seq=215 ttl=61 time=4.045 ms
^C
PC-2> ping 192.168.0.101
192.168.0.101 icmp_seq=1 timeout
192.168.0.101 icmp_seq=2 timeout
84 bytes from 192.168.0.101 icmp_seq=3 ttl=61 time=9.200 ms
84 bytes from 192.168.0.101 icmp_seq=4 ttl=61 time=4.381 ms
84 bytes from 192.168.0.101 icmp_seq=5 ttl=61 time=6.712 ms
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1
O     192.168.2.0/24 [110/2] via 192.168.1.2, 00:01:07, GigabitEthernet0/1
O     192.168.3.0/24 [110/3] via 192.168.1.2, 00:00:57, GigabitEthernet0/1
R1#sh ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1744        0x80000003 0x00973F 2
2.2.2.2         2.2.2.2         1687        0x80000004 0x000C4F 2
3.3.3.3         3.3.3.3         1687        0x80000003 0x00B30B 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.2     2.2.2.2         1745        0x80000001 0x0009B0
192.168.2.3     3.3.3.3         1688        0x80000001 0x002A81
R1#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.0.1 0.0.0.0 area 0
    192.168.1.1 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      00:29:53
    2.2.2.2              110      00:31:02
  Distance: (default is 110)
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
O     192.168.0.0/24 [110/2] via 192.168.1.1, 00:02:10, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
O     192.168.3.0/24 [110/2] via 192.168.2.3, 00:01:11, GigabitEthernet0/1
R2#sh ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1790        0x80000003 0x00973F 2
2.2.2.2         2.2.2.2         1730        0x80000004 0x000C4F 2
3.3.3.3         3.3.3.3         1731        0x80000003 0x00B30B 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.2     2.2.2.2         1789        0x80000001 0x0009B0
192.168.2.3     3.3.3.3         1731        0x80000001 0x002A81
R2#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 2.2.2.2
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.1.2 0.0.0.0 area 0
    192.168.2.2 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      00:30:14
    1.1.1.1              110      00:31:13
  Distance: (default is 110)

R2#
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
O     192.168.0.0/24 [110/3] via 192.168.2.2, 00:01:16, GigabitEthernet0/0
O     192.168.1.0/24 [110/2] via 192.168.2.2, 00:01:16, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.3/32 is directly connected, GigabitEthernet0/0
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, GigabitEthernet0/1
L        192.168.3.3/32 is directly connected, GigabitEthernet0/1
R3#sh ip ospf database

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1796        0x80000003 0x00973F 2
2.2.2.2         2.2.2.2         1737        0x80000004 0x000C4F 2
3.3.3.3         3.3.3.3         1736        0x80000003 0x00B30B 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.2     2.2.2.2         1795        0x80000001 0x0009B0
192.168.2.3     3.3.3.3         1736        0x80000001 0x002A81
R3#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 3.3.3.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.2.3 0.0.0.0 area 0
    192.168.3.3 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.2              110      00:30:28
    1.1.1.1              110      00:30:28
  Distance: (default is 110)

Multi-Area OSPF

  • R1
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.0.1 0.0.0.0 area 1
network 192.168.1.1 0.0.0.0 area 1
exit
!
end
  • R2
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.1.2 0.0.0.0 area 1
network 192.168.2.2 0.0.0.0 area 0
exit
!
end
  • R3
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.2.3 0.0.0.0 area 0
network 192.168.3.3 0.0.0.0 area 0
!
end
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1
O     192.168.2.0/24 [110/2] via 192.168.1.2, 00:01:07, GigabitEthernet0/1
O     192.168.3.0/24 [110/3] via 192.168.1.2, 00:00:57, GigabitEthernet0/1
R1#sh ip proto
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.0.1 0.0.0.0 area 1
    192.168.1.1 0.0.0.0 area 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.2              110      00:06:21
  Distance: (default is 110)

R1#sh ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         894         0x80000003 0x008D4A 2
2.2.2.2         2.2.2.2         873         0x80000003 0x0049FE 1

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.1     1.1.1.1         894         0x80000001 0x00417D

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.0     2.2.2.2         868         0x80000001 0x008F39
192.168.3.0     2.2.2.2         805         0x80000001 0x008E38
R1#sh ip ospf int
GigabitEthernet0/1 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 1, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
  Backup Designated router (ID) 2.2.2.2, Interface address 192.168.1.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up
  Internet Address 192.168.0.1/24, Area 1, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.0.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

R2 is ABR.

R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
O     192.168.0.0/24 [110/2] via 192.168.1.1, 00:01:22, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
O     192.168.3.0/24 [110/2] via 192.168.2.3, 00:00:14, GigabitEthernet0/1
R2#sh ip proto
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 2.2.2.2
  It is an area border router
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.1.2 0.0.0.0 area 1
    192.168.2.2 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      00:06:26
    1.1.1.1              110      00:07:34
  Distance: (default is 110)

R2#sh ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         841         0x80000002 0x0075CF 1
3.3.3.3         3.3.3.3         842         0x80000003 0x00B30B 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.3     3.3.3.3         842         0x80000001 0x002A81

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.0     2.2.2.2         904         0x80000001 0x00AF1A
192.168.1.0     2.2.2.2         904         0x80000001 0x009A2F

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         927         0x80000003 0x008D4A 2
2.2.2.2         2.2.2.2         904         0x80000003 0x0049FE 1

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.1     1.1.1.1         927         0x80000001 0x00417D

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.0     2.2.2.2         899         0x80000001 0x008F39
192.168.3.0     2.2.2.2         836         0x80000001 0x008E38
R2#sh ip ospf interface
GigabitEthernet0/1 is up, line protocol is up
  Internet Address 192.168.2.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 3.3.3.3, Interface address 192.168.2.3
  Backup Designated router (ID) 2.2.2.2, Interface address 192.168.2.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 3, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3  (Designated Router)
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 1, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
  Backup Designated router (ID) 2.2.2.2, Interface address 192.168.1.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 3, maximum is 3
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Designated Router)
  Suppress hello for 0 neighbor(s)
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
O IA  192.168.0.0/24 [110/3] via 192.168.2.2, 00:00:27, GigabitEthernet0/0
O IA  192.168.1.0/24 [110/2] via 192.168.2.2, 00:00:27, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.3/32 is directly connected, GigabitEthernet0/0
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, GigabitEthernet0/1
L        192.168.3.3/32 is directly connected, GigabitEthernet0/1
R3#sh ip proto
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 3.3.3.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.2.3 0.0.0.0 area 0
    192.168.3.3 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.2              110      00:07:37
  Distance: (default is 110)

R3#sh ip ospf database

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         857         0x80000002 0x0075CF 1
3.3.3.3         3.3.3.3         856         0x80000003 0x00B30B 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.3     3.3.3.3         856         0x80000001 0x002A81

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.0     2.2.2.2         921         0x80000001 0x00AF1A
192.168.1.0     2.2.2.2         921         0x80000001 0x009A2F
PC-1> ping 192.168.3.102
84 bytes from 192.168.3.102 icmp_seq=1 ttl=61 time=4.962 ms
84 bytes from 192.168.3.102 icmp_seq=2 ttl=61 time=4.245 ms
84 bytes from 192.168.3.102 icmp_seq=3 ttl=61 time=5.150 ms
84 bytes from 192.168.3.102 icmp_seq=4 ttl=61 time=4.067 ms
84 bytes from 192.168.3.102 icmp_seq=5 ttl=61 time=4.166 ms
PC-2> ping 192.168.0.101
84 bytes from 192.168.0.101 icmp_seq=1 ttl=61 time=4.128 ms
84 bytes from 192.168.0.101 icmp_seq=2 ttl=61 time=4.026 ms
84 bytes from 192.168.0.101 icmp_seq=3 ttl=61 time=3.976 ms
84 bytes from 192.168.0.101 icmp_seq=4 ttl=61 time=4.827 ms
84 bytes from 192.168.0.101 icmp_seq=5 ttl=61 time=4.019 ms
R3#sh ip ospf interface
GigabitEthernet0/1 is up, line protocol is up
  Internet Address 192.168.3.3/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 3.3.3.3, Interface address 192.168.3.3
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up
  Internet Address 192.168.2.3/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 3.3.3.3, Interface address 192.168.2.3
  Backup Designated router (ID) 2.2.2.2, Interface address 192.168.2.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 1 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
R1#debug ip ospf adj
OSPF adjacency debugging is on
R1#clea
R1#clear ip
R1#clear ip os
R1#clear ip ospf pro
R1#clear ip ospf process ?
  <cr>

R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes

Same cost load balancing

  • R1
en
conf t
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 1.1.1.1 255.255.255.255
no shut
exit
int gig0/0
ip address 172.16.1.1 255.255.255.0
no shut
exit
int gig0/1
ip address 172.16.2.1 255.255.255.0
no shut
int gig0/2
ip address 172.16.3.1 255.255.255.0
no shut
int gig0/3
ip address 172.16.4.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
en
conf t
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 2.2.2.2 255.255.255.255
no shut
exit
int gig0/0
ip address 172.16.2.2 255.255.255.0
no shut
exit
int gig0/1
ip address 172.16.5.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
en
conf t
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 3.3.3.3 255.255.255.255
no shut
exit
int gig0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int gig0/1
ip address 172.16.5.3 255.255.255.0
no shut
exit
!
end
wr
  • R4
en
conf t
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 4.4.4.4 255.255.255.255
no shut
exit
int gig0/0
ip address 172.16.4.4 255.255.255.0
no shut
exit
int gig0/1
ip address 172.16.5.4 255.255.255.0
no shut
exit
!
end
wr
  • PC1
ip 172.16.1.101 255.255.255.0 172.16.1.1
save
  • PC2
ip 172.16.5.102 255.255.255.0 172.16.5.2
save
  • R1
en
conf t
!
! OSPF Configuration
router ospf 1
network 172.16.1.1 0.0.0.0 area 0
network 172.16.2.1 0.0.0.0 area 0
network 172.16.3.1 0.0.0.0 area 0
network 172.16.4.1 0.0.0.0 area 0
exit
!
end
  • R2
en
conf t
!
! OSPF Configuration
router ospf 1
network 172.16.2.2 0.0.0.0 area 0
network 172.16.5.2 0.0.0.0 area 0
exit
!
end
  • R3
en
conf t
!
! OSPF Configuration
router ospf 1
network 172.16.3.3 0.0.0.0 area 0
network 172.16.5.3 0.0.0.0 area 0
!
end
  • R4
en
conf t
!
! OSPF Configuration
router ospf 1
network 172.16.4.4 0.0.0.0 area 0
network 172.16.5.4 0.0.0.0 area 0
!
end
R1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O        172.16.5.0/24 [110/2] via 172.16.4.4, 00:08:39, GigabitEthernet0/3
                       [110/2] via 172.16.3.3, 00:08:39, GigabitEthernet0/2
                       [110/2] via 172.16.2.2, 00:08:39, GigabitEthernet0/1
R2#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
O        172.16.1.0/24 [110/2] via 172.16.2.1, 00:12:20, GigabitEthernet0/0
O        172.16.3.0/24 [110/2] via 172.16.5.3, 00:12:10, GigabitEthernet0/1
                       [110/2] via 172.16.2.1, 00:12:10, GigabitEthernet0/0
O        172.16.4.0/24 [110/2] via 172.16.5.4, 00:12:10, GigabitEthernet0/1
                       [110/2] via 172.16.2.1, 00:12:10, GigabitEthernet0/0
R3#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
O        172.16.1.0/24 [110/2] via 172.16.3.1, 00:12:28, GigabitEthernet0/0
O        172.16.2.0/24 [110/2] via 172.16.5.2, 00:12:18, GigabitEthernet0/1
                       [110/2] via 172.16.3.1, 00:12:28, GigabitEthernet0/0
O        172.16.4.0/24 [110/2] via 172.16.5.4, 00:12:18, GigabitEthernet0/1
                       [110/2] via 172.16.3.1, 00:12:18, GigabitEthernet0/0
R4#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
O        172.16.1.0/24 [110/2] via 172.16.4.1, 00:13:43, GigabitEthernet0/0
O        172.16.2.0/24 [110/2] via 172.16.5.2, 00:13:43, GigabitEthernet0/1
                       [110/2] via 172.16.4.1, 00:13:43, GigabitEthernet0/0
O        172.16.3.0/24 [110/2] via 172.16.5.3, 00:13:43, GigabitEthernet0/1
                       [110/2] via 172.16.4.1, 00:13:43, GigabitEthernet0/0
conf t
!
router ospf 1
maximum-paths 2
!
end
R1#sh run | section router ospf 1
router ospf 1
 network 172.16.1.1 0.0.0.0 area 0
 network 172.16.2.1 0.0.0.0 area 0
 network 172.16.3.1 0.0.0.0 area 0
 network 172.16.4.1 0.0.0.0 area 0
 maximum-paths 2
R1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O        172.16.5.0/24 [110/2] via 172.16.4.4, 00:01:30, GigabitEthernet0/3
                       [110/2] via 172.16.3.3, 00:01:30, GigabitEthernet0/2
PC-1> ping 172.16.5.102
84 bytes from 172.16.5.102 icmp_seq=1 ttl=62 time=2.812 ms
84 bytes from 172.16.5.102 icmp_seq=2 ttl=62 time=2.823 ms
84 bytes from 172.16.5.102 icmp_seq=3 ttl=62 time=2.974 ms
84 bytes from 172.16.5.102 icmp_seq=4 ttl=62 time=3.375 ms
84 bytes from 172.16.5.102 icmp_seq=5 ttl=62 time=2.981 ms

passive-interface

  • R1
en
conf t
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 1.1.1.1 255.255.255.255
no shut
exit
int gig0/0
ip address 192.168.0.1 255.255.255.0
no shut
exit
int gig0/1
ip address 192.168.1.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
en
conf t
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 2.2.2.2 255.255.255.255
no shut
exit
int gig0/0
ip address 192.168.1.2 255.255.255.0
no shut
exit
int gig0/1
ip address 192.168.2.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
en
conf t
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int lo0
ip address 3.3.3.3 255.255.255.255
no shut
exit
int gig0/0
ip address 192.168.2.3 255.255.255.0
no shut
exit
int gig0/1
ip address 192.168.3.3 255.255.255.0
no shut
exit
!
end
wr
  • PC1
ip 192.168.0.101 255.255.255.0 192.168.0.1
save
  • PC2
ip 192.168.3.102 255.255.255.0 192.168.3.3
save
  • R1
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.0.1 0.0.0.0 area 0
network 192.168.1.1 0.0.0.0 area 0
exit
!
end
  • R2
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.1.2 0.0.0.0 area 0
network 192.168.2.2 0.0.0.0 area 0
exit
!
end
  • R3
en
conf t
!
! OSPF Configuration
router ospf 1
network 192.168.2.3 0.0.0.0 area 0
network 192.168.3.3 0.0.0.0 area 0
!
end
R1#debug ip ospf packet
OSPF packet debugging is on
R1#
*Oct  2 22:48:51.971: OSPF-1 PAK  : Gi0/1:  IN: 192.168.1.2->224.0.0.5: ver:2 type:1 len:48 rid:2.2.2.2 area:0.0.0.0 chksum:6340 auth:0
R1#
*Oct  2 22:48:53.949: OSPF-1 PAK  : Gi0/0: OUT: 192.168.0.1->224.0.0.5: ver:2 type:1 len:44 rid:1.1.1.1 area:0.0.0.0 chksum:29F3 auth:0
*Oct  2 22:48:54.874: OSPF-1 PAK  : Gi0/1: OUT: 192.168.1.1->224.0.0.5: ver:2 type:1 len:48 rid:1.1.1.1 area:0.0.0.0 chksum:6340 auth:0
R1#
*Oct  2 22:49:01.046: OSPF-1 PAK  : Gi0/1:  IN: 192.168.1.2->224.0.0.5: ver:2 type:1 len:48 rid:2.2.2.2 area:0.0.0.0 chksum:6340 auth:0
R1#
*Oct  2 22:49:03.852: OSPF-1 PAK  : Gi0/0: OUT: 192.168.0.1->224.0.0.5: ver:2 type:1 len:44 rid:1.1.1.1 area:0.0.0.0 chksum:29F3 auth:0
*Oct  2 22:49:03.961: OSPF-1 PAK  : Gi0/1: OUT: 192.168.1.1->224.0.0.5: ver:2 type:1 len:48 rid:1.1.1.1 area:0.0.0.0 chksum:6340 auth:0
R3#debug ip ospf packet
OSPF packet debugging is on
R3#
*Oct  2 22:48:49.181: OSPF-1 PAK  : Gi0/0:  IN: 192.168.2.2->224.0.0.5: ver:2 type:1 len:48 rid:2.2.2.2 area:0.0.0.0 chksum:5D3A auth:0
R3#
*Oct  2 22:48:52.958: OSPF-1 PAK  : Gi0/0: OUT: 192.168.2.3->224.0.0.5: ver:2 type:1 len:48 rid:3.3.3.3 area:0.0.0.0 chksum:5D3A auth:0
*Oct  2 22:48:53.489: OSPF-1 PAK  : Gi0/1: OUT: 192.168.3.3->224.0.0.5: ver:2 type:1 len:44 rid:3.3.3.3 area:0.0.0.0 chksum:22ED auth:0
R3#
*Oct  2 22:48:58.525: OSPF-1 PAK  : Gi0/0:  IN: 192.168.2.2->224.0.0.5: ver:2 type:1 len:48 rid:2.2.2.2 area:0.0.0.0 chksum:5D3A auth:0
R3#
*Oct  2 22:49:02.309: OSPF-1 PAK  : Gi0/0: OUT: 192.168.2.3->224.0.0.5: ver:2 type:1 len:48 rid:3.3.3.3 area:0.0.0.0 chksum:5D3A auth:0
*Oct  2 22:49:02.809: OSPF-1 PAK  : Gi0/1: OUT: 192.168.3.3->224.0.0.5: ver:2 type:1 len:44 rid:3.3.3.3 area:0.0.0.0 chksum:22ED auth:0
R3#
*Oct  2 22:49:07.637: OSPF-1 PAK  : Gi0/0:  IN: 192.168.2.2->224.0.0.5: ver:2 type:1 len:48 rid:2.2.2.2 area:0.0.0.0 chksum:5D3A auth:0
R3#
*Oct  2 22:49:11.746: OSPF-1 PAK  : Gi0/0: OUT: 192.168.2.3->224.0.0.5: ver:2 type:1 len:48 rid:3.3.3.3 area:0.0.0.0 chksum:5D3A auth:0
*Oct  2 22:49:12.264: OSPF-1 PAK  : Gi0/1: OUT: 192.168.3.3->224.0.0.5: ver:2 type:1 len:44 rid:3.3.3.3 area:0.0.0.0 chksum:22ED auth:0
R3#
R1#debug ip ospf hello
OSPF hello debugging is on
R1#
R1#
*Oct  6 02:47:40.551: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
*Oct  6 02:47:41.013: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1#
*Oct  6 02:47:46.608: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:47:50.214: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
*Oct  6 02:47:50.265: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
R1#
*Oct  6 02:47:55.625: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:47:59.557: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
*Oct  6 02:47:59.740: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1#
*Oct  6 02:48:05.175: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:48:08.865: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
*Oct  6 02:48:08.893: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1#
*Oct  6 02:48:14.841: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:48:17.981: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
*Oct  6 02:48:18.185: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
R1#
*Oct  6 02:48:24.836: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:48:27.307: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
*Oct  6 02:48:27.426: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
R1#
*Oct  6 02:48:34.410: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:48:37.138: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
*Oct  6 02:48:37.264: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1#
*Oct  6 02:48:44.360: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1#
*Oct  6 02:48:46.178: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.0.1
*Oct  6 02:48:46.600: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1#
*Oct  6 02:48:53.524: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R2#debug ip ospf hello
OSPF hello debugging is on
R2#
R2#
*Oct  6 02:48:47.310: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.1.2
R2#
*Oct  6 02:48:51.068: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.2.2
R2#
*Oct  6 02:48:54.237: OSPF-1 HELLO Gi0/0: Rcv hello from 1.1.1.1 area 0 192.168.1.1
R2#
*Oct  6 02:48:55.734: OSPF-1 HELLO Gi0/1: Rcv hello from 3.3.3.3 area 0 192.168.2.3
R2#
*Oct  6 02:48:56.744: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.1.2
R2#
*Oct  6 02:49:00.369: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.2.2
R2#
*Oct  6 02:49:04.133: OSPF-1 HELLO Gi0/0: Rcv hello from 1.1.1.1 area 0 192.168.1.1
*Oct  6 02:49:04.903: OSPF-1 HELLO Gi0/1: Rcv hello from 3.3.3.3 area 0 192.168.2.3
R2#
*Oct  6 02:49:06.742: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.1.2
R2#
*Oct  6 02:49:09.744: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.2.2
R2#
*Oct  6 02:49:13.856: OSPF-1 HELLO Gi0/0: Rcv hello from 1.1.1.1 area 0 192.168.1.1
*Oct  6 02:49:13.919: OSPF-1 HELLO Gi0/1: Rcv hello from 3.3.3.3 area 0 192.168.2.3
R2#
*Oct  6 02:49:16.597: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.1.2
R2#
*Oct  6 02:49:19.069: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.2.2
R2#
*Oct  6 02:49:23.252: OSPF-1 HELLO Gi0/0: Rcv hello from 1.1.1.1 area 0 192.168.1.1
*Oct  6 02:49:23.871: OSPF-1 HELLO Gi0/1: Rcv hello from 3.3.3.3 area 0 192.168.2.3
R2#
*Oct  6 02:49:26.106: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.1.2
R2#
R3#debug ip ospf hello
OSPF hello debugging is on
R3#
R3#
*Oct  6 02:48:22.292: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:48:26.166: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
R3#
*Oct  6 02:48:28.043: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:48:31.853: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:48:35.651: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
R3#
*Oct  6 02:48:37.571: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:48:41.674: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:48:44.689: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
R3#
*Oct  6 02:48:46.762: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:48:51.534: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:48:54.162: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
R3#
*Oct  6 02:48:56.184: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:49:00.814: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:49:04.136: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
R3#
*Oct  6 02:49:05.288: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:49:10.134: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:49:13.700: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
*Oct  6 02:49:14.311: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:49:19.456: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:49:23.223: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
R3#
*Oct  6 02:49:24.251: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:49:28.561: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
*Oct  6 02:49:33.040: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.3.3
*Oct  6 02:49:33.914: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3#
*Oct  6 02:49:37.592: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3#
conf t
router ospf 1
passive-interface gig0/0
R1(config-router)#passive-interface gig0/0
R1(config-router)#
*Oct  6 02:52:12.500: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:52:15.642: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1(config-router)#
*Oct  6 02:52:21.996: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:52:25.324: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1(config-router)#
*Oct  6 02:52:31.200: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:52:34.571: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1(config-router)#
*Oct  6 02:52:40.490: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:52:43.943: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1(config-router)#
*Oct  6 02:52:50.482: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:52:53.229: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1(config-router)#
*Oct  6 02:52:59.672: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:53:02.836: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R1(config-router)#
*Oct  6 02:53:09.513: OSPF-1 HELLO Gi0/1: Send hello to 224.0.0.5 area 0 from 192.168.1.1
R1(config-router)#
*Oct  6 02:53:12.209: OSPF-1 HELLO Gi0/1: Rcv hello from 2.2.2.2 area 0 192.168.1.2
R3(config-router)#passive-interface gig0/1
R3(config-router)#
*Oct  6 02:52:20.908: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:52:24.139: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:52:30.457: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:52:33.335: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:52:40.209: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:52:43.061: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:52:49.420: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:52:52.949: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:52:58.719: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:53:02.763: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:53:07.911: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:53:12.469: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:53:17.580: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R3(config-router)#
*Oct  6 02:53:21.996: OSPF-1 HELLO Gi0/0: Send hello to 224.0.0.5 area 0 from 192.168.2.3
R3(config-router)#
*Oct  6 02:53:26.985: OSPF-1 HELLO Gi0/0: Rcv hello from 2.2.2.2 area 0 192.168.2.2
R1#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.0.1 0.0.0.0 area 0
    192.168.1.1 0.0.0.0 area 0
  Passive Interface(s):
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      01:45:33
  Distance: (default is 110)

R1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

O     192.168.2.0/24 [110/2] via 192.168.1.2, 01:47:18, GigabitEthernet0/1
O     192.168.3.0/24 [110/3] via 192.168.1.2, 01:47:08, GigabitEthernet0/1
R3#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 3.3.3.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.2.3 0.0.0.0 area 0
    192.168.3.3 0.0.0.0 area 0
  Passive Interface(s):
    GigabitEthernet0/1
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.2              110      01:45:54
    1.1.1.1              110      01:45:54
  Distance: (default is 110)

R3#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

O     192.168.0.0/24 [110/3] via 192.168.2.2, 01:47:26, GigabitEthernet0/0
O     192.168.1.0/24 [110/2] via 192.168.2.2, 01:47:26, GigabitEthernet0/0
passive-interface default for Layer 3 switch

  • SW1
en
conf t
!
hostname SW1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
ip routing
!
vlan 10,20,30,40
exit
!
int vlan 10
ip address 172.16.10.1 255.255.255.0
no shut
exit
int vlan 20
ip address 172.16.20.1 255.255.255.0
no shut
exit
int vlan 30
ip address 172.16.30.1 255.255.255.0
no shut
exit
int vlan 40
ip address 172.16.40.1 255.255.255.0
no shut
exit
!
int gig0/0
switchport mode access
switchport access vlan 10
exit
int gig0/1
switchport mode access
switchport access vlan 20
exit
int gig0/2
switchport mode access
switchport access vlan 30
exit
int gig0/3
switchport mode access
switchport access vlan 40
exit
!
router ospf 1
network 172.16.10.1 0.0.0.0 area 0
network 172.16.20.1 0.0.0.0 area 0
network 172.16.30.1 0.0.0.0 area 0
network 172.16.40.1 0.0.0.0 area 0
exit
!
end
wr
  • SW2
en
conf t
!
hostname SW2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
ip routing
!
vlan 10,50,60,70
exit
!
int vlan 10
ip address 172.16.10.2 255.255.255.0
no shut
exit
int vlan 50
ip address 172.16.50.2 255.255.255.0
no shut
exit
int vlan 60
ip address 172.16.60.2 255.255.255.0
no shut
exit
int vlan 70
ip address 172.16.70.2 255.255.255.0
no shut
exit
!
int gig0/0
switchport mode access
switchport access vlan 10
exit
int gig0/1
switchport mode access
switchport access vlan 50
exit
int gig0/2
switchport mode access
switchport access vlan 60
exit
int gig0/3
switchport mode access
switchport access vlan 70
exit
!
router ospf 1
network 172.16.10.2 0.0.0.0 area 0
network 172.16.50.2 0.0.0.0 area 0
network 172.16.60.2 0.0.0.0 area 0
network 172.16.70.2 0.0.0.0 area 0
exit
!
end
wr
  • PC1
ip 172.16.20.101 255.255.255.0 172.16.20.1
save
  • PC2
ip 172.16.30.102 255.255.255.0 172.16.30.1
save
  • PC3
ip 172.16.40.103 255.255.255.0 172.16.40.1
save
  • PC4
ip 172.16.50.104 255.255.255.0 172.16.50.2
save
  • PC5
ip 172.16.60.105 255.255.255.0 172.16.60.2
save
  • PC6
ip 172.16.70.106 255.255.255.0 172.16.70.2
save
SW1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 11 subnets, 2 masks
C        172.16.10.0/24 is directly connected, Vlan10
L        172.16.10.1/32 is directly connected, Vlan10
C        172.16.20.0/24 is directly connected, Vlan20
L        172.16.20.1/32 is directly connected, Vlan20
C        172.16.30.0/24 is directly connected, Vlan30
L        172.16.30.1/32 is directly connected, Vlan30
C        172.16.40.0/24 is directly connected, Vlan40
L        172.16.40.1/32 is directly connected, Vlan40
O        172.16.50.0/24 [110/2] via 172.16.10.2, 00:00:31, Vlan10
O        172.16.60.0/24 [110/2] via 172.16.10.2, 00:00:31, Vlan10
O        172.16.70.0/24 [110/2] via 172.16.10.2, 00:00:31, Vlan10
SW1#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.16.10.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.10.1 0.0.0.0 area 0
    172.16.20.1 0.0.0.0 area 0
    172.16.30.1 0.0.0.0 area 0
    172.16.40.1 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.10.2          110      00:01:13
  Distance: (default is 110)
SW2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 11 subnets, 2 masks
C        172.16.10.0/24 is directly connected, Vlan10
L        172.16.10.2/32 is directly connected, Vlan10
O        172.16.20.0/24 [110/2] via 172.16.10.1, 00:00:49, Vlan10
O        172.16.30.0/24 [110/2] via 172.16.10.1, 00:00:49, Vlan10
O        172.16.40.0/24 [110/2] via 172.16.10.1, 00:00:49, Vlan10
C        172.16.50.0/24 is directly connected, Vlan50
L        172.16.50.2/32 is directly connected, Vlan50
C        172.16.60.0/24 is directly connected, Vlan60
L        172.16.60.2/32 is directly connected, Vlan60
C        172.16.70.0/24 is directly connected, Vlan70
L        172.16.70.2/32 is directly connected, Vlan70
SW2#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.16.10.2
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.10.2 0.0.0.0 area 0
    172.16.50.2 0.0.0.0 area 0
    172.16.60.2 0.0.0.0 area 0
    172.16.70.2 0.0.0.0 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.10.1          110      00:01:18
  Distance: (default is 110)
PC-1> ping 172.16.70.106
172.16.70.106 icmp_seq=1 timeout
84 bytes from 172.16.70.106 icmp_seq=2 ttl=62 time=10.786 ms
84 bytes from 172.16.70.106 icmp_seq=3 ttl=62 time=5.702 ms
84 bytes from 172.16.70.106 icmp_seq=4 ttl=62 time=6.371 ms
84 bytes from 172.16.70.106 icmp_seq=5 ttl=62 time=5.389 ms
debug ip ospf hello
undebug all
SW1#debug ip ospf hello
OSPF hello debugging is on
SW1#
*Oct  6 03:43:40.501: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#
*Oct  6 03:43:45.567: OSPF-1 HELLO Vl40: Send hello to 224.0.0.5 area 0 from 172.16.40.1
*Oct  6 03:43:45.666: OSPF-1 HELLO Vl30: Send hello to 224.0.0.5 area 0 from 172.16.30.1
*Oct  6 03:43:45.720: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:43:47.735: OSPF-1 HELLO Vl20: Send hello to 224.0.0.5 area 0 from 172.16.20.1
SW1#
*Oct  6 03:43:50.428: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#
*Oct  6 03:43:54.781: OSPF-1 HELLO Vl40: Send hello to 224.0.0.5 area 0 from 172.16.40.1
*Oct  6 03:43:55.108: OSPF-1 HELLO Vl30: Send hello to 224.0.0.5 area 0 from 172.16.30.1
*Oct  6 03:43:55.717: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:43:56.898: OSPF-1 HELLO Vl20: Send hello to 224.0.0.5 area 0 from 172.16.20.1
SW1#
*Oct  6 03:44:00.194: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#
*Oct  6 03:44:04.421: OSPF-1 HELLO Vl40: Send hello to 224.0.0.5 area 0 from 172.16.40.1
*Oct  6 03:44:04.437: OSPF-1 HELLO Vl30: Send hello to 224.0.0.5 area 0 from 172.16.30.1
*Oct  6 03:44:05.313: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:44:06.497: OSPF-1 HELLO Vl20: Send hello to 224.0.0.5 area 0 from 172.16.20.1
SW1#
*Oct  6 03:44:09.985: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW2#debug ip ospf hello
OSPF hello debugging is on
SW2#
*Oct  6 03:43:43.024: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:43:44.030: OSPF-1 HELLO Vl70: Send hello to 224.0.0.5 area 0 from 172.16.70.2
*Oct  6 03:43:44.087: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 172.16.60.2
*Oct  6 03:43:44.303: OSPF-1 HELLO Vl50: Send hello to 224.0.0.5 area 0 from 172.16.50.2
SW2#
*Oct  6 03:43:48.219: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:43:52.995: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
*Oct  6 03:43:53.339: OSPF-1 HELLO Vl70: Send hello to 224.0.0.5 area 0 from 172.16.70.2
*Oct  6 03:43:53.392: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 172.16.60.2
*Oct  6 03:43:53.590: OSPF-1 HELLO Vl50: Send hello to 224.0.0.5 area 0 from 172.16.50.2
SW2#
*Oct  6 03:43:58.266: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:44:02.600: OSPF-1 HELLO Vl70: Send hello to 224.0.0.5 area 0 from 172.16.70.2
*Oct  6 03:44:02.768: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
*Oct  6 03:44:02.841: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 172.16.60.2
*Oct  6 03:44:02.873: OSPF-1 HELLO Vl50: Send hello to 224.0.0.5 area 0 from 172.16.50.2
SW2#
*Oct  6 03:44:07.893: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1

there is no passive interface configured, then so noisy.

conf t
router ospf 1
passive-interface default
no passive-interface gig0/0
SW1(config-router)#passive-interface default
SW1(config-router)#
*Oct  6 03:46:26.532: OSPF-1 HELLO Vl40: Send hello to 224.0.0.5 area 0 from 172.16.40.1
*Oct  6 03:46:26.973: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
*Oct  6 03:46:27.667: OSPF-1 HELLO Vl30: Send hello to 224.0.0.5 area 0 from 172.16.30.1
SW1(config-router)#
*Oct  6 03:46:27.867: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.2 on Vlan10 from FULL to DOWN, Neighbor Down: Interface down or detached
SW1(config-router)#no pass
SW1(config-router)#no passive-interface gig0/0
SW1(config-router)#^Z
SW1#
*Oct  6 03:47:17.161: %SYS-5-CONFIG_I: Configured from console by console
SW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW1(config)#do sh run | s ospf
router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet0/0
 network 172.16.10.1 0.0.0.0 area 0
 network 172.16.20.1 0.0.0.0 area 0
 network 172.16.30.1 0.0.0.0 area 0
 network 172.16.40.1 0.0.0.0 area 0
SW1(config)#passive-interface gig0/0
                ^
% Invalid input detected at '^' marker.

SW1(config)#router
SW1(config)#router ospf 1
SW1(config-router)#passive-interface gig0/0
SW1(config-router)#pass
SW1(config-router)#passive-interface vla
SW1(config-router)#passive-interface vlan 10
SW1(config-router)#no passive-interface vlan 10
SW1(config-router)#
*Oct  6 03:48:37.867: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1(config-router)#
*Oct  6 03:48:47.552: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1(config-router)#
*Oct  6 03:48:54.363: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
*Oct  6 03:48:54.364: OSPF-1 HELLO Vl10: Send immediate hello to nbr 172.16.10.2, src address 172.16.10.2
*Oct  6 03:48:54.364: OSPF-1 HELLO Vl10: Send hello to 172.16.10.2 area 0 from 172.16.10.1
*Oct  6 03:48:54.378: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1(config-router)#
*Oct  6 03:48:57.176: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1(config-router)#^Z
SW1#
*Oct  6 03:49:02.080: %SYS-5-CONFIG_I: Configured from console by console
SW1#
*Oct  6 03:49:03.543: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#sh ip os
SW1#sh ip ospf
*Oct  6 03:49:06.409: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#sh run
*Oct  6 03:49:13.458: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2s
SW1#sh run s
*Oct  6 03:49:15.512: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.
SW1#sh run | sec ip osfp
*Oct  6 03:49:23.119: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#sh run | sec ro
*Oct  6 03:49:25.003: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#sh run | sec router ospf 1

*Oct  6 03:49:32.804: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2router ospf 1
 passive-interface default
 no passive-interface Vlan10
 network 172.16.10.1 0.0.0.0 area 0
 network 172.16.20.1 0.0.0.0 area 0
 network 172.16.30.1 0.0.0.0 area 0
 network 172.16.40.1 0.0.0.0 area 0
SW1#
*Oct  6 03:49:34.189: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
*Oct  6 03:49:34.342: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.2 on Vlan10 from LOADING to FULL, Loading Done
SW1#
*Oct  6 03:49:42.561: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#
*Oct  6 03:49:43.592: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:49:51.554: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#
*Oct  6 03:49:52.750: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:50:01.342: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
*Oct  6 03:50:01.922: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:50:10.665: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
*Oct  6 03:50:11.291: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#
*Oct  6 03:50:19.772: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#
*Oct  6 03:50:21.056: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#u all
*Oct  6 03:50:29.157: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.2 area 0 172.16.10.2
SW1#u all
*Oct  6 03:50:30.904: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.1
SW1#u all
All possible debugging has been turned off
SW2(config-router)#passive-interface default
SW2(config-router)#
*Oct  6 03:46:32.389: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on Vlan10 from FULL to DOWN, Neighbor Down: Interface down or detached
SW2(config-router)#no passive-interface gig0/0
SW2(config-router)#^Z
SW2#
*Oct  6 03:47:20.726: %SYS-5-CONFIG_I: Configured from console by console
SW2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW2(config)#no passive-interface vlan 10
                   ^
% Invalid input detected at '^' marker.

SW2(config)#router ospf 1
SW2(config-router)#no pass
SW2(config-router)#no passive-interface vlan 10
SW2(config-router)#
*Oct  6 03:48:57.598: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
*Oct  6 03:48:57.613: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
*Oct  6 03:48:57.614: OSPF-1 HELLO Vl10: Send immediate hello to nbr 172.16.10.1, src address 172.16.10.1
*Oct  6 03:48:57.614: OSPF-1 HELLO Vl10: Send hello to 172.16.10.1 area 0 from 172.16.10.2
SW2(config-router)#
*Oct  6 03:49:00.459: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2(config-router)#^Z
SW2#
*Oct  6 03:49:05.827: %SYS-5-CONFIG_I: Configured from console by console
SW2#
*Oct  6 03:49:06.803: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:49:09.694: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:49:16.788: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:49:18.865: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:49:26.494: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:49:28.389: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:49:36.220: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:49:37.628: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#sh run | sec router ospf 1
*Oct  6 03:49:37.720: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on Vlan10 from LOADING to FULL, Loading Done
SW2#sh run | sec router ospf 1
router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface Vlan10
 network 172.16.10.2 0.0.0.0 area 0
 network 172.16.50.2 0.0.0.0 area 0
 network 172.16.60.2 0.0.0.0 area 0
 network 172.16.70.2 0.0.0.0 area 0
SW2#
*Oct  6 03:49:46.043: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:49:47.107: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:49:55.062: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:49:56.262: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:50:04.864: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
*Oct  6 03:50:05.458: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:50:14.175: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
*Oct  6 03:50:14.820: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:50:23.307: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#
*Oct  6 03:50:24.564: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:50:32.663: OSPF-1 HELLO Vl10: Send hello to 224.0.0.5 area 0 from 172.16.10.2
SW2#u all
All possible debugging has been turned off
SW2#
*Oct  6 03:50:34.414: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#
*Oct  6 03:50:34.414: OSPF-1 HELLO Vl10: Rcv hello from 172.16.10.1 area 0 172.16.10.1
SW2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW2(config)#router ospf 1
SW2(config-router)#pas
SW2(config-router)#passive-interface gig
SW2(config-router)#passive-interface gigabitEthernet 0/0
SW2(config-router)#^Z
SW2#
*Oct  6 03:52:57.061: %SYS-5-CONFIG_I: Configured from console by console
SW2#sh run | sec router ospf 1
router ospf 1
 passive-interface default
 no passive-interface Vlan10
 network 172.16.10.2 0.0.0.0 area 0
 network 172.16.50.2 0.0.0.0 area 0
 network 172.16.60.2 0.0.0.0 area 0
 network 172.16.70.2 0.0.0.0 area 0

Traffic Black hole…

PC-1> ping 172.16.70.106
172.16.70.106 icmp_seq=1 timeout
172.16.70.106 icmp_seq=2 timeout
172.16.70.106 icmp_seq=3 timeout
172.16.70.106 icmp_seq=4 timeout
172.16.70.106 icmp_seq=5 timeout

another side subnet ping successful.

PC-1> ping 172.16.60.105
84 bytes from 172.16.60.105 icmp_seq=1 ttl=62 time=22.581 ms
84 bytes from 172.16.60.105 icmp_seq=2 ttl=62 time=5.663 ms
84 bytes from 172.16.60.105 icmp_seq=3 ttl=62 time=5.912 ms
84 bytes from 172.16.60.105 icmp_seq=4 ttl=62 time=10.730 ms
84 bytes from 172.16.60.105 icmp_seq=5 ttl=62 time=5.658 ms

reconfigure PC-6 now works.

172.16.70.106 icmp_seq=58 timeout
84 bytes from 172.16.70.106 icmp_seq=59 ttl=62 time=9.127 ms
84 bytes from 172.16.70.106 icmp_seq=60 ttl=62 time=13.600 ms
84 bytes from 172.16.70.106 icmp_seq=61 ttl=62 time=5.408 ms
172.16.70.106 icmp_seq=62 timeout
172.16.70.106 icmp_seq=63 timeout
84 bytes from 172.16.70.106 icmp_seq=64 ttl=62 time=9.775 ms
84 bytes from 172.16.70.106 icmp_seq=65 ttl=62 time=6.708 ms
84 bytes from 172.16.70.106 icmp_seq=66 ttl=62 time=10.058 ms
84 bytes from 172.16.70.106 icmp_seq=67 ttl=62 time=5.520 ms
^C
SW1#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.16.10.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.10.1 0.0.0.0 area 0
    172.16.20.1 0.0.0.0 area 0
    172.16.30.1 0.0.0.0 area 0
    172.16.40.1 0.0.0.0 area 0
  Passive Interface(s):
    Vlan20
    Vlan30
    Vlan40
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.10.2          110      00:02:29
  Distance: (default is 110)

SW1#sh ip ospf int vlan 10
Vlan10 is up, line protocol is up
  Internet Address 172.16.10.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 172.16.10.2, Interface address 172.16.10.2
  Backup Designated router (ID) 172.16.10.1, Interface address 172.16.10.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.10.2  (Designated Router)
  Suppress hello for 0 neighbor(s)
SW2#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.16.10.2
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.10.2 0.0.0.0 area 0
    172.16.50.2 0.0.0.0 area 0
    172.16.60.2 0.0.0.0 area 0
    172.16.70.2 0.0.0.0 area 0
  Passive Interface(s):
    Vlan50
    Vlan60
    Vlan70
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.10.1          110      00:09:56
  Distance: (default is 110)

SW2#sh ip ospf int vlan 10
Vlan10 is up, line protocol is up
  Internet Address 172.16.10.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 172.16.10.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 172.16.10.2, Interface address 172.16.10.2
  Backup Designated router (ID) 172.16.10.1, Interface address 172.16.10.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 1 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.10.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
SW2#sh ip ospf int vlan 20
                        ^
% Invalid input detected at '^' marker.

SW2#sh ip ospf int vlan 50
Vlan50 is up, line protocol is up
  Internet Address 172.16.50.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 172.16.10.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 172.16.10.2, Interface address 172.16.50.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    No Hellos (Passive interface)
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
no router ospf 1

command deletes all subsequent configuration!!(e.g. network)

References

tech/network/cisco/ospf/ospf/ospf-basic/ospf-basic.txt · Last modified: 2018/10/07 16:09 by wnoguchi