User Tools

Site Tools


tech:network:cisco:ospf:interface-authentication:interface-authentication

Cisco: OSPF Interface Authentication

Lab 1: a37028dd-7f55-43c3-b132-654db0f817a0

Topology

Base Configuration

Common Configuration Snippet

R1

R2

R3

Configuring OSPF w/o Authentication 9d900a39-2704-4fe1-bea6-f8334011341c

  • R1
configure terminal
!
router ospf 1
 router-id 1.1.1.1
 network 10.1.1.1 0.0.0.0 area 10
 network 10.1.2.1 0.0.0.0 area 10
 network 1.1.1.1 0.0.0.0 area 10
exit
!
end
  • R2
configure terminal
!
router ospf 1
 router-id 2.2.2.2
 network 10.1.2.2 0.0.0.0 area 10
 network 10.2.3.2 0.0.0.0 area 0
 network 2.2.2.2 0.0.0.0 area 0
exit
!
end
  • R3
configure terminal
!
router ospf 1
 router-id 3.3.3.3
 network 10.2.3.3 0.0.0.0 area 0
 network 10.3.3.3 0.0.0.0 area 0
 network 3.3.3.3 0.0.0.0 area 0
exit
!
end

Verification

Configuring OSPF w/ Interface Authentication d93da3d4-fb34-4950-9cd3-70c185867724

  • R1
configure terminal
!
interface GigabitEthernet 0/1
 ip ospf authentication
 ip ospf authentication-key PG1X
!
router ospf 1
 router-id 1.1.1.1
 network 10.1.1.1 0.0.0.0 area 10
 network 10.1.2.1 0.0.0.0 area 10
 network 1.1.1.1 0.0.0.0 area 10
exit
!
end
  • R2
configure terminal
!
interface GigabitEthernet 0/1
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 SuperSECRET
interface GigabitEthernet 0/2
 ip ospf authentication
 ip ospf authentication-key PG1X
!
router ospf 1
 router-id 2.2.2.2
 network 10.1.2.2 0.0.0.0 area 10
 network 10.2.3.2 0.0.0.0 area 0
 network 2.2.2.2 0.0.0.0 area 0
exit
!
end
  • R3
configure terminal
!
interface GigabitEthernet 0/2
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 SuperSECRET
!
router ospf 1
 router-id 3.3.3.3
 network 10.2.3.3 0.0.0.0 area 0
 network 10.3.3.3 0.0.0.0 area 0
 network 3.3.3.3 0.0.0.0 area 0
exit
!
end

Verification

  • Wireshark Display Filter
ospf
R1(config-if)#ip ospf authentication-key AuthenticateMe
% OSPF: Warning: The password/key will be truncated to 8 characters

R1 Console Log

R2 Console Log

R3 Console Log

Wireshark Packet Capture Result on R2

References

tech/network/cisco/ospf/interface-authentication/interface-authentication.txt · Last modified: 2020/02/23 16:08 by wnoguchi