PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:ospf:distribute-list:distribute-list

Cisco: OSPF: Route Filtering: distribute-list

distribute-list lab

  1. Lab ID: 8f1d8b56-574d-4c47-aa6b-fcfb605f5858

Common

Topology

Base Configuration

R1

R2

R3

R4

Configuring redistribute w/o distribute-list aef01937-7eea-4b94-ba35-32084f2ed5b8

  • R2
configure terminal
!
router eigrp N-EIGRP
 address-family ipv4 unicast autonomous-system 1
  topology base
   ! redistribute from ospf to eigrp
   ! bandwidth[kbps], delay[10us], reliability 100%, load 1, MTU 1500 
   redistribute ospf 1 metric 1000000 1 255 1 1500
  exit-af-topology
 exit-address-family
exit
!
router ospf 1
 ! redistribute from eigrp to ospf
 redistribute eigrp 1 subnets
exit
!
end

Configuring distribute-list out w/ redistribute b9de70c1-b53b-4ebc-99e3-4965720aaab5

  • R2
configure terminal
!
access-list 10 deny 172.16.8.0 0.0.0.255
access-list 10 deny 172.16.9.0 0.0.0.255
access-list 10 deny 172.16.10.0 0.0.0.255
access-list 10 permit any
!
router eigrp N-EIGRP
 address-family ipv4 unicast autonomous-system 1
  topology base
   ! redistribute from ospf to eigrp
   ! bandwidth[kbps], delay[10us], reliability 100%, load 1, MTU 1500 
   redistribute ospf 1 metric 1000000 1 255 1 1500
  exit-af-topology
 exit-address-family
exit
!
router ospf 1
 ! redistribute from eigrp to ospf
 redistribute eigrp 1 subnets
 distribute-list 10 out eigrp 1
exit
!
end

Verification

R1

R2

R3

R4

Configuring distribute-list in w/ redistribute ccd11159-e44a-4806-b2b5-359fb09fd6ba

  • R2
configure terminal
!
router eigrp N-EIGRP
 address-family ipv4 unicast autonomous-system 1
  topology base
   ! redistribute from ospf to eigrp
   ! bandwidth[kbps], delay[10us], reliability 100%, load 1, MTU 1500 
   redistribute ospf 1 metric 1000000 1 255 1 1500
  exit-af-topology
 exit-address-family
exit
!
router ospf 1
 ! redistribute from eigrp to ospf
 redistribute eigrp 1 subnets
exit
!
end
  • R3
configure terminal
!
access-list 10 deny 172.16.8.0 0.0.0.255
access-list 10 deny 172.16.9.0 0.0.0.255
access-list 10 deny 172.16.10.0 0.0.0.255
access-list 10 permit any
!
router ospf 1
 distribute-list 10 in GigabitEthernet 0/1
exit
!
end

Verification

R1

R2

R3

R4

Configuring distribute-list in w/o redistribute 32e9f386-a7fb-4ac3-ae28-00aa438ac23d

R1 is not used.

  • R2
configure terminal
!
interface Loopback 0
 ip address 10.2.0.2 255.255.255.0
 ip ospf network point-to-point
interface Loopback 1
 ip address 10.2.1.2 255.255.255.0
 ip ospf network point-to-point
interface Loopback 2
 ip address 10.2.2.2 255.255.255.0
 ip ospf network point-to-point
interface Loopback 3
 ip address 10.2.3.2 255.255.255.0
 ip ospf network point-to-point
interface Loopback 4
 ip address 10.2.4.2 255.255.255.0
 ip ospf network point-to-point
interface Loopback 5
 ip address 10.2.5.2 255.255.255.0
 ip ospf network point-to-point
interface Loopback 6
 ip address 10.2.6.2 255.255.255.0
 ip ospf network point-to-point
!
router ospf 1
 network 10.2.0.2 0.0.0.0 area 0
 network 10.2.1.2 0.0.0.0 area 0
 network 10.2.2.2 0.0.0.0 area 0
 network 10.2.3.2 0.0.0.0 area 0
 network 10.2.4.2 0.0.0.0 area 0
 network 10.2.5.2 0.0.0.0 area 0
 network 10.2.6.2 0.0.0.0 area 0
exit
!
end
  • R3
configure terminal
!
access-list 10 deny 10.2.2.0 0.0.0.255
access-list 10 deny 10.2.3.0 0.0.0.255
access-list 10 deny 10.2.4.0 0.0.0.255
access-list 10 permit any
! or
access-list 10 deny 10.2.4.0 0.0.1.255
access-list 10 permit any
!
router ospf 1
 distribute-list 10 in GigabitEthernet 0/1
exit
!
end

Verification

R2

R3

R4

References

tech/network/cisco/ospf/distribute-list/distribute-list.txt · Last modified: 2020/05/03 15:43 by wnoguchi