PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:nat-timeout:nat-timeout

This is an old revision of the document!


NAT Timeout

Physical Lab 6

Using Cisco IOS 15.1(4)M10, Cisco ISR1841 box.

Common Configuration

en
conf t
!
! ip configuration
int f0/1
ip addr 192.168.10.210 255.255.255.0
no shut
exit
int f0/0
ip addr 172.16.2.1 255.255.255.0
no shut
exit
!
! default route
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!
end

Dynamic NAT

conf t
!
ip nat pool PG1X-NAT-POOL 192.168.10.211 192.168.10.212 netmask 255.255.255.248
!
access-list 1 permit 172.16.2.11
access-list 1 permit 172.16.2.12
access-list 1 permit 172.16.2.13
!
ip nat inside source list 1 pool PG1X-NAT-POOL
!
int f0/1
ip nat outside
exit
!
int f0/0
ip nat inside
exit
!
end
pi@pi1:~ $ nc 160.16.63.136 80
GET /
pi@pi2:~ $ nc 160.16.63.136 80
GET /
pi@pi3:~ $ nc 160.16.63.136 80
GET /

PAT

conf t
!
access-list 1 permit 172.16.2.0 0.0.0.255
!
ip nat inside source list 1 interface f0/1 overload
!
int f0/0
ip nat inside
exit
int f0/1
ip nat outside
exit
!
end
pi@pi1:~ $ nc 160.16.63.136 80
GET /
pi@pi2:~ $ nc 160.16.63.136 80
GET /
pi@pi3:~ $ nc 160.16.63.136 80
GET /
R1#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- 192.168.10.211     172.16.2.11        ---                ---
--- 192.168.10.212     172.16.2.12        ---                ---
R1#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
tcp 192.168.10.211:50321 172.16.2.11:50321 160.16.63.136:80  160.16.63.136:80
--- 192.168.10.211     172.16.2.11        ---                ---
--- 192.168.10.212     172.16.2.12        ---                ---

References

tech/network/cisco/nat-timeout/nat-timeout.1523577578.txt.gz · Last modified: 2018/04/13 08:59 by wnoguchi