PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:multicast:l2:igmp:igmp-snooping-configuration:igmp-snooping-configuration

Multicast IGMP Snooping Configuration

Based on INCOMPLETE: Multicast IGMP Configuration

  • R3
configure terminal
!
interface GigabitEthernet0/2
 ip pim sparse-mode
 no shutdown
interface GigabitEthernet0/2.100
 encapsulation dot1q 100
 ip address 10.100.100.100 255.255.255.0
 ip pim sparse-mode
!
end
  • SW1
configure terminal
!
vtp mode transparent
vlan 1,100
exit
interface GigabitEthernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
interface GigabitEthernet0/1
 switchport mode access
 switchport access vlan 1
interface GigabitEthernet0/2
 switchport mode access
 switchport access vlan 100
 spanning-tree portfast
!
end
  • SW1
configure terminal
!
no ip igmp snooping vlan 100
interface GigabitEthernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
interface GigabitEthernet0/1
 switchport mode access
 switchport access vlan 1
interface GigabitEthernet0/2
 switchport mode access
 switchport access vlan 100
 spanning-tree portfast
!
end
  • Sender
msend -g 239.0.1.1 -p 8888 -text "hello multicast world" -t 60
msend -g 239.0.1.2 -p 8888 -text "hello multicast world" -t 60
msend -g 239.0.1.3 -p 8888 -text "hello multicast world" -t 60
  • Receiver
mreceive -g 239.0.1.1 -p 8888
mreceive -g 239.0.1.2 -p 8888
mreceive -g 239.0.1.3 -p 8888
  • Verify Operation
show ip igmp snooping
show ip igmp snooping mrouter
show ip igmp snooping querier
show ip igmp snooping groups
  1. How to recovery disable IGMP Snooping and enable traffic disruption...

Console Log R3

Console Log SW1

Immediate Leave

  • SW1
configure terminal
!
ip igmp snooping vlan 100
ip igmp snooping vlan 100 immediate-leave
!
end

Console Log

IGMP Leave Timer

  • SW1
configure terminal
!
! Global
ip igmp snooping last-member-query-interval 900
! VLAN: Global configuration will be overridden
ip igmp snooping vlan 100 last-menber-query-interval 800

!
end

Console Log

Disable IGMP Report Suppression

  • SW1
configure terminal
!
no ip igmp snooping report-suppression
!
end

Console Log

Multicast Router Port Learning [Deprecated]

Catalyst switch will learn multicast router port using one of following method.

  1. Default: IGMP query, PIM packet, DVMRP(Distance Vector Multicast Routing Protocol)
  2. CGMP(Cisco Group Management Protocol)
  3. Static connection to multicast router port: ip igmp snooping mrouter
  • SW1
configure terminal
!
! Default: IGMP query, PIM packet, DVMRP
ip igmp snooping vlan 100 mrouter learn pim-dvmrp
! CGMP packet
ip igmp snooping vlan 100 mrouter learn cgmp
! Static PIM router port connection
ip igmp snooping vlan 100 mrouter interface GigabitEthernet0/0
!
end

Console Log

INCOMPLETE: Multicast group join host static configuration

Usually host or L2 port join multicast groups dynamically.
But can be configured statically.

ip igmp snooping static

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipmulti/command/imc-cr-book/imc_i1.html#wp2791649010

ip igmp snooping vlan 100 static

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipmulti/command/imc-cr-book/imc_i1.html#wp2605932137

following command not applicable…

  1. IGMP Snooping join host static
  • SW1
configure terminal
!
! Invalid...
ip igmp snooping vlan 100 static 239.0.1.3 interface GigabitEthernet0/2
! Invalid...
ip igmp snooping static 239.0.1.3 interface GigabitEthernet0/2
!
end

Console Log

References

tech/network/cisco/multicast/l2/igmp/igmp-snooping-configuration/igmp-snooping-configuration.txt · Last modified: 2021/11/23 18:17 by wnoguchi