PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:ipv6:ripng:ripng

RIPng

Topology

IP

Project name: ccna-ipv6-0001-ripng

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:1:1:10::1/64
no shutdown
exit
interface Lo 0
ipv6 address fe80::1 link-local
ipv6 address 2001:1:1:1::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:1:1:10::2/64
no shutdown
exit
interface Lo 0
ipv6 address fe80::2 link-local
ipv6 address 2001:1:1:2::2/64
no shutdown
exit
!
end
write

RIPng Configuration

  • R1
enable
configure terminal
!
ipv6 router rip P1
exit
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface Lo 0
ipv6 rip P1 enable
exit
!
end
write
  • R2
enable
configure terminal
!
ipv6 router rip P1
exit
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface Lo 0
ipv6 rip P1 enable
exit
!
end
write
show ipv6 rip
show ipv6 route
debug ipv6 rip
R1#ping 2001:1:1:10::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:10::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/10/22 ms
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 route
R1(config)#ipv6 router
R1(config)#ipv6 router rip
R1(config)#ipv6 router rip P1
R1(config-rtr)#exit
R1(config)#int gig0/0
R1(config-if)#ipv
R1(config-if)#ipv6 rip
R1(config-if)#ipv6 rip P1 en
R1(config-if)#ipv6 rip P1 enable 
R1(config-if)#int Lo0
R1(config-if)#ipv
R1(config-if)#ipv6 rip
R1(config-if)#ipv6 rip P1 enable
R1(config-if)#^Z
R1#
*Mar  4 23:07:09.797: %SYS-5-CONFIG_I: Configured from console by console
R1#sh
R1#show ipv
R1#show ipv6 rip
R1#show ipv6 rip 
RIP process "P1", port 521, multicast-group FF02::9, pid 48
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 5, trigger updates 3
     Full Advertisement 0, Delayed Events 0
  Interfaces:
    Loopback0
    GigabitEthernet0/0
  Redistribution:
    None
R1#sho
R1#show ipv
R1#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:1:1:1::/64 [0/0]
     via Loopback0, directly connected
L   2001:1:1:1::1/128 [0/0]
     via Loopback0, receive
R   2001:1:1:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/0
C   2001:1:1:10::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:1:1:10::1/128 [0/0]
     via GigabitEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
R1#ping 2001:1:1:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
R1#traceroute 2001:1:1:2::2
Type escape sequence to abort.
Tracing the route to 2001:1:1:2::2

  1 2001:1:1:10::2 5 msec 3 msec 3 msec
R1#debu
R1#debug ip
R1#debug ipv
R1#debug ipv6 ri
R1#debug ipv6 rip 
  RIP Routing Protocol debugging is on
R1#
*Mar  4 23:11:03.050: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:03.050:        src=FE80::1
*Mar  4 23:11:03.050:        dst=FF02::9 (Loopback0)
*Mar  4 23:11:03.051:        sport=521, dport=521, length=72
*Mar  4 23:11:03.051:        command=2, version=1, mbz=0, #rte=3
*Mar  4 23:11:03.052:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:03.052:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  4 23:11:03.052:        tag=0, metric=2, prefix=2001:1:1:2::/64
*Mar  4 23:11:03.053: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:03.053:        src=FE80::1
R1#
*Mar  4 23:11:03.054:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  4 23:11:03.054:        sport=521, dport=521, length=52
*Mar  4 23:11:03.055:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:03.055:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:03.055:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  4 23:11:03.058: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:03.059: RIPng [Lo0, default VRF]: process "P1" received own response.
R1#
*Mar  4 23:11:16.545: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:16.545: RIPng [Gi0/0, default VRF]: response received from FE80::2 for process "P1".
*Mar  4 23:11:16.545:        src=FE80::2 (GigabitEthernet0/0)
*Mar  4 23:11:16.546:        dst=FF02::9
*Mar  4 23:11:16.546:        sport=521, dport=521, length=52
*Mar  4 23:11:16.547:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:16.547:        tag=0, metric=1, prefix=2001:1:1:2::/64
*Mar  4 23:11:16.547:        tag=0, metric=1, prefix=2001:1:1:10::/64
R1#
*Mar  4 23:11:40.629: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:40.630:        src=FE80::1
*Mar  4 23:11:40.630:        dst=FF02::9 (Loopback0)
*Mar  4 23:11:40.631:        sport=521, dport=521, length=72
*Mar  4 23:11:40.631:        command=2, version=1, mbz=0, #rte=3
*Mar  4 23:11:40.631:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:40.632:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  4 23:11:40.632:        tag=0, metric=2, prefix=2001:1:1:2::/64
*Mar  4 23:11:40.633: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:40.633:        src=FE80::1
R1#
*Mar  4 23:11:40.634:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  4 23:11:40.634:        sport=521, dport=521, length=52
*Mar  4 23:11:40.635:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:40.635:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:40.635:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  4 23:11:40.640: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:40.640: RIPng [Lo0, default VRF]: process "P1" received own response.
R1#
*Mar  4 23:11:44.396: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:44.397: RIPng [Gi0/0, default VRF]: response received from FE80::2 for process "P1".
*Mar  4 23:11:44.397:        src=FE80::2 (GigabitEthernet0/0)
*Mar  4 23:11:44.398:        dst=FF02::9
*Mar  4 23:11:44.398:        sport=521, dport=521, length=52
*Mar  4 23:11:44.398:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:44.398:        tag=0, metric=1, prefix=2001:1:1:2::/64
*Mar  4 23:11:44.399:        tag=0, metric=1, prefix=2001:1:1:10::/64
R1#u
*Mar  4 23:12:01.444: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:12:01.444:        src=FE80::1
*Mar  4 23:12:01.445:        dst=FF02::9 (Loopback0)
*Mar  4 23:12:01.445:        sport=521, dport=521, length=72
*Mar  4 23:12:01.446:        command=2, version=1, mbz=0, #rte=3
*Mar  4 23:12:01.446:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:12:01.446:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  4 23:12:01.447:        tag=0, metric=2, prefix=2001:1:1:2::/64
*Mar  4 23:12:01.447: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:12:01.448:        src=FE80::1 
R1#u all
All possible debugging has been turned off
R1#
*Mar  4 23:12:01.448:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  4 23:12:01.449:        sport=521, dport=521, length=52
*Mar  4 23:12:01.449:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:12:01.449:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:12:01.450:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  4 23:12:01.453: RIPng [default VRF]: a message has been received.
*Mar  4 23:12:01.453: RIPng [Lo0, default VRF]: process "P1" received own response.
R1#unde
R1#undebug all
All possible debugging has been turned off
R1#
R2#ping 2001:1:1:10::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:10::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/7 ms
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv
R2(config)#ipv6 router ri
R2(config)#ipv6 router rip P1
R2(config-rtr)#int gig0/0
R2(config-if)#ipv
R2(config-if)#ipv6 ri
R2(config-if)#ipv6 rip P1 en
R2(config-if)#ipv6 rip P1 enable 
R2(config-if)#int Lo0
R2(config-if)#ipv
R2(config-if)#ipv6 rip P1 ena
R2(config-if)#ipv6 rip P1 enable 
R2(config-if)#^Z
R2#
*Mar  4 23:08:12.415: %SYS-5-CONFIG_I: Configured from console by console
R2#shw
R2#sho  
R2#show ipv
R2#show ipv6 rip
RIP process "P1", port 521, multicast-group FF02::9, pid 48
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 5, trigger updates 2
     Full Advertisement 0, Delayed Events 0
  Interfaces:
    Loopback0
    GigabitEthernet0/0
  Redistribution:
    None
R2#show
R2#show ipv
R2#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
C   2001:1:1:2::/64 [0/0]
     via Loopback0, directly connected
L   2001:1:1:2::2/128 [0/0]
     via Loopback0, receive
C   2001:1:1:10::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:1:1:10::2/128 [0/0]
     via GigabitEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
R2#show ipv6 route
R2#show ipv6 route?
route  routers  

R2#debu           
R2#debug ipv
R2#debug ipv6 ri
R2#debug ipv6 rip 
  RIP Routing Protocol debugging is on
R2#
*Mar  4 23:11:03.196: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:03.197: RIPng [Gi0/0, default VRF]: response received from FE80::1 for process "P1".
*Mar  4 23:11:03.197:        src=FE80::1 (GigabitEthernet0/0)
*Mar  4 23:11:03.198:        dst=FF02::9
*Mar  4 23:11:03.198:        sport=521, dport=521, length=52
*Mar  4 23:11:03.198:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:03.199:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:03.199:        tag=0, metric=1, prefix=2001:1:1:1::/64
R2#
*Mar  4 23:11:16.693: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:16.693:        src=FE80::2
*Mar  4 23:11:16.693:        dst=FF02::9 (Loopback0)
*Mar  4 23:11:16.694:        sport=521, dport=521, length=72
*Mar  4 23:11:16.695:        command=2, version=1, mbz=0, #rte=3
*Mar  4 23:11:16.695:        tag=0, metric=1, prefix=2001:1:1:2::/64
*Mar  4 23:11:16.695:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:16.696:        tag=0, metric=2, prefix=2001:1:1:1::/64
*Mar  4 23:11:16.696: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:16.697:        src=FE80::2
R2#
*Mar  4 23:11:16.697:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  4 23:11:16.698:        sport=521, dport=521, length=52
*Mar  4 23:11:16.699:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:16.699:        tag=0, metric=1, prefix=2001:1:1:2::/64
*Mar  4 23:11:16.699:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:16.702: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:16.703: RIPng [Lo0, default VRF]: process "P1" received own response.
R2#
*Mar  4 23:11:40.771: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:40.772: RIPng [Gi0/0, default VRF]: response received from FE80::1 for process "P1".
*Mar  4 23:11:40.772:        src=FE80::1 (GigabitEthernet0/0)
*Mar  4 23:11:40.773:        dst=FF02::9
*Mar  4 23:11:40.773:        sport=521, dport=521, length=52
*Mar  4 23:11:40.773:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:40.773:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:40.774:        tag=0, metric=1, prefix=2001:1:1:1::/64
R2#
*Mar  4 23:11:44.557: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:44.558:        src=FE80::2
*Mar  4 23:11:44.558:        dst=FF02::9 (Loopback0)
*Mar  4 23:11:44.559:        sport=521, dport=521, length=72
*Mar  4 23:11:44.559:        command=2, version=1, mbz=0, #rte=3
*Mar  4 23:11:44.559:        tag=0, metric=1, prefix=2001:1:1:2::/64
*Mar  4 23:11:44.560:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:44.560:        tag=0, metric=2, prefix=2001:1:1:1::/64
*Mar  4 23:11:44.561: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  4 23:11:44.561:        src=FE80::2
R2#
*Mar  4 23:11:44.561:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  4 23:11:44.562:        sport=521, dport=521, length=52
*Mar  4 23:11:44.562:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:11:44.563:        tag=0, metric=1, prefix=2001:1:1:2::/64
*Mar  4 23:11:44.563:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:11:44.567: RIPng [default VRF]: a message has been received.
*Mar  4 23:11:44.567: RIPng [Lo0, default VRF]: process "P1" received own response.
R2#u all
*Mar  4 23:12:01.602: RIPng [default VRF]: a message has been received.
*Mar  4 23:12:01.603: RIPng [Gi0/0, default VRF]: response received from FE80::1 for process "P1".
*Mar  4 23:12:01.603:        src=FE80::1 (GigabitEthernet0/0)
*Mar  4 23:12:01.604:        dst=FF02::9
*Mar  4 23:12:01.604:        sport=521, dport=521, length=52
*Mar  4 23:12:01.604:        command=2, version=1, mbz=0, #rte=2
*Mar  4 23:12:01.605:        tag=0, metric=1, prefix=2001:1:1:10::/64
*Mar  4 23:12:01.605:        tag=0, metric=1, prefix=2001:1:1:1::/64
R2#u all
All possible debugging has been turned off
R2#unde
R2#undebug all
All possible debugging has been turned off
R2#

Topology

IP

Project name: ccna-ipv6-0002-ripng-maximum-paths

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface Loopback 0
ipv6 address fe80::1 link-local
ipv6 address 2001:1:1:1::1/64
no shutdown
exit
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:4::1/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:5::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface Loopback 0
ipv6 address fe80::2 link-local
ipv6 address 2001:2:2:2::2/64
no shutdown
exit
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:3::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:5::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::3 link-local
ipv6 address 2001:0:2:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:1:4::4/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write
  • R5
enable
configure terminal
!
hostname R5
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::5 link-local
ipv6 address 2001:0:1:5::5/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::5 link-local
ipv6 address 2001:0:2:5::5/64
no shutdown
exit
!
end
write

RIPng Configuration

  • R1
enable
configure terminal
!
interface Loopback 0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/2
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R2
enable
configure terminal
!
interface Loopback 0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/2
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R3
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R4
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R5
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
R1#sh ipv6 ro rip
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:2:3::/64 [120/2]
     via FE80::3, GigabitEthernet0/0
R   2001:0:2:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/1
R   2001:0:2:5::/64 [120/2]
     via FE80::5, GigabitEthernet0/2
R   2001:2:2:2::/64 [120/3]
     via FE80::3, GigabitEthernet0/0
     via FE80::4, GigabitEthernet0/1
     via FE80::5, GigabitEthernet0/2
R2#sh ipv6 route ri
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:3::/64 [120/2]
     via FE80::3, GigabitEthernet0/0
R   2001:0:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/1
R   2001:0:1:5::/64 [120/2]
     via FE80::5, GigabitEthernet0/2
R   2001:1:1:1::/64 [120/3]
     via FE80::3, GigabitEthernet0/0
     via FE80::4, GigabitEthernet0/1
     via FE80::5, GigabitEthernet0/2
R1#ping 2001:2:2:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/7 ms
R1#traceroute 2001:2:2:2::2
Type escape sequence to abort.
Tracing the route to 2001:2:2:2::2

  1 2001:0:1:5::5 3 msec
    2001:0:1:3::3 4 msec
    2001:0:1:4::4 5 msec
  2 2001:0:2:5::2 6 msec
    2001:0:2:3::2 4 msec
    2001:0:2:4::2 4 msec

Configure maximum-paths

  • R1
configure terminal
!
ipv6 router rip P1
maximum-paths 2
exit
!
end
write
R1#show ipv6 route rip 
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:2:3::/64 [120/2]
     via FE80::3, GigabitEthernet0/0
R   2001:0:2:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/1
R   2001:0:2:5::/64 [120/2]
     via FE80::5, GigabitEthernet0/2
R   2001:2:2:2::/64 [120/3]
     via FE80::3, GigabitEthernet0/0
     via FE80::4, GigabitEthernet0/1
R1#ping 2001:2:2:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/5 ms
R1#traceroute 2001:2:2:2::2
Type escape sequence to abort.
Tracing the route to 2001:2:2:2::2

  1 2001:0:1:5::5 6 msec
    2001:0:1:3::3 4 msec
    2001:0:1:4::4 5 msec
  2 2001:0:2:5::2 7 msec
    2001:0:2:3::2 6 msec
    2001:0:2:4::2 4 msec
  • R2
configure terminal
!
ipv6 router rip P1
maximum-paths 2
exit
!
end
write
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#^Z       
R2#
*Mar  6 23:14:36.438: %SYS-5-CONFIG_I: Configured from console by console
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv
R2(config)#ipv6 ro
R2(config)#ipv       
R2(config)#ipv  
R2(config)#ipv6 router rip
R2(config)#ipv6 router rip P1
R2(config-rtr)#maxi
R2(config-rtr)#maximum-paths 2
R2(config-rtr)#^Z
R2#sh ipv6
*Mar  6 23:15:14.407: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:3::/64 [120/2]
     via FE80::3, GigabitEthernet0/0
R   2001:0:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/1
R   2001:0:1:5::/64 [120/2]
     via FE80::5, GigabitEthernet0/2
R   2001:1:1:1::/64 [120/3]
     via FE80::4, GigabitEthernet0/1
     via FE80::5, GigabitEthernet0/2
R2#ping 2001:1:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/15 ms
R2#trace 2001:1:1:1::1
Type escape sequence to abort.
Tracing the route to 2001:1:1:1::1

  1 2001:0:2:5::5 6 msec
    2001:0:2:3::3 4 msec
    2001:0:2:4::4 5 msec
  2 2001:0:1:5::1 7 msec
    2001:0:1:3::1 6 msec
    2001:0:1:4::1 4 msec
R2#

Route to 2001:2:2:2::/64 shows 2 paths only.

R1#ping 2001:2:2:2::2 source 2001:1:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::2, timeout is 2 seconds:
Packet sent with a source address of 2001:1:1:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/6 ms
R1#trace 2001:2:2:2::2 source 2001:1:1:1::1
                       ^
% Invalid input detected at '^' marker.

R1#traceroute 2001:2:2:2::2 source 2001:1:1:1::1
                            ^
% Invalid input detected at '^' marker.

R1#traceroute 2001:2:2:2::2 ?                   
  <cr>

R1#traceroute ?             
  WORD       Trace route to destination address or hostname
  appletalk  AppleTalk Trace
  clns       ISO CLNS Trace
  ethernet   Ethernet Traceroute
  ip         IP Trace
  ipv6       IPv6 Trace
  ipx        IPX Trace
  mpls       MPLS LSP Trace
  <cr>

R1#traceroute ipv
R1#traceroute ipv6 2001:2:2:2::2 ?
  <cr>

whats…

Topology: default-information originate

IP

Project name: ccna-ipv6-0003-ripng-default-information

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:1234:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:1234:1:4::1/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::1 link-local
ipv6 address 2001:1234:1:5::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:1234:2:3::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:1234:1:2::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:1234:3:4::3/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::3 link-local
ipv6 address 2001:1234:2:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
ipv6 unicast-routing
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:1234:1:4::4/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::4 link-local
ipv6 address 2001:1234:3:4::4/64
no shutdown
exit
!
end
write
  • R5
enable
configure terminal
!
hostname R5
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::5 link-local
ipv6 address 2001:1234:1:5::5/64
no shutdown
exit
!
end
write

Configure Basic RIPng

  • R1
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 route ::/0 GigabitEthernet 0/2 fe80::5
!
ipv6 router rip P1
exit
!
end
write
  • R2
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R3
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R4
enable
configure terminal
!
interface GigabitEthernet 0/0
ipv6 rip P1 enable
exit
interface GigabitEthernet 0/1
ipv6 rip P1 enable
exit
!
ipv6 router rip P1
exit
!
end
write
  • R5
enable
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
!
end
write
R1#sh ipv6 route
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
S   ::/0 [1/0]
     via FE80::5, GigabitEthernet0/2
C   2001:1234:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:1234:1:2::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:1234:1:4::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:1234:1:4::1/128 [0/0]
     via GigabitEthernet0/1, receive
C   2001:1234:1:5::/64 [0/0]
     via GigabitEthernet0/2, directly connected
L   2001:1234:1:5::1/128 [0/0]
     via GigabitEthernet0/2, receive
R   2001:1234:2:3::/64 [120/2]
     via FE80::2, GigabitEthernet0/0
R   2001:1234:3:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/1
L   FF00::/8 [0/0]
     via Null0, receive
R1#ping 2001:1234:1:5::5 source 2001:1234:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:5::5, timeout is 2 seconds:
Packet sent with a source address of 2001:1234:1:2::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/7 ms
R5#sh ipv6 ro       
IPv6 Routing Table - default - 4 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
S   ::/0 [1/0]
     via FE80::1, GigabitEthernet0/0
C   2001:1234:1:5::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:1234:1:5::5/128 [0/0]
     via GigabitEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
R3#sh ipv6 ro
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:1234:1:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/0
C   2001:1234:2:3::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:1234:2:3::3/128 [0/0]
     via GigabitEthernet0/1, receive
C   2001:1234:3:4::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:1234:3:4::3/128 [0/0]
     via GigabitEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
R3#ping 2001:1234:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/6/18 ms
R3#ping 2001:1234:1:4::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/7/19 ms
R3#ping 2001:1234:1:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:5::1, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)

Configure RIPng default-information

  • R1
enable
configure terminal
!
interface GigabitEthernet 0/0
! advertise default route and all route
ipv6 rip P1 default-information originate
exit
!
end
write
R3#sh ipv6 ro rip
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   ::/0 [120/3]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/0
R3#ping 2001:1234:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/29 ms
R3#ping 2001:1234:1:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/7 ms
R3#ping 2001:1234:1:5::5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1234:1:5::5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/9/21 ms
  • R1
enable
configure terminal
!
interface GigabitEthernet 0/0
! advertise default route only
ipv6 rip P1 default-information only
exit
!
end
write
R3#sh ipv6 ro rip
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   ::/0 [120/3]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/0

????

Configure RIPng route redistribution

R1#sh run | i ::/0
ipv6 route ::/0 GigabitEthernet0/2 FE80::5
  • R5
enable
configure terminal
!
interface Loopback 0
ipv6 address fe80::5 link-local
ipv6 address 2001:5:5:5::5/64
exit
!
end
write
  • R1
enable
configure terminal
!
no ipv6 route ::/0
ipv6 route 2001:5:5:5::/64 GigabitEthernet 0/2 fe80::5
!
interface GigabitEthernet 0/0
no ipv6 rip P1 default-information only
exit
!
ipv6 router rip P1
redistribute static
exit
!
end
write
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#no ipv6 ro ::/0
R1(config)#do sh run | i ::/0
R1(config)#int gig0/0
R1(config-if)#no ipv
R1(config-if)#no ipv6 defa
R1(config-if)#no ipv6 rip P1 defau
R1(config-if)#no ipv6 rip P1 default-information o
R1(config-if)#no ipv6 rip P1 default-information  
% Incomplete command.

R1(config-if)#no ipv6 rip P1 default-information on
R1(config-if)#no ipv6 rip P1 default-information only 
R1(config-if)#do sh run int gig0/0
Building configuration...

Current configuration : 180 bytes
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address FE80::1 link-local
 ipv6 address 2001:1234:1:2::1/64
 ipv6 rip P1 enable
end

R1(config-if)#exit
R1(config)#ipv
R1(config)#ipv6 route 2001:5:5:5::/64 Giga
R1(config)#ipv6 route 2001:5:5:5::/64 GigabitEthernet 0/2 fe80::5
R1(config)#do ping 2001:5:5:5::5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:5:5:5::5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/5/15 ms
R1(config)#ipv
R1(config)#ipv6 route
R1(config)#ipv6 router rip P1 
R1(config-rtr)#ipv
R1(config-rtr)#ipv6 redi
R1(config-rtr)#redi     
R1(config-rtr)#redistribute sta
R1(config-rtr)#redistribute static 
R1(config-rtr)#^Z
R1#
*Mar  7 23:18:46.627: %SYS-5-CONFIG_I: Configured from console by console
R3#sh ipv6 ro rip
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:1234:1:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/0
R3#sh ipv6 ro rip
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:5:5:5::/64 [120/3]
     via FE80::4, GigabitEthernet0/0
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/1
R   2001:1234:1:4::/64 [120/2]
     via FE80::4, GigabitEthernet0/0
R3#ping 2001:5:5:5::5 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:5:5:5::5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/11/20 ms

Topology: distribute-list

IP & Basic RIPng Configuration

Project name: ccna-ipv6-0004-distribute-list

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface Loopback 0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:1::1/64
ipv6 rip P1 enable
no shutdown
exit
interface Loopback 1
ipv6 address fe80::1 link-local
ipv6 address 2001:1:1:1::1/64
ipv6 rip P1 enable
no shutdown
exit
interface Loopback 2
ipv6 address fe80::1 link-local
ipv6 address 2001:2:1:1::1/64
ipv6 rip P1 enable
no shutdown
exit
interface Loopback 3
ipv6 address fe80::1 link-local
ipv6 address 2001:3:1:1::1/64
ipv6 rip P1 enable
no shutdown
exit
interface Loopback 4
ipv6 address fe80::1 link-local
ipv6 address 2001:4:1:1::1/64
ipv6 rip P1 enable
no shutdown
exit
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
ipv6 rip P1 enable
no shutdown
exit
!
ipv6 router rip P1
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface Loopback 0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:2:2::2/64
ipv6 rip P1 enable
no shutdown
exit
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
ipv6 rip P1 enable
no shutdown
exit
!
ipv6 router rip P1
exit
!
end
write
R2#sh ipv6 ro rip    
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2#ping 2001:0:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/2 ms
R2#ping 2001:0:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R2#ping 2001:1:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
R2#ping 2001:2:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/5 ms
R2#ping 2001:3:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:3:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
R2#ping 2001:4:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:4:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms

distribute list Configuration

  • R2
configure terminal
!
! WRONG: match exact prefix 16 bit length only
!ipv6 prefix-list PRE01 permit 2001:2::/31
! CORRECT: check bits over 31 and prefix length matches over 64 bit
ipv6 prefix-list PRE01 permit 2001:2::/31 le 64
! Implicit deny any
!ipv6 prefix-list PRE01 deny ::/0
!
ipv6 router rip P1
distribute-list prefix-list PRE01 in GiGabitEthernet 0/0
exit
!
end
write
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#do sh ipv6 ro rip
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2(config)#ipv
R2(config)#ipv6 prefi
R2(config)#ipv6 prefix-list PRE01 per
R2(config)#ipv6 prefix-list PRE01 permit 2001:2::/15
R2(config)#ipv
R2(config)#ipv6 router rip P1
R2(config-rtr)#distri
R2(config-rtr)#distribute-list prefi
R2(config-rtr)#distribute-list prefix-list PRE01 in
R2(config-rtr)#distribute-list prefix-list PRE01 in GI
R2(config-rtr)#distribute-list prefix-list PRE01 in GiGa            
R2(config-rtr)#distribute-list prefix-list PRE01 in GiGabitEthernet 0/0
R2(config-rtr)#^Z
R2#sh ip
*Mar  9 02:18:27.100: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2#clear ip ri
R2#clear ipv  
R2#clear ipv6 ri
R2#clear ipv6 rip P1 ?
  <cr>

R2#clear ipv6 rip ?  
  WORD  IPv6 RIP process name
  <cr>

R2#clear ipv6 rip P1 ?
  <cr>

R2#clear ipv6 rip P1 
R2#sh ipv6 ro rip    
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#
R1#clear ipv6 rip P1 
R1#sh ipv6 rip      
RIP process "P1", port 521, multicast-group FF02::9, pid 369
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 38, trigger updates 3
     Full Advertisement 1, Delayed Events 0
  Interfaces:
    GigabitEthernet0/0
    Loopback4
    Loopback3
    Loopback2
    Loopback1
    Loopback0
  Redistribution:
    None
R1#sh ipv6 ro rip
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:2:2::/64 [120/2]
     via FE80::2, GigabitEthernet0/0
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2#sh ipv6 ro rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application

all routes disappeared…

R2#conf t        
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#do sh ipv6 rip                                          
RIP process "P1", port 521, multicast-group FF02::9, pid 369
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 38, trigger updates 2
     Full Advertisement 1, Delayed Events 0
  Interfaces:
    GigabitEthernet0/0
    Loopback0
  Redistribution:
    None
R2(config)#do sh ipv6 rip ?
  WORD       RIP process name
  database   RIP local RIB
  next-hops  RIP next-hops
  |          Output modifiers
  <cr>

R2(config)#do sh ipv6 rip da
R2(config)#do sh ipv6 rip database 
RIP process "P1", local RIB
R2(config)#no di                   
R2(config)#ipv6 router
R2(config)#ipv6 router rip P1
R2(config-rtr)#no di
R2(config-rtr)#no distri
R2(config-rtr)#no distribute-list pref
R2(config-rtr)#sh ipv                         
R2(config-rtr)#do sh ipv6 prefix-list
ipv6 prefix-list PRE01: 1 entries
   seq 5 permit 2000::/15
R2(config-rtr)#sh run | i prefix-list
                ^
% Invalid input detected at '^' marker.

R2(config-rtr)#do sh run | i prefix-list
 distribute-list prefix-list PRE01 in GigabitEthernet0/0
ipv6 prefix-list PRE01 seq 5 permit 2000::/15

WTF…prefix length misconfiguration……!!!!!!!

R2(config-rtr)#exit  
R2(config)#no ipv
R2(config)#no ipv6 prefi
R2(config)#no ipv6 prefix-list PRE01
R2(config)#ipv6 prefix-list PRE01 permi
R2(config)#ipv6 prefix-list PRE01 permit 2001:2::/31
R2(config)#do sh ipv
R2(config)#do sh ipv6 prefi
R2(config)#do sh ipv6 prefix-list 
ipv6 prefix-list PRE01: 1 entries
   seq 5 permit 2001:2::/31
R2(config)#do sh ipv6 ro rip
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2(config)#do clear ipv6 rip P1
R2(config)#do sh ipv6 ro rip   
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R1#clear ipv6 rip P1 
R2(config)#do sh run | s ipv6 router rip P1
ipv6 router rip P1
 distribute-list prefix-list PRE01 in GigabitEthernet0/0
R2(config)#do sh ipv6 prefi
R2(config)#do sh ipv6 prefix-list PRE01
ipv6 prefix-list PRE01: 1 entries
   seq 5 permit 2001:2::/31
R2(config)#do sh ipv6 ro rip               
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2(config-rtr)#do sh ipv6 ro rip 
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2(config-rtr)#do debug ipv6 rip
  RIP Routing Protocol debugging is on
R2(config-rtr)#
*Mar  9 02:41:09.965: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:41:09.965:        src=FE80::2
*Mar  9 02:41:09.966:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  9 02:41:09.966:        sport=521, dport=521, length=52
*Mar  9 02:41:09.966:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:41:09.967:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:41:09.967:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:41:09.969: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:41:09.969:        src=FE80::1
*Mar  9 02:41:09.969:        dst=FF02::9 (Loopback0)
R2(config-rtr)#
*Mar  9 02:41:09.970:        sport=521, dport=521, length=52
*Mar  9 02:41:09.970:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:41:09.971:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:41:09.971:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:41:09.974: RIPng [default VRF]: a message has been received.
*Mar  9 02:41:09.974: RIPng [Lo0, default VRF]: process "P1" received own response.
R2(config-rtr)#
*Mar  9 02:41:17.333: RIPng [default VRF]: a message has been received.
*Mar  9 02:41:17.334: RIPng [Gi0/0, default VRF]: response received from FE80::1 for process "P1".
*Mar  9 02:41:17.334:        src=FE80::1 (GigabitEthernet0/0)
*Mar  9 02:41:17.335:        dst=FF02::9
*Mar  9 02:41:17.335:        sport=521, dport=521, length=132
*Mar  9 02:41:17.335:        command=2, version=1, mbz=0, #rte=6
*Mar  9 02:41:17.336:        tag=0, metric=1, prefix=2001:0:1:1::/64
*Mar  9 02:41:17.336:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  9 02:41:17.336:        tag=0, metric=1, prefix=2001:2:1:1::/64
*Mar  9 02:41:17.336:        tag=0, metric=1, prefix=2001:3:1:1::/64
*Mar  9 02:41:17.337:        tag=0, metric=1, prefix=2001:4:1:1::/64
*Mar  9 02:41:17.337:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:41:17.338: RIPng [Gi0/0, default VRF]: added neighbor FE80::1/GigabitEthernet0/0.
*Mar  9 02:41:17.338: RIPng [Gi0/0, default VRF]: input filter rejects 2001:0:1:1::/64.
*Mar  9 02:41:17.338: RIPng [Gi0/0, default VRF]: input filter rejects 2001:1:1:1::/64.
*Mar  9 02:41:17.338: RIPng [Gi0/0, default VRF]: input filter rejects 2001:2:1:1::/64.
*Mar  9 02:41:17.339: RIPng [Gi0/0, default VRF]: input filter rejects 2001:3:1:1::/64.
*Mar  9 02:41:17.339: RIPng [Gi0/0, default VRF]: input filter rejects 2001:4:1:1::/64.
R2(config-rtr)#
*Mar  9 02:41:17.339: RIPng [Gi0/0, default VRF]: input filter rejects 2001:0:1:2::/64.
R2(config)#ipv6 prefix-list PRE01 permit 2001:0:1:2::/64
R2(config)#
*Mar  9 02:44:53.765: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:44:53.765:        src=FE80::2
*Mar  9 02:44:53.766:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  9 02:44:53.766:        sport=521, dport=521, length=52
*Mar  9 02:44:53.766:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:44:53.767:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:44:53.767:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:44:53.768: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:44:53.768:        src=FE80::1
*Mar  9 02:44:53.769:        dst=FF02::9 (Loopback0)
R2(config)#
*Mar  9 02:44:53.769:        sport=521, dport=521, length=52
*Mar  9 02:44:53.770:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:44:53.770:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:44:53.770:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:44:53.771: RIPng [default VRF]: deleted neighbor FE80::1/Gi0/0.
*Mar  9 02:44:53.773: RIPng [default VRF]: a message has been received.
*Mar  9 02:44:53.774: RIPng [Lo0, default VRF]: process "P1" received own response.
R2(config)#
*Mar  9 02:45:11.872: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:45:11.873:        src=FE80::2
*Mar  9 02:45:11.873:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  9 02:45:11.874:        sport=521, dport=521, length=52
*Mar  9 02:45:11.874:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:45:11.874:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:45:11.874:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:45:11.876: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:45:11.876:        src=FE80::1
*Mar  9 02:45:11.876:        dst=FF02::9 (Loopback0)
R2(config)#
*Mar  9 02:45:11.877:        sport=521, dport=521, length=52
*Mar  9 02:45:11.877:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:45:11.878:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:45:11.878:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:45:11.881: RIPng [default VRF]: a message has been received.
*Mar  9 02:45:11.882: RIPng [Lo0, default VRF]: process "P1" received own response.
R2(config)#
*Mar  9 02:45:21.757: RIPng [default VRF]: a message has been received.
*Mar  9 02:45:21.757: RIPng [Gi0/0, default VRF]: response received from FE80::1 for process "P1".
*Mar  9 02:45:21.758:        src=FE80::1 (GigabitEthernet0/0)
*Mar  9 02:45:21.758:        dst=FF02::9
*Mar  9 02:45:21.759:        sport=521, dport=521, length=132
*Mar  9 02:45:21.759:        command=2, version=1, mbz=0, #rte=6
*Mar  9 02:45:21.759:        tag=0, metric=1, prefix=2001:0:1:1::/64
*Mar  9 02:45:21.759:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  9 02:45:21.760:        tag=0, metric=1, prefix=2001:2:1:1::/64
*Mar  9 02:45:21.760:        tag=0, metric=1, prefix=2001:3:1:1::/64
*Mar  9 02:45:21.760:        tag=0, metric=1, prefix=2001:4:1:1::/64
*Mar  9 02:45:21.761:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:45:21.761: RIPng [Gi0/0, default VRF]: added neighbor FE80::1/GigabitEthernet0/0.
*Mar  9 02:45:21.761: RIPng [Gi0/0, default VRF]: input filter rejects 2001:0:1:1::/64.
*Mar  9 02:45:21.762: RIPng [Gi0/0, default VRF]: input filter rejects 2001:1:1:1::/64.
*Mar  9 02:45:21.762: RIPng [Gi0/0, default VRF]: input filter rejects 2001:2:1:1::/64.
*Mar  9 02:45:21.762: RIPng [Gi0/0, default VRF]: input filter rejects 2001:3:1:1::/64.
*Mar  9 02:45:21.763: RIPng [Gi0/0, default VRF]: input filter rejects 2001:4:1:1::/64.
R2(config)#
*Mar  9 02:45:21.763: RIPng [default VRF]: inserted 2001:0:1:2::/64, nexthop FE80::1, metric 2, tag 0.
*Mar  9 02:45:21.764: RIPng [default VRF]: ager started, 180000.
R2(config)#
*Mar  9 02:45:32.940: RIPng [Gi0/0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:45:32.940:        src=FE80::2
*Mar  9 02:45:32.940:        dst=FF02::9 (GigabitEthernet0/0)
*Mar  9 02:45:32.941:        sport=521, dport=521, length=52
*Mar  9 02:45:32.941:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:45:32.942:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:45:32.942:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:45:32.943: RIPng [Lo0, default VRF]: process "P1" is sending a multicast update.
*Mar  9 02:45:32.944:        src=FE80::1
*Mar  9 02:45:32.944:        dst=FF02::9 (Loopback0)
R2(config)#
*Mar  9 02:45:32.944:        sport=521, dport=521, length=52
*Mar  9 02:45:32.945:        command=2, version=1, mbz=0, #rte=2
*Mar  9 02:45:32.945:        tag=0, metric=1, prefix=2001:0:2:2::/64
*Mar  9 02:45:32.945:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:45:32.949: RIPng [default VRF]: a message has been received.
*Mar  9 02:45:32.949: RIPng [Lo0, default VRF]: process "P1" received own response.
R2(config)#
*Mar  9 02:45:46.701: RIPng [default VRF]: a message has been received.
*Mar  9 02:45:46.702: RIPng [Gi0/0, default VRF]: response received from FE80::1 for process "P1".
*Mar  9 02:45:46.702:        src=FE80::1 (GigabitEthernet0/0)
*Mar  9 02:45:46.702:        dst=FF02::9
*Mar  9 02:45:46.703:        sport=521, dport=521, length=132
*Mar  9 02:45:46.703:        command=2, version=1, mbz=0, #rte=6
*Mar  9 02:45:46.703:        tag=0, metric=1, prefix=2001:0:1:1::/64
*Mar  9 02:45:46.704:        tag=0, metric=1, prefix=2001:1:1:1::/64
*Mar  9 02:45:46.704:        tag=0, metric=1, prefix=2001:2:1:1::/64
*Mar  9 02:45:46.704:        tag=0, metric=1, prefix=2001:3:1:1::/64
R2(config)#
*Mar  9 02:45:46.705:        tag=0, metric=1, prefix=2001:4:1:1::/64
*Mar  9 02:45:46.705:        tag=0, metric=1, prefix=2001:0:1:2::/64
*Mar  9 02:45:46.705: RIPng [Gi0/0, default VRF]: input filter rejects 2001:0:1:1::/64.
*Mar  9 02:45:46.705: RIPng [Gi0/0, default VRF]: input filter rejects 2001:1:1:1::/64.
*Mar  9 02:45:46.706: RIPng [Gi0/0, default VRF]: input filter rejects 2001:2:1:1::/64.
*Mar  9 02:45:46.706: RIPng [Gi0/0, default VRF]: input filter rejects 2001:3:1:1::/64.
*Mar  9 02:45:46.706: RIPng [Gi0/0, default VRF]: input filter rejects 2001:4:1:1::/64.
R2(config)#

Cisco ip prefix-list コマンドの解説

this issue comes from my prefix-list misunderstanding.

R2(config)#do u all
All possible debugging has been turned off
R2(config)#no ipv
R2(config)#no ipv6 prefi
R2(config)#do sh ipv6 ro rip   
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R2(config)#no ipv
R2(config)#no ipv6 pref
R2(config)#no ipv6 prefix-list PRE01
R2(config)#ipv
R2(config)#ipv6 pre
R2(config)#ipv6 prefix-list PRE01 permit 2001:2::/64 ?
  ge  Minimum prefix length to be matched
  le  Maximum prefix length to be matched
  <cr>

R2(config)#ipv6 prefix-list PRE01 permit 2001:2::/31 le 64
R2(config)#debu
R2(config)#do sh ipv6 prefi
R2(config)#do sh ipv6 prefix-list 
ipv6 prefix-list PRE01: 1 entries
   seq 5 permit 2001:2::/31 le 64
R2(config)#do sh ipv6 ro rip
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2(config)#do sh ipv6 ro rip
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2(config)#do sh ipv6 ro rip
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2(config)#
R2(config)#do ping 2001:0:1:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
R2(config)#do ping 2001:0:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/15 ms
R2(config)#do ping 2001:2:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R2(config)#do ping 2001:3:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:3:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/5 ms
R2(config)#do ping 2001:4:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:4:1:1::1, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)
R2(config)#do ping 2001:1:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:1::1, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)

OK!

R1#show ipv6 interface brief 
GigabitEthernet0/0     [up/up]
    FE80::1
    2001:0:1:2::1
GigabitEthernet0/1     [administratively down/down]
    unassigned
GigabitEthernet0/2     [administratively down/down]
    unassigned
GigabitEthernet0/3     [administratively down/down]
    unassigned
Loopback0              [up/up]
    FE80::1
    2001:0:1:1::1
Loopback1              [up/up]
    FE80::1
    2001:1:1:1::1
Loopback2              [up/up]
    FE80::1
    2001:2:1:1::1
Loopback3              [up/up]
    FE80::1
    2001:3:1:1::1
Loopback4              [up/up]
    FE80::1
    2001:4:1:1::1

R1#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "rip P1"
  Interfaces:
    GigabitEthernet0/0
    Loopback4
    Loopback3
    Loopback2
    Loopback1
    Loopback0
  Redistribution:
    None
R1#show ipv6 rip 
RIP process "P1", port 521, multicast-group FF02::9, pid 369
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 14, trigger updates 2
     Full Advertisement 1, Delayed Events 0
  Interfaces:
    GigabitEthernet0/0
    Loopback4
    Loopback3
    Loopback2
    Loopback1
    Loopback0
  Redistribution:
    None
R2#show ipv6 route
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
C   2001:0:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:0:1:2::2/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:0:2:2::/64 [0/0]
     via Loopback0, directly connected
L   2001:0:2:2::2/128 [0/0]
     via Loopback0, receive
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
L   FF00::/8 [0/0]
     via Null0, receive
R2#ping 2001:3:1:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:3:1:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/14 ms
R2#show ipv6 route rip
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R   2001:0:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:1:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:2:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:3:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R   2001:4:1:1::/64 [120/2]
     via FE80::1, GigabitEthernet0/0
R2#ping 2001:0:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/13 ms
R2#sh ipv6 rip
RIP process "P1", port 521, multicast-group FF02::9, pid 369
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 34, trigger updates 2
     Full Advertisement 1, Delayed Events 0
  Interfaces:
    GigabitEthernet0/0
    Loopback0
  Redistribution:
    None
R2#sh ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "rip P1"
  Interfaces:
    GigabitEthernet0/0
    Loopback0
  Redistribution:
    None
R2#sh ipv6 interface brief 
GigabitEthernet0/0     [up/up]
    FE80::2
    2001:0:1:2::2
GigabitEthernet0/1     [administratively down/down]
    unassigned
GigabitEthernet0/2     [administratively down/down]
    unassigned
GigabitEthernet0/3     [administratively down/down]
    unassigned
Loopback0              [up/up]
    FE80::1
    2001:0:2:2::2

References

tech/network/cisco/ipv6/ripng/ripng.txt · Last modified: 2019/03/09 18:50 by wnoguchi