User Tools

Site Tools


tech:network:cisco:ipv6:ospfv3:ospfv3

OSPFv3

Topology

IP

Project name: ccna-ipv6-0007-ospfv3

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write

Configure OSPFv3

  • R1
configure terminal
!
ipv6 router ospf 1
router-id 1.1.1.1
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R2
configure terminal
!
ipv6 router ospf 1
router-id 2.2.2.2
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R3
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
!
end
  • R4
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::2
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 router
R1(config)#ipv6 router os
R1(config)#ipv6 router ospf 1
R1(config-rtr)#
*Mar 10 00:11:04.287: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R1(config-rtr)#router
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#pas
R1(config-rtr)#passive-interface Gig
R1(config-rtr)#passive-interface GigabitEthernet 0/1
R1(config-rtr)#int gig0/0
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#int gig0/1
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#^Z
R1#
*Mar 10 00:11:49.679: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar 10 00:13:16.404: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R1#sh ipv
R1#sh ipv6 ro ospf
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
R1#sh ipv6 pro
R1#sh ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 1.1.1.1
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Redistribution:
    None
R1#sh ipv6 ospf
R1#sh ipv6 ro ospf
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv
R2(config)#ipv6 router ospf2
                           ^
% Invalid input detected at '^' marker.

R2(config)#ipv6 router ospf 2
R2(config-rtr)#router-i
*Mar 10 00:11:59.639: %OSPFv3-4-NORTRID: Process OSPFv3-2-IPv6 could not pick a router-id, please configure manually
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#pas
R2(config-rtr)#passive-interface Gig
R2(config-rtr)#passive-interface GigabitEthernet 0/1
R2(config-rtr)#int gig0/0
R2(config-if)#ipv
R2(config-if)#ipv6 os
R2(config-if)#ipv6 ospf 1 are
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#ipv
R2(config-if)#ipv6 
*Mar 10 00:12:30.786: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R2(config-if)#ipv6 osp
R2(config-if)#ipv6 ospf 1 are
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#no ipv
R2(config-if)#no ipv6 router
R2(config-if)#no ipv6 router ospf 2
R2(config)#ipv6 router ospf 1   
R2(config-rtr)#router
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#
*Mar 10 00:13:16.960: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R2(config-rtr)#pass
R2(config-rtr)#passive-interface Gig
R2(config-rtr)#passive-interface GigabitEthernet 0/1
R2(config-rtr)#^Z
R2#
*Mar 10 00:13:31.814: %SYS-5-CONFIG_I: Configured from console by console
R2#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/5/16 ms
R2#sh ipv6 ospf
 Routing Process "ospfv3 1" with ID 2.2.2.2
 Supports NSSA (compatible with RFC 3101)
 Supports Database Exchange Summary List Optimization (RFC 5243)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Retransmission limit dc 24 non-dc 24
 EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
 Number of external LSA 0. Checksum Sum 0x000000
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Graceful restart helper support enabled
 Reference bandwidth unit is 100 mbps
 RFC1583 compatibility enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 1 times
        Number of LSA 7. Checksum Sum 0x047DB3
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R2#sh ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 2.2.2.2
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/0
  Redistribution:
    None
R2#conf t 
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int gig0/1
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#^Z
R2#sh ipv
R2#sh ipv6 
*Mar 10 00:17:40.930: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ipv6 pro
R2#sh ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 2.2.2.2
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Redistribution:
    None
R2#sh ipv6 ro
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:0:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:0:1:2::2/128 [0/0]
     via GigabitEthernet0/0, receive
O   2001:0:1:3::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
C   2001:0:2:4::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:0:2:4::2/128 [0/0]
     via GigabitEthernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R2#sh ipv6 ro ospf
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:1:3::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv
R3(config)#ipv6 route
R3(config)#ipv6 route ::/0 Gig
R3(config)#ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
R3(config)#^Z
R3#
*Mar 10 00:13:52.447: %SYS-5-CONFIG_I: Configured from console by console
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/7 ms
R3#
R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#ipv   
R4(config)#ipv6 route ::/0 Gig
R4(config)#ipv6 route ::/0 GigabitEthernet 0/0 fe80::2
R4(config)#^Z
R4#
*Mar 10 00:14:09.646: %SYS-5-CONFIG_I: Configured from console by console
R4#
R1#sh ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 1.1.1.1
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Redistribution:
    None
R1#sh ipv6 ospf
R1#sh ipv6 ro ospf
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
R1#show
R1#show ipv
R1#show ipv6 pro
R1#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 1.1.1.1
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Redistribution:
    None
R1#sho
R1#show ipv
R1#show ipv6 os
R1#show ipv6 ospf neigh
R1#show ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:33    2               GigabitEthernet0/0
R1#sho
R1#show ipv
R1#show ipv6 osf
R1#show ipv6 osfda
R1#show ipv6 ospf 
R1#show ipv6 ospf da
R1#show ipv6 ospf database 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 1.1.1.1         683         0x80000009  0            1           None
 2.2.2.2         561         0x80000008  0            1           None

                Net Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Rtr count
 1.1.1.1         683         0x80000008  2          2

                Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface
 1.1.1.1         683         0x80000008  3          Gi0/1
 1.1.1.1         683         0x80000008  2          Gi0/0
 2.2.2.2         561         0x80000008  2          Gi0/0

                Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 1.1.1.1         683         0x8000000A  0          0x2001      0
 1.1.1.1         683         0x80000008  2048       0x2002      2
 2.2.2.2         305         0x80000008  0          0x2001      0
R1#show
R1#show ipv
R1#show ipv6 route
R1#show ipv6 route ospf
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
R1#show ipv
R1#show ipv6 osp
R1#show ipv6 ospf inter
R1#show ipv6 ospf interface 
GigabitEthernet0/1 is up, line protocol is up 
  Link Local Address FE80::1, Interface ID 3
  Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
  Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, local address FE80::1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    No Hellos (Passive interface) 
  Graceful restart helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up 
  Link Local Address FE80::1, Interface ID 2
  Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
  Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, local address FE80::1
  Backup Designated router (ID) 2.2.2.2, local address FE80::2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
  Graceful restart helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 5
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
R1#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/8/26 ms
R1#

Topology: maximum-paths

IP

Project name: ccna-ipv6-0008-ospfv3-maximum-paths

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:4::1/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:5::1/64
no shutdown
exit
interface GigabitEthernet 0/3
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:6::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:3::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:5::2/64
no shutdown
exit
interface GigabitEthernet 0/3
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:7::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::3 link-local
ipv6 address 2001:0:2:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:1:4::4/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write
  • R5
enable
configure terminal
!
hostname R5
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::5 link-local
ipv6 address 2001:0:1:5::5/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::5 link-local
ipv6 address 2001:0:2:5::5/64
no shutdown
exit
!
end
write
  • R6
enable
configure terminal
!
hostname R6
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::6 link-local
ipv6 address 2001:60:1:6::6/64
no shutdown
exit
!
end
write
  • R7
enable
configure terminal
!
hostname R7
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::7 link-local
ipv6 address 2001:70:2:7::7/64
no shutdown
exit
!
end
write

Configure OSPFv3

  • R1
configure terminal
!
ipv6 router ospf 1
router-id 1.1.1.1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/2
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/3
ipv6 ospf 1 area 60
exit
!
end
  • R2
configure terminal
!
ipv6 router ospf 1
router-id 2.2.2.2
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/2
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/3
ipv6 ospf 1 area 70
exit
!
end
  • R3
configure terminal
!
ipv6 router ospf 1
router-id 3.3.3.3
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R4
configure terminal
!
ipv6 router ospf 1
router-id 4.4.4.4
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R5
configure terminal
!
ipv6 router ospf 1
router-id 5.5.5.5
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R6
configure terminal
!
ipv6 router ospf 1
router-id 6.6.6.6
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 60
exit
!
end
  • R7
configure terminal
!
ipv6 router ospf 1
router-id 7.7.7.7
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 70
exit
!
end
R1#sh ipv6 proto
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 router
R1(config)#ipv6 router os
R1(config)#ipv6 router ospf 1
R1(config-rtr)#
*Mar 10 22:26:02.780: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R1(config-rtr)#router
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#int gig0/0
R1(config-if)#ipv
R1(config-if)#ipv6 osp
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#int gig0/1
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#int gig0/2
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#int gig0/3
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 60
R1(config-if)#^Z
R1#
*Mar 10 22:26:56.226: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar 10 22:29:47.060: %OSPFv3-5-ADJCHG: Process 1, Nbr 3.3.3.3 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R1#
*Mar 10 22:30:23.989: %OSPFv3-5-ADJCHG: Process 1, Nbr 4.4.4.4 on GigabitEthernet0/1 from LOADING to FULL, Loading Done
R1#
*Mar 10 22:31:21.572: %OSPFv3-5-ADJCHG: Process 1, Nbr 5.5.5.5 on GigabitEthernet0/2 from LOADING to FULL, Loading Done
R1#
*Mar 10 22:32:39.570: %OSPFv3-5-ADJCHG: Process 1, Nbr 6.6.6.6 on GigabitEthernet0/3 from LOADING to FULL, Loading Done
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv
R2(config)#ipv6 router osp
R2(config)#ipv6 router ospf 1
R2(config-rtr)#
*Mar 10 22:27:04.328: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R2(config-rtr)#router
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#int gig0/0
R2(config-if)#ipv
R2(config-if)#ipv6 os
R2(config-if)#exit      
R2(config)#int ra
R2(config)#int range gig0/0-2
R2(config-if-range)#ipv
R2(config-if-range)#ipv6 os
R2(config-if-range)#ipv6 ospf 1 are
R2(config-if-range)#ipv6 ospf 1 area 0
R2(config-if-range)#int gig0/3
R2(config-if)#ipv
R2(config-if)#ipv6 os
R2(config-if)#ipv6 ospf 1 are
R2(config-if)#ipv6 ospf 1 area 70
R2(config-if)#^Z
R2#
*Mar 10 22:27:58.245: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ipv6 ospf
 Routing Process "ospfv3 1" with ID 2.2.2.2
 Supports NSSA (compatible with RFC 3101)
 Supports Database Exchange Summary List Optimization (RFC 5243)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 It is an area border router
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Retransmission limit dc 24 non-dc 24
 EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
 Number of external LSA 0. Checksum Sum 0x000000
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 Graceful restart helper support enabled
 Reference bandwidth unit is 100 mbps
 RFC1583 compatibility enabled
    Area BACKBONE(0) (Inactive)
        Number of interfaces in this area is 3
        SPF algorithm executed 3 times
        Number of LSA 6. Checksum Sum 0x02C17A
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 70
        Number of interfaces in this area is 1
        SPF algorithm executed 2 times
        Number of LSA 6. Checksum Sum 0x019B78
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R2#sh ipv
R2#sh ipv6 pro
R2#sh ipv6 protocols ospf
                     ^
% Invalid input detected at '^' marker.

R2#sh ipv6 protocols | s ospf
IPv6 Routing Protocol is "ospf 1"
  Router ID 2.2.2.2
  Area border router
  Number of areas: 2 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/2
    GigabitEthernet0/1
    GigabitEthernet0/0
  Interfaces (Area 70):
    GigabitEthernet0/3
  Redistribution:
    None
R2#
*Mar 10 22:29:45.722: %OSPFv3-5-ADJCHG: Process 1, Nbr 3.3.3.3 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R2#
*Mar 10 22:30:22.630: %OSPFv3-5-ADJCHG: Process 1, Nbr 4.4.4.4 on GigabitEthernet0/1 from LOADING to FULL, Loading Done
R2#
*Mar 10 22:31:20.294: %OSPFv3-5-ADJCHG: Process 1, Nbr 5.5.5.5 on GigabitEthernet0/2 from LOADING to FULL, Loading Done
R2#
*Mar 10 22:33:14.521: %OSPFv3-5-ADJCHG: Process 1, Nbr 7.7.7.7 on GigabitEthernet0/3 from LOADING to FULL, Loading Done
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#inter  
R3(config)#interface ra
R3(config)#interface range gig0/0-1
R3(config-if-range)#ipv
R3(config-if-range)#ipv6 router ospf 1
R3(config-rtr)#rout
*Mar 10 22:29:19.535: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R3(config-rtr)#router-id 3.3.3.3
R3(config-rtr)#int ra 
R3(config-rtr)#int ran
R3(config-rtr)#int ran gig0/0-1
R3(config-if-range)#ipv
R3(config-if-range)#ipv6 os
R3(config-if-range)#ipv6 ospf are
R3(config-if-range)#ipv6 ospf 1 are
R3(config-if-range)#ipv6 ospf 1 area 0
R3(config-if-range)#
*Mar 10 22:29:47.336: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/1 from LOADING to FULL, Loading Done
*Mar 10 22:29:47.345: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R3(config-if-range)#^Z
R3#
*Mar 10 22:29:51.885: %SYS-5-CONFIG_I: Configured from console by console
R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#ipv
R4(config)#ipv6 router
R4(config)#ipv6 router osp
R4(config)#ipv6 router ospf 1
R4(config-rtr)#ro
*Mar 10 22:29:56.406: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R4(config-rtr)#route
R4(config-rtr)#router-id 4.4.4.4
R4(config-rtr)#int range gig0/0-1
R4(config-if-range)#ipv
R4(config-if-range)#ipv6 osp
R4(config-if-range)#ipv6 ospf 1 are
R4(config-if-range)#ipv6 ospf 1 area 0
R4(config-if-range)#
*Mar 10 22:30:20.948: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/1 from LOADING to FULL, Loading Done
*Mar 10 22:30:20.958: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R4(config-if-range)#^Z
R4#
*Mar 10 22:30:24.662: %SYS-5-CONFIG_I: Configured from console by console
R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#ipv
R5(config)#ipv6 route
R5(config)#ipv6 router
R5(config)#ipv6 router os
R5(config)#ipv6 router ospf 1
R5(config-rtr)#
*Mar 10 22:30:42.965: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R5(config-rtr)#router
R5(config-rtr)#router-id 5.5.5.5
R5(config-rtr)#exit
R5(config)#int r
R5(config)#int r gig0/0-1
R5(config-if-range)#ipv
R5(config-if-range)#ipv os
R5(config-if-range)#ipv os 1 a   
R5(config-if-range)#ipv os 1 a 0  
R5(config-if-range)#
*Mar 10 22:31:22.031: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/1 from LOADING to FULL, Loading Done
*Mar 10 22:31:22.036: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R5(config-if-range)#^Z
R5#
*Mar 10 22:31:28.091: %SYS-5-CONFIG_I: Configured from console by console
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#ipv
R6(config)#ipv6 route
R6(config)#ipv6 router
R6(config)#ipv6 router os
R6(config)#ipv6 router ospf 1
R6(config-rtr)#rotue
*Mar 10 22:32:07.624: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R6(config-rtr)#rotue
R6(config-rtr)#rou  
R6(config-rtr)#router-id 6.6.6.6
R6(config-rtr)#int gig0/0    
R6(config-if)#ipv
R6(config-if)#ipv6 os
R6(config-if)#ipv6 ospf 1 are
R6(config-if)#ipv6 ospf 1 area 60
R6(config-if)#
*Mar 10 22:32:35.714: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R6(config-if)#^Z
R6#
*Mar 10 22:32:38.434: %SYS-5-CONFIG_I: Configured from console by console
R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#sh ipv
R7(config)#ipv   
R7(config)#ipv6 route
R7(config)#ipv6 router
R7(config)#ipv6 router os
R7(config)#ipv6 router ospf 1 
R7(config-rtr)#router
*Mar 10 22:32:55.569: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R7(config-rtr)#router
R7(config-rtr)#router-id 7.7.7.7
R7(config-rtr)#int gig0/0
R7(config-if)#ipv
R7(config-if)#ipv6 os
R7(config-if)#ipv6 ospf 1 are
R7(config-if)#ipv6 ospf 1 area 70
R7(config-if)#ipv6 ospf 1 area 70
R7(config-if)#
*Mar 10 22:33:18.176: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R7(config-if)#^Z
R7#
*Mar 10 22:33:20.329: %SYS-5-CONFIG_I: Configured from console by console
R6#sh ipv6 route ospf
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
OI  2001:0:1:3::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:1:4::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:1:5::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:2:3::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:2:4::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:2:5::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:70:2:7::/64 [110/4]
     via FE80::1, GigabitEthernet0/0
R1#sh ipv6 route ospf
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:3::/64 [110/2]
     via FE80::3, GigabitEthernet0/0
O   2001:0:2:4::/64 [110/2]
     via FE80::4, GigabitEthernet0/1
O   2001:0:2:5::/64 [110/2]
     via FE80::5, GigabitEthernet0/2
OI  2001:70:2:7::/64 [110/3]
     via FE80::3, GigabitEthernet0/0
     via FE80::4, GigabitEthernet0/1
     via FE80::5, GigabitEthernet0/2
R6#ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/14/44 ms
R6#traceroute 2001:70:2:7::7
Type escape sequence to abort.
Tracing the route to 2001:70:2:7::7

  1 2001:60:1:6::1 8 msec 5 msec 5 msec
  2 2001:0:1:4::4 6 msec 15 msec 7 msec
  3 2001:0:2:4::2 9 msec 12 msec 5 msec
  4 2001:70:2:7::7 12 msec 11 msec 10 msec
R1#ping 2001:0:2:3::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:3::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/11/33 ms
R1#ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/14/24 ms
R1#traceroute 2001:70:2:7::7
Type escape sequence to abort.
Tracing the route to 2001:70:2:7::7

  1 2001:0:1:5::5 6 msec
    2001:0:1:3::3 6 msec
    2001:0:1:4::4 4 msec
  2 2001:0:2:5::2 8 msec
    2001:0:2:3::2 8 msec
    2001:0:2:4::2 8 msec
  3 2001:70:2:7::7 9 msec 11 msec 10 msec

Configure maximum-paths

  • R1
configure terminal
!
ipv6 router ospf 1
maximum-paths 2
exit
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 route
R1(config)#ipv6 router os
R1(config)#ipv6 router ospf 1
R1(config-rtr)#mai
R1(config-rtr)#max
R1(config-rtr)#maxi
R1(config-rtr)#do sh ipv6 ro osp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:3::/64 [110/2]
     via FE80::3, GigabitEthernet0/0
O   2001:0:2:4::/64 [110/2]
     via FE80::4, GigabitEthernet0/1
O   2001:0:2:5::/64 [110/2]
     via FE80::5, GigabitEthernet0/2
OI  2001:70:2:7::/64 [110/3]
     via FE80::3, GigabitEthernet0/0
     via FE80::5, GigabitEthernet0/2
     via FE80::4, GigabitEthernet0/1
R1(config-rtr)#maximu
R1(config-rtr)#maximum-paths 2
R1(config-rtr)#do sh ipv6 ro osp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:3::/64 [110/2]
     via FE80::3, GigabitEthernet0/0
O   2001:0:2:4::/64 [110/2]
     via FE80::4, GigabitEthernet0/1
O   2001:0:2:5::/64 [110/2]
     via FE80::5, GigabitEthernet0/2
OI  2001:70:2:7::/64 [110/3]
     via FE80::5, GigabitEthernet0/2
     via FE80::4, GigabitEthernet0/1
R1(config-rtr)#do ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/20/42 ms
R6#ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/13/32 ms
R6#

Configure intra area summarization

  • R1
configure terminal
!
ipv6 router ospf 1
area 0 range 2001::/32
exit
!
end
  • R2
configure terminal
!
ipv6 router ospf 1
area 0 range 2001::/32
exit
!
end
R6#sh ipv6 ro ospf
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
OI  2001:0:1:3::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:1:4::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:1:5::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:2:3::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:2:4::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:0:2:5::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:70:2:7::/64 [110/4]
     via FE80::1, GigabitEthernet0/0
R1(config-rtr)#area 0 range 2001::/32
R1(config-rtr)#do sh ipv6 ro ospf
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001::/32 [110/2]
     via Null0, directly connected
O   2001:0:2:3::/64 [110/2]
     via FE80::3, GigabitEthernet0/0
O   2001:0:2:4::/64 [110/2]
     via FE80::4, GigabitEthernet0/1
O   2001:0:2:5::/64 [110/2]
     via FE80::5, GigabitEthernet0/2
OI  2001:70:2:7::/64 [110/3]
     via FE80::5, GigabitEthernet0/2
     via FE80::4, GigabitEthernet0/1
R6#sh ipv6 ro ospf
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
OI  2001::/32 [110/3]
     via FE80::1, GigabitEthernet0/0
OI  2001:70:2:7::/64 [110/4]
     via FE80::1, GigabitEthernet0/0
R6#ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/10/13 ms
R6#ping 2001:0:2:3::3 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/10 ms
R7#sh ipv6 ro ospf
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
OI  2001:0:1:3::/64 [110/3]
     via FE80::2, GigabitEthernet0/0
OI  2001:0:1:4::/64 [110/3]
     via FE80::2, GigabitEthernet0/0
OI  2001:0:1:5::/64 [110/3]
     via FE80::2, GigabitEthernet0/0
OI  2001:0:2:3::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
OI  2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
OI  2001:0:2:5::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
OI  2001:60:1:6::/64 [110/4]
     via FE80::2, GigabitEthernet0/0
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv
R2(config)#ipv6 route
R2(config)#ipv6 router os
R2(config)#ipv6 router ospf 1
R2(config-rtr)#are
R2(config-rtr)#do sh ipv
R2(config-rtr)#do sh ipv6 ro ospf
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:1:3::/64 [110/2]
     via FE80::3, GigabitEthernet0/0
O   2001:0:1:4::/64 [110/2]
     via FE80::4, GigabitEthernet0/1
O   2001:0:1:5::/64 [110/2]
     via FE80::5, GigabitEthernet0/2
OI  2001:60:1:6::/64 [110/3]
     via FE80::5, GigabitEthernet0/2
     via FE80::4, GigabitEthernet0/1
     via FE80::3, GigabitEthernet0/0
R2(config-rtr)#area 0 ran        
R2(config-rtr)#area 0 range 2001::/32   
R2(config-rtr)#no area 0 range 2001::/32
R2(config-rtr)#area 0 range 2001::/32   
R2(config-rtr)#do sh ipv6 ro ospf
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001::/32 [110/2]
     via Null0, directly connected
O   2001:0:1:3::/64 [110/2]
     via FE80::3, GigabitEthernet0/0
O   2001:0:1:4::/64 [110/2]
     via FE80::4, GigabitEthernet0/1
O   2001:0:1:5::/64 [110/2]
     via FE80::5, GigabitEthernet0/2
OI  2001:60:1:6::/64 [110/3]
     via FE80::5, GigabitEthernet0/2
     via FE80::4, GigabitEthernet0/1
     via FE80::3, GigabitEthernet0/0
R7#sh ipv6 ro ospf
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
OI  2001::/32 [110/3]
     via FE80::2, GigabitEthernet0/0
OI  2001:60:1:6::/64 [110/4]
     via FE80::2, GigabitEthernet0/0
R7#sh ipv6 ro ospf
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
OI  2001::/32 [110/3]
     via FE80::2, GigabitEthernet0/0
OI  2001:60:1:6::/64 [110/4]
     via FE80::2, GigabitEthernet0/0
R7#ping 2001:60:1:6::6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:60:1:6::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/9/10 ms
R7#ping 2001:0:1:4::1 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/8/13 ms
R7#traceroute 2001:0:1:4::1
Type escape sequence to abort.
Tracing the route to 2001:0:1:4::1

  1 2001:70:2:7::2 6 msec 4 msec 4 msec
  2 2001:0:2:4::4 7 msec 6 msec 9 msec
  3 2001:0:1:4::1 11 msec 16 msec 8 msec
R7#sh ipv6 ospf database        

            OSPFv3 Router with ID (7.7.7.7) (Process ID 1)

                Router Link States (Area 70)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 2.2.2.2         1061        0x80000002  0            1           B
 7.7.7.7         1060        0x80000002  0            1           None

                Net Link States (Area 70)

ADV Router       Age         Seq#        Link ID    Rtr count
 7.7.7.7         1060        0x80000001  2          2

                Inter Area Prefix Link States (Area 70)

ADV Router       Age         Seq#        Prefix
 2.2.2.2         1047        0x80000001  2001:60:1:6::/64
 2.2.2.2         329         0x80000001  2001::/32

                Link (Type-8) Link States (Area 70)

ADV Router       Age         Seq#        Link ID    Interface
 2.2.2.2         1106        0x80000001  5          Gi0/0
 7.7.7.7         1102        0x80000001  2          Gi0/0

                Intra Area Prefix Link States (Area 70)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 7.7.7.7         1060        0x80000001  2048       0x2002      2

R7#sh ipv6 ospf database inter-area ?
  prefix  Inter area prefix link states
  router  Inter area router link states

R7#sh ipv6 ospf database inter-area prefix 

            OSPFv3 Router with ID (7.7.7.7) (Process ID 1)

                Inter Area Prefix Link States (Area 70)

  LS age: 1129
  LS Type: Inter Area Prefix Links
  Link State ID: 6
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000001
  Checksum: 0x421B
  Length: 36
  Metric: 3 
  Prefix Address: 2001:60:1:6::
  Prefix Length: 64, Options: None

  LS age: 410
  LS Type: Inter Area Prefix Links
  Link State ID: 14
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000001
  Checksum: 0x41A0
  Length: 32
  Metric: 2 
  Prefix Address: 2001::
  Prefix Length: 32, Options: None

Topology: NBMA

IP

Project name: ccna-ipv6-0009-ospfv3-nbma

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:1234:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:1234:1:4::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:1234:2:3::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:1234:1:2::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:1234:3:4::3/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::3 link-local
ipv6 address 2001:1234:2:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
ipv6 unicast-routing
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:1234:1:4::4/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::4 link-local
ipv6 address 2001:1234:3:4::4/64
no shutdown
exit
!
end
write

OSPF Configuration: NBMA

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write

Configure OSPFv3

  • R1
configure terminal
!
ipv6 router ospf 1
router-id 1.1.1.1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf network non-broadcast
ipv6 ospf neighbor fe80::2
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R2
configure terminal
!
ipv6 router ospf 1
router-id 2.2.2.2
exit
!
interface GigabitEthernet 0/0
ipv6 ospf network non-broadcast
ipv6 ospf neighbor fe80::1
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R3
configure terminal
!
ipv6 router ospf 1
router-id 3.3.3.3
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
!
end
  • R4
configure terminal
!
ipv6 router ospf 1
router-id 4.4.4.4
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 router
R1(config)#ipv6 router os
R1(config)#ipv6 router ospf 1
R1(config-rtr)#router
R1(config-rtr)#router-id 
*Mar 11 21:54:28.700: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#do sh ipv6 ospf int   
R1(config-rtr)#int gig0/0
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf net
R1(config-if)#ipv6 ospf network ?
  broadcast            Specify OSPF broadcast multi-access network
  manet                Specify MANET OSPF interface type
  non-broadcast        Specify OSPF NBMA network
  point-to-multipoint  Specify OSPF point-to-multipoint network
  point-to-point       Specify OSPF point-to-point network

R1(config-if)#ipv6 ospf network non-br
R1(config-if)#ipv6 ospf network non-broadcast ?
  <cr>

R1(config-if)#ipv6 ospf network non-broadcast ipv
R1(config-if)#ipv6 ospf network non-broadcast    
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 are
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#do sh ipv6 int gig0/0
GigabitEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1 
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:0:1:2::1, subnet is 2001:0:1:2::/64 
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::1:FF00:1
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.
R1(config-if)#do ping 2001:0:1:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1(config-if)#do sh ipv6 ospf int gig0/0
GigabitEthernet0/0 is up, line protocol is up 
  Link Local Address FE80::1, Interface ID 2
  Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
  Network Type NON_BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, local address FE80::1
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:18
  Graceful restart helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)
R1(config-if)#nei
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf nei
R1(config-if)#ipv6 ospf 1 nei    
R1(config-if)#ipv6 ospf 1 ?  
  area  Set the OSPF area ID

R1(config-if)#ipv6 ospf nei
R1(config-if)#ipv6 ospf neighbor fe80::2
R1(config-if)#
*Mar 11 22:44:48.908: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R1(config-if)#int gig0/1
R1(config-if)#ipv
R1(config-if)#ipv6 os
R1(config-if)#ipv6 ospf 1 area 0
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv
R2(config)#ipv6 router osp
R2(config)#ipv6 router ospf 1
R2(config-rtr)#
*Mar 11 21:55:00.581: %OSPFv3-4-NORTRID: Process OSPFv3-1-IPv6 could not pick a router-id, please configure manually
R2(config-rtr)#router
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#ipv
R2(config-rtr)#int gig0/0
R2(config-if)#ipv
R2(config-if)#ipv6 os
R2(config-if)#ipv6 ospf ne
R2(config-if)#ipv6 ospf neno
R2(config-if)#ipv6 ospf netwo
R2(config-if)#ipv6 ospf network no
R2(config-if)#ipv6 ospf network non-broadcast 
R2(config-if)#ipv
R2(config-if)#ipv6 os
R2(config-if)#ipv6 ospf 1 are
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#sh ipv6 ospf int
                 ^
% Invalid input detected at '^' marker.

R2(config-if)#do sh ipv6 ospf int
GigabitEthernet0/0 is up, line protocol is up 
  Link Local Address FE80::2, Interface ID 2
  Area 0, Process ID 1, Instance ID 0, Router ID 2.2.2.2
  Network Type NON_BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, local address FE80::2
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:03
  Graceful restart helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)
R2(config-if)#ipv6 neih
R2(config-if)#ipv6 os  
R2(config-if)#ipv6 ospf nei
R2(config-if)#ipv6 ospf neighbor fe80::1
R2(config-if)#
*Mar 11 22:44:49.036: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R2(config-if)#ipv
R2(config-if)#int gig0/1
R2(config-if)#ipv
R2(config-if)#ipv6 os
R2(config-if)#ipv6 ospf 1 are
R2(config-if)#ipv6 ospf 1 area 0
R3#sh ipv6 ro ospf
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:1:2::/64 [110/2]
     via FE80::1, GigabitEthernet0/0
O   2001:0:2:4::/64 [110/3]
     via FE80::1, GigabitEthernet0/0
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/9/16 ms

Topology: show commands

IP

Project name: ccna-ipv6-0007-ospfv3

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write

Configure OSPFv3

  • R1
configure terminal
!
ipv6 router ospf 1
router-id 1.1.1.1
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R2
configure terminal
!
ipv6 router ospf 1
router-id 2.2.2.2
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 ospf 1 area 0
exit
interface GigabitEthernet 0/1
ipv6 ospf 1 area 0
exit
!
end
  • R3
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
!
end
  • R4
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::2
!
end

Verification

R1#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 1.1.1.1
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Redistribution:
    None
R1#sho
R1#show ipv
R1#show ipv6 osp
R1#show ipv6 ospf 
 Routing Process "ospfv3 1" with ID 1.1.1.1
 Supports NSSA (compatible with RFC 3101)
 Supports Database Exchange Summary List Optimization (RFC 5243)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Retransmission limit dc 24 non-dc 24
 EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
 Number of external LSA 0. Checksum Sum 0x000000
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Graceful restart helper support enabled
 Reference bandwidth unit is 100 mbps
 RFC1583 compatibility enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        SPF algorithm executed 2 times
        Number of LSA 9. Checksum Sum 0x04A930
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R1#sho
R1#show ipv
R1#show ipv6 ospf inter
R1#show ipv6 ospf interface 
GigabitEthernet0/1 is up, line protocol is up 
  Link Local Address FE80::1, Interface ID 3
  Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
  Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, local address FE80::1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    No Hellos (Passive interface) 
  Graceful restart helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up 
  Link Local Address FE80::1, Interface ID 2
  Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
  Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, local address FE80::1
  Backup Designated router (ID) 2.2.2.2, local address FE80::2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:06
  Graceful restart helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 3
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
R1#show ipv6 osp
R1#show ipv6 ospf neigh
R1#show ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:33    2               GigabitEthernet0/0
R1#sh ipv
R1#sh ipv6 os
R1#sh ipv6 ospf nei
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:39    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:36    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:34    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:33    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:32    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:31    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:30    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:39    2               GigabitEthernet0/0
R1#sh ipv6 ospf neighbor 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:38    2               GigabitEthernet0/0
R1#sho
R1#show ipv
R1#show ipv6 osp
R1#show ipv6 ospf da
R1#show ipv6 ospf database 

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 1.1.1.1         1649        0x80000002  0            1           None
 2.2.2.2         1650        0x80000001  0            1           None

                Net Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Rtr count
 1.1.1.1         1649        0x80000001  2          2

                Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface
 1.1.1.1         1682        0x80000001  3          Gi0/1
 1.1.1.1         1692        0x80000001  2          Gi0/0
 2.2.2.2         1650        0x80000001  2          Gi0/0

                Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 1.1.1.1         1649        0x80000003  0          0x2001      0
 1.1.1.1         1649        0x80000001  2048       0x2002      2
 2.2.2.2         1640        0x80000003  0          0x2001      0
R1#sho
R1#show ipv
R1#show ipv6 ro
R1#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:0:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:0:1:2::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:0:1:3::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:0:1:3::1/128 [0/0]
     via GigabitEthernet0/1, receive
O   2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
L   FF00::/8 [0/0]
     via Null0, receive
R1#sho
R1#show ipv
R1#show ipv6 ro ospf
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
O   2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
R1#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms
R1#

Topology: Address Family

IP

Project name: ccna-ipv6-0010-ospfv3-address-family

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ip address 10.1.2.1 255.255.255.0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ip address 10.1.3.1 255.255.255.0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ip address 10.1.2.2 255.255.255.0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ip address 10.2.4.2 255.255.255.0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ip address 10.1.3.3 255.255.255.0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ip address 10.2.4.4 255.255.255.0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write

Configure OSPFv3

  • R1
configure terminal
!
router ospfv3 1
router-id 1.1.1.1
passive-interface GigabitEthernet 0/1
address-family ipv4 unicast
exit-address-family
address-family ipv6 unicast
exit-address-family
exit
!
interface GigabitEthernet 0/0
ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
interface GigabitEthernet 0/1
ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
!
end
  • R2
configure terminal
!
router ospfv3 1
router-id 2.2.2.2
passive-interface GigabitEthernet 0/1
address-family ipv4 unicast
exit-address-family
address-family ipv6 unicast
exit-address-family
exit
!
interface GigabitEthernet 0/0
ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
interface GigabitEthernet 0/1
ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
!
end
  • R3
configure terminal
!
ip route 0.0.0.0 0.0.0.0 10.1.3.1
ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
!
end
  • R4
configure terminal
!
ip route 0.0.0.0 0.0.0.0 10.2.4.2
ipv6 route ::/0 GigabitEthernet 0/0 fe80::2
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router os
R1(config)#router ospfv
R1(config)#router ospfv3 1
R1(config-router)#rotuer
R1(config-router)#rotuer-
R1(config-router)#rotuer-i 
R1(config-router)#rotuer-i
R1(config-router)#rotuer-id
R1(config-router)#rotuer-id
R1(config-router)#rotuer-id 
R1(config-router)#rotuer-id ?
% Unrecognized command
R1(config-router)#router-id 1.1.1.1
R1(config-router)#pass
R1(config-router)#passive-interface passi
R1(config-router)#passive-interface gi      
R1(config-router)#passive-interface gigabitEthernet 0/1
R1(config-router)#add
R1(config-router)#address-family ipv
R1(config-router)#address-family ipvu
R1(config-router)#address-family ip  
R1(config-router)#address-family ipv4
R1(config-router-af)#exi                
R1(config-router-af)#exit-address-family 
R1(config-router)#exit-address-family ipv
R1(config-router)#no add                 
R1(config-router)#no address-family ipv4
R1(config-router)#address-family ipv4 u 
R1(config-router)#address-family ipv4 ?       
  unicast  Address Family modifier
  vrf      Specify parameters for a VPN Routing/Forwarding instance
  <cr>

R1(config-router)#address-family ipv4 uni
R1(config-router)#address-family ipv4 unicast 
R1(config-router-af)#exi
R1(config-router-af)#exit-address-family 
R1(config-router)#add
R1(config-router)#address-family ipv6 uni
R1(config-router)#address-family ipv6 unicast 
R1(config-router-af)#exi
R1(config-router-af)#exit-address-family 
R1(config-router)#exit
R1(config)#int gig0/0
R1(config-if)#ospf
R1(config-if)#ospfv3 1 ipv
R1(config-if)#ospfv3 1 ipv4 are
R1(config-if)#ospfv3 1 ipv4 area 0
R1(config-if)#ospfv3 1 ipv6 area 0
R1(config-if)#int gig0/1
R1(config-if)#ospfv3 1 ipv4 are
R1(config-if)#ospfv3 1 ipv4 area 0
R1(config-if)#os
R1(config-if)#ospfv3 1 ipv6
R1(config-if)#ospfv3 1 ipv6 are
R1(config-if)#ospfv3 1 ipv6 area 0
R1(config-if)#do sh run | s ospfv3
 ospfv3 1 ipv6 area 0
 ospfv3 1 ipv4 area 0
 ospfv3 1 ipv6 area 0
 ospfv3 1 ipv4 area 0
router ospfv3 1
 router-id 1.1.1.1
 !
 address-family ipv4 unicast
 exit-address-family
 !
 address-family ipv6 unicast
 exit-address-family
R1(config-if)#
*Mar 13 22:59:00.340: %OSPFv3-5-ADJCHG: Process 1, IPv4, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R1(config-if)#
*Mar 13 22:59:18.780: %OSPFv3-5-ADJCHG: Process 1, IPv6, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R1(config-if)#^Z
R1#pi
*Mar 13 23:02:28.006: %SYS-5-CONFIG_I: Configured from console by console
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospfv3 1
R2(config-router)#router
R2(config-router)#router-id 2.2.2.2
R2(config-router)#passi
R2(config-router)#passive-interface Gi
R2(config-router)#passive-interface GigabitEthernet 0/1
R2(config-router)#add
R2(config-router)#address-family ipv
R2(config-router)#address-family ipv4 unica
R2(config-router)#address-family ipv4 unicast 
R2(config-router-af)#exi
R2(config-router-af)#exit-address-family 
R2(config-router)#add
R2(config-router)#address-family ipv6 uni
R2(config-router)#address-family ipv6 unicast 
R2(config-router-af)#exit
R2(config-router)#exti
                    ^
% Invalid input detected at '^' marker.

R2(config-router)#exit
R2(config)#int gig0/0
R2(config-if)#ospf
R2(config-if)#ospfv3 1 ip
R2(config-if)#ospfv3 1 ipv4
R2(config-if)#ospfv3 1 ipv4 are
R2(config-if)#ospfv3 1 ipv4 area 0
R2(config-if)#
*Mar 13 22:59:01.511: %OSPFv3-5-ADJCHG: Process 1, IPv4, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R2(config-if)#ospfv3 1 ipv6 are   
R2(config-if)#ospfv3 1 ipv6 area 0
R2(config-if)#
*Mar 13 22:59:19.956: %OSPFv3-5-ADJCHG: Process 1, IPv6, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
R2(config-if)#int gi0/1
R2(config-if)#ospf
R2(config-if)#ospfv3 1 ipv
R2(config-if)#ospfv3 1 ipv4 are
R2(config-if)#ospfv3 1 ipv4 area 0
R2(config-if)#os
R2(config-if)#ospfv3 1 ipv
R2(config-if)#ospfv3 1 ipv6 are
R2(config-if)#ospfv3 1 ipv6 area 0
R2(config-if)#^Z
R2#
*Mar 13 22:59:54.850: %SYS-5-CONFIG_I: Configured from console by console
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv6 ro
R3(config)#ipv6 rout    
R3(config)#ipv6 route ::/0 Gig
R3(config)#ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
R3(config)#ip ro 0.0.0.0 0.0.0.0 10.1.3.1
% Ambiguous command:  "ip ro 0.0.0.0 0.0.0.0 10.1.3.1"
R3(config)#ip rou 0.0.0.0 0.0.0.0 10.1.3.1
% Ambiguous command:  "ip rou 0.0.0.0 0.0.0.0 10.1.3.1"
R3(config)#ip rou 0.0.0.0 0.0.0.0 10.1.3.1
% Ambiguous command:  "ip rou 0.0.0.0 0.0.0.0 10.1.3.1"
R3(config)#ip route 0.0.0.0 0.0.0.0 10.1.3.1
R3(config)#^Z
R3#
*Mar 13 23:02:25.269: %SYS-5-CONFIG_I: Configured from console by console
R3#
R3#ping 10.2.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/7/9 ms
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/10/34 ms
R1#show ospfv3 neighbor 

          OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:31    2               GigabitEthernet0/0

          OSPFv3 1 address-family ipv6 (router-id 1.1.1.1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:39    2               GigabitEthernet0/0
R1#sho
R1#show ospf
R1#show ospfv3 inter
R1#show ospfv3 interface bri
R1#show ospfv3 interface brief 
Interface    PID   Area            AF         Cost  State Nbrs F/C
Gi0/1        1     0               ipv4       1     DR    0/0
Gi0/0        1     0               ipv4       1     DR    1/1
Gi0/1        1     0               ipv6       1     DR    0/0
Gi0/0        1     0               ipv6       1     DR    1/1
R1#show ospfv3 da
R1#show ospfv3 database 

          OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)

                Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 1.1.1.1         473         0x80000002  0            1           None
 2.2.2.2         474         0x80000001  0            1           None

                Net Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Rtr count
 1.1.1.1         473         0x80000001  2          2

                Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface
 1.1.1.1         577         0x80000001  3          Gi0/1
 1.1.1.1         595         0x80000001  2          Gi0/0
 2.2.2.2         475         0x80000001  2          Gi0/0

                Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 1.1.1.1         473         0x80000003  0          0x2001      0
 1.1.1.1         473         0x80000001  2048       0x2002      2
 2.2.2.2         436         0x80000001  0          0x2001      0

          OSPFv3 1 address-family ipv6 (router-id 1.1.1.1)

                Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 1.1.1.1         455         0x80000002  0            1           None
 2.2.2.2         456         0x80000001  0            1           None

                Net Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Rtr count
 1.1.1.1         455         0x80000001  2          2

                Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface
 1.1.1.1         570         0x80000001  3          Gi0/1
 1.1.1.1         591         0x80000001  2          Gi0/0
 2.2.2.2         457         0x80000001  2          Gi0/0

                Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 1.1.1.1         455         0x80000003  0          0x2001      0
 1.1.1.1         455         0x80000001  2048       0x2002      2
 2.2.2.2         428         0x80000001  0          0x2001      0
R1#show ip proto
R1#show ip protocols 
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "ospfv3 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Maximum path: 4
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.2              110      00:07:56
  Distance: (default is 110)

R1#show ipv6 pro
R1#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 1.1.1.1
  Number of areas: 1 normal, 0 stub, 0 nssa
  Interfaces (Area 0):
    GigabitEthernet0/1
    GigabitEthernet0/0
  Redistribution:
    None
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.1.2.0/24 is directly connected, GigabitEthernet0/0
L        10.1.2.1/32 is directly connected, GigabitEthernet0/0
C        10.1.3.0/24 is directly connected, GigabitEthernet0/1
L        10.1.3.1/32 is directly connected, GigabitEthernet0/1
O        10.2.4.0/24 [110/2] via 10.1.2.2, 00:09:34, GigabitEthernet0/0
R1#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:0:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:0:1:2::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:0:1:3::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:0:1:3::1/128 [0/0]
     via GigabitEthernet0/1, receive
O   2001:0:2:4::/64 [110/2]
     via FE80::2, GigabitEthernet0/0
L   FF00::/8 [0/0]
     via Null0, receive
R1#

References

tech/network/cisco/ipv6/ospfv3/ospfv3.txt · Last modified: 2019/03/14 08:11 by wnoguchi