PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:ipv6-tunnel:ipv6-tunnel

IPv6 and IPv4 Interoperable Tunneling Technology

R1(config)#int tunnel 0
R1(config-if)#
*Jul  9 23:59:45.338: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#tunn
R1(config-if)#tunnel mo
R1(config-if)#tunnel mode ?
  aurp    AURP TunnelTalk AppleTalk encapsulation
  cayman  Cayman TunnelTalk AppleTalk encapsulation
  dvmrp   DVMRP multicast tunnel
  eon     EON compatible CLNS tunnel
  gre     generic route encapsulation protocol
  ipip    IP over IP encapsulation
  ipsec   IPSec tunnel encapsulation
  iptalk  Apple IPTalk encapsulation
  ipv6    Generic packet tunneling in IPv6
  ipv6ip  IPv6 over IP encapsulation
  mpls    MPLS encapsulations
  nos     IP over IP encapsulation (KA9Q/NOS compatible)
  rbscp   RBSCP in IP tunnel
  udp     UDP encapsulation protocol

R1(config-if)#tunnel mode gre ?
  ip          over IP
  ipv6        over IPv6
  multipoint  over IPv4 (multipoint)

IPv6 Manual Tunneling

Initial config

  • R1
conf t
!
hostname R1
!
int gig0/0
ip address 192.168.0.1 255.255.255.0
no shut
exit
!
int gig0/1
ipv6 address 2001:1:1:1::1/64
no shut
exit
!
end
!
wr
  • R2
conf t
!
hostname R2
!
int gig0/0
ip address 192.168.0.2 255.255.255.0
no shut
exit
!
int gig0/1
ipv6 address 2001:2:2:2::1/64
no shut
exit
!
end
!
wr
  • PC-1
ip 2001:1:1:1::2/64 2001:1:1:1::1
  • PC-2
ip 2001:1:1:1::3/64 2001:1:1:1::1
  • PC-3
ip 2001:1:1:1::4/64 2001:1:1:1::1
  • PC-4
ip 2001:2:2:2::2/64 2001:2:2:2::1
  • PC-5
ip 2001:2:2:2::3/64 2001:2:2:2::1
PC-1> ip ?

ip ARG ... [OPTION]
  Configure the current VPC's IP settings
    ARG ...:
    address [mask] [gateway]
    address [gateway] [mask]
                   Set the VPC's ip, default gateway ip and network mask
                   Default IPv4 mask is /24, IPv6 is /64. Example:
                   ip 10.1.1.70/26 10.1.1.65 set the VPC's ip to 10.1.1.70,
                   the gateway to 10.1.1.65, the netmask to 255.255.255.192.
                   In tap mode, the ip of the tapx is the maximum host ID
                   of the subnet. In the example above the tapx ip would be
                   10.1.1.126
                   mask may be written as /26, 26 or 255.255.255.192
    auto           Attempt to obtain IPv6 address, mask and gateway using SLAAC
    dhcp [OPTION]  Attempt to obtain IPv4 address, mask, gateway, DNS via DHCP
          -d         Show DHCP packet decode
          -r         Renew DHCP lease
          -x         Release DHCP lease
    dns ip         Set DNS server ip, delete if ip is '0'
    domain NAME    Set local domain name to NAME

PC-1> ip 2001:1:1:1::2/64 2001:1:1:1::1
PC1 : 2001:1:1:1::2/64

PC-1> ping6
Bad command: "ping6". Use ? for help.

PC-1> ping 2001:1:1:1::1

2001:1:1:1::1 icmp6_seq=1 ttl=64 time=2.323 ms
2001:1:1:1::1 icmp6_seq=2 ttl=64 time=2.278 ms
2001:1:1:1::1 icmp6_seq=3 ttl=64 time=1.911 ms
2001:1:1:1::1 icmp6_seq=4 ttl=64 time=1.779 ms
2001:1:1:1::1 icmp6_seq=5 ttl=64 time=1.852 ms

PC-1> ping 2001:1:1:1::3

2001:1:1:1::3 icmp6_seq=1 timeout
2001:1:1:1::3 icmp6_seq=2 timeout
2001:1:1:1::3 icmp6_seq=3 timeout
2001:1:1:1::3 icmp6_seq=4 timeout
2001:1:1:1::3 icmp6_seq=5 timeout

PC-1> ping 2001:1:1:1::4

2001:1:1:1::4 icmp6_seq=1 timeout
2001:1:1:1::4 icmp6_seq=2 timeout
2001:1:1:1::4 icmp6_seq=3 timeout
2001:1:1:1::4 icmp6_seq=4 timeout
2001:1:1:1::4 icmp6_seq=5 timeout

PC-1> ping 2001:1:1:1::2

2001:1:1:1::2 icmp_seq=1 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=2 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=3 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=4 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=5 ttl=64 time=0.001 ms

PC-1> ping 2001:1:1:1::4

2001:1:1:1::4 icmp6_seq=1 timeout
2001:1:1:1::4 icmp6_seq=2 timeout
2001:1:1:1::4 icmp6_seq=3 timeout
2001:1:1:1::4 icmp6_seq=4 timeout
2001:1:1:1::4 icmp6_seq=5 timeout

PC-1> ping 2001:1:1:1::1

2001:1:1:1::1 icmp6_seq=1 ttl=64 time=5.849 ms
2001:1:1:1::1 icmp6_seq=2 ttl=64 time=7.039 ms
2001:1:1:1::1 icmp6_seq=3 ttl=64 time=7.016 ms
2001:1:1:1::1 icmp6_seq=4 ttl=64 time=6.697 ms
2001:1:1:1::1 icmp6_seq=5 ttl=64 time=7.019 ms

PC-1> ping 2001:1:1:1::2

2001:1:1:1::2 icmp_seq=1 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=2 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=3 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=4 ttl=64 time=0.001 ms
2001:1:1:1::2 icmp_seq=5 ttl=64 time=0.001 ms

PC-1> ping 2001:1:1:1::3

2001:1:1:1::3 icmp6_seq=1 timeout
2001:1:1:1::3 icmp6_seq=2 timeout
2001:1:1:1::3 icmp6_seq=3 timeout
2001:1:1:1::3 icmp6_seq=4 timeout
2001:1:1:1::3 icmp6_seq=5 timeout

PC-1> ping 2001:1:1:1::3

2001:1:1:1::3 icmp6_seq=1 timeout
2001:1:1:1::3 icmp6_seq=2 timeout
2001:1:1:1::3 icmp6_seq=3 timeout
2001:1:1:1::3 icmp6_seq=4 timeout
2001:1:1:1::3 icmp6_seq=5 timeout

PC-1> ip

ip ARG ... [OPTION]
  Configure the current VPC's IP settings
    ARG ...:
    address [mask] [gateway]
    address [gateway] [mask]
                   Set the VPC's ip, default gateway ip and network mask
                   Default IPv4 mask is /24, IPv6 is /64. Example:
                   ip 10.1.1.70/26 10.1.1.65 set the VPC's ip to 10.1.1.70,
                   the gateway to 10.1.1.65, the netmask to 255.255.255.192.
                   In tap mode, the ip of the tapx is the maximum host ID
                   of the subnet. In the example above the tapx ip would be
                   10.1.1.126
                   mask may be written as /26, 26 or 255.255.255.192
    auto           Attempt to obtain IPv6 address, mask and gateway using SLAAC
    dhcp [OPTION]  Attempt to obtain IPv4 address, mask, gateway, DNS via DHCP
          -d         Show DHCP packet decode
          -r         Renew DHCP lease
          -x         Release DHCP lease
    dns ip         Set DNS server ip, delete if ip is '0'
    domain NAME    Set local domain name to NAME

PC-1> show ipv6

NAME              : PC-1[1]
LINK-LOCAL SCOPE  : fe80::250:79ff:fe66:6800/64
GLOBAL SCOPE      : 2001:1:1:1::2/64
ROUTER LINK-LAYER :
MAC               : 00:50:79:66:68:00
LPORT             : 10010
RHOST:PORT        : 127.0.0.1:10011
MTU:              : 1500

PC-1> ping 2001:1:1:1::3

2001:1:1:1::3 icmp6_seq=1 timeout
2001:1:1:1::3 icmp6_seq=2 timeout
2001:1:1:1::3 icmp6_seq=3 timeout
2001:1:1:1::3 icmp6_seq=4 timeout
2001:1:1:1::3 icmp6_seq=5 timeout

PC-1> ping fe80::250:79ff:fe66:6801

fe80::250:79ff:fe66:6801 icmp6_seq=1 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=2 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=3 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=4 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=5 timeout

PC-1> ping fe80::250:79ff:fe66:6801

fe80::250:79ff:fe66:6801 icmp6_seq=1 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=2 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=3 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=4 timeout
fe80::250:79ff:fe66:6801 icmp6_seq=5 timeout

PC-1 to PC-2 ping fail.

I packet captured this each link.

I found Router Solicitation.

Enter global config into R1.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv6 unicast-routing
R1(config)#^Z
R1#
*Jul 10 12:29:30.731: %SYS-5-CONFIG_I: Configured from console by console
I need to verify physical box this behavior.
PC-1> ping fe80::250:79ff:fe66:6801

fe80::250:79ff:fe66:6801 icmp6_seq=1 ttl=63 time=12.556 ms
fe80::250:79ff:fe66:6801 icmp6_seq=2 ttl=63 time=5.737 ms
fe80::250:79ff:fe66:6801 icmp6_seq=3 ttl=63 time=2.097 ms
fe80::250:79ff:fe66:6801 icmp6_seq=4 ttl=63 time=1.972 ms
fe80::250:79ff:fe66:6801 icmp6_seq=5 ttl=63 time=6.617 ms

PC-1> ping fe80::250:79ff:fe66:6801

fe80::250:79ff:fe66:6801 icmp6_seq=1 ttl=63 time=2.521 ms
fe80::250:79ff:fe66:6801 icmp6_seq=2 ttl=63 time=2.451 ms
fe80::250:79ff:fe66:6801 icmp6_seq=3 ttl=63 time=2.539 ms
fe80::250:79ff:fe66:6801 icmp6_seq=4 ttl=63 time=4.155 ms
fe80::250:79ff:fe66:6801 icmp6_seq=5 ttl=63 time=4.905 ms

PC-1> ping 2001:1:1:1::3

2001:1:1:1::3 icmp6_seq=1 ttl=63 time=10.223 ms
2001:1:1:1::3 icmp6_seq=2 ttl=63 time=3.075 ms
2001:1:1:1::3 icmp6_seq=3 ttl=63 time=7.477 ms
2001:1:1:1::3 icmp6_seq=4 ttl=63 time=4.419 ms
2001:1:1:1::3 icmp6_seq=5 ttl=63 time=3.260 ms

PC-1> save
Saving startup configuration to startup.vpc
.  done
PC-2> ip 2001:1:1:1::3/64 2001:1:1:1::1
PC1 : 2001:1:1:1::3/64

PC-2> 2001:1:1:1::1
Bad command: "2001:1:1:1::1". Use ? for help.

PC-2> png 2001:1:1:1::1
Bad command: "png 2001:1:1:1::1". Use ? for help.

PC-2> ping 2001:1:1:1::1

2001:1:1:1::1 icmp6_seq=1 ttl=64 time=2.303 ms
2001:1:1:1::1 icmp6_seq=2 ttl=64 time=2.342 ms
2001:1:1:1::1 icmp6_seq=3 ttl=64 time=2.243 ms
2001:1:1:1::1 icmp6_seq=4 ttl=64 time=3.027 ms
2001:1:1:1::1 icmp6_seq=5 ttl=64 time=2.075 ms

PC-2> show ipv6

NAME              : PC-2[1]
LINK-LOCAL SCOPE  : fe80::250:79ff:fe66:6801/64
GLOBAL SCOPE      : 2001:1:1:1::3/64
ROUTER LINK-LAYER :
MAC               : 00:50:79:66:68:01
LPORT             : 10028
RHOST:PORT        : 127.0.0.1:10029
MTU:              : 1500

PC-2> fe80::250:79ff:fe66:6801
Bad command: "fe80::250:79ff:fe66:6801". Use ? for help.

PC-2> save
Saving startup configuration to startup.vpc
.  done

PC-2> ping 2001:1:1:1::2

2001:1:1:1::2 icmp6_seq=1 ttl=63 time=2.592 ms
2001:1:1:1::2 icmp6_seq=2 ttl=63 time=2.313 ms
2001:1:1:1::2 icmp6_seq=3 ttl=63 time=4.196 ms
2001:1:1:1::2 icmp6_seq=4 ttl=63 time=3.127 ms
2001:1:1:1::2 icmp6_seq=5 ttl=63 time=3.685 ms
PC-3> ping 2001:1:1:1::1

2001:1:1:1::1 icmp6_seq=1 ttl=64 time=2.154 ms
2001:1:1:1::1 icmp6_seq=2 ttl=64 time=1.326 ms
2001:1:1:1::1 icmp6_seq=3 ttl=64 time=2.129 ms
2001:1:1:1::1 icmp6_seq=4 ttl=64 time=1.777 ms
2001:1:1:1::1 icmp6_seq=5 ttl=64 time=2.119 ms

PC-3> show ipv6

NAME              : PC-3[1]
LINK-LOCAL SCOPE  : fe80::250:79ff:fe66:6802/64
GLOBAL SCOPE      : 2001:1:1:1::4/64
ROUTER LINK-LAYER :
MAC               : 00:50:79:66:68:02
LPORT             : 10030
RHOST:PORT        : 127.0.0.1:10031
MTU:              : 1500

PC-3> save
Saving startup configuration to startup.vpc
.  done

Same manner, I repeated same thing.

PC-4> ip 2001:2:2:2::2/64 2001:2:2:2::1
PC1 : 2001:2:2:2::2/64

PC-4> ping 2001:2:2:2::1

2001:2:2:2::1 icmp6_seq=1 ttl=64 time=2.513 ms
2001:2:2:2::1 icmp6_seq=2 ttl=64 time=2.613 ms
2001:2:2:2::1 icmp6_seq=3 ttl=64 time=1.975 ms
2001:2:2:2::1 icmp6_seq=4 ttl=64 time=2.008 ms
2001:2:2:2::1 icmp6_seq=5 ttl=64 time=2.334 ms

PC-4> ping 2001:2:2:2::3

2001:2:2:2::3 icmp6_seq=1 timeout
2001:2:2:2::3 icmp6_seq=2 timeout
2001:2:2:2::3 icmp6_seq=3 timeout
2001:2:2:2::3 icmp6_seq=4 timeout
2001:2:2:2::3 icmp6_seq=5 timeout

PC-4> ping 2001:2:2:2::3

2001:2:2:2::3 icmp6_seq=1 timeout
2001:2:2:2::3 icmp6_seq=2 timeout
2001:2:2:2::3 icmp6_seq=3 timeout
2001:2:2:2::3 icmp6_seq=4 timeout
2001:2:2:2::3 icmp6_seq=5 timeout
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv6 unicast-routing
R2(config)#^Z
R2#
*Jul 10 12:29:33.466: %SYS-5-CONFIG_I: Configured from console by console
PC-4> ping 2001:2:2:2::3

2001:2:2:2::3 icmp6_seq=1 ttl=63 time=8.627 ms
2001:2:2:2::3 icmp6_seq=2 ttl=63 time=2.363 ms
2001:2:2:2::3 icmp6_seq=3 ttl=63 time=1.783 ms
2001:2:2:2::3 icmp6_seq=4 ttl=63 time=8.114 ms
2001:2:2:2::3 icmp6_seq=5 ttl=63 time=5.345 ms

PC-4> save
Saving startup configuration to startup.vpc
.  done

OK, It works.

Finally I verified R1 - R2 link IPv4 reachability.

R1#ping 192.168.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 3/4/5 ms
R1#ping 192.168.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
R1#ping 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Good.

<R1#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.0.1     YES manual up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
R1#sh ipv6 int b
GigabitEthernet0/0     [up/up]
    unassigned
GigabitEthernet0/1     [up/up]
    FE80::E7D:49FF:FE94:BB01
    2001:1:1:1::1
GigabitEthernet0/2     [administratively down/down]
    unassigned
GigabitEthernet0/3     [administratively down/down]
    unassigned
/code>

<code>
R2#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.0.2     YES manual up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
R2#sh ipv6 int b
GigabitEthernet0/0     [up/up]
    unassigned
GigabitEthernet0/1     [up/up]
    FE80::E7D:49FF:FE66:5B01
    2001:2:2:2::1
GigabitEthernet0/2     [administratively down/down]
    unassigned
GigabitEthernet0/3     [administratively down/down]
    unassigned

Seems good.

  • R1
conf t
!
ipv6 unicast-routing
!
ipv6 router rip P1
exit
!
int gig0/1
ipv6 rip P1 enable
exit
!
interface tunnel 0
ipv6 address 2001:1:1:0::1/64
ipv6 rip P1 enable
tunnel source 192.168.0.1
tunnel destination 192.168.0.2
tunnel mode ipv6ip
exit
!
end
  • R2
conf t
!
ipv6 unicast-routing
!
ipv6 router rip P1
exit
!
int gig0/1
ipv6 rip P1 enable
exit
!
interface tunnel 0
ipv6 address 2001:1:1:0::2/64
ipv6 rip P1 enable
tunnel source 192.168.0.2
tunnel destination 192.168.0.1
tunnel mode ipv6ip
exit
!
end
R1#sh ipv6 ro
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:1:1::/64 [0/0]
     via Tunnel0, directly connected
L   2001:1:1::1/128 [0/0]
     via Tunnel0, receive
C   2001:1:1:1::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:1:1:1::1/128 [0/0]
     via GigabitEthernet0/1, receive
R   2001:2:2:2::/64 [120/2]
     via FE80::C0A8:2, Tunnel0
L   FF00::/8 [0/0]
     via Null0, receive
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
R2#sh ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:1:1::/64 [0/0]
     via Tunnel0, directly connected
L   2001:1:1::2/128 [0/0]
     via Tunnel0, receive
R   2001:1:1:1::/64 [120/2]
     via FE80::C0A8:1, Tunnel0
C   2001:2:2:2::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:2:2:2::1/128 [0/0]
     via GigabitEthernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.2/32 is directly connected, GigabitEthernet0/0
R1#ping ipv6 2001:2:2:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/12 ms
R1#ping ipv6 2001:2:2:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R1#ping ipv6 2001:1:1::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms
R1#ping ipv6 2001:2:2:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms

end to end ping reachability check.

PC-1> ping 2001:1:1::2

2001:1:1::2 icmp6_seq=1 ttl=63 time=5.824 ms
2001:1:1::2 icmp6_seq=2 ttl=63 time=3.862 ms
2001:1:1::2 icmp6_seq=3 ttl=63 time=3.702 ms
2001:1:1::2 icmp6_seq=4 ttl=63 time=4.281 ms
2001:1:1::2 icmp6_seq=5 ttl=63 time=3.818 ms

PC-1> ping 2001:2:2:2::2

2001:2:2:2::2 icmp6_seq=1 ttl=60 time=18.775 ms
2001:2:2:2::2 icmp6_seq=2 ttl=60 time=3.858 ms
2001:2:2:2::2 icmp6_seq=3 ttl=60 time=2.238 ms
2001:2:2:2::2 icmp6_seq=4 ttl=60 time=2.826 ms
2001:2:2:2::2 icmp6_seq=5 ttl=60 time=2.983 ms

PC-1> ping 2001:2:2:2::3

2001:2:2:2::3 icmp6_seq=1 ttl=60 time=7.556 ms
2001:2:2:2::3 icmp6_seq=2 ttl=60 time=2.156 ms
2001:2:2:2::3 icmp6_seq=3 ttl=60 time=2.273 ms
2001:2:2:2::3 icmp6_seq=4 ttl=60 time=2.546 ms
2001:2:2:2::3 icmp6_seq=5 ttl=60 time=2.750 ms
R1#sh ipv6 int b tun0
Tunnel0                [up/up]
    FE80::C0A8:1
    2001:1:1::1
R2#sh ipv6 int b tun0
Tunnel0                [up/up]
    FE80::C0A8:2
    2001:1:1::2

IPv6 Automatic Tunneling

  • 6to4 Tunnel
  • ISATAP Tunnel

References

tech/network/cisco/ipv6-tunnel/ipv6-tunnel.txt · Last modified: 2018/07/11 08:28 by wnoguchi