User Tools

Site Tools


tech:network:cisco:ip-sla:ip-sla

Cisco: IP SLA

Blueprint

      • 4.0 Network Assurance
        • 4.5 Configure and verify IPSLA
      • 4.0 Infrastructure Security and Services
        • 4.6 Network optimization
          • 4.6.a IP SLA
            • 4.6.a i ICMP probes
            • 4.6.a ii UDP probes
            • 4.6.a iii TCP probes
      • 6.0 Infrastructure Services
        • 6.4 Network optimization
          • 6.4.a Implement and troubleshoot IP SLA
            • 6.4.a [i] ICMP, UDP, Jitter, VoIP
          • 6.4.b Implement and troubleshoot tracking object
            • 6.4.b [i] Tracking object, tracking list
            • 6.4.b [ii] Tracking different entities [e.g. interfaces, routes, IPSLA, and such]
      • 5.0 Infrastructure Services
        • 5.4 Network optimization
          • 5.4.a Implement and troubleshoot IP SLA
            • 5.4.a [i] ICMP, UDP, jitter, VoIP
          • 5.4.b Implement and troubleshoot tracking object
            • 5.4.b [i] Tracking object, tracking list
            • 5.4.b [ii] Tracking different entities [e.g. interfaces, routes, IPSLA, and such]

IP SLA Active Monitoring Lab

R1 Base Config

R2 Base Config

R3 Base Config

R4 Base Config

R5 Base Config

  • R4
configure terminal
!
ip sla responder
!
end
  • R1
configure terminal
!
ip sla 1
 ! destination port is 16384/udp
 udp-jitter 10.4.4.4 16384 codec g711ulaw
 !tos 160
 ! EF(Expedited Forwarding, 46)
 tos 184
exit
ip sla schedule 1 life forever start-time now
!
end
  • R1
configure terminal
!
snmp-server host 10.0.128.254 public
snmp-server enable traps ipsla
! Legacy
!snmp-server enable traps rtr
!
ip sla reaction-configuration 1 react mos threshold-value 500 300 threshold-type immediate action-type trapOnly
!
end
/etc/snmp/snmptrapd.conf
authCommunity log,execute,net public
sudo systemctl restart snmptrapd
systemctl status snmptrapd
tail -f /var/log/syslog | grep --line-buffered snmp
show ip sla statistics

R1 IP SLA Console Log

R1 Console Log

Let's say to apply packet filter: Packet loss, Delay.

R1 Console Log

MIB

1.3.6.1.4.1.9.9.42.1.2.19.1.9

rttMonReactValue

Free CISCO-RTTMON-MIB SNMP MIB Download - Free MIB Download - Search MIBs - OiDViEW

IP SLA MOS Score Verification

IP SLA HSRP Object Tracking

R1 Base Configuration

R2 Base Configuration

R3 Base Configuration

R4 Base Configuration

  • R1
configure terminal
!
ip sla 1
 icmp-echo 10.1.3.3 source-interface GigabitEthernet 0/2
  timeout 5000
  frequency 10
exit
ip sla schedule 1 life forever start-time now
!
track 101 ip sla 1 reachability
exit
track 102 interface GigabitEthernet 0/2 line-protocol
exit
!
interface GigabitEthernet 0/1
 standby 1 track 101
 standby 1 track 102
!
end

R1 Console Log

R2 Console Log

IP SLA Floating Static Route Object Tracking

R1 Base Configuration

R2 Base Configuration

R3 Base Configuration

R4 Base Configuration

IP SLA Object Tracking Floating Static Route Configuration

  • R1
configure terminal
!
ip sla 1
 icmp-echo 10.3.3.3 source-interface GigabitEthernet 0/2
  timeout 5000
  frequency 10
exit
ip sla schedule 1 life forever start-time now
!
track 101 ip sla 1 reachability
exit
!
no ip route 0.0.0.0 0.0.0.0 10.1.3.3
ip route 0.0.0.0 0.0.0.0 10.1.3.3 track 101
ip route 0.0.0.0 0.0.0.0 172.16.0.2 250
!
end

R4 Console Log

R1 Console Log

R4 Console Log

R1 Console Log

R3 Console Log

R1 Console Log

Optional Configuration

R1 Config

R1 Console Log

static floating route tracking down delay not works interface down, changes immediately.

but delay down timer works when opposite side router down.

up timer works fine.

R3 Console Log

show clock
show ip sla statistics
show ip route | include 0.0.0.0
show track 101

R1 Console Log

R3 Console Log

R1 Console Log

R1 Console Log

R1 Console Log

following verification is not work as expected because misconfiguration that default track route and floating static route(backup default route) has default admininistrative distance.

  • Wrong
ip route 0.0.0.0 0.0.0.0 172.16.0.2 track 101
ip route 0.0.0.0 0.0.0.0 10.1.3.3
  • Correct
ip route 0.0.0.0 0.0.0.0 10.1.3.3 track 101
ip route 0.0.0.0 0.0.0.0 172.16.0.2 250

R1 Console Log

R4 Console Log

R1 Console Log

why static route disappeared…

References

tech/network/cisco/ip-sla/ip-sla.txt · Last modified: 2019/11/09 08:39 by wnoguchi