PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:ios-management:ios-management

Cisco: IOS Management Features

Blueprint

  • N/A

This feature executed C1841 IOS 15.1(4)M10.

Base Configuration

  • shizuku(TFTP server)
ip addr add 10.0.128.254/24 dev ens160
  • R1
configure terminal
!
interface FastEthernet 0/0
 ip address 10.0.128.1 255.255.255.0
 no shutdown
interface FastEthernet 0/1
 ip address 10.0.4.111 255.255.255.0
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 10.0.4.1
!
ip domain lookup
ip name-server 8.8.8.8 8.8.4.4 1.1.1.1
!
clock timezone JST 9
!
! Japan NTP Server
ntp server ntp.nict.jp
ntp server ntp.jst.mfeed.ad.jp
!
end

R1 wrong configuration

kron Configuration

kron naming reassembe *NIX cron.

  • R1
configure terminal
!
kron policy-list RUNCONFIG
 cli show running-config | redirect tftp://10.0.128.254/R1.txt
exit
!
kron policy-list VERSION
 cli show version | redirect tftp://10.0.128.254/R1-version.txt
exit
!
kron policy-list TIME
 cli show clock | redirect tftp://10.0.128.254/R1-clock.txt
exit
!
!kron occurrence KRON-TIME at 11:28 recurring
kron occurrence KRON-TIME in 00:05 recurring
 policy-list RUNCONFIG
 policy-list VERSION
 policy-list TIME
exit
!
end
show kron schedule
debug kron all
root@shizuku:~# cd /var/lib/tftpboot/
root@shizuku:/var/lib/tftpboot# ll
total 8
drwxr-xr-x  2 root nogroup 4096 Nov 14 12:16 ./
drwxr-xr-x 38 root root    4096 Nov 14 12:16 ../
R1(config)#kron poli
R1(config)#kron policy-list RUNCONFIG
R1(config-kron-policy)#cli
R1(config-kron-policy)#cli show runni
R1(config-kron-policy)#cli show runnig-config | red
R1(config-kron-policy)#cli show runnig-config | red?
LINE    <cr>

R1(config-kron-policy)#$nnig-config | redirect tftp://10.0.128.254/R1.txt    
R1(config-kron-policy)#kro
R1(config-kron-policy)#kron
R1(config-kron-policy)#kron occ
R1(config-kron-policy)#exit    
R1(config)#kro
R1(config)#kron occu
R1(config)#kron occurrence KRON-TIME in ?
Delay before occurrence (mmm or hhh:mm or ddd:hh:mm)

R1(config)#kron occurrence KRON-TIME in 00:01 recu
R1(config)#kron occurrence KRON-TIME in 00:01 recurring 
R1(config-kron-occurrence)#poli
R1(config-kron-occurrence)#policy-list RUNCONFIG
R1(config-kron-occurrence)#exit
R1(config)#end
R1#
Nov 14 23:13:14.676: %SYS-5-CONFIG_I: Configured from console by console
R1#
R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:50 

why not working…

root@shizuku:/var/lib/tftpboot# ll
total 8
drwxr-xr-x  2 root nogroup 4096 Nov 14 12:16 ./
drwxr-xr-x 38 root root    4096 Nov 14 12:16 ../
root@shizuku:/var/lib/tftpboot# ll
total 8
drwxr-xr-x  2 root nogroup 4096 Nov 14 12:16 ./
drwxr-xr-x 38 root root    4096 Nov 14 12:16 ../
root@shizuku:/var/lib/tftpboot#
R1#sh run | sec kron
kron occurrence KRON-TIME in 1 recurring
 policy-list RUNCONFIG
kron policy-list RUNCONFIG
 cli show runnig-config | redirect tftp://10.0.128.254/R1.txt
R1#ping 10.0.128.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.128.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
root@shizuku:/var/lib/tftpboot# tcpdump -ni ens160 not port 61727

(snip)

12:24:56.836769 IP 10.0.128.254 > 10.0.4.111: ICMP echo reply, id 6, seq 0, length 80
12:24:56.838073 IP 10.0.4.111 > 10.0.128.254: ICMP echo request, id 6, seq 1, length 80
12:24:56.838098 IP 10.0.128.254 > 10.0.4.111: ICMP echo reply, id 6, seq 1, length 80
12:24:56.839192 IP 10.0.4.111 > 10.0.128.254: ICMP echo request, id 6, seq 2, length 80
12:24:56.839213 IP 10.0.128.254 > 10.0.4.111: ICMP echo reply, id 6, seq 2, length 80
12:24:56.840267 IP 10.0.4.111 > 10.0.128.254: ICMP echo request, id 6, seq 3, length 80
12:24:56.840288 IP 10.0.128.254 > 10.0.4.111: ICMP echo reply, id 6, seq 3, length 80
12:24:56.841407 IP 10.0.4.111 > 10.0.128.254: ICMP echo request, id 6, seq 4, length 80
12:24:56.841428 IP 10.0.128.254 > 10.0.4.111: ICMP echo reply, id 6, seq 4, length 80

secondary address is not used

R1#ping 10.0.128.254 source 10.0.128.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.128.254, timeout is 2 seconds:
Packet sent with a source address of 10.0.128.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
root@shizuku:/var/lib/tftpboot# tcpdump -ni ens160 not port 61727
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ens160, link-type EN10MB (Ethernet), capture size 262144 bytes
12:26:00.642080 ARP, Request who-has 10.0.4.254 (00:0c:29:a2:dc:b2) tell 10.0.4.197, length 46
12:26:00.642121 ARP, Reply 10.0.4.254 is-at 00:0c:29:a2:dc:b2, length 28
12:26:10.950035 IP 10.0.128.1 > 10.0.128.254: ICMP echo request, id 7, seq 0, length 80
12:26:10.950241 IP 10.0.128.254 > 10.0.128.1: ICMP echo reply, id 7, seq 0, length 80
12:26:10.951539 IP 10.0.128.1 > 10.0.128.254: ICMP echo request, id 7, seq 1, length 80
12:26:10.951587 IP 10.0.128.254 > 10.0.128.1: ICMP echo reply, id 7, seq 1, length 80
12:26:10.952661 IP 10.0.128.1 > 10.0.128.254: ICMP echo request, id 7, seq 2, length 80
12:26:10.952692 IP 10.0.128.254 > 10.0.128.1: ICMP echo reply, id 7, seq 2, length 80
12:26:10.953736 IP 10.0.128.1 > 10.0.128.254: ICMP echo request, id 7, seq 3, length 80
12:26:10.953771 IP 10.0.128.254 > 10.0.128.1: ICMP echo reply, id 7, seq 3, length 80
12:26:10.954810 IP 10.0.128.1 > 10.0.128.254: ICMP echo request, id 7, seq 4, length 80
12:26:10.954840 IP 10.0.128.254 > 10.0.128.1: ICMP echo reply, id 7, seq 4, length 80
12:26:16.165174 ARP, Request who-has 10.0.128.1 tell 10.0.128.254, length 28
12:26:16.166000 ARP, Reply 10.0.128.1 is-at 00:1b:2a:77:66:d2, length 46
^C
14 packets captured
14 packets received by filter
0 packets dropped by kernel

packet not captured.

R1#sh run | sec kron
kron occurrence KRON-TIME in 1 recurring
 policy-list RUNCONFIG
kron policy-list RUNCONFIG
 cli show runnig-config | redirect tftp://10.0.128.254/R1.txt

my misspelling… runnig-config

R1#conf t                     
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#kron policy-list RUNCONFIG
R1(config-kron-policy)#$ runnig-config | redirect tftp://10.0.128.254/R1.txt 
R1(config-kron-policy)#$nning-config | redirect tftp://10.0.128.254/R1.txt   
R1(config-kron-policy)#end
R1#sh run
Nov 16 22:17:01.615: %SYS-5-CONFIG_I: Configured from console by console
R1#sh run | sec kron
kron occurrence KRON-TIME in 1 recurring
 policy-list RUNCONFIG
kron policy-list RUNCONFIG
 cli show running-config | redirect tftp://10.0.128.254/R1.txt
R1#sh kron sche
R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:19 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:17 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:16 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:07 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:05 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:04 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:02 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:01 

R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:59 

R1#
Nov 16 22:17:37.121: %PARSER-3-URLOPENFAIL: cannot open file for redirection 'Undefined error'
R1#sh kron schedule 
Kron Occurrence Schedule
KRON-TIME inactive, will run again in 0 days 00:00:54 

R1#

still get error…

capture it.

root@shizuku:/var/lib/tftpboot# tcpdump -nXi ens160 host 10.0.128.1
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ens160, link-type EN10MB (Ethernet), capture size 262144 bytes
22:32:14.230974 IP 10.0.128.1.50004 > 10.0.128.254.69:  15 WRQ "R1.txt" octet
        0x0000:  4500 002b 0000 0000 ff11 a6c2 0a00 8001  E..+............
        0x0010:  0a00 80fe c354 0045 0017 64b3 0002 5231  .....T.E..d...R1
        0x0020:  2e74 7874 006f 6374 6574 0000 0000       .txt.octet....
22:32:14.232295 IP 10.0.128.254.43453 > 10.0.128.1.50004: UDP, length 22
        0x0000:  4500 0032 10b3 0000 4011 5509 0a00 80fe  E..2....@.U.....
        0x0010:  0a00 8001 a9bd c354 001e 152f 0005 0000  .......T.../....
        0x0020:  5065 726d 6973 7369 6f6e 2064 656e 6965  Permission.denie
        0x0030:  6400                                     d.

identified TFTP server side problem.

16.04 - What should be correct ownership and permissions for TFTP root directory? - Ask Ubuntu

wnoguchi@shizuku:~$ systemctl status tftpd-hpa
● tftpd-hpa.service - LSB: HPA's tftp server
   Loaded: loaded (/etc/init.d/tftpd-hpa; generated)
   Active: active (running) since Thu 2019-11-14 22:15:46 UTC; 2 days ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3637 ExecStop=/etc/init.d/tftpd-hpa stop (code=exited, status=0/SUCCESS)
  Process: 3642 ExecStart=/etc/init.d/tftpd-hpa start (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 1109)
   CGroup: /system.slice/tftpd-hpa.service
           └─3650 /usr/sbin/in.tftpd --listen --user tftp --address :69 -c --secure /var/lib/tftpboot

Nov 14 22:15:46 shizuku systemd[1]: Starting LSB: HPA's tftp server...
Nov 14 22:15:46 shizuku tftpd-hpa[3642]:  * Starting HPA's tftpd in.tftpd
Nov 14 22:15:46 shizuku tftpd-hpa[3642]:    ...done.
Nov 14 22:15:46 shizuku systemd[1]: Started LSB: HPA's tftp server.
wnoguchi@shizuku:~$ ls -ld /var/lib/tftpboot/
drwxr-xr-x 2 root nogroup 4096 Nov 14 12:16 /var/lib/tftpboot/
sudo chown tftp:tftp /var/lib/tftpboot/

successfull.

root@shizuku:/var/lib/tftpboot# ll
total 12
drwxr-xr-x  2 tftp tftp 4096 Nov 17 00:06 ./
drwxr-xr-x 38 root root 4096 Nov 14 12:16 ../
-rw-rw-rw-  1 tftp tftp 1494 Nov 17 00:21 R1.txt
root@shizuku:/var/lib/tftpboot# tail R1.txt
line vty 5 15
 privilege level 15
 no login
 transport input all
!
scheduler allocate 20000 1000
ntp server ntp.jst.mfeed.ad.jp
ntp server ntp.nict.jp
end

R1 Console Log

R1 Console Log Again

TFTP Server Log Again

archive

dir flash:/archive/
mkdir archive
dir flash:/archive/
archive
 path flash:/archive/R1
 !path tftp://10.0.128.254/archive/R1
 maximum 5
 write-memory
 time-period 2
more flash:/archive/R1Jan--2-12-03-31.039-0

R1 Console Log

root@shizuku:/var/lib/tftpboot# mkdir archive
root@shizuku:/var/lib/tftpboot# chown tftp:tftp archive/
root@shizuku:/var/lib/tftpboot# ll
total 24
drwxr-xr-x  3 tftp tftp 4096 Nov 17 03:11 ./
drwxr-xr-x 38 root root 4096 Nov 14 12:16 ../
drwxr-xr-x  2 tftp tftp 4096 Nov 17 03:11 archive/
-rw-rw-rw-  1 tftp tftp   34 Nov 17 02:28 R1-clock.txt
-rw-rw-rw-  1 tftp tftp 1712 Nov 17 02:28 R1.txt
-rw-rw-rw-  1 tftp tftp 1882 Nov 17 02:28 R1-version.txt
root@shizuku:/var/lib/tftpboot# cd archive/
root@shizuku:/var/lib/tftpboot/archive# ll
total 8
drwxr-xr-x 2 tftp tftp 4096 Nov 17 03:11 ./
drwxr-xr-x 3 tftp tftp 4096 Nov 17 03:11 ../
root@shizuku:/var/lib/tftpboot/archive# ll
total 20
drwxr-xr-x 2 tftp tftp 4096 Nov 17 03:16 ./
drwxr-xr-x 3 tftp tftp 4096 Nov 17 03:11 ../
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:14 R1Jan--2-12-32-20.503-0
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:15 R1Jan--2-12-33-20.795-1
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:16 R1Jan--2-12-34-21.087-2
root@shizuku:/var/lib/tftpboot/archive# less R1Jan--2-12-32-20.503-0
root@shizuku:/var/lib/tftpboot/archive# ll
total 24
drwxr-xr-x 2 tftp tftp 4096 Nov 17 03:17 ./
drwxr-xr-x 3 tftp tftp 4096 Nov 17 03:11 ../
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:14 R1Jan--2-12-32-20.503-0
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:15 R1Jan--2-12-33-20.795-1
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:16 R1Jan--2-12-34-21.087-2
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:17 R1Jan--2-12-35-21.379-3
root@shizuku:/var/lib/tftpboot/archive# grep ntp -R
R1Jan--2-12-36-21.670-4:ntp server ntp.jst.mfeed.ad.jp
R1Jan--2-12-36-21.670-4:ntp server ntp.nict.jp
root@shizuku:/var/lib/tftpboot/archive# ll
total 28
drwxr-xr-x 2 tftp tftp 4096 Nov 17 03:18 ./
drwxr-xr-x 3 tftp tftp 4096 Nov 17 03:11 ../
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:14 R1Jan--2-12-32-20.503-0
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:15 R1Jan--2-12-33-20.795-1
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:16 R1Jan--2-12-34-21.087-2
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:17 R1Jan--2-12-35-21.379-3
-rw-rw-rw- 1 tftp tftp 1442 Nov 17 03:18 R1Jan--2-12-36-21.670-4
root@shizuku:/var/lib/tftpboot/archive# diff -u R1Jan--2-12-35-21.379-3 R1Jan--2-12-36-21.670-4
--- R1Jan--2-12-35-21.379-3     2019-11-17 03:17:56.023236722 +0000
+++ R1Jan--2-12-36-21.670-4     2019-11-17 03:18:56.310251378 +0000
@@ -101,4 +101,6 @@
  transport input all
 !
 scheduler allocate 20000 1000
+ntp server ntp.jst.mfeed.ad.jp
+ntp server ntp.nict.jp
 end
root@shizuku:/var/lib/tftpboot/archive#
root@shizuku:/var/lib/tftpboot/archive# ll
total 32
drwxr-xr-x 2 tftp tftp 4096 Nov 17 03:19 ./
drwxr-xr-x 3 tftp tftp 4096 Nov 17 03:11 ../
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:14 R1Jan--2-12-32-20.503-0
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:15 R1Jan--2-12-33-20.795-1
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:16 R1Jan--2-12-34-21.087-2
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:17 R1Jan--2-12-35-21.379-3
-rw-rw-rw- 1 tftp tftp 1442 Nov 17 03:18 R1Jan--2-12-36-21.670-4
-rw-rw-rw- 1 tftp tftp 1442 Nov 17 03:19 R1Nov-17-03-19-56.318-5
root@shizuku:/var/lib/tftpboot/archive# less R1Nov-17-03-19-56.318-5
root@shizuku:/var/lib/tftpboot/archive# ll
total 36
drwxr-xr-x 2 tftp tftp 4096 Nov 17 04:19 ./
drwxr-xr-x 3 tftp tftp 4096 Nov 17 03:11 ../
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:14 R1Jan--2-12-32-20.503-0
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:15 R1Jan--2-12-33-20.795-1
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:16 R1Jan--2-12-34-21.087-2
-rw-rw-rw- 1 tftp tftp 1388 Nov 17 03:17 R1Jan--2-12-35-21.379-3
-rw-rw-rw- 1 tftp tftp 1442 Nov 17 03:18 R1Jan--2-12-36-21.670-4
-rw-rw-rw- 1 tftp tftp 1442 Nov 17 03:19 R1Nov-17-03-19-56.318-5
-rw-rw-rw- 1 tftp tftp 1444 Nov 17 04:19 R1Nov-17-04-19-56.371-6
root@shizuku:/var/lib/tftpboot/archive# less R1Nov-17-04-19-56.371-6
root@shizuku:/var/lib/tftpboot/archive# diff -u R1Nov-17-03-19-56.318-5 R1Nov-17-04-19-56.371-6
--- R1Nov-17-03-19-56.318-5     2019-11-17 03:19:56.597269529 +0000
+++ R1Nov-17-04-19-56.371-6     2019-11-17 04:19:56.580526196 +0000
@@ -1,6 +1,6 @@

 !
-! Last configuration change at 12:22:04 UTC Mon Jan 2 2006
+! Last configuration change at 03:20:24 UTC Sun Nov 17 2019
 ! NVRAM config last updated at 12:15:41 UTC Mon Jan 2 2006
 ! NVRAM config last updated at 12:15:41 UTC Mon Jan 2 2006
 version 15.1
@@ -41,7 +41,7 @@
 archive
  path tftp://10.0.128.254/archive/R1
  write-memory
- time-period 1
+ time-period 60
 !
 redundancy
 !
root@shizuku:/var/lib/tftpboot/archive#

configure replace


show archive config differences flash:/archive/R1Jan--2-12-19-17.303-5 system:running-config
R1#$ifferences flash:/archive/R1Jan--2-12-19-17.303-5 system:running-config    
!Contextual Config Diffs:
archive
 +maximum 5
 +time-period 5
line con 0
 +length 0
+ntp server ntp.jst.mfeed.ad.jp
+ntp server ntp.nict.jp
archive
 -maximum 3
 -time-period 4
show archive config differences system:running-config flash:/archive/R1Jan--2-12-11-51.147-0
R1#$ifferences system:running-config flash:/archive/R1Jan--2-12-11-51.147-0  
!Contextual Config Diffs:
+no ip domain lookup
interface FastEthernet0/0
 +no ip address
 +shutdown
interface FastEthernet0/1
 +no ip address
 +shutdown
-clock timezone JST 9 0
-ip name-server 8.8.8.8
-ip name-server 8.8.4.4
-ip name-server 1.1.1.1
interface FastEthernet0/0
 -ip address 10.0.128.1 255.255.255.0
interface FastEthernet0/1
 -ip address 10.0.4.111 255.255.255.0
-ip route 0.0.0.0 0.0.0.0 10.0.4.1
line con 0
 -length 0
-ntp server ntp.jst.mfeed.ad.jp

-ntp server ntp.nict.jp
copy running-config tftp://10.0.128.254/R1-A.txt
configure replace flash:/archive/R1Jan--2-12-11-51.147-0
R1#configure replace flash:/archive/R1Jan--2-12-11-51.147-0
This will apply all necessary additions and deletions
to replace the current running configuration with the
contents of the specified configuration file, which is
assumed to be a complete configuration, not a partial
configuration. Enter Y if you are sure you want to proceed. ? [no]: Y
Total number of passes: 1
Rollback Done

R1#
Nov 17 09:25:41.352: Rollback:Acquired Configuration lock.
.Nov 17 09:25:41.796: %SYS-6-CLOCKUPDATE: System clock has been updated from 18:25:41 JST Sun Nov 17 2019 to 09:25:41 UTC Sun Nov 17 2019, configured from console by console.
R1#
.Nov 17 09:25:43.812: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
.Nov 17 09:25:43.816: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
.Nov 17 09:25:44.812: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R1#
.Nov 17 09:25:44.816: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1#sh run
Building configuration...

Current configuration : 1132 bytes
!
! Last configuration change at 09:25:41 UTC Sun Nov 17 2019




R1#sh ip int  brie
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial0/0/0                unassigned      YES NVRAM  administratively down down    
write
dir flash:/archive/
!
configure terminal
interface FastEthernet 0/0
 ip address 10.0.128.1
exit
ip name-server 8.8.8.8
end
write
!
configure replace flash:/archive/R1.Nov-17-09-56-49.023-0
!
configure terminal
interface FastEthernet 0/1
 ip address 10.0.4.111
exit
ip name-server 8.8.4.4
ip name-server 1.1.1.1
end
write
!
configure replace flash:/archive/R1.Nov-17-09-56-49.023-0
show ip interface brief
show running-config | include name-server
!
show archive config differences system:running-config flash:/archive/R1.Nov-17-09-58-45.963-1
!
show archive config differences system:running-config flash:/archive/R1.Nov-17-10-01-15.791-2
!
configure replace flash:/archive/R1.Nov-17-09-58-45.963-1
show ip interface brief
show running-config | include name-server
!
configure replace flash:/archive/R1.Nov-17-10-01-15.791-2
show ip interface brief
show running-config | include name-server
!
configure replace flash:/archive/R1.Nov-17-09-56-49.023-0
show ip interface brief
show running-config | include name-server
!
copy flash:/archive/R1.Nov-17-09-58-45.963-1 system:running-config
copy flash:/archive/R1.Nov-17-10-01-15.791-2 system:running-config
show ip interface brief
show running-config | include name-server

R1 Console Log

show archive config differences

show archive config differences nvram:startup-config system:running-config
write
show archive config differences nvram:startup-config system:running-config
R1#show archive config differences nvram:startup-config system:running-config
!Contextual Config Diffs:
+ip name-server 8.8.8.8
interface FastEthernet0/1
 +shutdown

R1#wr
Building configuration...
[OK]
R1#show ar
R1#show arc
R1#show archive confi
R1#show archive config diffe
R1#show archive config differences nvram:star
R1#show archive config differences nvram:startup-configsystem:runn
R1#show archive config differences nvram:startup-configsystem:runn
Error: Could not open file nvram:startup-configsystem:runn for reading

R1#show archive config differences nvram:startup-configsystem:running-config
Error: Could not open file nvram:startup-configsystem:running-config for reading

R1#show archive config differences nvram:startup-config system:running-config
!Contextual Config Diffs:
!No changes were found

R1#

References

tech/network/cisco/ios-management/ios-management.txt · Last modified: 2019/11/17 19:27 by wnoguchi