User Tools

Site Tools


tech:network:cisco:icmp-redirects:icmp-redirects

ICMP Redirects

ICMP Redirects

R1>en
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip red
R1(config)#ip redi
R1(config)#ip redi
R1(config)#ip redi
R1(config)#ip redi
R1(config)#int f0/0
R1(config-if)#ip red
R1(config-if)#do sh run | i ip redirect
R1(config-if)#do sh run all | i ip redirect
 ip redirects
 ip redirects
 ip redirects
R1(config-if)#no ip redi
R1(config-if)#no ip redirects
R1(config-if)#do sh run all | i ip redirect
 no ip redirects
 ip redirects
 ip redirects
R1(config-if)#ip redirects
R1(config-if)#^Z
R1#
*Sep 24 10:45:53.035: %SYS-5-CONFIG_I: Configured from console by console
R1#en
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#!
R1(config)#int f0/0
R1(config-if)#ip address 172.16.3.3 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int f0/1
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#standby 2 ip 172.16.2.254
R1(config-if)#standby 2 priority 110
R1(config-if)#standby 2 preempt
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#!
R1(config)#router ospf 1
R1(config-router)#network 172.16.0.0 0.0.255.255 area 0
R1(config-router)#exit
R1(config)#!
R1(config)#end
R1#
*Sep 24 10:45:56.719: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Sep 24 10:45:59.483: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Sep 24 10:45:59.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1#do sh run all | i ip redirects
       ^
% Invalid input detected at '^' marker.

R1#do sh run all | i ip redirect
*Sep 24 10:46:20.155: %HSRP-5-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R1#sh run all | i ip redirect
 ip redirects
 ip redirects
 ip redirects
R1#
*Sep 24 10:46:46.763: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from LOADING to FULL, Loading Done
R1#sh run all | i ip redirect
 ip redirects
 ip redirects
 ip redirects
R1#sh run int f0/1
Building configuration...

Current configuration : 165 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.1 255.255.255.0
 standby 2 ip 172.16.2.254
 standby 2 priority 110
 standby 2 preempt
 duplex auto
 speed auto
end

R1#

Full Configuration here.

  • ASW1
en
conf t
!
vlan 1
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 1
spanning-tree portfast
no shut
exit
!Reserved
int f0/8
switchport mode access
switchport access vlan 1
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 1
spanning-tree portfast
no shut
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.1.1 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.1 255.255.255.0
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.1.2 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.3.2 255.255.255.0
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • PC1
route add 172.16.0.0 mask 255.255.0.0 172.16.1.1 metric 1 if 26
  • PC2
sudo ip route add 172.16.0.0/16 via 172.16.3.2
  • PC3(ASW3)

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.2.23 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.2.1
!
end
✘╹◡╹✘  18-09-29 19:40:35 /home/wnoguchi
% sudo vim /etc/network/interfaces
✘╹◡╹✘  18-09-29 19:41:08 /home/wnoguchi
% sudo systemctl restart networking.service
✘╹◡╹✘  18-09-29 19:41:21 /home/wnoguchi
%
✘╹◡╹✘  18-09-29 19:41:22 /home/wnoguchi
%
✘╹◡╹✘  18-09-29 19:41:22 /home/wnoguchi
%
✘╹◡╹✘  18-09-29 19:41:22 /home/wnoguchi
%
✘╹◡╹✘  18-09-29 19:41:22 /home/wnoguchi
% ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether f4:30:b9:3c:99:56 brd ff:ff:ff:ff:ff:ff
    inet 10.0.1.128/24 brd 10.0.1.255 scope global noprefixroute enp3s0
       valid_lft forever preferred_lft forever
    inet6 fe80::de50:dd15:552c:9161/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: enx84afec739c0a: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 84:af:ec:73:9c:0a brd ff:ff:ff:ff:ff:ff
    inet 172.16.2.245/24 brd 172.16.2.255 scope global enx84afec739c0a
       valid_lft forever preferred_lft forever
    inet 172.16.3.245/24 brd 172.16.3.255 scope global enx84afec739c0a
       valid_lft forever preferred_lft forever
4: wlo1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 7c:67:a2:29:00:68 brd ff:ff:ff:ff:ff:ff
✘╹◡╹✘  18-09-29 19:41:33 /home/wnoguchi
% sudo ip addr del 172.16.2.245/24 dev enx84afec739c0a
✘╹◡╹✘  18-09-29 19:42:04 /home/wnoguchi
% ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether f4:30:b9:3c:99:56 brd ff:ff:ff:ff:ff:ff
    inet 10.0.1.128/24 brd 10.0.1.255 scope global noprefixroute enp3s0
       valid_lft forever preferred_lft forever
    inet6 fe80::de50:dd15:552c:9161/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: enx84afec739c0a: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 84:af:ec:73:9c:0a brd ff:ff:ff:ff:ff:ff
    inet 172.16.3.245/24 brd 172.16.3.255 scope global enx84afec739c0a
       valid_lft forever preferred_lft forever
4: wlo1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 7c:67:a2:29:00:68 brd ff:ff:ff:ff:ff:ff
✘╹◡╹✘  18-09-29 19:42:07 /home/wnoguchi
% ip ro | fgrep 172.16.
172.16.3.0/24 dev enx84afec739c0a proto kernel scope link src 172.16.3.245 linkdown
✘╹◡╹✘  18-09-29 19:43:08 /home/wnoguchi
% sudo ip route add 172.16.0.0/16 via 172.16.3.3
✘╹◡╹✘  18-09-29 19:43:35 /home/wnoguchi
% ip ro | fgrep 172.16.
172.16.0.0/16 via 172.16.3.3 dev enx84afec739c0a linkdown
172.16.3.0/24 dev enx84afec739c0a proto kernel scope link src 172.16.3.245 linkdown
C:\WINDOWS\system32>route print | findstr 172.16.0
       172.16.0.0      255.255.0.0       172.16.1.1      172.16.1.10     26

C:\WINDOWS\system32>ping 172.16.2.23

Pinging 172.16.2.23 with 32 bytes of data:
Request timed out.
Reply from 172.16.2.23: bytes=32 time=1ms TTL=254
Reply from 172.16.2.23: bytes=32 time=1ms TTL=254
Reply from 172.16.2.23: bytes=32 time=1ms TTL=254

Ping statistics for 172.16.2.23:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\WINDOWS\system32>route print | findstr 172.16.0
       172.16.0.0      255.255.0.0       172.16.1.1      172.16.1.10     26

C:\WINDOWS\system32>ping 172.16.3.245

Pinging 172.16.3.245 with 32 bytes of data:
Reply from 172.16.3.1: Destination host unreachable.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 172.16.3.245:
    Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),

C:\WINDOWS\system32>ping 172.16.3.245

Pinging 172.16.3.245 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 172.16.3.245:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\WINDOWS\system32>route print | findstr 172.16.0
       172.16.0.0      255.255.0.0       172.16.1.1      172.16.1.10     26
R1#
*Sep 29 10:50:11.346: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.1/32 is directly connected, FastEthernet0/0
C        172.16.2.0/24 is directly connected, FastEthernet0/1
L        172.16.2.1/32 is directly connected, FastEthernet0/1
O        172.16.3.0/24 [110/2] via 172.16.1.2, 01:06:28, FastEthernet0/0
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0
L        172.16.1.2/32 is directly connected, FastEthernet0/0
O        172.16.2.0/24 [110/2] via 172.16.1.1, 01:06:36, FastEthernet0/0
C        172.16.3.0/24 is directly connected, FastEthernet0/1
L        172.16.3.2/32 is directly connected, FastEthernet0/1
R1#ping 172.16.3.245
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.245, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#ping 172.16.3.245
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.245, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R1#ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 172.16.2.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.23, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
✘╹◡╹✘  18-09-29 19:43:40 /home/wnoguchi
% ip ro | fgrep 172.16.
172.16.0.0/16 via 172.16.3.3 dev enx84afec739c0a
172.16.3.0/24 dev enx84afec739c0a proto kernel scope link src 172.16.3.245
✘╹◡╹✘  18-09-29 21:10:31 /home/wnoguchi
% ping 172.16.3.3 -c4
PING 172.16.3.3 (172.16.3.3) 56(84) bytes of data.
From 172.16.3.245 icmp_seq=1 Destination Host Unreachable
From 172.16.3.245 icmp_seq=2 Destination Host Unreachable
From 172.16.3.245 icmp_seq=3 Destination Host Unreachable
From 172.16.3.245 icmp_seq=4 Destination Host Unreachable

--- 172.16.3.3 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3070ms
pipe 4
✘╹◡╹✘  18-09-29 21:11:49 /home/wnoguchi
% ping 172.16.3.3 -c4
PING 172.16.3.3 (172.16.3.3) 56(84) bytes of data.
From 172.16.3.245 icmp_seq=1 Destination Host Unreachable
From 172.16.3.245 icmp_seq=2 Destination Host Unreachable
From 172.16.3.245 icmp_seq=3 Destination Host Unreachable
From 172.16.3.245 icmp_seq=4 Destination Host Unreachable

--- 172.16.3.3 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3064ms
pipe 4

Wrong route gateway address on PC2 …

  • PC2
sudo ip route del 172.16.0.0/16 via 172.16.3.3
sudo ip route add 172.16.0.0/16 via 172.16.3.2
✘╹◡╹✘  18-09-29 21:11:57 /home/wnoguchi
% sudo ip route del 172.16.0.0/16 via 172.16.3.3

✘╹◡╹✘  18-09-29 21:15:31 /home/wnoguchi
% sudo ip route add 172.16.0.0/16 via 172.16.3.2

✘╹◡╹✘  18-09-29 21:15:35 /home/wnoguchi
% ip ro | fgrep 172.16.
172.16.0.0/16 via 172.16.3.2 dev enx84afec739c0a
172.16.3.0/24 dev enx84afec739c0a proto kernel scope link src 172.16.3.245
✘╹◡╹✘  18-09-29 21:15:54 /home/wnoguchi
% ping 172.16.3.2
PING 172.16.3.2 (172.16.3.2) 56(84) bytes of data.
64 bytes from 172.16.3.2: icmp_seq=1 ttl=255 time=1.17 ms
64 bytes from 172.16.3.2: icmp_seq=2 ttl=255 time=1.05 ms
64 bytes from 172.16.3.2: icmp_seq=3 ttl=255 time=1.07 ms
^C
--- 172.16.3.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 1.057/1.103/1.174/0.050 ms
✘╹◡╹✘  18-09-29 21:16:06 /home/wnoguchi
% ping 172.16.2.23
PING 172.16.2.23 (172.16.2.23) 56(84) bytes of data.
64 bytes from 172.16.2.23: icmp_seq=1 ttl=253 time=1.85 ms
64 bytes from 172.16.2.23: icmp_seq=2 ttl=253 time=1.94 ms
^C
--- 172.16.2.23 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 1.854/1.897/1.940/0.043 ms

C:\WINDOWS\system32>ping 172.16.3.245

Pinging 172.16.3.245 with 32 bytes of data:
Reply from 172.16.3.245: bytes=32 time=1ms TTL=63
Reply from 172.16.3.245: bytes=32 time=1ms TTL=63
Reply from 172.16.3.245: bytes=32 time=2ms TTL=63
Reply from 172.16.3.245: bytes=32 time=1ms TTL=63

Ping statistics for 172.16.3.245:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2ms, Average = 1ms

C:\WINDOWS\system32>route print | findstr 172.16.0
       172.16.0.0      255.255.0.0       172.16.1.1      172.16.1.10     26

ICMP redirect observed, but no route added.

Disable Firewall rule temporarily.

C:\WINDOWS\system32>ping 172.16.3.245

Pinging 172.16.3.245 with 32 bytes of data:
Reply from 172.16.3.245: bytes=32 time=1ms TTL=63
Reply from 172.16.3.245: bytes=32 time=1ms TTL=63
Reply from 172.16.3.245: bytes=32 time=2ms TTL=63
Reply from 172.16.3.245: bytes=32 time=1ms TTL=63

Ping statistics for 172.16.3.245:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2ms, Average = 1ms

C:\WINDOWS\system32>route print | findstr 172.16.0
       172.16.0.0      255.255.0.0       172.16.1.1      172.16.1.10     26

WSL same

wnoguchi@LASTHOPE-WIN:~$ ping 172.16.2.23 -c4
PING 172.16.2.23 (172.16.2.23) 56(84) bytes of data.
64 bytes from 172.16.2.23: icmp_seq=1 ttl=254 time=1.96 ms
64 bytes from 172.16.2.23: icmp_seq=2 ttl=254 time=2.08 ms
64 bytes from 172.16.2.23: icmp_seq=3 ttl=254 time=2.14 ms
64 bytes from 172.16.2.23: icmp_seq=4 ttl=254 time=2.09 ms

--- 172.16.2.23 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 1.963/2.071/2.144/0.073 ms
wnoguchi@LASTHOPE-WIN:~$ ping 172.16.3.245 -c4
PING 172.16.3.245 (172.16.3.245) 56(84) bytes of data.
64 bytes from 172.16.3.245: icmp_seq=1 ttl=63 time=2.03 ms
64 bytes from 172.16.3.245: icmp_seq=2 ttl=63 time=1.41 ms
64 bytes from 172.16.3.245: icmp_seq=3 ttl=63 time=2.43 ms
64 bytes from 172.16.3.245: icmp_seq=4 ttl=63 time=1.21 ms

--- 172.16.3.245 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3002ms
rtt min/avg/max/mdev = 1.216/1.776/2.439/0.489 ms

How is ICMP redirect enabled?

still seems incorrect behavior.

disable all ESET protection for a 10 minutes.

works fine, but no temporary route printed. → wrong filter string…

C:\Users\wnogu>route print | findstr 172.16.3
       172.16.3.0    255.255.255.0         On-link        172.16.3.1    291
       172.16.3.1  255.255.255.255         On-link        172.16.3.1    291
     172.16.3.255  255.255.255.255         On-link        172.16.3.1    291
        224.0.0.0        240.0.0.0         On-link        172.16.3.1    291
  255.255.255.255  255.255.255.255         On-link        172.16.3.1    291

before redirect.

after redirect.

Destination MAC address changed.

Linux verification.

linux - How to accept ICMP redirects? - Unix & Linux Stack Exchange

   68  vim /etc/network/interfaces
   69  reboot
   70  ip add
   71  ip addr del 172.16.2.250/24 dev eth0
   72  ip a
   73  ip addr add 172.16.1.11/24 dev eth0
   74  ip a s
   75  ip ro
   76  ping 172.16.1.1
   77  ping 172.16.1.2
   78  ping 172.16.2.23
   79  ip ro
   80  ip ro add default via 172.16.1.1
   81  ip ro
   82  ping 172.16.2.23
   83  ping 172.16.3.245
   84  ip ro
   85  ping 172.16.3.245
   86  ip ro a
   87  ip ro --all
   88  ip ro -a
   89  ip ro dynamic
   90  sysctl -a | fgrep accept_redirects
   91  ping 172.16.3.245
   92  ping 172.16.3.245
   93  traceroute 172.16.3.245
   94  ping 172.16.3.245
   95  ip -d route
   96  ping 172.16.3.245
   97  ip -d route
   98  sysctl -a | fgrep secure_redi
   99  ping 172.16.3.245
  100  man ip
  101  man ip-route
  102  ip ro --help
  103  ip ro help
  104  ip ro show help
  105  ip ro show
  106  ping 172.16.3.245
  107  ping -d 172.16.3.245
  108  ip -d ro show
  109  ip -d ro show
  110  ping -d 172.16.3.245
  111  ping 172.16.3.245
  112  sysctl -a | fgrep secure_redi
  113  echo -n 0 >/proc/sys/net/ipv4/conf/all/secure_redirects
  114  ping 172.16.3.245
  115  ping 172.16.3.245
  116  sysctl -a | fgrep secure_redi
  117  ip -d ro show
  118  ip ro show cache
  119  ip ro show cache 172.16.2.245
  120  ping 172.16.3.245
  121  ip ro show cache 172.16.2.245
  122  exit
  123  history
root@raspberrypi:~# ip addr show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:1f:45:00 brd ff:ff:ff:ff:ff:ff
    inet 172.16.1.11/24 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a0b2:82c4:44bb:bfd6/64 scope link
       valid_lft forever preferred_lft forever
root@raspberrypi:~# uname -a
Linux raspberrypi 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux
root@raspberrypi:~# ping 172.16.3.245 -c10
PING 172.16.3.245 (172.16.3.245) 56(84) bytes of data.
From 172.16.1.1: icmp_seq=1 Redirect Host(New nexthop: 172.16.1.2)
64 bytes from 172.16.3.245: icmp_seq=1 ttl=63 time=1.86 ms
64 bytes from 172.16.3.245: icmp_seq=2 ttl=63 time=0.926 ms
64 bytes from 172.16.3.245: icmp_seq=3 ttl=63 time=0.923 ms
64 bytes from 172.16.3.245: icmp_seq=4 ttl=63 time=0.987 ms
64 bytes from 172.16.3.245: icmp_seq=5 ttl=63 time=0.835 ms
64 bytes from 172.16.3.245: icmp_seq=6 ttl=63 time=0.875 ms
64 bytes from 172.16.3.245: icmp_seq=7 ttl=63 time=0.844 ms
64 bytes from 172.16.3.245: icmp_seq=8 ttl=63 time=0.933 ms
64 bytes from 172.16.3.245: icmp_seq=9 ttl=63 time=0.886 ms
64 bytes from 172.16.3.245: icmp_seq=10 ttl=63 time=0.839 ms

--- 172.16.3.245 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9010ms
rtt min/avg/max/mdev = 0.835/0.991/1.865/0.295 ms
root@raspberrypi:~# ping 172.16.3.245 -c3
PING 172.16.3.245 (172.16.3.245) 56(84) bytes of data.
64 bytes from 172.16.3.245: icmp_seq=1 ttl=63 time=0.853 ms
64 bytes from 172.16.3.245: icmp_seq=2 ttl=63 time=0.840 ms
64 bytes from 172.16.3.245: icmp_seq=3 ttl=63 time=0.815 ms

--- 172.16.3.245 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 0.815/0.836/0.853/0.015 ms
root@raspberrypi:~# ip route show
default via 172.16.1.1 dev eth0
172.16.1.0/24 dev eth0  proto kernel  scope link  src 172.16.1.11
root@raspberrypi:~# ip -d route show
unicast default via 172.16.1.1 dev eth0  proto boot  scope global
unicast 172.16.1.0/24 dev eth0  proto kernel  scope link  src 172.16.1.11

Hmm…

References

tech/network/cisco/icmp-redirects/icmp-redirects.txt · Last modified: 2018/09/29 22:52 by wnoguchi