PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:hsrp:hsrp

HSRP

  • ASW1
en
conf t
!
vlan 5
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 5
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 5
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • SW1
en
conf t
!
ip routing
!
int vlan 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
int vlan 5
ip address 172.16.5.1 255.255.255.0
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 5
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • SW2
en
conf t
!
ip routing
!
int vlan 5
ip address 172.16.5.2 255.255.255.0
no shut
exit
int vlan 4
ip address 172.16.4.2 255.255.255.0
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 5
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 4
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.1 255.255.255.0
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.2 255.255.255.0
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
SW1#
*Mar  1 00:30:55.031: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.2 on Vlan5 from LOADING to FULL, Loading Done
SW1#
*Mar  1 00:31:06.062: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on Vlan3 from LOADING to FULL, Loading Done
SW1#
SW2#
*Mar  1 00:30:55.006: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.1 on Vlan5 from LOADING to FULL, Loading Done
SW2#
*Mar  1 00:31:13.545: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Vlan4 from LOADING to FULL, Loading Done
SW2#
R1#
*Sep  4 21:46:39.067: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from LOADING to FULL, Loading Done
R1#
*Sep  4 21:46:58.631: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R1#
R2#
*Sep  4 21:49:01.699: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on FastEthernet0/1 from LOADING to FULL, Loading Done
R2#
*Sep  4 21:49:28.771: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
R2#
SW1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.2.0/24 [110/2] via 172.16.3.3, 00:01:48, Vlan3
O        172.16.4.0/24 [110/2] via 172.16.5.2, 00:01:59, Vlan5
SW1#
SW2#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.2.0/24 [110/2] via 172.16.4.4, 00:01:38, Vlan4
O        172.16.3.0/24 [110/2] via 172.16.5.1, 00:01:59, Vlan5
SW2#
R1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.4.0/24 [110/2] via 172.16.2.2, 00:14:51, FastEthernet0/1
O        172.16.5.0/24 [110/2] via 172.16.3.1, 00:15:01, FastEthernet0/0
R2#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.3.0/24 [110/2] via 172.16.2.1, 00:15:01, FastEthernet0/1
O        172.16.5.0/24 [110/2] via 172.16.4.2, 00:14:51, FastEthernet0/0

change OSPF cost value

SW1

Solved: Trouble adding an OSPF cost on an VLAN ... - Cisco Community

SW2

en
conf t
!
int vlan 4
ip ospf cost 100
exit
!
end

R1

R2

en
conf t
!
int f0/0
ip ospf cost 100
exit
!
end
SW1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.2.0/24 [110/2] via 172.16.3.3, 00:29:47, Vlan3
O        172.16.4.0/24 [110/101] via 172.16.5.2, 00:13:58, Vlan5
SW1#
SW2#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.2.0/24 [110/3] via 172.16.5.1, 00:14:08, Vlan5
O        172.16.3.0/24 [110/2] via 172.16.5.1, 00:29:58, Vlan5
SW2#
R1#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.4.0/24 [110/101] via 172.16.2.2, 00:13:59, FastEthernet0/1
O        172.16.5.0/24 [110/2] via 172.16.3.1, 00:29:48, FastEthernet0/0
R1#
R2#sh ip ro ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O        172.16.3.0/24 [110/2] via 172.16.2.1, 00:29:47, FastEthernet0/1
O        172.16.5.0/24 [110/3] via 172.16.2.1, 00:13:58, FastEthernet0/1
R2#

SW1

en
conf t
!
int vlan 5
standby 5 ip 172.16.5.254
standby 5 priority 105
standby 5 preempt
exit
!
end

SW2

en
conf t
!
int vlan 5
standby 5 ip 172.16.5.254
standby 5 priority 100
standby 5 preempt
exit
!
end

R1

en
conf t
!
int fa0/1
standby 2 ip 172.16.2.254
standby 2 priority 110
standby 2 preempt
exit
!
end

R2

en
conf t
!
int fa0/1
standby 2 ip 172.16.2.254
standby 2 priority 100
standby 2 preempt
exit
!
end
SW1#sh run int vlan 5
Building configuration...

Current configuration : 130 bytes
!
interface Vlan5
 ip address 172.16.5.1 255.255.255.0
 standby 5 ip 172.16.5.254
 standby 5 priority 105
 standby 5 preempt
end

SW1#

SW2#sh run int vlan 5
Building configuration...

Current configuration : 106 bytes
!
interface Vlan5
 ip address 172.16.5.2 255.255.255.0
 standby 5 ip 172.16.5.254
 standby 5 preempt
end

SW2#

R1#sh run int f0/1
Building configuration...

Current configuration : 165 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.1 255.255.255.0
 standby 2 ip 172.16.2.254
 standby 2 priority 105
 standby 2 preempt
 duplex auto
 speed auto
end
R2#sh run int f0/1
Building configuration...

Current configuration : 141 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.2 255.255.255.0
 standby 2 ip 172.16.2.254
 standby 2 preempt
 duplex auto
 speed auto
end
R2(config)#int f0/1
R2(config-if)#standby 2 ip 172.16.2.254
R2(config-if)#sta
R2(config-if)#standby 2 pri
R2(config-if)#standby 2 priority 100
R2(config-if)#standby 2 priority 100
*Sep  4 22:56:34.291: %HSRP-5-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R2(config-if)#standby 2 pree
R2(config-if)#standby 2 preempt
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/1
R1(config-if)#stad
R1(config-if)#stand
R1(config-if)#standby 2 ip 172.16.2.254
R1(config-if)#sta
R1(config-if)#no standby 2 ip 172.16.2.254
R1(config-if)#stad
R1(config-if)#stand
R1(config-if)#standby 2 ip 172.16.2.254
R1(config-if)#sta
R1(config-if)#standby 2 pri
R1(config-if)#standby 2 priority 105
R1(config-if)#sta
R1(config-if)#standby 2
*Sep  4 22:55:52.235: %HSRP-5-STATECHANGE: FastEthernet0/1 Grp 2 state Speak -> Standby
R1(config-if)#standby 2 preem
R1(config-if)#standby 2 preempt
R1(config-if)#
*Sep  4 22:56:04.627: %HSRP-5-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R1(config-if)#
R2(config-if)#
*Sep  4 22:58:27.283: %HSRP-5-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Speak
R2(config-if)#
*Sep  4 22:58:38.243: %HSRP-5-STATECHANGE: FastEthernet0/1 Grp 2 state Speak -> Standby
R2(config-if)#

Full Configuration

  • ASW1
en
conf t
!
vlan 5
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 5
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 5
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • SW1
en
conf t
!
ip routing
!
int vlan 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
int vlan 5
ip address 172.16.5.1 255.255.255.0
standby 5 ip 172.16.5.254
standby 5 priority 105
standby 5 preempt
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 5
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • SW2
en
conf t
!
ip routing
!
int vlan 5
ip address 172.16.5.2 255.255.255.0
standby 5 ip 172.16.5.254
standby 5 priority 100
standby 5 preempt
no shut
exit
int vlan 4
ip address 172.16.4.2 255.255.255.0
ip ospf cost 100
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 5
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 4
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.1 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 110
standby 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
ip ospf cost 100
no shut
exit
int f0/1
ip address 172.16.2.2 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 100
standby 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
SW1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl5         5    105 P Active  local           172.16.5.2      172.16.5.254
SW1#
SW2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl5         5    100 P Standby 172.16.5.1      local           172.16.5.254
SW2#
R1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Fa0/1       2    105 P Active  local           172.16.2.2      172.16.2.254
R1#
R2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Fa0/1       2    100 P Standby 172.16.2.1      local           172.16.2.254
R2#

C:\Users\wnogu>ping 172.16.5.1

Pinging 172.16.5.1 with 32 bytes of data:
Reply from 172.16.5.1: bytes=32 time=7ms TTL=255
Reply from 172.16.5.1: bytes=32 time=2ms TTL=255
Reply from 172.16.5.1: bytes=32 time=2ms TTL=255
Reply from 172.16.5.1: bytes=32 time=1ms TTL=255

Ping statistics for 172.16.5.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 7ms, Average = 3ms

C:\Users\wnogu>ping 172.16.5.2

Pinging 172.16.5.2 with 32 bytes of data:
Reply from 172.16.5.2: bytes=32 time=7ms TTL=255
Reply from 172.16.5.2: bytes=32 time=2ms TTL=255
Reply from 172.16.5.2: bytes=32 time=1ms TTL=255
Reply from 172.16.5.2: bytes=32 time=2ms TTL=255

Ping statistics for 172.16.5.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 7ms, Average = 3ms

C:\Users\wnogu>ping 172.16.5.254

Pinging 172.16.5.254 with 32 bytes of data:
Reply from 172.16.5.254: bytes=32 time=3ms TTL=255
Reply from 172.16.5.254: bytes=32 time=1ms TTL=255
Reply from 172.16.5.254: bytes=32 time=1ms TTL=255
Reply from 172.16.5.254: bytes=32 time=2ms TTL=255

Ping statistics for 172.16.5.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 3ms, Average = 1ms
C:\Users\wnogu>ping 172.16.2.245

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.1: Destination host unreachable.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 172.16.2.245:
    Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),
C:\Users\wnogu>route print
===========================================================================
Interface List
 18...00 1b 21 b8 26 5c ......Intel(R) Gigabit CT Desktop Adapter
 27...4c 72 b9 58 0e e0 ......Intel(R) 82579V Gigabit Network Connection
  6...0a 00 27 00 00 06 ......VirtualBox Host-Only Ethernet Adapter
 25...84 af ec 73 9c 01 ......ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter
 23...00 50 56 c0 00 01 ......VMware Virtual Ethernet Adapter for VMnet1
 15...00 50 56 c0 00 02 ......VMware Virtual Ethernet Adapter for VMnet2
  5...00 50 56 c0 00 03 ......VMware Virtual Ethernet Adapter for VMnet3
 17...00 50 56 c0 00 04 ......VMware Virtual Ethernet Adapter for VMnet4
 13...00 50 56 c0 00 05 ......VMware Virtual Ethernet Adapter for VMnet5
 14...00 50 56 c0 00 08 ......VMware Virtual Ethernet Adapter for VMnet8
 21...00 50 56 c0 00 06 ......VMware Virtual Ethernet Adapter for VMnet6
  1...........................Software Loopback Interface 1
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0         10.0.0.1         10.0.0.5     25
         10.0.0.0    255.255.255.0         On-link          10.0.0.5    281
         10.0.0.5  255.255.255.255         On-link          10.0.0.5    281
       10.0.0.255  255.255.255.255         On-link          10.0.0.5    281
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    331
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    331
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    331
       172.16.1.0    255.255.255.0         On-link        172.16.1.1    291
       172.16.1.1  255.255.255.255         On-link        172.16.1.1    291
     172.16.1.255  255.255.255.255         On-link        172.16.1.1    291
       172.16.2.0    255.255.255.0         On-link        172.16.2.1    291
       172.16.2.1  255.255.255.255         On-link        172.16.2.1    291
     172.16.2.255  255.255.255.255         On-link        172.16.2.1    291
       172.16.3.0    255.255.255.0         On-link        172.16.3.1    291
       172.16.3.1  255.255.255.255         On-link        172.16.3.1    291
     172.16.3.255  255.255.255.255         On-link        172.16.3.1    291
       172.16.5.0    255.255.255.0         On-link       172.16.5.10    281
      172.16.5.10  255.255.255.255         On-link       172.16.5.10    281
     172.16.5.255  255.255.255.255         On-link       172.16.5.10    281
      172.16.10.0    255.255.255.0         On-link       172.16.10.1    291
      172.16.10.1  255.255.255.255         On-link       172.16.10.1    291
    172.16.10.255  255.255.255.255         On-link       172.16.10.1    291
     192.168.56.0    255.255.255.0         On-link      192.168.56.1    281
     192.168.56.1  255.255.255.255         On-link      192.168.56.1    281
   192.168.56.255  255.255.255.255         On-link      192.168.56.1    281
    192.168.200.0    255.255.255.0         On-link     192.168.200.1    291
    192.168.200.1  255.255.255.255         On-link     192.168.200.1    291
  192.168.200.255  255.255.255.255         On-link     192.168.200.1    291
    192.168.229.0    255.255.255.0         On-link     192.168.229.1    291
    192.168.229.1  255.255.255.255         On-link     192.168.229.1    291
  192.168.229.255  255.255.255.255         On-link     192.168.229.1    291
    192.168.249.0    255.255.255.0         On-link     192.168.249.1    291
    192.168.249.1  255.255.255.255         On-link     192.168.249.1    291
  192.168.249.255  255.255.255.255         On-link     192.168.249.1    291
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    331
        224.0.0.0        240.0.0.0         On-link      192.168.56.1    281
        224.0.0.0        240.0.0.0         On-link          10.0.0.5    281
        224.0.0.0        240.0.0.0         On-link       172.16.5.10    281
        224.0.0.0        240.0.0.0         On-link        172.16.3.1    291
        224.0.0.0        240.0.0.0         On-link     192.168.249.1    291
        224.0.0.0        240.0.0.0         On-link        172.16.1.1    291
        224.0.0.0        240.0.0.0         On-link     192.168.229.1    291
        224.0.0.0        240.0.0.0         On-link        172.16.2.1    291
        224.0.0.0        240.0.0.0         On-link       172.16.10.1    291
        224.0.0.0        240.0.0.0         On-link     192.168.200.1    291
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    331
  255.255.255.255  255.255.255.255         On-link      192.168.56.1    281
  255.255.255.255  255.255.255.255         On-link          10.0.0.5    281
  255.255.255.255  255.255.255.255         On-link       172.16.5.10    281
  255.255.255.255  255.255.255.255         On-link        172.16.3.1    291
  255.255.255.255  255.255.255.255         On-link     192.168.249.1    291
  255.255.255.255  255.255.255.255         On-link        172.16.1.1    291
  255.255.255.255  255.255.255.255         On-link     192.168.229.1    291
  255.255.255.255  255.255.255.255         On-link        172.16.2.1    291
  255.255.255.255  255.255.255.255         On-link       172.16.10.1    291
  255.255.255.255  255.255.255.255         On-link     192.168.200.1    291
===========================================================================
Persistent Routes:
  None

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
 27    281 ::/0                     fe80::212:e2ff:fe70:81a0
  1    331 ::1/128                  On-link
 27    281 2408:211:c228:ce00::/64  On-link
 27    281 2408:211:c228:ce00:39bf:1350:d75c:45e9/128
                                    On-link
 27    281 2408:211:c228:ce00:4d33:cfc3:c9fd:fee/128
                                    On-link
 27    281 2408:211:c228:ce00:4dc5:e93e:afcd:5f58/128
                                    On-link
 27    281 2408:211:c228:ce00:6596:92b7:993f:69c1/128
                                    On-link
 27    281 2408:211:c228:ce00:81be:22ab:8a10:e3c0/128
                                    On-link
 27    281 2408:211:c228:ce00:88a3:25eb:71f1:9186/128
                                    On-link
 27    281 2408:211:c228:ce00:a4cd:8137:f58a:e764/128
                                    On-link
 27    281 2408:211:c228:ce00:ac58:1220:e04:8b8e/128
                                    On-link
  6    281 fe80::/64                On-link
 27    281 fe80::/64                On-link
 25    281 fe80::/64                On-link
  5    291 fe80::/64                On-link
 21    291 fe80::/64                On-link
 23    291 fe80::/64                On-link
 13    291 fe80::/64                On-link
 15    291 fe80::/64                On-link
 17    291 fe80::/64                On-link
 14    291 fe80::/64                On-link
  5    291 fe80::103:21a3:8c45:b7e2/128
                                    On-link
  6    281 fe80::1970:9ce:93b0:cff8/128
                                    On-link
 13    291 fe80::644c:8427:cfa8:2610/128
                                    On-link
 23    291 fe80::6c2a:fd3:7185:6399/128
                                    On-link
 15    291 fe80::8918:9727:f436:2964/128
                                    On-link
 14    291 fe80::9d11:9e85:47b4:ae1d/128
                                    On-link
 21    291 fe80::a801:5a87:f25c:99dd/128
                                    On-link
 27    281 fe80::ac58:1220:e04:8b8e/128
                                    On-link
 25    281 fe80::d950:b218:210:b25f/128
                                    On-link
 17    291 fe80::f8f4:ccb4:665d:2153/128
                                    On-link
  1    331 ff00::/8                 On-link
  6    281 ff00::/8                 On-link
 27    281 ff00::/8                 On-link
 25    281 ff00::/8                 On-link
  5    291 ff00::/8                 On-link
 21    291 ff00::/8                 On-link
 23    291 ff00::/8                 On-link
 13    291 ff00::/8                 On-link
 15    291 ff00::/8                 On-link
 17    291 ff00::/8                 On-link
 14    291 ff00::/8                 On-link
===========================================================================
Persistent Routes:
  None
route add 172.16.0.0 mask 255.255.0.0 172.16.5.254 metric 1 if 25

PC

C:\WINDOWS\system32>route add 172.16.0.0 mask 255.255.0.0 172.16.5.254 metric 1 if 25
 OK!
✘╹◡╹✘  18-09-05 20:52:31 /home/wnoguchi
% ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether f4:30:b9:3c:99:56 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.128/24 brd 10.0.0.255 scope global noprefixroute enp3s0
       valid_lft forever preferred_lft forever
    inet6 fe80::de50:dd15:552c:9161/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: enx84afec739c0a: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 84:af:ec:73:9c:0a brd ff:ff:ff:ff:ff:ff
    inet 172.16.2.245/24 brd 172.16.2.255 scope global enx84afec739c0a
       valid_lft forever preferred_lft forever
    inet6 fe80::86af:ecff:fe73:9c0a/64 scope link
       valid_lft forever preferred_lft forever
4: wlo1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 7c:67:a2:29:00:68 brd ff:ff:ff:ff:ff:ff
✘╹◡╹✘  18-09-05 21:03:41 /home/wnoguchi
% ip route show
default via 10.0.0.1 dev enp3s0 proto static metric 100
10.0.0.0/24 dev enp3s0 proto kernel scope link src 10.0.0.128 metric 100
169.254.0.0/16 dev enx84afec739c0a scope link metric 1000
172.16.2.0/24 dev enx84afec739c0a proto kernel scope link src 172.16.2.245
✘╹◡╹✘  18-09-05 21:03:45 /home/wnoguchi
% ping -c4 172.16.2.1
PING 172.16.2.1 (172.16.2.1) 56(84) bytes of data.
64 bytes from 172.16.2.1: icmp_seq=1 ttl=255 time=1.09 ms
64 bytes from 172.16.2.1: icmp_seq=2 ttl=255 time=1.16 ms
64 bytes from 172.16.2.1: icmp_seq=3 ttl=255 time=1.20 ms
64 bytes from 172.16.2.1: icmp_seq=4 ttl=255 time=1.04 ms

--- 172.16.2.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 1.045/1.127/1.207/0.071 ms
✘╹◡╹✘  18-09-05 21:05:05 /home/wnoguchi
% ping -c4 172.16.2.2
PING 172.16.2.2 (172.16.2.2) 56(84) bytes of data.
64 bytes from 172.16.2.2: icmp_seq=1 ttl=255 time=3.10 ms
64 bytes from 172.16.2.2: icmp_seq=2 ttl=255 time=1.13 ms
64 bytes from 172.16.2.2: icmp_seq=3 ttl=255 time=1.22 ms
64 bytes from 172.16.2.2: icmp_seq=4 ttl=255 time=1.09 ms

--- 172.16.2.2 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 1.099/1.638/3.106/0.849 ms
✘╹◡╹✘  18-09-05 21:05:11 /home/wnoguchi
% ping -c4 172.16.2.254
PING 172.16.2.254 (172.16.2.254) 56(84) bytes of data.
64 bytes from 172.16.2.254: icmp_seq=1 ttl=255 time=2.20 ms
64 bytes from 172.16.2.254: icmp_seq=2 ttl=255 time=1.12 ms
64 bytes from 172.16.2.254: icmp_seq=3 ttl=255 time=1.20 ms
64 bytes from 172.16.2.254: icmp_seq=4 ttl=255 time=1.09 ms

--- 172.16.2.254 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 1.099/1.407/2.209/0.466 ms
sudo ip route add 172.16.0.0/16 via 172.16.2.254
✘╹◡╹✘  18-09-05 21:05:18 /home/wnoguchi
% sudo ip route add 172.16.0.0/16 via 172.16.2.254
✘╹◡╹✘  18-09-05 21:05:40 /home/wnoguchi
% ip ro
default via 10.0.0.1 dev enp3s0 proto static metric 100
10.0.0.0/24 dev enp3s0 proto kernel scope link src 10.0.0.128 metric 100
169.254.0.0/16 dev enx84afec739c0a scope link metric 1000
172.16.0.0/16 via 172.16.2.254 dev enx84afec739c0a
172.16.2.0/24 dev enx84afec739c0a proto kernel scope link src 172.16.2.245
✘╹◡╹✘  18-09-05 21:22:00 /home/wnoguchi
% sudo tcpdump -n -i enx84afec739c0a icmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enx84afec739c0a, link-type EN10MB (Ethernet), capture size 262144 bytes
21:22:06.532027 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 261, length 40
21:22:06.532141 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 261, length 40
21:22:07.537775 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 262, length 40
21:22:07.537874 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 262, length 40
21:22:08.543449 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 263, length 40
21:22:08.543547 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 263, length 40
21:22:09.549815 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 264, length 40
21:22:09.549917 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 264, length 40
21:22:10.555181 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 265, length 40
21:22:10.555288 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 265, length 40
21:22:11.560240 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 266, length 40
21:22:11.560337 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 266, length 40
21:22:12.566540 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 267, length 40
21:22:12.566637 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 267, length 40
21:22:13.572398 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 268, length 40
21:22:13.572497 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 268, length 40
21:22:14.578394 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 269, length 40
21:22:14.578499 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 269, length 40
21:22:15.583884 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 270, length 40
21:22:15.583982 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 270, length 40
21:22:16.590128 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 271, length 40
21:22:16.590229 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 271, length 40
21:22:17.595242 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 272, length 40
21:22:17.595342 IP 172.16.2.245 > 172.16.5.10: ICMP echo reply, id 1, seq 272, length 40
21:22:18.600985 IP 172.16.5.10 > 172.16.2.245: ICMP echo request, id 1, seq 273, length 40
C:\Users\wnogu>ping 172.16.2.245 -t

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62

Ping statistics for 172.16.2.245:
    Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms
Control-C
^C
C:\Users\wnogu>ping 172.16.2.254 -t

Pinging 172.16.2.254 with 32 bytes of data:
Reply from 172.16.2.254: bytes=32 time=1ms TTL=254
Reply from 172.16.2.254: bytes=32 time=1ms TTL=254
Reply from 172.16.2.254: bytes=32 time=1ms TTL=254

Ping statistics for 172.16.2.254:
    Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms
Control-C
^C
C:\Users\wnogu>

Parameter Configuration

conf t
int vlan 5
standby 5 timers 1 4
SW1(config-if)#standby 5 timers ?
  <1-254>  Hello interval in seconds
  msec     Specify hello interval in milliseconds

SW1(config-if)#standby 5 timers 1 ?
  <2-255>  Hold time in seconds
*Mar  1 00:43:50.508: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
SW1(config-if)#standby 5 timers 1 4
SW1(config-if)#
SW1(config-if)#
*Mar  1 00:45:53.485: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:45:53.770: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:54.474: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
SW1(config-if)#
*Mar  1 00:45:54.676: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:55.473: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:45:55.531: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
SW1(config-if)#
*Mar  1 00:45:56.345: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:45:56.488: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:57.234: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:45:57.326: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
SW1(config-if)#
*Mar  1 00:45:58.056: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:45:58.266: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:59.029: HSRP: Vl5 Grp 5 Hello  in  172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:45:59.088: HSRP: Vl5 Grp 5 Hello  out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:59.508: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan5, changed state to down
*Mar  1 00:45:59.508: HSRP: Vl5 G
SW1(config-if)#rp 5 Resign out 172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:59.516: %HSRP-5-STATECHANGE: Vlan5 Grp 5 state Active -> Init
*Mar  1 00:45:59.516: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.2 on Vlan5 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:46:00.506: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
SW1(config-if)#
*Mar  1 00:46:01.512: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down
SW1(config-if)#
SW2(config-if)#
*Mar  1 00:45:59.080: HSRP: Vl5 Grp 5 Hello  in  172.16.5.1 Active  pri 105 vIP 172.16.5.254
*Mar  1 00:45:59.935: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Standby pri 100 vIP 172.16.5.254
SW2(config-if)#
*Mar  1 00:46:00.875: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:46:01.731: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Standby pri 100 vIP 172.16.5.254
SW2(config-if)#
*Mar  1 00:46:02.729: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Standby pri 100 vIP 172.16.5.254
*Mar  1 00:46:03.719: %HSRP-5-STATECHANGE: Vlan5 Grp 5 state Standby -> Active
SW2(config-if)#
*Mar  1 00:46:03.719: HSRP: Vl5 Interface adv out, Active, active 1 passive 0
*Mar  1 00:46:03.719: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
*Mar  1 00:46:04.708: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
SW2(config-if)#
*Mar  1 00:46:05.715: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
*Mar  1 00:46:06.688: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
SW2(config-if)#
*Mar  1 00:46:07.661: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
*Mar  1 00:46:08.601: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
SW2(config-if)#
*Mar  1 00:46:09.540: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
*Mar  1 00:46:10.480: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
SW2(config-if)#
*Mar  1 00:46:11.294: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
*Mar  1 00:46:12.116: HSRP: Vl5 Grp 5 Hello  out 172.16.5.2 Active  pri 100 vIP 172.16.5.254
SW2(config-if)#
SW2(config-if)#standby 5 preempt delay minimum 60

HSRP version 2

  • SW1
en
conf t
!
int vlan 5
ip address 172.16.5.1 255.255.255.0
standby version 2
standby 3005 ip 172.16.5.254
standby 3005 priority 105
standby 3005 preempt
no shut
exit
!
end
  • SW2
en
conf t
!
int vlan 5
ip address 172.16.5.2 255.255.255.0
standby version 2
standby 3005 ip 172.16.5.254
standby 3005 priority 100
standby 3005 preempt
no shut
exit
!
end
  • R1
en
conf t
!
int f0/1
ip address 172.16.2.1 255.255.255.0
standby version 2
standby 3002 ip 172.16.2.254
standby 3002 priority 110
standby 3002 preempt
no shut
exit
!
end
  • R2
en
conf t
!
int f0/1
ip address 172.16.2.2 255.255.255.0
standby version 2
standby 3002 ip 172.16.2.254
standby 3002 priority 100
standby 3002 preempt
no shut
exit
!
end

Interface Tracking

sudo ip route add 172.16.0.0/16 via 172.16.2.254
SW1(config-ip-sla)#do ping 172.16.2.245
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.245, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/33 ms
  • SW1
en
conf t
!
int vlan 5
ip address 172.16.5.1 255.255.255.0
standby 5 ip 172.16.5.254
standby 5 priority 105
standby 5 preempt
standby 5 track fa 1/0/2
no shut
exit
!
end
int vlan 5
standby 5 preempt
standby 5 track fa 1/0/2
  • SW2
en
conf t
!
int vlan 5
ip address 172.16.5.2 255.255.255.0
standby 5 ip 172.16.5.254
standby 5 priority 100
standby 5 preempt
no shut
exit
!
end
int vlan 5
standby 5 preempt
SW1#sh standby
Vlan5 - Group 5
  State is Active
    2 state changes, last state change 00:28:30
  Virtual IP address is 172.16.5.254
  Active virtual MAC address is 0000.0c07.ac05
    Local virtual MAC address is 0000.0c07.ac05 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.024 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.5.2, priority 100 (expires in 10.368 sec)
  Priority 105 (configured 105)
    Track interface FastEthernet1/0/2 state Up decrement 10
  Group name is "hsrp-Vl5-5" (default)
SW1#sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl5         5    105 P Active  local           172.16.5.2      172.16.5.254
SW1#
SW2#sh standby
Vlan5 - Group 5
  State is Standby
    1 state change, last state change 00:28:28
  Virtual IP address is 172.16.5.254
  Active virtual MAC address is 0000.0c07.ac05
    Local virtual MAC address is 0000.0c07.ac05 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.280 secs
  Preemption enabled
  Active router is 172.16.5.1, priority 105 (expires in 9.280 sec)
  Standby router is local
  Priority 100 (default 100)
  Group name is "hsrp-Vl5-5" (default)
SW2#sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl5         5    100 P Standby 172.16.5.1      local           172.16.5.254
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/0
R1(config-if)#shut
R1(config-if)#
*Sep 12 22:53:21.127: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 12 22:53:23.123: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Sep 12 22:53:24.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R1(config-if)#
SW1#
*Mar  1 01:20:44.177: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to down
*Mar  1 01:20:44.186: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on Vlan3 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:20:45.092: %TRACKING-5-STATE: 1 interface Fa1/0/2 line-protocol Up->Down
*Mar  1 01:20:45.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to down
SW1#
*Mar  1 01:20:46.174: %LINK-3-UPDOWN: Interface FastEthernet1/0/2, changed state to down
SW1#
*Mar  1 01:20:47.415: %HSRP-5-STATECHANGE: Vlan5 Grp 5 state Active -> Speak
SW1#sh standby
Vlan5 - Group 5
  State is Speak
    3 state changes, last state change 00:00:03
  Virtual IP address is 172.16.5.254
  Active virtual MAC address is 0000.0c07.ac05
    Local virtual MAC address is 0000.0c07.ac05 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.464 secs
  Preemption enabled
  Active router is 172.16.5.2, priority 100 (expires in 10.352 sec)
  Standby router is unknown
  Priority 95 (configured 105)
    Track interface FastEthernet1/0/2 state Down decrement 10
  Group name is "hsrp-Vl5-5" (default)
SW1#
*Mar  1 01:20:57.767: %HSRP-5-STATECHANGE: Vlan5 Grp 5 state Speak -> Standby
SW1#
SW2#
*Mar  1 01:20:47.382: %HSRP-5-STATECHANGE: Vlan5 Grp 5 state Standby -> Active
SW2#sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl5         5    100 P Active  local           172.16.5.1      172.16.5.254
SW2#sh standby
Vlan5 - Group 5
  State is Active
    2 state changes, last state change 00:00:20
  Virtual IP address is 172.16.5.254
  Active virtual MAC address is 0000.0c07.ac05
    Local virtual MAC address is 0000.0c07.ac05 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.528 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.5.1, priority 95 (expires in 8.528 sec)
  Priority 100 (default 100)
  Group name is "hsrp-Vl5-5" (default)
SW2#
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/0
R1(config-if)#shut
R1(config-if)#
*Sep 12 22:53:21.127: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 12 22:53:23.123: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Sep 12 22:53:24.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R1(config-if)#

Object Tracking

  • SW1
en
conf t
!
int vlan 5
ip address 172.16.5.1 255.255.255.0
standby 5 ip 172.16.5.254
standby 5 priority 105
standby 5 preempt
no shut
exit
!
end

  • SW2
en
conf t
!
int vlan 5
ip address 172.16.5.2 255.255.255.0
standby 5 ip 172.16.5.254
standby 5 priority 100
standby 5 preempt
no shut
exit
!
end
  • R1
en
conf t
!
int f0/1
ip address 172.16.2.1 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 110
standby 2 preempt
no shut
exit
!
end
  • R2
en
conf t
!
int f0/1
ip address 172.16.2.2 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 100
standby 2 preempt
no shut
exit
!
end

MHSRP

  • ASW1
en
conf t
!
vlan 5
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 5
no shut
exit
int f0/8
switchport mode access
switchport access vlan 5
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 5
spanning-tree portfast
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • ASW3

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.5.121 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.5.254
!
end
✘╹◡╹✘  18-09-16 10:52:03 /home/wnoguchi/logs
% less screen-20180916-09:56:05-0.log
  • SW1
en
conf t
!
ip routing
!
int f1/0/1
no switchport
ip address 172.16.5.1 255.255.255.0
standby 1 ip 172.16.5.253
standby 1 priority 105
standby 1 preempt
standby 2 ip 172.16.5.254
standby 2 preempt
no shut
exit
int f1/0/2
no switchport
ip address 172.16.3.1 255.255.255.0
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • SW2
en
conf t
!
ip routing
!
int f1/0/1
no switchport
ip address 172.16.5.2 255.255.255.0
standby 1 ip 172.16.5.253
standby 1 preempt
standby 2 ip 172.16.5.254
standby 2 priority 105
standby 2 preempt
no shut
exit
int f1/0/2
no switchport
ip address 172.16.4.2 255.255.255.0
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.1 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 110
standby 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
ip ospf cost 100
no shut
exit
int f0/1
ip address 172.16.2.2 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 100
standby 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
route add 172.16.0.0 mask 255.255.0.0 172.16.5.253 metric 1 if 25
C:\WINDOWS\system32>route print | findstr 172.16.5.
       172.16.5.0    255.255.255.0         On-link       172.16.5.10    281
      172.16.5.10  255.255.255.255         On-link       172.16.5.10    281
     172.16.5.255  255.255.255.255         On-link       172.16.5.10    281
        224.0.0.0        240.0.0.0         On-link       172.16.5.10    281
  255.255.255.255  255.255.255.255         On-link       172.16.5.10    281

C:\WINDOWS\system32>route add 172.16.0.0 mask 255.255.0.0 172.16.5.253 metric 1 if 25
 OK!

C:\WINDOWS\system32>route print | findstr 172.16.5.
       172.16.0.0      255.255.0.0     172.16.5.253      172.16.5.10     26
       172.16.5.0    255.255.255.0         On-link       172.16.5.10    281
      172.16.5.10  255.255.255.255         On-link       172.16.5.10    281
     172.16.5.255  255.255.255.255         On-link       172.16.5.10    281
        224.0.0.0        240.0.0.0         On-link       172.16.5.10    281
  255.255.255.255  255.255.255.255         On-link       172.16.5.10    281
C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  172.16.5.1
  2     1 ms     1 ms     1 ms  172.16.3.3
  3     1 ms     1 ms    <1 ms  172.16.2.245

Trace complete.
ASW3#ping 172.16.2.245

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.245, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/20 ms
ASW3#tracer 172.16.2.245
ASW3#tracer 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1 172.16.5.2 4 msec 4 msec 0 msec
  2 172.16.4.4 0 msec 0 msec 4 msec
  3 172.16.2.245 0 msec 4 msec 0 msec
ASW3#tracer 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1 172.16.5.2 4 msec 4 msec 4 msec
  2 172.16.4.4 4 msec 0 msec 4 msec
  3 172.16.2.245 0 msec 0 msec 4 msec

SW1 down

SW1(config)#int f1/0/1
SW1(config-if)#shut
SW1(config-if)#
*Mar  1 08:43:15.874: %HSRP-5-STATECHANGE: FastEthernet1/0/1 Grp 1 state Active -> Init
*Mar  1 08:43:15.874: %HSRP-5-STATECHANGE: FastEthernet1/0/1 Grp 2 state Standby -> Init
*Mar  1 08:43:15.882: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.2 on FastEthernet1/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
SW1(config-if)#
*Mar  1 08:43:17.870: %LINK-5-CHANGED: Interface FastEthernet1/0/1, changed state to administratively down
*Mar  1 08:43:18.877: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  172.16.5.2
  2     1 ms     1 ms     1 ms  172.16.4.4
  3     1 ms     1 ms     1 ms  172.16.2.245

Trace complete.
ASW3#tracer 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1 172.16.5.2 0 msec 4 msec 4 msec
  2 172.16.4.4 0 msec 4 msec 0 msec
  3 172.16.2.245 4 msec 0 msec 4 msec

next SW2 goes down

SW1(config-if)#no shut
SW1(config-if)#int f1/0/
*Mar  1 08:44:50.380: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
*Mar  1 08:44:51.387: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to up
SW2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW2(config)#int f1/0/1
SW2(config-if)#shut
SW2(config-if)#
*Mar  1 08:45:49.696: %HSRP-5-STATECHANGE: FastEthernet1/0/1 Grp 1 state Standby -> Init
*Mar  1 08:45:49.696: %HSRP-5-STATECHANGE: FastEthernet1/0/1 Grp 2 state Active -> Init
*Mar  1 08:45:49.704: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.1 on FastEthernet1/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
SW2(config-if)#
*Mar  1 08:45:51.701: %LINK-5-CHANGED: Interface FastEthernet1/0/1, changed state to administratively down
*Mar  1 08:45:52.707: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     2 ms     2 ms     1 ms  172.16.5.1
  2     *        1 ms     1 ms  172.16.3.3
  3     1 ms     1 ms     1 ms  172.16.2.245

Trace complete.

C:\WINDOWS\system32>ping 172.16.2.245

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62

Ping statistics for 172.16.2.245:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms
ASW3#ping 172.16.2.245

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.245, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
ASW3#tracer 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1 172.16.5.1 4 msec 4 msec 4 msec
  2 172.16.3.3 4 msec 0 msec 4 msec
  3 172.16.2.245 0 msec 0 msec 4 msec
SW1#sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Fa1/0/1     1    105 P Active  local           172.16.5.2      172.16.5.253
Fa1/0/1     2    100 P Standby 172.16.5.2      local           172.16.5.254
SW2#sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Fa1/0/1     1    100 P Standby 172.16.5.1      local           172.16.5.253
Fa1/0/1     2    105 P Active  local           172.16.5.1      172.16.5.254
SW1#sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Fa1/0/1     1    105 P Active  local           unknown         172.16.5.253
Fa1/0/1     2    100 P Active  local           unknown         172.16.5.254
SW2#
*Mar  1 09:23:00.025: %HSRP-5-STATECHANGE: FastEthernet1/0/1 Grp 1 state Standby -> Active
*Mar  1 09:23:00.831: %HSRP-5-STATECHANGE: FastEthernet1/0/1 Grp 2 state Standby -> Active
SW2#sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Fa1/0/1     1    100 P Active  local           unknown         172.16.5.253
Fa1/0/1     2    105 P Active  local           unknown         172.16.5.254

HSRP Load Balancing

  • ASW1
en
conf t
!
vlan 10,20
exit
!
int range f0/1 - 2
switchport mode trunk
no shut
exit
int f0/8
switchport mode access
switchport access vlan 20
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 10
spanning-tree portfast
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • ASW3

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.20.121 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.20.254
!
end
  • SW1
en
conf t
!
ip routing
!
vlan 3,10,20
exit
!
spanning-tree vlan 10 priority 0
spanning-tree vlan 20 priority 4096
!
int vlan 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
int vlan 10
ip address 172.16.10.1 255.255.255.0
standby 10 ip 172.16.10.254
standby 10 priority 105
standby 10 preempt
no shut
exit
int vlan 20
ip address 172.16.20.1 255.255.255.0
standby 20 ip 172.16.20.254
standby 20 preempt
no shut
exit
int f1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
SW1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
SW1(config-if)#
  • SW2
en
conf t
!
ip routing
!
vlan 4,10,20
exit
!
spanning-tree vlan 10 priority 4096
spanning-tree vlan 20 priority 0
!
int vlan 4
ip address 172.16.4.2 255.255.255.0
no shut
exit
int vlan 10
ip address 172.16.10.2 255.255.255.0
standby 10 ip 172.16.10.254
standby 10 preempt
no shut
exit
int vlan 20
ip address 172.16.20.2 255.255.255.0
standby 20 ip 172.16.20.254
standby 20 priority 105
standby 20 preempt
no shut
exit
int f1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 4
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.1 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 110
standby 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
ip ospf cost 100
no shut
exit
int f0/1
ip address 172.16.2.2 255.255.255.0
standby 2 ip 172.16.2.254
standby 2 priority 100
standby 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
route delete 172.16.0.0 mask 255.255.0.0 172.16.5.253 metric 1 if 25
route add 172.16.0.0 mask 255.255.0.0 172.16.10.254 metric 1 if 25
C:\WINDOWS\system32>ping 172.16.2.245

Pinging 172.16.2.245 with 32 bytes of data:
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62
Reply from 172.16.2.245: bytes=32 time=1ms TTL=62

Ping statistics for 172.16.2.245:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     2 ms     1 ms     1 ms  LASTHOPE-WIN [172.16.10.1]
  2     1 ms     1 ms     1 ms  172.16.3.3
  3     1 ms     1 ms     1 ms  172.16.2.245

Trace complete.
ASW3#ping 172.16.2.245

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.245, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
ASW3#tracer 172.16.2.245
ASW3#traceroute 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1 172.16.20.2 4 msec 4 msec 4 msec
  2 172.16.4.4 0 msec 4 msec 0 msec
  3 172.16.2.245 4 msec 0 msec 0 msec
SW1(config-if)#do sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   105 P Active  local           172.16.10.2     172.16.10.254
Vl20        20   100 P Standby 172.16.20.2     local           172.16.20.254
SW1(config-if)#do sh span vlan 10,20

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    10
             Address     e8ed.f315.9380
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    10     (priority 0 sys-id-ext 10)
             Address     e8ed.f315.9380
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Desg FWD 19        128.3    P2p


VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    20
             Address     c08c.6045.5200
             Cost        38
             Port        3 (FastEthernet1/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4116   (priority 4096 sys-id-ext 20)
             Address     e8ed.f315.9380
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Root FWD 19        128.3    P2p
SW2(config-if)#do sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   100 P Standby 172.16.10.1     local           172.16.10.254
Vl20        20   105 P Active  local           172.16.20.1     172.16.20.254
SW2(config-if)#do sh span vlan 10,20

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    10
             Address     e8ed.f315.9380
             Cost        38
             Port        3 (FastEthernet1/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4106   (priority 4096 sys-id-ext 10)
             Address     c08c.6045.5200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Root FWD 19        128.3    P2p


VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    20
             Address     c08c.6045.5200
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    20     (priority 0 sys-id-ext 20)
             Address     c08c.6045.5200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Desg FWD 19        128.3    P2p


shut down SW1

SW1(config)#int f1/0/1
SW1(config-if)#shut
SW1(config-if)#
*Mar  1 02:29:47.378: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  1 02:29:47.378: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
*Mar  1 02:29:47.378: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Active -> Init
*Mar  1 02:29:47.378: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to down
*Mar  1 02:29:47.386: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Standby -> Init
*Mar  1 02:29:47.403: %OSPF-5-ADJCHG: Process 1,
SW1(config-if)# Nbr 172.16.20.2 on Vlan10 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 02:29:47.403: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.2 on Vlan20 from FULL to DOWN, Neighbor Down: Interface down or detached
SW1(config-if)#
*Mar  1 02:29:49.341: %LINK-5-CHANGED: Interface FastEthernet1/0/1, changed state to administratively down
*Mar  1 02:29:50.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
SW1(config-if)#
SW2(config-if)#
*Mar  1 02:29:56.857: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Standby -> Active
SW2(config-if)#
*Mar  1 02:30:19.003: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.1 on Vlan20 from FULL to DOWN, Neighbor Down: Dead timer expired
*Mar  1 02:30:19.531: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.1 on Vlan10 from FULL to DOWN, Neighbor Down: Dead timer expired
SW2(config-if)#do sh standby bri
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   100 P Active  local           unknown         172.16.10.254
Vl20        20   105 P Active  local           unknown         172.16.20.254
ASW3#traceroute 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1 172.16.20.2 4 msec 4 msec 4 msec
  2 172.16.4.4 4 msec 0 msec 4 msec
  3 172.16.2.245 0 msec 0 msec 4 msec
C:\WINDOWS\system32>tracert 172.16.2.245

Tracing route to 172.16.2.245 over a maximum of 30 hops

  1     2 ms     3 ms    <1 ms  172.16.10.2
  2     2 ms     1 ms     1 ms  172.16.4.4
  3     1 ms     1 ms     1 ms  172.16.2.245

Trace complete.

back to normal, and SW2 down

SW1(config-if)#no shut
SW1(config-if)#
*Mar  1 02:33:42.359: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
SW1(config-if)#
*Mar  1 02:33:46.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to up
SW1(config-if)#
*Mar  1 02:34:15.159: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
*Mar  1 02:34:15.176: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
*Mar  1 02:34:15.176: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
SW1(config-if)#
*Mar  1 02:34:16.895: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Listen -> Active
SW1(config-if)#
*Mar  1 02:34:19.873: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.2 on Vlan20 from LOADING to FULL, Loading Done
*Mar  1 02:34:20.066: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.2 on Vlan10 from LOADING to FULL, Loading Done
SW2(config)#int f1/0/1
SW2(config-if)#shut
SW2(config-if)#
*Mar  1 02:34:48.160: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  1 02:34:48.160: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
*Mar  1 02:34:48.160: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Standby -> Init
*Mar  1 02:34:48.160: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to down
*Mar  1 02:34:48.160: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Active -> Init
*Mar  1 02:34:48.176: %OSPF-5-ADJCHG: Process 1,
SW2(config-if)# Nbr 172.16.20.1 on Vlan10 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 02:34:48.176: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.1 on Vlan20 from FULL to DOWN, Neighbor Down: Interface down or detached
SW2(config-if)#
*Mar  1 02:34:50.123: %LINK-5-CHANGED: Interface FastEthernet1/0/1, changed state to administratively down
*Mar  1 02:34:51.129: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
SW2(config-if)#
SW1(config-if)#
*Mar  1 02:34:38.077: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Speak -> Standby
SW1(config-if)#
*Mar  1 02:34:57.337: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Standby -> Active
SW1(config-if)#
*Mar  1 02:35:24.398: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.2 on Vlan20 from FULL to DOWN, Neighbor Down: Dead timer expired
SW1(config-if)#
*Mar  1 02:35:27.787: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.20.2 on Vlan10 from FULL to DOWN, Neighbor Down: Dead timer expired
SW1(config-if)#
SW1(config-if)#do sh standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   105 P Active  local           unknown         172.16.10.254
Vl20        20   100 P Active  local           unknown         172.16.20.254
ASW3#traceroute 172.16.2.245

Type escape sequence to abort.
Tracing the route to 172.16.2.245

  1  *
    172.16.20.1 0 msec 4 msec
  2 172.16.3.3 4 msec 0 msec 4 msec
  3 172.16.2.245 0 msec 0 msec 4 msec
racing route to 172.16.2.245 over a maximum of 30 hops

  1     2 ms     1 ms     1 ms  LASTHOPE-WIN [172.16.10.1]
  2     1 ms     1 ms     1 ms  172.16.3.3
  3     1 ms     1 ms     1 ms  172.16.2.245

Trace complete.
SW2(config-if)#no shut

References

tech/network/cisco/hsrp/hsrp.txt · Last modified: 2018/09/17 15:25 by wnoguchi