PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:glbp:glbp

GLBP

  • ASW1
en
conf t
!
vlan 10
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 10
no shut
exit
int f0/8
switchport mode access
switchport access vlan 10
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 10
spanning-tree portfast
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • ASW3

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.10.121 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.10.254
!
end
  • SW1
en
conf t
!
ip routing
!
vlan 3,10
exit
!
int vlan 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
int vlan 10
ip address 172.16.10.1 255.255.255.0
glbp 10 ip 172.16.10.254
glbp 10 priority 105
glbp 10 preempt
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 10
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • SW2
en
conf t
!
ip routing
!
vlan 4,10
exit
!
int vlan 10
ip address 172.16.10.2 255.255.255.0
glbp 10 ip 172.16.10.254
glbp 10 preempt
no shut
exit
int vlan 4
ip address 172.16.4.2 255.255.255.0
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 10
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 4
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.3 255.255.255.0
glbp 2 ip 172.16.2.254
glbp 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.4 255.255.255.0
glbp 2 ip 172.16.2.254
glbp 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • PC1
route delete 172.16.0.0 mask 255.255.0.0 172.16.10.1 metric 1 if 25
route add 172.16.0.0 mask 255.255.0.0 172.16.10.254 metric 1 if 25
  • PC2
sudo ip route del 172.16.0.0/16 via 172.16.2.3
sudo ip route add 172.16.0.0/16 via 172.16.2.254
SW1#
*Mar  1 02:14:30.318: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  1 02:14:30.453: %SYS-5-CONFIG_I: Configured from console by console
SW1#
*Mar  1 02:15:21.883: %LINK-3-UPDOWN: Interface FastEthernet1/0/2, changed state to up
*Mar  1 02:15:22.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to up
SW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW1(config)#int f1
*Mar  1 02:15:49.909: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up
SW1(config)#int f1/0/2
SW1(config-if)#int f0/1
                    ^
% Invalid input detected at '^' marker.

SW1(config)#int f1/0/2
SW1(config-if)#int vlan 10
SW1(config-if)#
*Mar  1 02:16:24.286: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
SW1(config-if)#
*Mar  1 02:16:30.091: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on Vlan3 from LOADING to FULL, Loading Done
SW1(config-if)#ip addr
SW1(config-if)#ip address 172.16.10.254 255.255.255.0
SW1(config-if)#glb
SW1(config-if)#glbp 10
SW1(config-if)#glbp 10 ip
SW1(config-if)#glbp 10 ip 172.16.10.254
%GLBP is not supported by the switch stack

SW1(config-if)#

Catalyst 3750 platform not supported GLBP.

redesign.

  • ASW1
en
conf t
!
vlan 10
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 10
no shut
exit
no shut
exit
!
end
  • ASW2
en
conf t
!
vlan 2
exit
!
int range f0/1 - 2
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
int f0/8
switchport mode access
switchport access vlan 2
spanning-tree portfast
int gig0/1
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shut
exit
!
end
  • ASW3

As a simple IP terminal.

en
conf t
!
no cdp run
no spanning-tree vlan 1-4094
spanning-tree portfast default
!
int vlan 1
ip addr 172.16.10.121 255.255.255.0
no shut
exit
!
ip default-gateway 172.16.10.254
!
end
  • SW1
en
conf t
!
ip routing
!
vlan 3,10
exit
!
int vlan 3
ip address 172.16.3.1 255.255.255.0
no shut
exit
int vlan 10
ip address 172.16.10.1 255.255.255.0
standby 10 ip 172.16.10.254
standby 10 priority 105
standby 10 preempt
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 10
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 3
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • SW2
en
conf t
!
ip routing
!
vlan 4,10
exit
!
int vlan 10
ip address 172.16.10.2 255.255.255.0
standby 10 ip 172.16.10.254
standby 10 preempt
no shut
exit
int vlan 4
ip address 172.16.4.2 255.255.255.0
no shut
exit
int f1/0/1
switchport mode access
switchport access vlan 10
no shut
exit
int f1/0/2
switchport mode access
switchport access vlan 4
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R1
en
conf t
!
int f0/0
ip address 172.16.3.3 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.3 255.255.255.0
glbp 2 ip 172.16.2.254
glbp 2 priority 105
glbp 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • R2
en
conf t
!
int f0/0
ip address 172.16.4.4 255.255.255.0
no shut
exit
int f0/1
ip address 172.16.2.4 255.255.255.0
glbp 2 ip 172.16.2.254
glbp 2 preempt
no shut
exit
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
exit
!
end
  • PC1
route delete 172.16.0.0 mask 255.255.0.0 172.16.10.254 metric 1 if 25
route add 172.16.0.0 mask 255.255.0.0 172.16.2.254 metric 1 if 25
  • PC2
sudo ip route del 172.16.0.0/16 via 172.16.2.3
sudo ip route add 172.16.0.0/16 via 172.16.2.254
R1#sh glbp brief
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Active   172.16.2.254    local           172.16.2.4
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Listen   0007.b400.0202  172.16.2.4      -
R1#
R2#show glbp brief
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Standby  172.16.2.254    172.16.2.3      local
Fa0/1       2    1   -   Listen   0007.b400.0201  172.16.2.3      -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
C:\WINDOWS\system32>ping 172.16.10.121 -t

Pinging 172.16.10.121 with 32 bytes of data:
Request timed out.
Request timed out.
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=2ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253

Ping statistics for 172.16.10.121:
    Packets: Sent = 34, Received = 32, Lost = 2 (5% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2ms, Average = 1ms
Control-C
^C
C:\WINDOWS\system32>
C:\WINDOWS\system32>arp -a | findstr 254
  172.16.2.254          00-07-b4-00-02-01     dynamic
64 bytes from 172.16.10.121: icmp_seq=23 ttl=253 time=1.78 ms
64 bytes from 172.16.10.121: icmp_seq=24 ttl=253 time=1.86 ms
^C
--- 172.16.10.121 ping statistics ---
24 packets transmitted, 24 received, 0% packet loss, time 23038ms
rtt min/avg/max/mdev = 1.702/1.865/3.759/0.399 ms
✘╹◡╹✘  18-09-23 20:11:43 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 REACHABLE
✘╹◡╹✘  18-09-23 20:11:46 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 REACHABLE
✘╹◡╹✘  18-09-23 20:11:48 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 REACHABLE
✘╹◡╹✘  18-09-23 20:11:48 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 STALE
✘╹◡╹✘  18-09-23 20:11:49 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 STALE
✘╹◡╹✘  18-09-23 20:11:49 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 STALE
✘╹◡╹✘  18-09-23 20:11:50 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 STALE
✘╹◡╹✘  18-09-23 20:11:50 /home/wnoguchi
% ip neigh clear 172.16.2.254
Command "clear" is unknown, try "ip neigh help".
✘╹◡╹✘  18-09-23 20:12:06 /home/wnoguchi
% ip neigh delete 172.16.2.254
Device and destination are required arguments.
✘╹◡╹✘  18-09-23 20:12:15 /home/wnoguchi
% sudo ip neigh delete 172.16.2.254 dev enx84afec739c0a
✘╹◡╹✘  18-09-23 20:12:25 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=2.81 ms
64 bytes from 172.16.10.121: icmp_seq=2 ttl=253 time=1.94 ms
^C
--- 172.16.10.121 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 1.940/2.378/2.816/0.438 ms
✘╹◡╹✘  18-09-23 20:12:41 /home/wnoguchi
% ip neigh delete 172.16.2.254
Device and destination are required arguments.
✘╹◡╹✘  18-09-23 20:12:45 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:02 REACHABLE
✘╹◡╹✘  18-09-23 20:12:51 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=1.82 ms
64 bytes from 172.16.10.121: icmp_seq=2 ttl=253 time=1.77 ms
^C
--- 172.16.10.121 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 1.778/1.803/1.828/0.025 ms
✘╹◡╹✘  18-09-23 20:13:02 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:02 REACHABLE
✘╹◡╹✘  18-09-23 20:13:53 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=1.81 ms
64 bytes from 172.16.10.121: icmp_seq=2 ttl=253 time=1.83 ms
^C
--- 172.16.10.121 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 1.814/1.826/1.838/0.012 ms
✘╹◡╹✘  18-09-23 20:13:56 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:02 DELAY
✘╹◡╹✘  18-09-23 20:13:58 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=2.10 ms
64 bytes from 172.16.10.121: icmp_seq=2 ttl=253 time=2.69 ms
^C
--- 172.16.10.121 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 2.102/2.397/2.693/0.299 ms
✘╹◡╹✘  18-09-23 20:14:02 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:02 PROBE
✘╹◡╹✘  18-09-23 20:14:04 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a  FAILED
✘╹◡╹✘  18-09-23 20:14:06 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a  FAILED
✘╹◡╹✘  18-09-23 20:14:08 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=2.80 ms
^C
--- 172.16.10.121 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 2.805/2.805/2.805/0.000 ms
✘╹◡╹✘  18-09-23 20:14:11 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:02 REACHABLE
✘╹◡╹✘  18-09-23 20:14:12 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=1.87 ms
64 bytes from 172.16.10.121: icmp_seq=2 ttl=253 time=1.84 ms
64 bytes from 172.16.10.121: icmp_seq=3 ttl=253 time=1.81 ms
64 bytes from 172.16.10.121: icmp_seq=4 ttl=253 time=1.77 ms
64 bytes from 172.16.10.121: icmp_seq=5 ttl=253 time=1.79 ms
64 bytes from 172.16.10.121: icmp_seq=6 ttl=253 time=1.78 ms
^C
--- 172.16.10.121 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5008ms
rtt min/avg/max/mdev = 1.778/1.814/1.873/0.048 ms

Let's say R1 shut down.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/1
R1(config-if)#shut
R1(config-if)#
*Sep 23 11:14:16.978: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Init
*Sep 23 11:14:16.986: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Init
R1(config-if)#
*Sep 23 11:14:16.990: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 23 11:14:18.978: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Sep 23 11:14:19.978: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#
R2#
*Sep 23 11:17:15.566: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
*Sep 23 11:17:16.302: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R2#sh glbp standby
R2#sh glbp brief
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Active   172.16.2.254    local           unknown
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R2#
*Sep 23 11:17:43.646: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Dead timer expired
R2#

back to normal

R1#sh glbp
FastEthernet0/1 - Group 2
  State is Active
    3 state changes, last state change 00:00:30
  Virtual IP address is 172.16.2.254
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.368 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 0 sec
  Active is local
  Standby is 172.16.2.4, priority 100 (expires in 8.704 sec)
  Priority 105 (configured)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4)
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      3 state changes, last state change 00:00:01
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 100
    Client selection count: 13
  Forwarder 2
    State is Listen
    MAC address is 0007.b400.0202 (learnt)
    Owner ID is 0024.c431.126f
    Redirection enabled, 598.720 sec remaining (maximum 600 sec)
    Time to live: 14398.720 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (primary), weighting 100 (expires in 10.080 sec)
    Client selection count: 12
R2#sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    4 state changes, last state change 00:01:29
  Virtual IP address is 172.16.2.254
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.128 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 0 sec
  Active is 172.16.2.3, priority 105 (expires in 11.648 sec)
  Standby is local
  Priority 100 (default)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    001b.2a77.66d3 (172.16.2.3)
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      2 state changes, last state change 00:01:11
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.680 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.3 (primary), weighting 100 (expires in 9.856 sec)
    Client selection count: 3
  Forwarder 2
    State is Active
      1 state change, last state change 00:16:15
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 100
    Client selection count: 2

timers

R1(config-if)#glbp 2 timers msec 50 msec 1000
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/1
R1(config-if)#glb
R1(config-if)#glbp 2 tim
R1(config-if)#glbp 2 timers ?
  <1-60>    Hello interval in seconds
  msec      Specify hello interval in milliseconds
  redirect  Specify timeout values for failed forwarders

R1(config-if)#glbp 2 timers mse
R1(config-if)#glbp 2 timers msec *?
% Unrecognized command
R1(config-if)#glbp 2 timers msec ?
  <50-60000>  Hello interval in milliseconds

R1(config-if)#glbp 2 timers msec 50 ?
  <1-180>  Hold time in seconds
  msec     Specify hold time in milliseconds

R1(config-if)#glbp 2 timers msec 50 mse
R1(config-if)#glbp 2 timers msec 50 msec 160
R1(config-if)#no glbp 2 timers msec 50 msec 160
R1(config-if)#glbp 2 timers msec 50 msec 160
R1(config-if)#
*Sep 24 02:52:10.667: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Listen -> Active
R1(config-if)#
*Sep 24 02:52:13.171: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Active -> Listen
R1(config-if)#glbp 2 timers msec 50 msec 1000

preempt delay timers

R1(config-if)#glbp 2 preempt delay minimum ?
  <0-3600>  Number of seconds for minimum delay

R1(config-if)#glbp 2 preempt delay minimum 60
R1(config-if)#glbp 2 preempt delay minimum ?
  <0-3600>  Number of seconds for minimum delay

R1(config-if)#glbp 2 preempt delay minimum 60
R1(config-if)#shut
R1(config-if)#
*Sep 24 03:03:07.251: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Init
*Sep 24 03:03:07.259: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Init
R1(config-if)#
*Sep 24 03:03:07.263: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 24 03:03:09.251: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
R1(config-if)#
*Sep 24 03:03:10.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#do sh glbp brief
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Init     172.16.2.254    unknown         unknown
Fa0/1       2    1   -   Init     0007.b400.0201  unknown         -
Fa0/1       2    2   -   Init     0007.b400.0202  unknown         -
R1(config-if)#no shut
R1(config-if)#
*Sep 24 03:04:07.123: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Sep 24 03:04:08.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#
*Sep 24 03:04:16.343: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from LOADING to FULL, Loading Done
R1(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    3 state changes, last state change 00:00:16
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.256 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec (37 secs remaining)
  Active is 172.16.2.4, priority 100 (expires in 3.712 sec)
  Standby is local
  Priority 105 (configured)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4)
  There are 2 forwarders (0 active)
  Forwarder 1
    State is Listen
      2 state changes, last state change 00:01:22
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3

R1(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Standby  172.16.2.254    172.16.2.4      local
Fa0/1       2    1   -   Listen   0007.b400.0201  172.16.2.4      -
Fa0/1       2    2   -   Listen   0007.b400.0202  172.16.2.4      -
R1(config-if)#
*Sep 24 03:04:37.079: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
R1(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Standby  172.16.2.254    172.16.2.4      local
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Listen   0007.b400.0202  172.16.2.4      -
R1(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Standby  172.16.2.254    172.16.2.4      local
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Listen   0007.b400.0202  172.16.2.4      -
R1(config-if)#
*Sep 24 03:05:06.971: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R1(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Active   172.16.2.254    local           172.16.2.4
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Listen   0007.b400.0202  172.16.2.4      -
R1(config-if)#
R1(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 192 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.3 255.255.255.0
 glbp 2 ip 172.16.2.254
 glbp 2 timers 1 4
 glbp 2 priority 105
 glbp 2 preempt delay minimum 60
 duplex auto
 speed auto
end

R1(config-if)#
R1(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 230 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.3 255.255.255.0
 glbp 2 ip 172.16.2.254
 glbp 2 timers 1 4
 glbp 2 priority 105
 glbp 2 preempt delay minimum 60
 glbp 2 load-balancing host-dependent
 duplex auto
 speed auto
end

R2(config-if)#glbp 2 preempt delay minimum 60
R2(config-if)#
*Sep 24 03:06:01.331: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
*Sep 24 03:06:01.395: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
R2(config-if)#do sh glbp brief
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Active   172.16.2.254    local           unknown
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R2(config-if)#
*Sep 24 03:06:31.239: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Dead timer expired
R2(config-if)#
*Sep 24 03:07:06.027: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on FastEthernet0/1 from LOADING to FULL, Loading Done
R2(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Active
    2 state changes, last state change 00:01:17
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.416 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec
  Active is local
  Standby is 172.16.2.3, priority 105 (expires in 3.328 sec)
  Priority 100 (default)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    001b.2a77.66d3 (172.16.2.3)
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (2 active)
  Forwarder 1
    State is Active
      1 state change, last state change 00:01:17
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Redirection enabled, 599.328 sec remaining (maximum 600 sec)

R2(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Active   172.16.2.254    local           172.16.2.3
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R2(config-if)#
*Sep 24 03:07:26.763: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Listen
R2(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Active   172.16.2.254    local           172.16.2.3
Fa0/1       2    1   -   Listen   0007.b400.0201  172.16.2.3      -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R2(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Active   172.16.2.254    local           172.16.2.3
Fa0/1       2    1   -   Listen   0007.b400.0201  172.16.2.3      -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R2(config-if)#
*Sep 24 03:07:56.659: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Speak
R2(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   100 Standby  172.16.2.254    172.16.2.3      local
Fa0/1       2    1   -   Listen   0007.b400.0201  172.16.2.3      -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R2(config-if)#
R2(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 209 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.4 255.255.255.0
 glbp 2 ip 172.16.2.254
 glbp 2 timers 1 4
 glbp 2 preempt delay minimum 60
 glbp 2 load-balancing host-dependent
 duplex auto
 speed auto
end
R1(config-if)#glbp 2 load-balancing ?
  host-dependent  Load balance equally, source MAC determines forwarder choice
  round-robin     Load balance equally using each forwarder in turn
  weighted        Load balance in proportion to forwarder weighting
  <cr>

R1(config-if)#glbp 2 load-balancing host-dependent
R2(config-if)#glbp 2 load-balancing ?
  host-dependent  Load balance equally, source MAC determines forwarder choice
  round-robin     Load balance equally using each forwarder in turn
  weighted        Load balance in proportion to forwarder weighting
  <cr>

R2(config-if)#glbp 2 load-balancing host-dependent
✘╹◡╹✘  18-09-24 11:51:36 /home/wnoguchi
% ping 172.16.10.121
PING 172.16.10.121 (172.16.10.121) 56(84) bytes of data.
64 bytes from 172.16.10.121: icmp_seq=1 ttl=253 time=3.45 ms
64 bytes from 172.16.10.121: icmp_seq=2 ttl=253 time=1.79 ms
64 bytes from 172.16.10.121: icmp_seq=3 ttl=253 time=1.85 ms
64 bytes from 172.16.10.121: icmp_seq=4 ttl=253 time=1.83 ms
64 bytes from 172.16.10.121: icmp_seq=5 ttl=253 time=1.69 ms
64 bytes from 172.16.10.121: icmp_seq=6 ttl=253 time=1.66 ms
64 bytes from 172.16.10.121: icmp_seq=7 ttl=253 time=1.83 ms
^C
--- 172.16.10.121 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6009ms
rtt min/avg/max/mdev = 1.665/2.019/3.458/0.593 ms
✘╹◡╹✘  18-09-24 12:14:32 /home/wnoguchi
% ip neighbour show | fgrep 254
172.16.2.254 dev enx84afec739c0a lladdr 00:07:b4:00:02:01 REACHABLE
C:\WINDOWS\system32>ping 172.16.10.121

Pinging 172.16.10.121 with 32 bytes of data:
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253
Reply from 172.16.10.121: bytes=32 time=1ms TTL=253

Ping statistics for 172.16.10.121:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\WINDOWS\system32>arp -a | findstr 254
  172.16.2.254          00-07-b4-00-02-02     dynamic

Object Tracking

R1(config)#int f0/1
R1(config-if)#glbp 2 weighting lowe?
% Unrecognized command
R1(config-if)#glbp 2 weighting  ?
  <1-254>  Weighting maximum value
  track    Interface tracking

R1(config-if)#glbp 2 weighting  max
R1(config-if)#glbp 2 weighting  200 ?
  lower  Weighting lower threshold
  upper  Weighting upper threshold
  <cr>

R1(config-if)#glbp 2 weighting 150 lower 50 upper 100
R1(config-if)#exit
R1(config)#track 2 interface fa0/0 line-protocol
R1(config-track)#exit
R1(config-if)#glbp 2 weighting track 2 decrement 105
R1(config)#int f0/1
R2(config-if)#glbp 2 weighting 150 lower 50 upper 100
R2(config-if)#exit
R2(config)#track 2 interface fa0/0 line-protocol
R2(config-track)#exit
R2(config)#int f0/1
R2(config-if)#glbp 2 weighting track 2 decrement 105
R1(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 311 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.3 255.255.255.0
 glbp 2 ip 172.16.2.254
 glbp 2 timers 1 4
 glbp 2 priority 105
 glbp 2 preempt delay minimum 60
 glbp 2 weighting 150 lower 50 upper 100
 glbp 2 load-balancing host-dependent
 glbp 2 weighting track 2 decrement 105
 duplex auto
 speed auto
end
R2(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 290 bytes
!
interface FastEthernet0/1
 ip address 172.16.2.4 255.255.255.0
 glbp 2 ip 172.16.2.254
 glbp 2 timers 1 4
 glbp 2 preempt delay minimum 60
 glbp 2 weighting 150 lower 50 upper 100
 glbp 2 load-balancing host-dependent
 glbp 2 weighting track 2 decrement 105
 duplex auto
 speed auto
end
R1(config)#int f
*Sep 24 03:36:08.819: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet0/1 from LOADING to FULL, Loading Done
R1(config)#int f0/0
R1(config-if)#shut
R1(config-if)#
*Sep 24 03:36:15.855: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Up->Down
*Sep 24 03:36:15.859: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.10.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Sep 24 03:36:17.855: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Sep 24 03:36:18.855: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R1(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Active
    7 state changes, last state change 00:00:40
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.032 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec
  Active is local
  Standby is 172.16.2.4, priority 100 (expires in 4.000 sec)
  Priority 105 (configured)
  Weighting 45, low (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Down decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4)
  There are 2 forwarders (0 active)
  Forwarder 1
    State is Listen
      4 state changes, last state change 00:02:01
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (secondary), weighting 150 (expires in 4.288 sec)
    Client selection count: 2
  Forwarder 2
    State is Listen
      2 state changes, last state change 00:45:28
    MAC address is 0007.b400.0202 (learnt)
    Owner ID is 0024.c431.126f
    Redirection enabled, 600.000 sec remaining (maximum 600 sec)
    Time to live: 14400.000 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (primary), weighting 150 (expires in 4.224 sec)
    Client selection count: 1
R2(config-if)#
*Sep 24 03:38:33.643: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
*Sep 24 03:38:33.707: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R2(config-if)#
*Sep 24 03:38:58.515: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.3.3 on FastEthernet0/1 from LOADING to FULL, Loading Done
R2(config-if)#
*Sep 24 03:39:51.155: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Speak
R2(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    7 state changes, last state change 00:00:36
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.992 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec
  Active is 172.16.2.3, priority 105 (expires in 3.712 sec)
  Standby is local
  Priority 100 (default)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3)
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (2 active)
  Forwarder 1
    State is Active
      3 state changes, last state change 00:01:57
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.136 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
  Forwarder 2
    State is Active
      1 state change, last state change 00:47:38
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
R1(config)#int f
R1(config-if)#no shut
R1(config-if)#
*Sep 24 03:38:36.963: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Down->Up
R1(config-if)#
*Sep 24 03:38:38.951: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Up->Down
R1(config-if)#
*Sep 24 03:38:40.123: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Down->Up
R1(config-if)#
*Sep 24 03:38:42.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#no shut
R1(config-if)#
*Sep 24 03:38:36.963: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Down->Up
R1(config-if)#
*Sep 24 03:38:38.951: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Up->Down
R1(config-if)#
*Sep 24 03:38:40.123: %TRACKING-5-STATE: 2 interface Fa0/0 line-protocol Down->Up
R1(config-if)#
*Sep 24 03:38:42.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Active
    7 state changes, last state change 00:07:32
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.672 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec
  Active is local
  Standby is 172.16.2.4, priority 100 (expires in 3.424 sec)
  Priority 105 (configured)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4)
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      5 state changes, last state change 00:05:23
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
    Client selection count: 2
  Forwarder 2
    State is Listen
      2 state changes, last state change 00:52:20
    MAC address is 0007.b400.0202 (learnt)
    Owner ID is 0024.c431.126f
    Redirection enabled, 599.424 sec remaining (maximum 600 sec)
    Time to live: 14399.424 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (primary), weighting 150 (expires in 4.064 sec)
    Client selection count: 1
R2(config-if)#
*Sep 24 03:42:00.631: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Listen
R2(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    7 state changes, last state change 00:02:28
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.032 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec
  Active is 172.16.2.3, priority 105 (expires in 3.744 sec)
  Standby is local
  Priority 100 (default)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3)
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      4 state changes, last state change 00:00:23
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.744 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.3 (primary), weighting 150 (expires in 4.224 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 00:49:30
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
R2(config-if)#
R2#
*Sep 24 03:45:14.027: %SYS-5-CONFIG_I: Configured from console by console
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int f0/1
R2(config-if)#^Z
R2#
*Sep 24 03:47:52.491: %SYS-5-CONFIG_I: Configured from console by console
R2#sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    7 state changes, last state change 00:08:01
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.640 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Preemption enabled, min delay 60 sec
  Active is 172.16.2.3, priority 105 (expires in 3.328 sec)
  Standby is local
  Priority 100 (default)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3)
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      4 state changes, last state change 00:05:55
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.296 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.3 (primary), weighting 150 (expires in 3.360 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 00:55:03
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150

GLBP Authentication

Clear Text

R1(config)#int f0/1
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#glbp
R1(config-if)#glbp 2 auth
R1(config-if)#glbp 2 authentication te
R1(config-if)#glbp 2 authentication text ccieglbp
R1(config-if)#
*Sep 24 03:51:42.879: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 03:51:45.979: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Listen -> Active
R1(config-if)#
*Sep 24 03:52:08.203: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Active -> Listen
R1(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Active
    7 state changes, last state change 00:15:21
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.160 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication text, string "ccieglbp"
  Preemption enabled, min delay 60 sec
  Active is local
  Standby is 172.16.2.4, priority 100 (expires in 3.200 sec)
  Priority 105 (configured)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4)
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      5 state changes, last state change 00:13:12
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
    Client selection count: 2
  Forwarder 2
    State is Listen
      4 state changes, last state change 00:00:15
    MAC address is 0007.b400.0202 (learnt)
    Owner ID is 0024.c431.126f
    Redirection enabled, 599.200 sec remaining (maximum 600 sec)
    Time to live: 14399.200 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (primary), weighting 150 (expires in 3.712 sec)
    Client selection count: 1
R1(config-if)#
R2(config)#int f0/1
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
*Sep 24 03:54:32.543: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#
*Sep 24 03:54:35.687: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
*Sep 24 03:54:36.039: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R2(config-if)#glbp 2 auth
R2(config-if)#glbp 2 authentication te
R2(config-if)#glbp 2 authentication text ccieglbp
R2(config-if)#
*Sep 24 03:54:57.907: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Speak
*Sep 24 03:54:57.907: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Listen
R2(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    10 state changes, last state change 00:00:04
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.768 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication text, string "ccieglbp"
  Preemption enabled, min delay 60 sec
  Active is 172.16.2.3, priority 105 (expires in 3.776 sec)
  Standby is local
  Priority 100 (default)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3)
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      6 state changes, last state change 00:00:08
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.360 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.3 (primary), weighting 150 (expires in 3.520 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 01:02:13
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
R2(config-if)#

MD5 Authentication

R1(config-if)#glbp 2 authentication md5 key-string ccie
R1(config-if)#
*Sep 24 03:53:36.239: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 03:53:39.899: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Listen -> Active
R1(config-if)#
*Sep 24 03:54:06.827: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 03:54:07.691: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Active -> Listen
R1(config-if)#
R1(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Active
    7 state changes, last state change 00:18:22
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.320 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication MD5, key-string
  Preemption enabled, min delay 60 sec
  Active is local
  Standby is 172.16.2.4, priority 100 (expires in 3.296 sec)
  Priority 105 (configured)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4) authenticated
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      5 state changes, last state change 00:16:12
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
    Client selection count: 2
  Forwarder 2
    State is Listen
      8 state changes, last state change 00:01:16
    MAC address is 0007.b400.0202 (learnt)
    Owner ID is 0024.c431.126f
    Redirection enabled, 599.296 sec remaining (maximum 600 sec)
    Time to live: 14399.296 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (primary), weighting 150 (expires in 3.616 sec)
    Client selection count: 1
R2(config-if)#
*Sep 24 03:56:25.663: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#
*Sep 24 03:56:29.047: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
*Sep 24 03:56:29.143: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#glb
R2(config-if)#glbp 2 auth
R2(config-if)#glbp 2 authentication md
R2(config-if)#glbp 2 authentication md5 key-str
R2(config-if)#glbp 2 authentication md5 key-string ccie
R2(config-if)#
*Sep 24 03:56:56.291: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#
*Sep 24 03:56:57.395: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Speak
*Sep 24 03:56:57.395: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Listen
R2(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    16 state changes, last state change 00:01:18
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.576 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication MD5, key-string
  Preemption enabled, min delay 60 sec
  Active is 172.16.2.3, priority 105 (expires in 4.256 sec)
  Standby is local
  Priority 100 (default)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) authenticated
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      10 state changes, last state change 00:01:22
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.904 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.3 (primary), weighting 150 (expires in 4.448 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 01:05:26
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150

Key Chain Authentication

R1(config)#key chain
R1(config)#key chain CCIE
R1(config-keychain)#key 1
R1(config-keychain-key)#keys
R1(config-keychain-key)#key-str
R1(config-keychain-key)#key-string pg1x
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int f0/1
R1(config-if)#glb
R1(config-if)#glbp 2 atuh
R1(config-if)#glbp 2 auth
R1(config-if)#glbp 2 authentication md
R1(config-if)#glbp 2 authentication md5 key-chain
R1(config-if)#glbp 2 authentication md5 key-chain PG1X
R1(config-if)#
*Sep 24 04:00:04.003: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 04:00:07.831: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Listen -> Active
R1(config-if)#
*Sep 24 04:00:34.183: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#do sh glbp bri
Interface   Grp  Fwd Pri State    Address         Active router   Standby router
Fa0/1       2    -   105 Active   172.16.2.254    local           unknown
Fa0/1       2    1   -   Active   0007.b400.0201  local           -
Fa0/1       2    2   -   Active   0007.b400.0202  local           -
R1(config-if)#
*Sep 24 04:01:04.219: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#exit
R1(config)#key cha
R1(config)#key chain PG1
*Sep 24 04:01:34.867: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config)#key chain PG1X
R1(config-keychain)#key 1
R1(config-keychain-key)#key-str
R1(config-keychain-key)#key-string pg1x
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#
*Sep 24 04:02:05.007: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config)#key cha
R1(config)#key chain
*Sep 24 04:02:35.875: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config)#int f0/1
R1(config-if)#key
R1(config-if)#key-ch
R1(config-if)#glbp 2 auth
R1(config-if)#glbp 2 authentication md
R1(config-if)#glbp 2 authentication md5 key
R1(config-if)#glbp 2 authentication md5 key-ch
R1(config-if)#glbp 2 authentication md5 key-chain CCIE
R1(config-if)#
*Sep 24 04:03:06.251: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 04:03:37.099: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 04:04:07.799: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 04:04:38.679: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.4, group 2
R1(config-if)#
*Sep 24 04:04:59.647: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 2 state Active -> Listen
R1(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Active
    7 state changes, last state change 00:28:20
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.864 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication MD5, key-chain "CCIE"
  Preemption enabled, min delay 60 sec
  Active is local
  Standby is 172.16.2.4, priority 100 (expires in 3.392 sec)
  Priority 105 (configured)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) local
    0024.c431.126f (172.16.2.4) authenticated
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      5 state changes, last state change 00:26:11
    MAC address is 0007.b400.0201 (default)
    Owner ID is 001b.2a77.66d3
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
    Client selection count: 2
  Forwarder 2
    State is Listen
      12 state changes, last state change 00:00:22
    MAC address is 0007.b400.0202 (learnt)
    Owner ID is 0024.c431.126f
    Redirection enabled, 599.392 sec remaining (maximum 600 sec)
    Time to live: 14399.392 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.4 (primary), weighting 150 (expires in 3.936 sec)
    Client selection count: 1
R1(config-if)#
R2(config)#key chain PG1X
R2(config-keychain)#key
R2(config-keychain)#key 1
R2(config-keychain-key)#key-stri
R2(config-keychain-key)#key-string pg1x
R2(config-keychain-key)#key-string pg2x
R2(config-keychain-key)#exit
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string pg1x
R2(config-keychain-key)#exit
R2(config-keychain)#exit
R2(config)#int f0/1
R2(config-if)#glb
R2(config-if)#glbp 2 authe
R2(config-if)#glbp 2 authentication md
R2(config-if)#glbp 2 authentication md5 key-ch
R2(config-if)#
*Sep 24 04:02:53.215: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#
*Sep 24 04:02:56.559: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Standby -> Active
*Sep 24 04:02:57.007: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Listen -> Active
R2(config-if)#glbp 5 auth
R2(config-if)#glbp 5 authentication md
R2(config-if)#glbp 5 authentication md5 key-chai
R2(config-if)#glbp 5 authentication md5 key-chain PG1X
*Sep 24 04:03:23.471: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#glbp 5 authentication md5 key-chain PG1X
R2(config-if)#do sh glbp
*Sep 24 04:03:53.635: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#do sh glbp
*Sep 24 04:04:23.859: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#do sh glbp
*Sep 24 04:04:54.399: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#do sh glbp
*Sep 24 04:05:25.119: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#do sh glbp
*Sep 24 04:05:55.359: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#glbp 5 authentication md5 key-chain CCIE
R2(config-if)#exit
R2(config)#key-ch
*Sep 24 04:06:25.467: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config)#key chain
R2(config)#key chain CCIE
R2(config-keychain)#key 1
R2(config-keychain-key)#key-str
R2(config-keychain-key)#key-string pg1x
R2(config-keychain-key)#int f0/1
R2(config-if)#gl
*Sep 24 04:06:55.519: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#glbp 2 auth
R2(config-if)#glbp 2 authentication md5 key-chai
R2(config-if)#glbp 2 authentication md5 key-chain
*Sep 24 04:07:25.583: %GLBP-4-BADAUTH: Bad authentication received from 172.16.2.3, group 2
R2(config-if)#glbp 2 authentication md5 key-chain CCIE
R2(config-if)#
*Sep 24 04:07:49.355: %GLBP-6-STATECHANGE: FastEthernet0/1 Grp 2 state Active -> Speak
*Sep 24 04:07:49.355: %GLBP-6-FWDSTATECHANGE: FastEthernet0/1 Grp 2 Fwd 1 state Active -> Listen
R2(config-if)#do sh glbp
FastEthernet0/1 - Group 2
  State is Standby
    22 state changes, last state change 00:00:28
  Virtual IP address is 172.16.2.254
  Hello time 1 sec, hold time 4 sec
    Next hello sent in 0.256 secs
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication MD5, key-chain "CCIE"
  Preemption enabled, min delay 60 sec
  Active is 172.16.2.3, priority 105 (expires in 4.288 sec)
  Standby is local
  Priority 100 (default)
  Weighting 150 (configured 150), thresholds: lower 50, upper 100
    Track object 2 state Up decrement 105
  Load balancing: host-dependent
  Group members:
    001b.2a77.66d3 (172.16.2.3) authenticated
    0024.c431.126f (172.16.2.4) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      14 state changes, last state change 00:00:32
    MAC address is 0007.b400.0201 (learnt)
    Owner ID is 001b.2a77.66d3
    Time to live: 14399.840 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 172.16.2.3 (primary), weighting 150 (expires in 4.224 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 01:15:28
    MAC address is 0007.b400.0202 (default)
    Owner ID is 0024.c431.126f
    Preemption enabled, min delay 30 sec
    Active is local, weighting 150
FastEthernet0/1 - Group 5
  State is Disabled
  Virtual IP address is unknown
  Hello time 3 sec, hold time 10 sec
  Redirect time 600 sec, forwarder timeout 14400 sec
  Authentication MD5, key-chain "CCIE"
  Preemption disabled
  Active is unknown
  Standby is unknown
  Priority 100 (default)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    0024.c431.126f (unknown) local
  There are no forwarders
R2(config-if)#

References

tech/network/cisco/glbp/glbp.txt · Last modified: 2018/09/24 13:13 by wnoguchi