User Tools

Site Tools


tech:network:cisco:eigrp:stub:stub

Cisco: EIGRP Stub

  1. ✔receive-only
  2. ✔connected
  3. ✔static
  4. ✔summary
  5. ✔redistributed

Lab 1

Topology

Base Configuration

R1

R2

R3

R4

R5

Configuration

  • R3 - R5
configure terminal
!
router eigrp 1
 eigrp stub
exit
!
end

Lab 2 connected, summary

Topology

Base Configuration

R1

R2

R3

R4

R5

R6

R7

Configuration

Lab 2-1

  • R5
configure terminal
!
router eigrp 1
 eigrp stub connected
 no network 5.5.5.5 0.0.0.0
 network 172.16.6.5 0.0.0.0
exit
!
end

Lab 2-2

  • R5
configure terminal
!
router eigrp 1
 eigrp stub connected
 redistribute connected
exit
!
end

Lab 2-3

  • R5
configure terminal
!
router eigrp 1
 eigrp stub summary
 network 172.16.6.5 0.0.0.0
exit
!
interface GigabitEthernet 0/1
 ip summary-address eigrp 1 172.16.0.0 255.255.0.0
!
ip route 172.16.0.0 255.255.0.0 172.16.6.6
!
end
  • R6
ip route 0.0.0.0 0.0.0.0 172.16.6.5
  • R7
ip route 0.0.0.0 0.0.0.0 172.16.7.6

Lab 2-4

  • R5
configure terminal
!
router eigrp 1
 eigrp stub summary
 auto-summary
 network 172.16.6.5 0.0.0.0
exit
!
ip route 172.16.0.0 255.255.0.0 172.16.6.6
!
end
  • R6
ip route 0.0.0.0 0.0.0.0 172.16.6.5
  • R7
ip route 0.0.0.0 0.0.0.0 172.16.7.6

Lab 3 static

Topology

Base Configuration

R1

R2

R3

R4

R5

R6

R7

Configuration

Lab 3-1

  • R5
configure terminal
!
router eigrp 1
 eigrp stub static
 redistribute static
exit
!
end

Lab 3-2

  • R5
configure terminal
!
router eigrp 1
 eigrp stub static connected
 redistribute static
exit
!
end

Lab 4 redistributed

Topology

Base Configuration

R1

R2

R3

R4

R5

R6

R7

Configuration

Lab 4-1

  • R5
configure terminal
!
router eigrp 1
 eigrp stub redistributed
 ! redistribute from ospf to eigrp
 redistribute ospf 1
 default-metric 1000000 1 255 1 1500
exit
router ospf 1
 ! redistribute from eigrp to ospf
 redistribute eigrp 1
exit
!
end

References

tech/network/cisco/eigrp/stub/stub.txt · Last modified: 2019/12/02 06:55 by wnoguchi