PG1X

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:eigrp:eigrp:eigrp-for-ipv6:eigrp-for-ipv6

This is an old revision of the document!


EIGRP for IPv6

Topology

IP

Project name: ccna-ipv6-0011-eigrp-for-ipv6

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write

Configure EIGRP for IPv6

  • R1
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 1.1.1.1
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
!
end
  • R2
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
passive-interface GigabitEthernet 0/1
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
!
end
  • R3
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
!
end
  • R4
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::2
!
end

Verification

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv    
R1(config)#ipv6 router eig
R1(config)#ipv6 router eigrp 1
R1(config-rtr)#router
R1(config-rtr)#router-i
R1(config-rtr)#rou     
R1(config-rtr)#rou
R1(config-rtr)#rou
R1(config-rtr)#router
R1(config-rtr)#router
R1(config-rtr)#router
R1(config-rtr)#router
R1(config-rtr)#router-i
R1(config-rtr)#router-id
R1(config-rtr)#router-id
R1(config-rtr)#router-id
R1(config-rtr)#router-id?
% Unrecognized command
R1(config-rtr)#r?       
redistribute  

R1(config-rtr)#id
R1(config-rtr)#? 
  default            Set a command to its defaults
  default-metric     Set metric of redistributed routes
  distance           Define an administrative distance
  distribute-list    Filter networks in routing updates
  eigrp              EIGRP specific commands
  exit               Exit from IPv6 routing protocol configuration mode
  maximum-paths      Forward packets over multiple paths
  metric             Modify metrics and parameters for advertisement
  neighbor           Specify a neighbor router
  no                 Negate a command or set its defaults
  passive-interface  Suppress routing updates on an interface
  redistribute       Redistribute IPv6 prefixes from another routing protocol
  shutdown           Shutdown this instance of EIGRP 
  summary-metric     Specify summary to apply metric/filtering
  timers             Adjust topology specific timers
  variance           Control load balancing variance

R1(config-rtr)#rou?
% Unrecognized command
R1(config-rtr)#eigr
R1(config-rtr)#eigrp rou
R1(config-rtr)#eigrp router-id 1.1.1.1
R1(config-rtr)#pass
R1(config-rtr)#passive-interface Gig
R1(config-rtr)#passive-interface GigabitEthernet 0/1
R1(config-rtr)#int gig0/0
R1(config-if)#ipv
R1(config-if)#ipv6 eig
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int gig0/1
R1(config-if)#eig
R1(config-if)#ipv
R1(config-if)#ipv6 eig
R1(config-if)#ipv6 eigrp 1
R1(config-if)#^Z
R1#
*Mar 14 22:36:11.567: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar 14 22:37:04.643: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (GigabitEthernet0/0) is up: new adjacency
R1#sh ipv6 ro eigrp
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
R1#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/17 ms
R1#sh ipv
R1#sh ipv6 pro
R1#sh ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 1"
EIGRP-IPv6 Protocol for AS(1)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  Soft SIA disabled
  NSF-aware route hold timer is 240
  Router-ID: 1.1.1.1
  Topology : 0 (base) 
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1

  Interfaces:
    GigabitEthernet0/0
    GigabitEthernet0/1 (passive)
  Redistribution:
    None
R1#sho
R1#show ipv
R1#show ipv6 ei
R1#show ipv6 eigrp neigh
R1#show ipv6 eigrp neighbors 
EIGRP-IPv6 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Gi0/0                    11 00:13:33    9   100  0  4
    FE80::2
R1#sho
R1#show ipv
R1#show ipv6 eig
R1#show ipv6 eigrp top
R1#show ipv6 eigrp topology 
EIGRP-IPv6 Topology Table for AS(1)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 2001:0:2:4::/64, 1 successors, FD is 3072
        via FE80::2 (3072/2816), GigabitEthernet0/0
P 2001:0:1:3::/64, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/1
P 2001:0:1:2::/64, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/0

R1#show
R1#show ipv
R1#show ipv6 route eigr
R1#show ipv6 route eigrp 
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
R1#show
R1#show ipv
R1#show ipv6 eig
R1#show ipv6 eigrp inter
R1#show ipv6 eigrp interfaces 
EIGRP-IPv6 Interfaces for AS(1)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0                    1        0/0       0/0           9       0/0           50           0
R1#show ipv
R1#show ipv6 ei
R1#show ipv6 eigrp tra
R1#show ipv6 eigrp traffic 
EIGRP-IPv6 Traffic Statistics for AS(1)
  Hellos sent/received: 227/212
  Updates sent/received: 4/4
  Queries sent/received: 0/0
  Replies sent/received: 0/0
  Acks sent/received: 4/2
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
  Hello Process ID: 100
  PDM Process ID: 48
  Socket Queue: 0/10000/1/0 (current/max/highest/drops)
  Input Queue: 0/10000/1/0 (current/max/highest/drops)

R1#
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv
R3(config)#ipv6 route ::/0 giga
R3(config)#ipv6 route ::/0 gigabitEthernet 0/0 fe80::1
R3(config)#^Z
R3#
*Mar 14 22:39:21.450: %SYS-5-CONFIG_I: Configured from console by console
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/8 ms
R3#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "static"

Topology: route sumarization

IP

Project name: ccna-ipv6-0012-eigrp-for-ipv6-router-summarization

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:4::1/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:5::1/64
no shutdown
exit
interface GigabitEthernet 0/3
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:6::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:3::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
interface GigabitEthernet 0/2
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:5::2/64
no shutdown
exit
interface GigabitEthernet 0/3
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:7::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::3 link-local
ipv6 address 2001:0:2:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:1:4::4/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write
  • R5
enable
configure terminal
!
hostname R5
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::5 link-local
ipv6 address 2001:0:1:5::5/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::5 link-local
ipv6 address 2001:0:2:5::5/64
no shutdown
exit
!
end
write
  • R6
enable
configure terminal
!
hostname R6
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::6 link-local
ipv6 address 2001:60:1:6::6/64
no shutdown
exit
!
end
write
  • R7
enable
configure terminal
!
hostname R7
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::7 link-local
ipv6 address 2001:70:2:7::7/64
no shutdown
exit
!
end
write

Configure EIGRP for IPv6

  • R1
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 1.1.1.1
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
interface GigabitEthernet 0/2
ipv6 eigrp 1
exit
interface GigabitEthernet 0/3
ipv6 eigrp 1
exit
!
end
  • R2
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
interface GigabitEthernet 0/2
ipv6 eigrp 1
exit
interface GigabitEthernet 0/3
ipv6 eigrp 1
exit
!
end
  • R3
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 3.3.3.3
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
!
end
  • R4
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 4.4.4.4
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
!
end
  • R5
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 5.5.5.5
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
interface GigabitEthernet 0/1
ipv6 eigrp 1
exit
!
end
  • R6
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 6.6.6.6
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
!
end
  • R7
configure terminal
!
ipv6 router eigrp 1
eigrp router-id 7.7.7.7
exit
!
interface GigabitEthernet 0/0
ipv6 eigrp 1
exit
!
end
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#ipv 
R6(config)#ipv6 router eig
R6(config)#ipv6 router eigrp 6.6.6.6
                              ^
% Invalid input detected at '^' marker.

R6(config)#ipv6 router eigrp ?      
  <1-65535>  Autonomous system number

R6(config)#ipv6 router eigrp 1
R6(config-rtr)#eig
R6(config-rtr)#eigrp router
R6(config-rtr)#eigrp router-id 6.6.6.6
R6(config-rtr)#int gig0/0
R6(config-if)#ipv
R6(config-if)#ipv6 ei    
R6(config-if)#ipv6 eigrp 1
R6(config-if)#
*Mar 17 10:20:54.758: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::1 (GigabitEthernet0/0) is up: new adjacency
R6(config-if)#^Z
R6#
*Mar 17 12:46:31.851: %SYS-5-CONFIG_I: Configured from console by console
R6#sh ipv6 ro eigpr
Translating "eigpr"
                 ^
% Invalid input detected at '^' marker.

R6#sh ipv
R6#sh ipv6 route eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3328]
     via FE80::1, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3328]
     via FE80::1, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3328]
     via FE80::1, GigabitEthernet0/0
D   2001:70:2:7::/64 [90/3584]
     via FE80::1, GigabitEthernet0/0
R6#ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/11/22 ms
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv    
R1(config)#ipv6 router ei
R1(config)#ipv6 router eigrp 1
R1(config-rtr)#eig
R1(config-rtr)#eigrp router
R1(config-rtr)#eigrp router-id 1.1.1.1
R1(config-rtr)#inta gig0/0
               ^
% Invalid input detected at '^' marker.

R1(config-rtr)#int gig0/0
R1(config-if)#ipv
R1(config-if)#ipv6 eig
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int gig0/1
R1(config-if)#ipv
R1(config-if)#ipv6 eig
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int gig0/2
R1(config-if)#ipv
R1(config-if)#ipv6 eig
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int gig0/3
R1(config-if)#ipv
R1(config-if)#ipv6 eig
R1(config-if)#ipv6 eigrp 1
R1(config-if)#^Z
R1#
*Mar 17 06:24:19.793: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar 17 10:20:55.427: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::6 (GigabitEthernet0/3) is up: new adjacency
R1#
*Mar 17 10:21:57.559: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::3 (GigabitEthernet0/0) is up: new adjacency
R1#
*Mar 17 12:45:17.624: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::4 (GigabitEthernet0/1) is up: new adjacency
R1#
*Mar 17 12:46:04.719: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::5 (GigabitEthernet0/2) is up: new adjacency
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv  
R2(config)#ipv6 router
R2(config)#ipv6 router eig
R2(config)#ipv6 router eigrp 1
R2(config-rtr)#eig
R2(config-rtr)#eigrp router
R2(config-rtr)#eigrp router-id 2.2.2.2
R2(config-rtr)#int gig0/0
R2(config-if)#ipv
R2(config-if)#ipv6 ei
R2(config-if)#ipv6 eigrp 1
R2(config-if)#ipv
R2(config-if)#ipv6 ei
R2(config-if)#int gig0/1  
R2(config-if)#ipv
R2(config-if)#ipv6 ei
R2(config-if)#ipv6 eigrp 1
R2(config-if)#int gig0/2
R2(config-if)#ipv
R2(config-if)#ipv6 ei
R2(config-if)#ipv6 eigrp 1
R2(config-if)#ipv
R2(config-if)#int gig0/3
R2(config-if)#ipv
R2(config-if)#ipv6 ei
R2(config-if)#ipv6 eigrp 1
R2(config-if)#^Z
R2#
*Mar 17 06:25:19.035: %SYS-5-CONFIG_I: Configured from console by console
R2#
*Mar 17 10:21:27.137: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::7 (GigabitEthernet0/3) is up: new adjacency
R2#
*Mar 17 10:22:13.116: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::3 (GigabitEthernet0/0) is up: new adjacency
R2#
*Mar 17 12:45:31.857: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::4 (GigabitEthernet0/1) is up: new adjacency
R2#
*Mar 17 12:46:18.121: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::5 (GigabitEthernet0/2) is up: new adjacency
R2#sh ipv
R2#sh ipv6 ro eigrp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3072]
     via FE80::3, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3072]
     via FE80::4, GigabitEthernet0/1
D   2001:0:1:5::/64 [90/3072]
     via FE80::5, GigabitEthernet0/2
D   2001:60:1:6::/64 [90/3328]
     via FE80::3, GigabitEthernet0/0
     via FE80::4, GigabitEthernet0/1
     via FE80::5, GigabitEthernet0/2
R2#ping 2001:60:1:6::6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:60:1:6::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/15/33 ms
R2#ping 2001:0:1:3::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:3::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/6/13 ms
R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#ipv
R7(config)#ipv6 router eig
R7(config)#ipv6 router eigrp 1
R7(config-rtr)#ei
R7(config-rtr)#eigrp router
R7(config-rtr)#eigrp router-id 7.7.7.7
R7(config-rtr)#int gig0/0
R7(config-if)#ipv
R7(config-if)#ipv6 ei
R7(config-if)#ipv6 eigrp 1
R7(config-if)#
*Mar 17 10:21:37.931: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (GigabitEthernet0/0) is up: new adjacency
R7(config-if)#^Z
R7#
*Mar 17 12:46:53.267: %SYS-5-CONFIG_I: Configured from console by console
R7#sh ipv
R7#sh ipv6 ro eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:60:1:6::/64 [90/3584]
     via FE80::2, GigabitEthernet0/0

Configure EIGRP for IPv6 manual router summarization

  • R1
configure terminal
!
interface GigabitEthernet 0/3
ipv6 sumamry-address eigrp 1 2001::/32
exit
!
end
  • R2
configure terminal
!
interface GigabitEthernet 0/3
ipv6 sumamry-address eigrp 1 2001::/32
exit
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int gig0/3
R1(config-if)#ipv
R1(config-if)#ipv6 su
R1(config-if)#ipv6 summary-address eig
R1(config-if)#ipv6 summary-address eigrp 1 2001::/32 
R1(config-if)#
*Mar 17 12:57:53.772: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::6 (GigabitEthernet0/3) is resync: summary configured
R1(config-if)#^Z
R1#
*Mar 17 12:57:56.843: %SYS-5-CONFIG_I: Configured from console by console
R1#sh ipv6 ro eigrp
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001::/32 [5/2816]
     via Null0, directly connected
D   2001:0:2:3::/64 [90/3072]
     via FE80::3, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3072]
     via FE80::4, GigabitEthernet0/1
D   2001:0:2:5::/64 [90/3072]
     via FE80::5, GigabitEthernet0/2
D   2001:70:2:7::/64 [90/3328]
     via FE80::3, GigabitEthernet0/0
     via FE80::4, GigabitEthernet0/1
     via FE80::5, GigabitEthernet0/2
R6#sh ipv6 ro eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3328]
     via FE80::1, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3328]
     via FE80::1, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3328]
     via FE80::1, GigabitEthernet0/0
D   2001:70:2:7::/64 [90/3584]
     via FE80::1, GigabitEthernet0/0
R6#
*Mar 17 12:57:58.952: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::1 (GigabitEthernet0/0) is resync: peer graceful-restart
R6#sh ipv  
R6#sh ipv6 ro eigrp
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001::/32 [90/3072]
     via FE80::1, GigabitEthernet0/0
D   2001:70:2:7::/64 [90/3584]
     via FE80::1, GigabitEthernet0/0
R6#ping 2001:0:2:3::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:3::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/12/36 ms
R6#ping 2001:70:2:7::7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:70:2:7::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/12/30 ms
R2#sh ipv6 ro eigrp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3072]
     via FE80::3, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3072]
     via FE80::4, GigabitEthernet0/1
D   2001:0:1:5::/64 [90/3072]
     via FE80::5, GigabitEthernet0/2
D   2001:60:1:6::/64 [90/3328]
     via FE80::4, GigabitEthernet0/1
     via FE80::3, GigabitEthernet0/0
     via FE80::5, GigabitEthernet0/2
R7#sh ipv6 ro eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:60:1:6::/64 [90/3584]
     via FE80::2, GigabitEthernet0/0

let's say configure R2 side summarization.

R2#sh ipv6 ro eigrp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3072]
     via FE80::3, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3072]
     via FE80::4, GigabitEthernet0/1
D   2001:0:1:5::/64 [90/3072]
     via FE80::5, GigabitEthernet0/2
D   2001:60:1:6::/64 [90/3328]
     via FE80::4, GigabitEthernet0/1
     via FE80::3, GigabitEthernet0/0
     via FE80::5, GigabitEthernet0/2
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int gig0/3
R2(config-if)#ipv6 su
R2(config-if)#ipv6 summary-address eig
R2(config-if)#ipv6 summary-address eigrp 1 2002::/32
R2(config-if)#
*Mar 17 13:01:22.720: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::7 (GigabitEthernet0/3) is resync: summary configured
R2(config-if)#^Z
R2#
*Mar 17 13:01:26.169: %SYS-5-CONFIG_I: Configured from console by console
R2#conf t          
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int gig0/3
R2(config-if)#no ipv6 summary-address eigrp 1 2002::/32
R2(config-if)#no ipv6 summary-address eigrp 1 2002::/32
*Mar 17 13:02:02.656: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::7 (GigabitEthernet0/3) is resync: summary configured
R2(config-if)#ipv                                      
R2(config-if)#ipv6 su
R2(config-if)#ipv6 summary-address ei
R2(config-if)#ipv6 summary-address eigrp 1 2001::/32
R2(config-if)#
*Mar 17 13:02:18.385: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::7 (GigabitEthernet0/3) is resync: summary configured
R2(config-if)#^Z
R2#
*Mar 17 13:02:21.404: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ipv6 ro eigrp
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001::/32 [5/2816]
     via Null0, directly connected
D   2001:0:1:3::/64 [90/3072]
     via FE80::3, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3072]
     via FE80::4, GigabitEthernet0/1
D   2001:0:1:5::/64 [90/3072]
     via FE80::5, GigabitEthernet0/2
D   2001:60:1:6::/64 [90/3328]
     via FE80::4, GigabitEthernet0/1
     via FE80::3, GigabitEthernet0/0
     via FE80::5, GigabitEthernet0/2
R2#
R7#sh ipv6 ro eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:60:1:6::/64 [90/3584]
     via FE80::2, GigabitEthernet0/0
R7#
*Mar 17 13:01:24.118: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (GigabitEthernet0/0) is resync: peer graceful-restart
R7#sh ipv6 ro eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:60:1:6::/64 [90/3584]
     via FE80::2, GigabitEthernet0/0
R7#sh ipv6 ro eigrp
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001:0:1:3::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:4::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:1:5::/64 [90/3328]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:3::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:4::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:0:2:5::/64 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:60:1:6::/64 [90/3584]
     via FE80::2, GigabitEthernet0/0
R7#
*Mar 17 13:02:04.027: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (GigabitEthernet0/0) is resync: peer graceful-restart
R7#
*Mar 17 13:02:19.805: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (GigabitEthernet0/0) is resync: peer graceful-restart
R7#sh ipv6 ro eigrp
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001::/32 [90/3072]
     via FE80::2, GigabitEthernet0/0
D   2001:60:1:6::/64 [90/3584]
     via FE80::2, GigabitEthernet0/0
R7#ping 2001:0:1:3::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:1:3::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/9/17 ms
R7#ping 2001:60:1:6::6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:60:1:6::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/11 ms































References

tech/network/cisco/eigrp/eigrp/eigrp-for-ipv6/eigrp-for-ipv6.1552827940.txt.gz · Last modified: 2019/03/17 13:05 by wnoguchi