User Tools

Site Tools


tech:network:cisco:eigrp:eigrp:eigrp-default-route:eigrp-default-route

Cisco: EIGRP default route

Blueprint

    • 3.0 Infrastructure
      • 3.2 Layer 3
        • 3.2.a Compare routing concepts of EIGRP and OSPF (advanced distance vector vs. linked state, load balancing, path selection, path operations, metrics)
      • 1.0 Network Infrastructure
        • 1.3 EIGRP
          • 1.3.a Adjacencies
          • 1.3.b Best path selection
            • 1.3.b i RD, FD, FC, successor, feasible successor
            • 1.3.b ii Classic Metrics and Wide Metrics
          • 1.3.c Operations
            • 1.3.c i General operations
            • 1.3.c ii Topology table
            • 1.3.c iii Packet types
            • 1.3.c iv Stuck In Active
            • 1.3.c v Graceful shutdown
          • 1.3.d EIGRP load-balancing
            • 1.3.d i Equal-cost
            • 1.3.d ii Unequal-cost
            • 1.3.d iii Add-path
          • 1.3.e EIGRP Named Mode
          • 1.3.f Optimization, convergence and scalability
            • 1.3.f i Fast convergence requirements
            • 1.3.f ii Query propagation boundaries
            • 1.3.f iii IP FRR (single hop)
            • 1.3.f iv Leak-map with summary routes
            • 1.3.f v EIGRP stub with leak map
      • 3.0 Layer 3 Technologies
        • 3.5 EIGRP [for IPv4 and IPv6]
          • 3.5.a Describe packet types
            • 3.5.a [i] Packet types [hello, query, update, and such]
            • 3.5.a [ii] Route types [internal, external]
          • 3.5.b Implement and troubleshoot neighbor relationship
            • 3.5.b [i] Multicast, unicast EIGRP peering
            • 3.5.b [ii] OTP point-to-point peering
            • 3.5.b [iii] OTP route-reflector peering
            • 3.5.b [iv] OTP multiple service providers scenario
          • 3.5.c Implement and troubleshoot loop free path selection
            • 3.5.c [i] RD, FD, FC, successor, feasible successor
            • 3.5.c [ii] Classic metric
            • 3.5.c [iii] Wide metric
          • 3.5.d Implement and troubleshoot operations
            • 3.5.d [i] General operations
            • 3.5.d [ii] Topology table, update, query, active, passive
            • 3.5.d [iii] Stuck in active
            • 3.5.d [iv] Graceful shutdown
          • 3.5.e Implement and troubleshoot EIGRP stub
            • 3.5.e [i] Stub
            • 3.5.e [ii] Leak-map
          • 3.5.f Implement and troubleshoot load-balancing
            • 3.5.f [i] equal-cost
            • 3.5.f [ii] unequal-cost
            • 3.5.f [iii] add-path
          • 3.5.g Implement EIGRP [multi-address] named mode
            • 3.5.g [i] Types of families
            • 3.5.g [ii] IPv4 address-family
            • 3.5.g [iii] IPv6 address-family
          • 3.5.h Implement, troubleshoot and optimize EIGRP convergence and scalability
            • 3.5.h [i] Describe fast convergence requirements
            • 3.5.h [ii] Control query boundaries
            • 3.5.h [iii] IP FRR/fast reroute [single hop]
            • 3.5.8 [iv] Summary leak-map
            • 3.5.h [v] Summary metric
      • 2.0 Layer 3 Technologies
        • 2.5 EIGRP [for IPv4 and IPv6]
          • 2.5.a Describe packet types
            • 2.5.a [i] Packet types [hello, query, update, and such]
            • 2.5.a [ii] Route types [internal, external]
          • 2.5.b Implement and troubleshoot neighbor relationship
            • 2.5.b [i] Multicast, unicast EIGRP peering
          • 2.5.c Implement and Troubleshoot Loop free path selection
            • 2.5.c [i] RD, FD, FC, successor, feasible successor
            • 2.5.c [ii] Classic metric
            • 2.5.c [iii] Wide metric
          • 2.5.d Implement and troubleshoot operations
            • 2.5.d [i] General operations
            • 2.5.d [ii] Topology table, update, query, active, passive
            • 2.5.d [iii] Stuck in active
            • 2.5.d [iv] Graceful shutdown
          • 2.5.e Implement and troubleshoot EIGRP stub
            • 2.5.e [i] stub
            • 2.5.e [ii] leak-map
          • 2.5.f Implement and troubleshoot load-balancing
            • 2.5.f [i] equal-cost
            • 2.5.f [ii] unequal-cost
            • 2.5.f [iii] add-path
          • 2.5.g Implement EIGRP [multi-address] named mode
            • 2.5.g [i] Types of families
            • 2.5.g [ii] IPv4 address-family
            • 2.5.g [iii] IPv6 address-family
          • 2.5.h Implement, troubleshoot and optimize EIGRP convergence and scalability
            • 2.5.h [i] Describe fast convergence requirements
            • 2.5.h [ii] Control query boundaries
            • 2.5.h [iii] IP FRR/fast reroute [single hop]
            • 2.5.h [iv] Summary leak-map
            • 2.5.h [v] Summary metric

Base Configuration

  • R1
configure terminal
!
interface GigabitEthernet 0/1
 ip address 10.1.2.1 255.255.255.0
 no shutdown
!
router eigrp 1
 network 10.1.2.1 0.0.0.0
exit
!
end
  • R2
configure terminal
!
interface GigabitEthernet 0/1
 ip address 10.2.3.2 255.255.255.0
 no shutdown
interface GigabitEthernet 0/2
 ip address 10.1.2.2 255.255.255.0
 no shutdown
!
router eigrp 1
 network 10.1.2.2 0.0.0.0
 network 10.2.3.2 0.0.0.0
exit
!
end
  • R3
configure terminal
!
interface GigabitEthernet 0/1
 ip address 10.0.4.103 255.255.255.0
 ip nat outside
 no shutdown
interface GigabitEthernet 0/2
 ip address 10.2.3.3 255.255.255.0
 ip nat inside
 no shutdown
!
access-list 1 deny 10.0.4.0 0.0.0.255
access-list 1 permit 10.0.0.0 0.255.255.255
!
ip nat inside source list 1 interface GigabitEthernet 0/1 overload
!
ip route 0.0.0.0 0.0.0.0 10.0.4.1
!
router eigrp 1
 network 10.2.3.3 0.0.0.0
 network 10.0.4.103 0.0.0.0
exit
!
end

redistribute default route

  • R3
configure terminal
!
router eigrp 1
 redistribute static
!
end

Verification

  • R1
R1#sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 10.1.2.2 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/3328] via 10.1.2.2, 00:00:51, GigabitEthernet0/1
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D        10.0.4.0/24 [90/3328] via 10.1.2.2, 00:18:13, GigabitEthernet0/1
D        10.2.3.0/24 [90/3072] via 10.1.2.2, 00:21:17, GigabitEthernet0/1
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
R1#
  • R1
R2#sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 10.2.3.3 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/3072] via 10.2.3.3, 00:00:32, GigabitEthernet0/1
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.0.4.0/24 [90/3072] via 10.2.3.3, 00:17:54, GigabitEthernet0/1
R2#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
R2#
  • R3
configure terminal
!
no ip route 0.0.0.0 0.0.0.0 10.0.4.1
ip route 0.0.0.0 0.0.0.0 GigabitEthernet 0/1
!
router eigrp 1
 no redistribute static
 network 0.0.0.0
!
end

Verification

  • R3
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#no ip route 0.0.0.0 0.0.0.0 10.0.4.1
R3(config)#ip route 0.0.0.0 0.0.0.0 Gig
R3(config)#ip route 0.0.0.0 0.0.0.0 GigabitEthernet 0/1
%Default route without gateway, if not a point-to-point interface, may impact performance
R3(config)#do sh ip ro 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, GigabitEthernet0/1
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.0.4.0/24 is directly connected, GigabitEthernet0/1
L        10.0.4.103/32 is directly connected, GigabitEthernet0/1
D        10.1.2.0/24 [90/3072] via 10.2.3.2, 00:31:59, GigabitEthernet0/2
C        10.2.3.0/24 is directly connected, GigabitEthernet0/2
L        10.2.3.3/32 is directly connected, GigabitEthernet0/2
R3(config)#router eigrp 1
R3(config-router)#no redi
R3(config-router)#no redistribute stat
R3(config-router)#no redistribute static 
R3(config-router)#netwo
R3(config-router)#network 0.0.0.0 ?
  A.B.C.D  EIGRP wild card bits
  <cr>

R3(config-router)#network 0.0.0.0 
R3(config-router)#end]
                   ^
% Invalid input detected at '^' marker.

R3(config-router)#end
R3#
*Nov 18 22:41:21.576: %SYS-5-CONFIG_I: Configured from console by console
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, GigabitEthernet0/1
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.0.4.0/24 is directly connected, GigabitEthernet0/1
L        10.0.4.103/32 is directly connected, GigabitEthernet0/1
D        10.1.2.0/24 [90/3072] via 10.2.3.2, 00:32:52, GigabitEthernet0/2
C        10.2.3.0/24 is directly connected, GigabitEthernet0/2
L        10.2.3.3/32 is directly connected, GigabitEthernet0/2
R3#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#ping 10.0.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/6 ms
R3#ping 8.8.8.8 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#
R2#sh ip ro     
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 10.2.3.3 to network 0.0.0.0

D*    0.0.0.0/0 [90/3072] via 10.2.3.3, 00:01:15, GigabitEthernet0/1
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.0.4.0/24 [90/3072] via 10.2.3.3, 00:31:00, GigabitEthernet0/1
C        10.1.2.0/24 is directly connected, GigabitEthernet0/2
L        10.1.2.2/32 is directly connected, GigabitEthernet0/2
C        10.2.3.0/24 is directly connected, GigabitEthernet0/1
L        10.2.3.2/32 is directly connected, GigabitEthernet0/1
R2#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 10.1.2.2 to network 0.0.0.0

D*    0.0.0.0/0 [90/3328] via 10.1.2.2, 00:01:39, GigabitEthernet0/1
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D        10.0.4.0/24 [90/3328] via 10.1.2.2, 00:31:24, GigabitEthernet0/1
C        10.1.2.0/24 is directly connected, GigabitEthernet0/1
L        10.1.2.1/32 is directly connected, GigabitEthernet0/1
D        10.2.3.0/24 [90/3072] via 10.1.2.2, 00:34:28, GigabitEthernet0/1
R1#

this configuration not work properly because interface network is not point-to-point network.

ip default-network

Base Configuration

  • R1
configure terminal
!
interface GigabitEthernet 0/1
 ip address 192.168.0.1 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.0.1 0.0.0.0
exit
!
end
  • R2
configure terminal
!
interface GigabitEthernet 0/1
 ip address 192.168.1.2 255.255.255.0
 no shutdown
interface GigabitEthernet 0/2
 ip address 192.168.0.2 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.0.2 0.0.0.0
 network 192.168.1.2 0.0.0.0
exit
!
end
  • R3
configure terminal
!
interface GigabitEthernet 0/1
 ip address 192.168.2.3 255.255.255.0
 no shutdown
interface GigabitEthernet 0/2
 ip address 192.168.1.3 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.1.3 0.0.0.0
 network 192.168.2.3 0.0.0.0
exit
!
end
  • R4
configure terminal
!
interface Loopback 0
 ip address 4.4.4.4 255.255.255.255
 no shutdown
interface GigabitEthernet 0/2
 ip address 192.168.2.4 255.255.255.0
 no shutdown
!
ip route 192.168.0.0 255.255.0.0 192.168.2.3
!
end

Configuration

  • R3
configure terminal
!
router eigrp 1
 network 192.168.2.0 0.0.0.255
!
ip default-network 192.168.2.0
!
end

Verification

do not work…

R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

S*    0.0.0.0/0 [0/0], GigabitEthernet0/1
D     192.168.0.0/24 [90/3072] via 192.168.1.2, 16:08:45, GigabitEthernet0/2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/2
L        192.168.1.3/32 is directly connected, GigabitEthernet0/2
 *    192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C*       192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.3/32 is directly connected, GigabitEthernet0/1
R3#sh run | i route
router eigrp 1
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/2
L        192.168.0.2/32 is directly connected, GigabitEthernet0/2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.2/32 is directly connected, GigabitEthernet0/1
D     192.168.2.0/24 [90/3072] via 192.168.1.3, 00:01:23, GigabitEthernet0/1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/1
L        192.168.0.1/32 is directly connected, GigabitEthernet0/1
D     192.168.1.0/24 [90/3072] via 192.168.0.2, 16:09:15, GigabitEthernet0/1
D     192.168.2.0/24 [90/3328] via 192.168.0.2, 16:09:09, GigabitEthernet0/1
R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#

ip summary-address

Base Configuration

  • R1
configure terminal
!
interface GigabitEthernet 0/1
 ip address 192.168.0.1 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.0.1 0.0.0.0
exit
!
end
  • R2
configure terminal
!
interface GigabitEthernet 0/1
 ip address 192.168.1.2 255.255.255.0
 no shutdown
interface GigabitEthernet 0/2
 ip address 192.168.0.2 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.0.2 0.0.0.0
 network 192.168.1.2 0.0.0.0
exit
!
end
  • R3
configure terminal
!
interface GigabitEthernet 0/1
 ip address 192.168.2.3 255.255.255.0
 no shutdown
interface GigabitEthernet 0/2
 ip address 192.168.1.3 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.1.3 0.0.0.0
 network 192.168.2.3 0.0.0.0
exit
!
end
  • R4
configure terminal
!
interface Loopback 0
 ip address 4.4.4.4 255.255.255.255
 no shutdown
interface GigabitEthernet 0/2
 ip address 192.168.2.4 255.255.255.0
 no shutdown
!
router eigrp 1
 network 192.168.2.4 0.0.0.0
exit
!
end

Configuration

normal

  • R4
configure terminal
!
interface GigabitEthernet 0/2
 ip summary-address eigrp 1 0.0.0.0 0.0.0.0
!
end

redistribute and summary-address behavior

  • R3
configure terminal
!
ip route 0.0.0.0 0.0.0.0 192.168.2.4
!
router eigrp 1
 redistribute static
!
end
  • R2
configure terminal
!
interface GigabitEthernet 0/2
 ip summary-address eigrp 1 0.0.0.0 0.0.0.0
!
end
  • R2 change administrative distance over 170
configure terminal
!
interface GigabitEthernet 0/2
 ! deprecated
 !ip summary-address eigrp 1 0.0.0.0 0.0.0.0 200
!
router eigrp 1
 summary-metric 0.0.0.0 0.0.0.0 distance 200
!
end
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.1.3 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/3072] via 192.168.1.3, 00:01:00, GigabitEthernet0/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/2
L        192.168.0.2/32 is directly connected, GigabitEthernet0/2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.2/32 is directly connected, GigabitEthernet0/1
D     192.168.2.0/24 [90/3072] via 192.168.1.3, 03:31:36, GigabitEthernet0/1
R2#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/8 ms
R2#conf t   
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int gig0/1
R2(config-if)#end
R2#int 
*Nov 24 00:10:02.749: %SYS-5-CONFIG_I: Configured from console by console
R2#int gig0/2
    ^
% Invalid input detected at '^' marker.

R2#conf t    
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int gig0/2
R2(config-if)#ip summ
R2(config-if)#ip summary-address ei
R2(config-if)#ip summary-address eigrp 1 0.0.0.0 0.0.0.0
R2(config-if)#
*Nov 24 00:10:25.925: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.0.1 (GigabitEthernet0/2) is resync: summary configured
R2(config-if)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

D*    0.0.0.0/0 is a summary, 00:00:32, Null0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/2
L        192.168.0.2/32 is directly connected, GigabitEthernet0/2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.2/32 is directly connected, GigabitEthernet0/1
D     192.168.2.0/24 [90/3072] via 192.168.1.3, 03:33:57, GigabitEthernet0/1
R2(config-if)#
R2(config-if)#
*Nov 24 00:12:00.723: %PNP-6-PNP_DISCOVERY_STOPPED: PnP Discovery stopped (Config Wizard)
R2(config-if)#no ip summary-address eigrp 1 0.0.0.0 0.0.0.0
R2(config-if)#ip  
*Nov 24 00:15:13.425: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.0.1 (GigabitEthernet0/2) is resync: summary configured
R2(config-if)#ip summ
R2(config-if)#ip summary-address ei
R2(config-if)#ip summary-address eigrp 1 0.0.0.0 0.0.0.0 ?
  leak-map  Allow dynamic prefixes based on the leak-map
  <cr>

R2(config-if)#ip summary-address eigrp 1 0.0.0.0 0.0.0.0 200
%EIGRP: summary-address accepted but distance option deprecated; use summary-metric command for distance.
R2(config-if)#
*Nov 24 00:15:36.925: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.0.1 (GigabitEthernet0/2) is resync: summary configured
R2(config-if)#

Cisco IOS IP Routing: EIGRP Command Reference - S through V [Support] - Cisco

R2(config-if)#
*Nov 24 00:34:05.677: %PNP-6-PNP_DISCOVERY_STOPPED: PnP Discovery stopped (Config Wizard)
R2(config-if)#route
R2(config-if)#exit 
R2(config)#router
R2(config)#router eigr
R2(config)#router eigrp 1 
R2(config-router)#summa
R2(config-router)#summary-metric 0.0.0.0 0.0.0.0 dis
R2(config-router)#summary-metric 0.0.0.0 0.0.0.0 distance 200
R2(config-router)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.1.3 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/3072] via 192.168.1.3, 00:00:34, GigabitEthernet0/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/2
L        192.168.0.2/32 is directly connected, GigabitEthernet0/2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.2/32 is directly connected, GigabitEthernet0/1
D     192.168.2.0/24 [90/3072] via 192.168.1.3, 00:07:23, GigabitEthernet0/1
R2(config-router)#
show ip route

References

tech/network/cisco/eigrp/eigrp/eigrp-default-route/eigrp-default-route.txt · Last modified: 2019/11/24 09:54 by wnoguchi