PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:eigrp:address-family:address-family

Cisco: EIGRP Named Mode (Address Family)

  1. router eigrp 1 form is called classic EIGRP.
  2. router eigrp EIGRP-INSTANCE-NAME called Named Mode.

Lab 1 address-family

Topology

Base Configuration

Common Configuration Snippet

R1

R2

R3

R4

Configuration

Lab 1-1

  • R1
configure terminal
!
router eigrp N-EIGRP-R1
 address-family ipv4 unicast autonomous-system 1
  network 10.1.1.1 0.0.0.0
  network 10.1.2.1 0.0.0.0
 exit-address-family
exit
!
end
  • R2
configure terminal
!
router eigrp N-EIGRP-R2
 address-family ipv4 unicast autonomous-system 1
  network 10.1.2.2 0.0.0.0
  network 10.2.3.2 0.0.0.0
 exit-address-family
exit
!
end
  • R3
configure terminal
!
router eigrp N-EIGRP-R3
 address-family ipv4 unicast autonomous-system 1
  network 10.2.3.3 0.0.0.0
  network 10.3.4.3 0.0.0.0
 exit-address-family
exit
!
end
  • R4
configure terminal
!
router eigrp N-EIGRP-R4
 address-family ipv4 unicast autonomous-system 1
  network 10.3.4.4 0.0.0.0
  network 10.4.4.4 0.0.0.0
 exit-address-family
exit
!
end

Logs

R1 Console Log

Lab 2 passive-interface

Topology

Base Configuration

Common Configuration Snippet

R1

R2

R3

R4

Configuration

Lab 2-1

  • R4
configure terminal
!
router eigrp N-EIGRP-R4
 address-family ipv4 unicast autonomous-system 1
  af-interface Gigabitethernet 0/2
   passive-interface
  exit-af-interface
 exit-address-family
exit
!
end

Lab 2-2

  • R4
configure terminal
!
router eigrp N-EIGRP-R4
 address-family ipv4 unicast autonomous-system 1
  af-interface default
   passive-interface
  exit-af-interface
  af-interface Gigabitethernet 0/1
   no passive-interface
  exit-af-interface
 exit-address-family
exit
!
end

Lab 3

  1. summary-address
  2. hello-interval
  3. hold-time
  4. offset-list

Topology

Base Configuration

Common Configuration Snippet

R1

R2

R3

R4

Configuration

Lab 3-1

  • R3
configure terminal
!
router eigrp N-EIGRP-R3
 address-family ipv4 unicast autonomous-system 1
  af-interface Gigabitethernet 0/1
   summary-address 10.2.0.0 255.255.0.0
  exit-af-interface
  af-interface Gigabitethernet 0/2
   summary-address 10.1.0.0 255.255.0.0
  exit-af-interface
 exit-address-family
exit
!
end

Lab 3-2

default value is

  1. hello-interval 5
  2. hold-timer 15
  • R2
configure terminal
!
router eigrp N-EIGRP-R2
 address-family ipv4 unicast autonomous-system 1
  af-interface Gigabitethernet 0/2
   hello-interval 1
   hold-time 3
  exit-af-interface
 exit-address-family
exit
!
end
R2#show ip eigrp interfaces detail GigabitEthernet 0/2
EIGRP-IPv4 VR(N-EIGRP-R2) Address-Family Interfaces for AS(1)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/2                    1        0/0       0/0         252       0/0          848           0
  Hello-interval is 1, Hold-time is 3
  Split-horizon is enabled
  Next xmit serial <none>
  Packetized sent/expedited: 3/0
  Hello's sent/expedited: 2599/2
  Un/reliable mcasts: 0/3  Un/reliable ucasts: 3/2
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 1  Out-of-sequence rcvd: 1
  Topology-ids on interface - 0 
  Authentication mode is not set
  Topologies advertised on this interface:  base
  Topologies not advertised on this interface:

Lab 3-3 offset-list

EIGRP classic mode calculation assumuption

EIGRP composite cost metric = 256*((K1*Bw) + (K2*Bw)/(256 – Load) + (K3*Delay)*(K5/(Reliability + K4)))
EIGRP composite cost metric = 256*(((K1*Bw) + (K2*Bw)/(256 – Load) + (K3*Delay))*K5/(Reliability + K4)))
EIGRP composite cost metric = 256 * (Bw + Delay) = 256 * (10000000 / 1000000 + 20 / 10) = 256 * (10 + 2) = 2816

not match……………………………………………!!!!!!!!!!!!!!!!!!!!!!!

Wide Metric in EIGRP Named Mode. 64-bit. no named mode eigrp is 32-bit mode Metric version 64bit

Metric = [(K1*Minimum Throughput + {K2*Minimum Throughput} / 256-Load) + (K3*Total Latency) + (K6*Extended Attributes)]* [K5/(K4 + Reliability)]
Metric = [(K1*Minimum Throughput + {K2*Minimum Throughput} / 256-Load) + (K3*Total Latency)]* [K5/(K4 + Reliability)]
Composite Cost Metric = (K1*Minimum Throughput) + (K3*Total Latency)
Composite Cost Metric = 10^7 * 65536 / 10^6 + 65536 * 20000000 / 10^6 = 1966080
Composite Cost Metric = 10^7 * 65536 / 10^6 + 65536 * (35258790) / 10^6 = 2621440
  • R3
configure terminal
!
access-list 1 permit 10.2.5.0 0.0.0.255
!
router eigrp N-EIGRP-R3
 address-family ipv4 unicast autonomous-system 1
  topology base
   offset-list 1 in 1000000 Gigabitethernet 0/2
  exit-af-topology
 exit-address-family
exit
!
end
R4#sh int gig0/1 | i BW
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
R4#sh int gig0/2 | i BW
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
R3#sh ip eigrp topology 10.2.5.0/24
EIGRP-IPv4 VR(N-EIGRP-R3) Topology Entry for AS(1)/ID(10.2.4.3) for 10.2.5.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2966080, RIB is 23172
  Descriptor Blocks:
  10.2.4.4 (GigabitEthernet0/2), from 10.2.4.4, Send flag is 0x0
      Composite metric is (2966080/2310720), route is Internal
      Vector metric:
        Minimum bandwidth is 1000000 Kbit
        Total delay is 35258790 picoseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
        Originating router is 10.2.5.4
R3#sh ip eigrp topology 10.2.5.0/24 | i delay
        Total delay is 20000000 picoseconds
R3(config-router-af-topology)#do sh int gig0/2
GigabitEthernet0/2 is up, line protocol is up 
  Hardware is iGbE, address is fa16.3eae.4a29 (bia fa16.3eae.4a29)
  Internet address is 10.2.4.3/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto Duplex, Auto Speed, link type is auto, media type is RJ45
  output flow-control is unsupported, input flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4370 packets input, 432919 bytes, 0 no buffer
     Received 94 broadcasts (0 IP multicasts)
     14 runts, 0 giants, 0 throttles 
     14 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     6171 packets output, 537037 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
R3(config-router-af-topology)#do sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D        10.1.1.0/24 [90/20480] via 10.1.3.2, 01:57:37, GigabitEthernet0/1
D        10.1.2.0/24 [90/15360] via 10.1.3.2, 01:57:37, GigabitEthernet0/1
D        10.2.5.0/24 [90/15360] via 10.2.4.4, 00:16:05, GigabitEthernet0/2
R3(config-router-af-topology)#do sh ip eigrp topology
EIGRP-IPv4 VR(N-EIGRP-R3) Topology Table for AS(1)/ID(10.2.4.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.3.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/1
P 10.2.5.0/24, 1 successors, FD is 1966080
        via 10.2.4.4 (1966080/1310720), GigabitEthernet0/2
P 10.1.2.0/24, 1 successors, FD is 1966080
        via 10.1.3.2 (1966080/1310720), GigabitEthernet0/1
P 10.2.4.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/2
P 10.1.1.0/24, 1 successors, FD is 2621440
        via 10.1.3.2 (2621440/1966080), GigabitEthernet0/1

R3#sh ip proto | sec eigrp
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 VR(N-EIGRP-R3) Address-Family Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
    Metric rib-scale 128
    Metric version 64bit
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 10.2.4.3
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
      Total Prefix Count: 5
      Total Redist Count: 0

Lab 4

  1. auto-summary
  2. maximum-paths
  3. variance

Topology

Base Configuration

Common Configuration Snippet

R1

R2

R3

R4

R5

R6

R7

R8

R9

Lab 4-1

Configuration

  • R8
configure terminal
!
router eigrp N-EIGRP
 address-family ipv4 unicast autonomous-system 1
  topology base
   auto-summary
  exit-af-topology
 exit-address-family
exit
!
end

Verification

auto-summary verification

Lab 4-2

Configuration

R6(config-if)#do sh int gig0/2 | i DLY
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 20 usec, 
R7(config-if)#do sh int gig0/2 | i DLY
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 30 usec, 
  • R3-R7 (May be unecessary)
clear eigrp address-family ipv4 1 neighbors
  • R2
configure terminal
!
interface GigabitEthernet 0/5
 delay 2
interface GigabitEthernet 0/6
 delay 3
!
router eigrp N-EIGRP
 address-family ipv4 unicast autonomous-system 1
  topology base
   maximum-paths 5
   variance 2
  exit-af-topology
 exit-address-family
exit
!
end

Verification

R2#sh ip eigrp topology 
EIGRP-IPv4 VR(N-EIGRP) Topology Table for AS(1)/ID(10.2.7.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 172.16.8.0/24, 3 successors, FD is 2621440
        via 10.2.3.3 (2621440/1966080), GigabitEthernet0/2
        via 10.2.4.4 (2621440/1966080), GigabitEthernet0/3
        via 10.2.5.5 (2621440/1966080), GigabitEthernet0/4
P 10.5.8.0/24, 1 successors, FD is 1966080
        via 10.2.5.5 (1966080/1310720), GigabitEthernet0/4
P 10.3.8.0/24, 1 successors, FD is 1966080
        via 10.2.3.3 (1966080/1310720), GigabitEthernet0/2
P 10.2.7.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/6
P 10.7.8.0/24, 3 successors, FD is 2621440
        via 10.2.3.3 (2621440/1966080), GigabitEthernet0/2
        via 10.2.4.4 (2621440/1966080), GigabitEthernet0/3
        via 10.2.5.5 (2621440/1966080), GigabitEthernet0/4
P 10.2.5.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/4
P 10.1.2.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/1
P 10.2.6.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/5
P 10.2.4.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/3
P 10.4.8.0/24, 1 successors, FD is 1966080
        via 10.2.4.4 (1966080/1310720), GigabitEthernet0/3
P 10.6.8.0/24, 3 successors, FD is 2621440
        via 10.2.3.3 (2621440/1966080), GigabitEthernet0/2
        via 10.2.4.4 (2621440/1966080), GigabitEthernet0/3
        via 10.2.5.5 (2621440/1966080), GigabitEthernet0/4
P 172.16.9.0/24, 3 successors, FD is 3276800
        via 10.2.3.3 (3276800/2621440), GigabitEthernet0/2
        via 10.2.4.4 (3276800/2621440), GigabitEthernet0/3
        via 10.2.5.5 (3276800/2621440), GigabitEthernet0/4
P 10.2.3.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/2
P 10.1.1.0/24, 1 successors, FD is 1966080
        via 10.1.2.1 (1966080/1310720), GigabitEthernet0/1

R2#sh ip protocols | section eigrp
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 VR(N-EIGRP) Address-Family Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
    Metric rib-scale 128
    Metric version 64bit
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 10.2.7.2
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
      Total Prefix Count: 14
      Total Redist Count: 0
R2#sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
D        10.1.1.0/24 [90/15360] via 10.1.2.1, 00:07:27, GigabitEthernet0/1
D        10.3.8.0/24 [90/15360] via 10.2.3.3, 00:01:31, GigabitEthernet0/2
D        10.4.8.0/24 [90/15360] via 10.2.4.4, 00:01:31, GigabitEthernet0/3
D        10.5.8.0/24 [90/15360] via 10.2.5.5, 00:01:31, GigabitEthernet0/4
D        10.6.8.0/24 [90/20480] via 10.2.5.5, 00:01:28, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:01:28, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:01:28, GigabitEthernet0/2
D        10.7.8.0/24 [90/20480] via 10.2.5.5, 00:01:28, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:01:28, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:01:28, GigabitEthernet0/2
      172.16.0.0/24 is subnetted, 2 subnets
D        172.16.8.0 [90/20480] via 10.2.5.5, 00:01:28, GigabitEthernet0/4
                    [90/20480] via 10.2.4.4, 00:01:28, GigabitEthernet0/3
                    [90/20480] via 10.2.3.3, 00:01:28, GigabitEthernet0/2
D        172.16.9.0 [90/25600] via 10.2.5.5, 00:01:28, GigabitEthernet0/4
                    [90/25600] via 10.2.4.4, 00:01:28, GigabitEthernet0/3
                    [90/25600] via 10.2.3.3, 00:01:28, GigabitEthernet0/2
R2#

default is equal cost load balancing.

after delay configured

R2(config-router-af-topology)#do sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
D        10.1.1.0/24 [90/15360] via 10.1.2.1, 00:03:24, GigabitEthernet0/1
D        10.3.8.0/24 [90/15360] via 10.2.3.3, 00:00:31, GigabitEthernet0/2
D        10.4.8.0/24 [90/15360] via 10.2.4.4, 00:00:31, GigabitEthernet0/3
D        10.5.8.0/24 [90/15360] via 10.2.5.5, 00:00:31, GigabitEthernet0/4
D        10.6.8.0/24 [90/20480] via 10.2.6.6, 00:00:31, GigabitEthernet0/5
                     [90/20480] via 10.2.5.5, 00:00:31, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:00:31, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:31, GigabitEthernet0/2
D        10.7.8.0/24 [90/20480] via 10.2.5.5, 00:00:31, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:00:31, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:31, GigabitEthernet0/2
      172.16.0.0/24 is subnetted, 2 subnets
D        172.16.8.0 [90/20480] via 10.2.5.5, 00:00:31, GigabitEthernet0/4
                    [90/20480] via 10.2.4.4, 00:00:31, GigabitEthernet0/3
                    [90/20480] via 10.2.3.3, 00:00:31, GigabitEthernet0/2
D        172.16.9.0 [90/25600] via 10.2.5.5, 00:00:31, GigabitEthernet0/4
                    [90/25600] via 10.2.4.4, 00:00:31, GigabitEthernet0/3
                    [90/25600] via 10.2.3.3, 00:00:31, GigabitEthernet0/2
R2(config-router-af-topology)#do sh ip eigrp topology
EIGRP-IPv4 VR(N-EIGRP) Topology Table for AS(1)/ID(10.2.7.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 172.16.8.0/24, 3 successors, FD is 2621440
        via 10.2.3.3 (2621440/1966080), GigabitEthernet0/2
        via 10.2.4.4 (2621440/1966080), GigabitEthernet0/3
        via 10.2.5.5 (2621440/1966080), GigabitEthernet0/4
        via 10.2.7.7 (3932160/1966080), GigabitEthernet0/6
        via 10.2.6.6 (3276800/1966080), GigabitEthernet0/5
P 10.5.8.0/24, 1 successors, FD is 1966080
        via 10.2.5.5 (1966080/1310720), GigabitEthernet0/4
P 10.3.8.0/24, 1 successors, FD is 1966080
        via 10.2.3.3 (1966080/1310720), GigabitEthernet0/2
P 10.2.7.0/24, 1 successors, FD is 2621440
        via Connected, GigabitEthernet0/6
P 10.7.8.0/24, 3 successors, FD is 2621440
        via 10.2.3.3 (2621440/1966080), GigabitEthernet0/2
        via 10.2.4.4 (2621440/1966080), GigabitEthernet0/3
        via 10.2.5.5 (2621440/1966080), GigabitEthernet0/4
        via 10.2.7.7 (3276800/1310720), GigabitEthernet0/6
        via 10.2.6.6 (3276800/1966080), GigabitEthernet0/5
P 10.2.5.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/4
P 10.1.2.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/1
P 10.2.6.0/24, 1 successors, FD is 1966080
        via Connected, GigabitEthernet0/5
P 10.2.4.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/3
P 10.4.8.0/24, 1 successors, FD is 1966080
        via 10.2.4.4 (1966080/1310720), GigabitEthernet0/3
P 10.6.8.0/24, 4 successors, FD is 1966080
        via 10.2.6.6 (2621440/1310720), GigabitEthernet0/5
P 172.16.9.0/24, 3 successors, FD is 3276800
        via 10.2.3.3 (3276800/2621440), GigabitEthernet0/2
        via 10.2.4.4 (3276800/2621440), GigabitEthernet0/3
        via 10.2.5.5 (3276800/2621440), GigabitEthernet0/4
        via 10.2.7.7 (4587520/2621440), GigabitEthernet0/6
        via 10.2.6.6 (3932160/2621440), GigabitEthernet0/5
P 10.2.3.0/24, 1 successors, FD is 1310720
        via Connected, GigabitEthernet0/2
P 10.1.1.0/24, 1 successors, FD is 1966080
        via 10.1.2.1 (1966080/1310720), GigabitEthernet0/1

R2(config-router-af-topology)#

3 successor routes selected for 172.16.9.0/24. 10.2.7.7, 10.2.6.6 is feasible successor.

configure variance.

R2(config-router-af-topology)#variance 2
R2(config-router-af-topology)#do sh ip ro eigrp      
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
D        10.1.1.0/24 [90/15360] via 10.1.2.1, 00:00:04, GigabitEthernet0/1
D        10.3.8.0/24 [90/15360] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
D        10.4.8.0/24 [90/15360] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
D        10.5.8.0/24 [90/15360] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
D        10.6.8.0/24 [90/20480] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                     [90/20480] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
D        10.7.8.0/24 [90/25600] via 10.2.7.7, 00:00:04, GigabitEthernet0/6
                     [90/20480] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
      172.16.0.0/24 is subnetted, 2 subnets
D        172.16.8.0 [90/25600] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                    [90/20480] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                    [90/20480] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                    [90/20480] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
D        172.16.9.0 [90/30720] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                    [90/25600] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                    [90/25600] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                    [90/25600] via 10.2.3.3, 00:00:04, GigabitEthernet0/2

5 routes selected for 172.16.9.0/24. limited because maximum-paths is 4.

configure maximum-paths.

R2(config-router-af-topology)#maximum-paths 5
R2(config-router-af-topology)#do sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
D        10.1.1.0/24 [90/15360] via 10.1.2.1, 00:00:04, GigabitEthernet0/1
D        10.3.8.0/24 [90/15360] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
D        10.4.8.0/24 [90/15360] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
D        10.5.8.0/24 [90/15360] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
D        10.6.8.0/24 [90/30720] via 10.2.7.7, 00:00:04, GigabitEthernet0/6
                     [90/20480] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                     [90/20480] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
D        10.7.8.0/24 [90/25600] via 10.2.7.7, 00:00:04, GigabitEthernet0/6
                     [90/25600] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                     [90/20480] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                     [90/20480] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
      172.16.0.0/24 is subnetted, 2 subnets
D        172.16.8.0 [90/30720] via 10.2.7.7, 00:00:04, GigabitEthernet0/6
                    [90/25600] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                    [90/20480] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                    [90/20480] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                    [90/20480] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
D        172.16.9.0 [90/35840] via 10.2.7.7, 00:00:04, GigabitEthernet0/6
                    [90/30720] via 10.2.6.6, 00:00:04, GigabitEthernet0/5
                    [90/25600] via 10.2.5.5, 00:00:04, GigabitEthernet0/4
                    [90/25600] via 10.2.4.4, 00:00:04, GigabitEthernet0/3
                    [90/25600] via 10.2.3.3, 00:00:04, GigabitEthernet0/2
R2(config-router-af-topology)#maximum-paths 2  
R2(config-router-af-topology)#do sh ip ro eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
D        10.1.1.0/24 [90/15360] via 10.1.2.1, 00:00:02, GigabitEthernet0/1
D        10.3.8.0/24 [90/15360] via 10.2.3.3, 00:00:02, GigabitEthernet0/2
D        10.4.8.0/24 [90/15360] via 10.2.4.4, 00:00:02, GigabitEthernet0/3
D        10.5.8.0/24 [90/15360] via 10.2.5.5, 00:00:02, GigabitEthernet0/4
D        10.6.8.0/24 [90/20480] via 10.2.6.6, 00:00:02, GigabitEthernet0/5
                     [90/20480] via 10.2.3.3, 00:00:02, GigabitEthernet0/2
D        10.7.8.0/24 [90/20480] via 10.2.4.4, 00:00:02, GigabitEthernet0/3
                     [90/20480] via 10.2.3.3, 00:00:02, GigabitEthernet0/2
      172.16.0.0/24 is subnetted, 2 subnets
D        172.16.8.0 [90/20480] via 10.2.4.4, 00:00:02, GigabitEthernet0/3
                    [90/20480] via 10.2.3.3, 00:00:02, GigabitEthernet0/2
D        172.16.9.0 [90/25600] via 10.2.4.4, 00:00:02, GigabitEthernet0/3
                    [90/25600] via 10.2.3.3, 00:00:02, GigabitEthernet0/2
R2(config-router-af-topology)#

References

tech/network/cisco/eigrp/address-family/address-family.txt · Last modified: 2019/12/16 15:28 by wnoguchi