User Tools

Site Tools


tech:network:cisco:dhcp-redundancy:dhcp-redundancy

DHCP Redundancy

  • R1
configure terminal
!
hostname R1
!
no ip domain-lookup
line console 0
 exec-timeout 0 0
 logging synchronous
exit
!
interface GigabitEthernet 0/0
 ip address 192.168.0.1 255.255.255.0
 no shutdown
exit
!
interface GigabitEthernet 0/1
 ip address 192.168.1.1 255.255.255.0
 no shutdown
exit
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.0.1 192.168.0.2
ip dhcp excluded-address 192.168.0.121 192.168.0.255
!
ip dhcp pool TEST
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.254
 lease infinite
exit
!
end
  • R2
configure terminal
!
hostname R2
!
no ip domain-lookup
line console 0
 exec-timeout 0 0
 logging synchronous
exit
!
interface GigabitEthernet 0/0
 ip address 192.168.0.2 255.255.255.0
 no shutdown
exit
!
interface GigabitEthernet 0/1
 ip address 192.168.1.2 255.255.255.0
 no shutdown
exit
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.0.1 192.168.0.120
ip dhcp excluded-address 192.168.0.241 192.168.0.255
!
ip dhcp pool TEST
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.254
 lease infinite
exit
!
end
configure terminal
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.0.1 192.168.0.2
ip dhcp excluded-address 192.168.0.254
!
ip dhcp pool TEST
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.254
 lease infinite
exit
!
end
ip dhcp
save
ip dhcp
save
ip dhcp
save
ip dhcp
save
ip 192.168.1.105 255.255.255.0 192.168.1.254
save

ip address duplicate check may worked.

Ciscoルータ、Catalyst:DHCPサーバの冗長設定で注意すべき点

tech/network/cisco/dhcp-redundancy/dhcp-redundancy.txt · Last modified: 2019/07/20 08:18 by wnoguchi