PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:bgp:bgp:route-reflector:route-reflector

BGP: Route Reflector

Project name: ccna-bgp9-route-reflector

Issued BGP Configuration

  1. IGP: OSPF
  2. BGP: peering policy: do not advertise eBGP link.

Base Configuration

  • R1
en
conf t
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int gig0/0
ip address 21.0.0.1 255.255.255.0
no shut
exit
int gig0/1
ip address 31.0.0.1 255.255.255.0
no shut
exit
int gig0/2
ip address 41.0.0.1 255.255.255.0
no shut
exit
!
router bgp 10
neighbor 21.0.0.2 remote-as 10
neighbor 31.0.0.3 remote-as 10
neighbor 41.0.0.4 remote-as 10
exit
!
router ospf 1
network 21.0.0.1 0.0.0.0 area 0
network 31.0.0.1 0.0.0.0 area 0
network 41.0.0.1 0.0.0.0 area 0
exit
!
end
wr
  • R2
en
conf t
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int gig0/0
ip address 52.0.0.2 255.255.255.0
no shut
exit
int gig0/1
ip address 21.0.0.2 255.255.255.0
no shut
exit
!
router bgp 10
neighbor 21.0.0.1 remote-as 10
neighbor 52.0.0.5 remote-as 20
neighbor 21.0.0.1 next-hop-self
exit
!
router ospf 1
network 21.0.0.2 0.0.0.0 area 0
exit
!
end
wr
  • R3
en
conf t
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int gig0/1
ip address 31.0.0.3 255.255.255.0
no shut
exit
int gig0/2
ip address 1.0.0.3 255.0.0.0
no shut
exit
!
router bgp 10
neighbor 31.0.0.1 remote-as 10
neighbor 31.0.0.1 next-hop-self
network 1.0.0.0 mask 255.0.0.0
exit
!
router ospf 1
network 31.0.0.3 0.0.0.0 area 0
exit
!
end
wr
  • R4
en
conf t
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int gig0/0
ip address 64.0.0.4 255.255.255.0
no shut
exit
int gig0/1
ip address 41.0.0.4 255.255.255.0
no shut
exit
!
router bgp 10
neighbor 41.0.0.1 remote-as 10
neighbor 64.0.0.6 remote-as 30
neighbor 41.0.0.1 next-hop-self
exit
!
router ospf 1
network 41.0.0.4 0.0.0.0 area 0
exit
!
end
wr
  • R5
en
conf t
!
hostname R5
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int gig0/1
ip address 52.0.0.5 255.255.255.0
no shut
exit
int gig0/2
ip address 2.0.0.5 255.0.0.0
no shut
exit
!
router bgp 20
neighbor 52.0.0.2 remote-as 10
network 2.0.0.0 mask 255.0.0.0
exit
!
end
wr
  • R6
en
conf t
!
hostname R6
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
!
int gig0/1
ip address 64.0.0.6 255.255.255.0
no shut
exit
int gig0/2
ip address 3.0.0.6 255.0.0.0
no shut
exit
!
router bgp 30
neighbor 64.0.0.4 remote-as 10
network 3.0.0.0 mask 255.0.0.0
exit
!
end
wr
  • PC1
ip 2.0.0.101 255.0.0.0 2.0.0.5
save
  • PC2
ip 1.0.0.102 255.0.0.0 1.0.0.3
save
  • PC3
ip 3.0.0.103 255.0.0.0 3.0.0.6
save

Basic Configuration Verification

  • PC-1
VPCS> ping 2.0.0.5
84 bytes from 2.0.0.5 icmp_seq=1 ttl=255 time=4.049 ms
84 bytes from 2.0.0.5 icmp_seq=2 ttl=255 time=1.464 ms
84 bytes from 2.0.0.5 icmp_seq=3 ttl=255 time=1.395 ms
84 bytes from 2.0.0.5 icmp_seq=4 ttl=255 time=1.320 ms
84 bytes from 2.0.0.5 icmp_seq=5 ttl=255 time=1.704 ms

VPCS> ping 52.0.0.2
84 bytes from 52.0.0.2 icmp_seq=1 ttl=254 time=4.201 ms
84 bytes from 52.0.0.2 icmp_seq=2 ttl=254 time=3.083 ms
84 bytes from 52.0.0.2 icmp_seq=3 ttl=254 time=2.890 ms
84 bytes from 52.0.0.2 icmp_seq=4 ttl=254 time=3.130 ms
84 bytes from 52.0.0.2 icmp_seq=5 ttl=254 time=4.110 ms
  • PC-2
VPCS> ping 1.0.0.3
84 bytes from 1.0.0.3 icmp_seq=1 ttl=255 time=3.232 ms
84 bytes from 1.0.0.3 icmp_seq=2 ttl=255 time=2.210 ms
84 bytes from 1.0.0.3 icmp_seq=3 ttl=255 time=2.476 ms
84 bytes from 1.0.0.3 icmp_seq=4 ttl=255 time=1.429 ms
84 bytes from 1.0.0.3 icmp_seq=5 ttl=255 time=1.532 ms
  • PC-3
VPCS> ping 3.0.0.6
84 bytes from 3.0.0.6 icmp_seq=1 ttl=255 time=3.888 ms
84 bytes from 3.0.0.6 icmp_seq=2 ttl=255 time=1.692 ms
84 bytes from 3.0.0.6 icmp_seq=3 ttl=255 time=4.225 ms
84 bytes from 3.0.0.6 icmp_seq=4 ttl=255 time=1.867 ms
84 bytes from 3.0.0.6 icmp_seq=5 ttl=255 time=2.346 ms

VPCS> ping 64.0.0.4
84 bytes from 64.0.0.4 icmp_seq=1 ttl=254 time=4.134 ms
84 bytes from 64.0.0.4 icmp_seq=2 ttl=254 time=2.599 ms
84 bytes from 64.0.0.4 icmp_seq=3 ttl=254 time=2.045 ms
84 bytes from 64.0.0.4 icmp_seq=4 ttl=254 time=2.143 ms
84 bytes from 64.0.0.4 icmp_seq=5 ttl=254 time=2.424 ms
R1#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:04:57
  BGP state = Established, up for 00:02:55
  BGP state = Established, up for 00:04:25
R1#ping 21.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 21.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
R1#ping 31.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 31.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/3 ms
R1#ping 41.0.0.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 41.0.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R1#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     1.0.0.0/8 [200/0] via 31.0.0.3, 00:11:24
B     2.0.0.0/8 [200/0] via 21.0.0.2, 00:11:23
B     3.0.0.0/8 [200/0] via 41.0.0.4, 00:11:06
R1#sh ip bgp
BGP table version is 4, local router ID is 41.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.0.0.0          31.0.0.3                 0    100      0 i
 *>i 2.0.0.0          21.0.0.2                 0    100      0 20 i
 *>i 3.0.0.0          41.0.0.4                 0    100      0 30 i
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     1.0.0.0/8 [200/0] via 31.0.0.3, 00:16:38
B     2.0.0.0/8 [200/0] via 21.0.0.2, 00:16:37
B     3.0.0.0/8 [200/0] via 41.0.0.4, 00:16:20
      21.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        21.0.0.0/24 is directly connected, GigabitEthernet0/0
L        21.0.0.1/32 is directly connected, GigabitEthernet0/0
      31.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        31.0.0.0/24 is directly connected, GigabitEthernet0/1
L        31.0.0.1/32 is directly connected, GigabitEthernet0/1
      41.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        41.0.0.0/24 is directly connected, GigabitEthernet0/2
L        41.0.0.1/32 is directly connected, GigabitEthernet0/2
R2#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:04:57
  BGP state = Established, up for 00:04:10
R2#ping 52.0.0.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 52.0.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/6 ms
R2#ping 31.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 31.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/9 ms
R2#ping 41.0.0.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 41.0.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/9 ms
R2#sh ip ro 31.0.0.3
Routing entry for 31.0.0.0/24
  Known via "ospf 1", distance 110, metric 2, type intra area
  Last update from 21.0.0.1 on GigabitEthernet0/1, 00:10:24 ago
  Routing Descriptor Blocks:
  * 21.0.0.1, from 41.0.0.1, 00:10:24 ago, via GigabitEthernet0/1
      Route metric is 2, traffic share count is 1
R2#sh ip ro 41.0.0.4
Routing entry for 41.0.0.0/24
  Known via "ospf 1", distance 110, metric 2, type intra area
  Last update from 21.0.0.1 on GigabitEthernet0/1, 00:10:09 ago
  Routing Descriptor Blocks:
  * 21.0.0.1, from 64.0.0.4, 00:10:09 ago, via GigabitEthernet0/1
      Route metric is 2, traffic share count is 1
R2#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     2.0.0.0/8 [20/0] via 52.0.0.5, 00:11:25
R2#sh ip bgp
BGP table version is 2, local router ID is 52.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2.0.0.0          52.0.0.5                 0             0 20 i
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     2.0.0.0/8 [20/0] via 52.0.0.5, 00:16:43
      21.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        21.0.0.0/24 is directly connected, GigabitEthernet0/1
L        21.0.0.2/32 is directly connected, GigabitEthernet0/1
      31.0.0.0/24 is subnetted, 1 subnets
O        31.0.0.0 [110/2] via 21.0.0.1, 00:17:13, GigabitEthernet0/1
      41.0.0.0/24 is subnetted, 1 subnets
O        41.0.0.0 [110/2] via 21.0.0.1, 00:16:53, GigabitEthernet0/1
      52.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        52.0.0.0/24 is directly connected, GigabitEthernet0/0
L        52.0.0.2/32 is directly connected, GigabitEthernet0/0
R3#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:02:55
R3#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R3#sh ip bgp
BGP table version is 2, local router ID is 31.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          0.0.0.0                  0         32768 i
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, GigabitEthernet0/2
L        1.0.0.3/32 is directly connected, GigabitEthernet0/2
      21.0.0.0/24 is subnetted, 1 subnets
O        21.0.0.0 [110/2] via 31.0.0.1, 00:17:05, GigabitEthernet0/1
      31.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        31.0.0.0/24 is directly connected, GigabitEthernet0/1
L        31.0.0.3/32 is directly connected, GigabitEthernet0/1
      41.0.0.0/24 is subnetted, 1 subnets
O        41.0.0.0 [110/2] via 31.0.0.1, 00:16:55, GigabitEthernet0/1
R4#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:04:25
  BGP state = Established, up for 00:00:37
R4#ping 64.0.0.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 64.0.0.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/5 ms
R4#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     3.0.0.0/8 [20/0] via 64.0.0.6, 00:11:09
R4#sh ip bgp
BGP table version is 2, local router ID is 64.0.0.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  3.0.0.0          64.0.0.6                 0             0 30 i
R4#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     3.0.0.0/8 [20/0] via 64.0.0.6, 00:16:31
      21.0.0.0/24 is subnetted, 1 subnets
O        21.0.0.0 [110/2] via 41.0.0.1, 00:17:00, GigabitEthernet0/1
      31.0.0.0/24 is subnetted, 1 subnets
O        31.0.0.0 [110/2] via 41.0.0.1, 00:17:00, GigabitEthernet0/1
      41.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        41.0.0.0/24 is directly connected, GigabitEthernet0/1
L        41.0.0.4/32 is directly connected, GigabitEthernet0/1
      64.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        64.0.0.0/24 is directly connected, GigabitEthernet0/0
L        64.0.0.4/32 is directly connected, GigabitEthernet0/0
R5#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:04:11
R5#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R5#sh ip bgp
BGP table version is 2, local router ID is 52.0.0.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2.0.0.0          0.0.0.0                  0         32768 i
R5#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, GigabitEthernet0/2
L        2.0.0.5/32 is directly connected, GigabitEthernet0/2
      52.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        52.0.0.0/24 is directly connected, GigabitEthernet0/1
L        52.0.0.5/32 is directly connected, GigabitEthernet0/1
R6#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:00:37
R6#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R6#sh ip bgp
BGP table version is 2, local router ID is 64.0.0.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  3.0.0.0          0.0.0.0                  0         32768 i
R6#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, GigabitEthernet0/2
L        3.0.0.6/32 is directly connected, GigabitEthernet0/2
      64.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        64.0.0.0/24 is directly connected, GigabitEthernet0/1
L        64.0.0.6/32 is directly connected, GigabitEthernet0/1

The Issue

  • PC-2
PC-2> ping 2.0.0.101
*1.0.0.3 icmp_seq=1 ttl=255 time=2.371 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=2 ttl=255 time=2.597 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=3 ttl=255 time=2.325 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=4 ttl=255 time=2.886 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=5 ttl=255 time=2.608 ms (ICMP type:3, code:1, Destination host unreachable)

PC-2> ping 3.0.0.103
*1.0.0.3 icmp_seq=1 ttl=255 time=2.714 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=2 ttl=255 time=2.475 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=3 ttl=255 time=2.874 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=4 ttl=255 time=2.732 ms (ICMP type:3, code:1, Destination host unreachable)
*1.0.0.3 icmp_seq=5 ttl=255 time=3.071 ms (ICMP type:3, code:1, Destination host unreachable)
  • R3
R3#sh ip bgp
BGP table version is 2, local router ID is 31.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          0.0.0.0                  0         32768 i
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, GigabitEthernet0/2
L        1.0.0.3/32 is directly connected, GigabitEthernet0/2
      21.0.0.0/24 is subnetted, 1 subnets
O        21.0.0.0 [110/2] via 31.0.0.1, 00:22:51, GigabitEthernet0/1
      31.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        31.0.0.0/24 is directly connected, GigabitEthernet0/1
L        31.0.0.3/32 is directly connected, GigabitEthernet0/1
      41.0.0.0/24 is subnetted, 1 subnets
O        41.0.0.0 [110/2] via 31.0.0.1, 00:22:41, GigabitEthernet0/1

BGP route not advertised properly because BGP split horizon issue.

Route Reflector Configuration

  • R1
conf t
!
router bgp 10
neighbor 21.0.0.2 route-reflector-client
neighbor 31.0.0.3 route-reflector-client
neighbor 41.0.0.4 route-reflector-client
exit
!
end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 10
R1(config-router)#neigh
R1(config-router)#neighbor 21.0.0.2 route-refle
R1(config-router)#neighbor 21.0.0.2 route-reflector-client
R1(config-router)#neighbor 21.0.0.2 route-reflector-client
*Dec  1 04:08:52.396: %BGP-5-ADJCHANGE: neighbor 21.0.0.2 Down RR client config change
*Dec  1 04:08:52.397: %BGP_SESSION-5-ADJCHANGE: neighbor 21.0.0.2 IPv4 Unicast topology base removed from session  RR client config change
*Dec  1 04:08:52.645: %BGP-5-ADJCHANGE: neighbor 21.0.0.2 Up
R1(config-router)#neighbor 31.0.0.3 route-reflector-client
R1(config-router)#neighbor 31.0.0.3 route-reflector-client
*Dec  1 04:09:09.982: %BGP-5-ADJCHANGE: neighbor 31.0.0.3 Down RR client config change
*Dec  1 04:09:09.982: %BGP_SESSION-5-ADJCHANGE: neighbor 31.0.0.3 IPv4 Unicast topology base removed from session  RR client config change
*Dec  1 04:09:10.050: %BGP-5-ADJCHANGE: neighbor 31.0.0.3 Up
R1(config-router)#neighbor 41.0.0.4 route-reflector-client
R1(config-router)#
*Dec  1 04:09:20.244: %BGP-5-ADJCHANGE: neighbor 41.0.0.4 Down RR client config change
*Dec  1 04:09:20.244: %BGP_SESSION-5-ADJCHANGE: neighbor 41.0.0.4 IPv4 Unicast topology base removed from session  RR client config change
*Dec  1 04:09:20.289: %BGP-5-ADJCHANGE: neighbor 41.0.0.4 Up
R1(config-router)#exit
R1(config)#end
R1#
*Dec  1 04:09:28.754: %SYS-5-CONFIG_I: Configured from console by console
R1#
R1#sh ip bgp
BGP table version is 10, local router ID is 41.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.0.0.0          31.0.0.3                 0    100      0 i
 *>i 2.0.0.0          21.0.0.2                 0    100      0 20 i
 *>i 3.0.0.0          41.0.0.4                 0    100      0 30 i
R2#sh ip bgp
BGP table version is 10, local router ID is 52.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.0.0.0          31.0.0.3                 0    100      0 i
 *>  2.0.0.0          52.0.0.5                 0             0 20 i
 *>i 3.0.0.0          41.0.0.4                 0    100      0 30 i
R3#sh ip bgp
BGP table version is 10, local router ID is 31.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          0.0.0.0                  0         32768 i
 *>i 2.0.0.0          21.0.0.2                 0    100      0 20 i
 *>i 3.0.0.0          41.0.0.4                 0    100      0 30 i
R3#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     2.0.0.0/8 [200/0] via 21.0.0.2, 00:01:43
B     3.0.0.0/8 [200/0] via 41.0.0.4, 00:01:33
R4#sh ip bgp
BGP table version is 10, local router ID is 64.0.0.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.0.0.0          31.0.0.3                 0    100      0 i
 *>i 2.0.0.0          21.0.0.2                 0    100      0 20 i
 *>  3.0.0.0          64.0.0.6                 0             0 30 i
R5#sh ip bgp
BGP table version is 4, local router ID is 52.0.0.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          52.0.0.2                               0 10 i
 *>  2.0.0.0          0.0.0.0                  0         32768 i
 *>  3.0.0.0          52.0.0.2                               0 10 30 i
R6#sh ip bgp
BGP table version is 4, local router ID is 64.0.0.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          64.0.0.4                               0 10 i
 *>  2.0.0.0          64.0.0.4                               0 10 20 i
 *>  3.0.0.0          0.0.0.0                  0         32768 i
PC-2> ping 2.0.0.101
2.0.0.101 icmp_seq=1 timeout
2.0.0.101 icmp_seq=2 timeout
84 bytes from 2.0.0.101 icmp_seq=3 ttl=60 time=6.539 ms
84 bytes from 2.0.0.101 icmp_seq=4 ttl=60 time=6.087 ms
84 bytes from 2.0.0.101 icmp_seq=5 ttl=60 time=5.252 ms

PC-2> ping 3.0.0.103
3.0.0.103 icmp_seq=1 timeout
3.0.0.103 icmp_seq=2 timeout
84 bytes from 3.0.0.103 icmp_seq=3 ttl=60 time=4.755 ms
84 bytes from 3.0.0.103 icmp_seq=4 ttl=60 time=5.233 ms
84 bytes from 3.0.0.103 icmp_seq=5 ttl=60 time=8.023 ms
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 10
R1(config-router)#bgp cluster
R1(config-router)#bgp cluster-id ?
  <1-4294967294>  Route-Reflector Cluster-id as 32 bit quantity
  A.B.C.D         Route-Reflector Cluster-id in IP address format

R1(config-router)#bgp cluster-id 1.1.1.1
R1(config-router)#^Z
R1#
*Dec  1 06:37:41.051: %SYS-5-CONFIG_I: Configured from console by console
R1#sh ip proto | section bgp
Routing Protocol is "bgp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Route Reflector for address family IPv4 Unicast with the cluster-id 1.1.1.1, 3 clients
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Neighbor(s):
    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
    21.0.0.2
    31.0.0.3
     41.0.0.4
    41.0.0.4
  Maximum path: 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    21.0.0.2             200      00:05:08
    31.0.0.3             200      00:04:54
    41.0.0.4             200      00:04:40
  Distance: external 20 internal 200 local 200

References

tech/network/cisco/bgp/bgp/route-reflector/route-reflector.txt · Last modified: 2018/12/01 15:59 by wnoguchi