User Tools

Site Tools


tech:network:cisco:bgp:bgp:route-flap-dampening:route-flap-dampening

BGP: route flap dampening

Topology

IP

Project name: ccna-bgp30-route-flap-dampening

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 1.1.0.1 255.255.0.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 10.1.2.1 255.255.255.0
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface GigabitEthernet 0/0
ip address 100.2.3.2 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/1
ip address 10.1.2.2 255.255.255.0
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface GigabitEthernet 0/0
ip address 10.3.4.3 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/1
ip address 100.2.3.3 255.255.255.0
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 4.4.0.4 255.255.0.0
no shutdown
exit
interface GigabitEthernet 0/1
ip address 10.3.4.4 255.255.255.0
no shutdown
exit
!
end
write

Verification

show ip interface brief
show ip interface | include Internet address
R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         10.1.2.1        YES NVRAM  up                    up      
GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down    
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down    
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down    
Loopback1                  1.1.0.1         YES NVRAM  up                    up      
R1#show ip interface | include Internet address
  Internet address is 10.1.2.1/24
  Internet address is 1.1.0.1/16

Basic BGP Configuration

  • R1
configure terminal
!
router bgp 10
network 1.1.0.0 mask 255.255.0.0
neighbor 10.1.2.2 remote-as 10
exit
!
end
  • R2
configure terminal
!
router bgp 10
neighbor 10.1.2.1 remote-as 10
neighbor 10.1.2.1 next-hop-self
neighbor 100.2.3.3 remote-as 20
exit
!
end
  • R3
configure terminal
!
router bgp 20
neighbor 100.2.3.2 remote-as 10
neighbor 10.3.4.4 remote-as 20
neighbor 10.3.4.4 next-hop-self
exit
!
end
  • R4
configure terminal
!
router bgp 20
network 4.4.0.0 mask 255.255.0.0
neighbor 10.3.4.3 remote-as 20
exit
!
end

Verification

show ip bgp neighbor | include BGP state
show ip bgp
ping 4.4.0.4 source 1.1.0.1
R1#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:00:22
R1#sh ip bgp
BGP table version is 3, local router ID is 1.1.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.1.0.0/16       0.0.0.0                  0         32768 i
 *>i 4.4.0.0/16       10.1.2.2                 0    100      0 20 i
R1#ping 4.4.0.4 source 1.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.0.4, timeout is 2 seconds:
Packet sent with a source address of 1.1.0.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/8 ms
R2#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:00:22
  BGP state = Established, up for 00:00:17
R2#sh ip bgp
BGP table version is 3, local router ID is 100.2.3.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.1.0.0/16       10.1.2.1                 0    100      0 i
 *>  4.4.0.0/16       100.2.3.3                              0 20 i
R3#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:00:13
  BGP state = Established, up for 00:00:17
R3#sh ip bgp
BGP table version is 3, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.1.0.0/16       100.2.3.2                              0 10 i
 *>i 4.4.0.0/16       10.3.4.4                 0    100      0 i
R4#sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:00:13
R4#sh ip bgp
BGP table version is 3, local router ID is 4.4.0.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.1.0.0/16       10.3.4.3                 0    100      0 10 i
 *>  4.4.0.0/16       0.0.0.0                  0         32768 i

bgp dampening Configuration

configure terminal
!
router bgp 20
! incorrect
!bgp dampening 30 1500 3000 120 
! correct
bgp dampening 3 400 800 9
exit
!
end

Verification

show ip bgp dampening flap-statistics
show ip bgp 1.1.0.0
R3(config-router)#bgp dampening ?            
  <1-45>     Half-life time for the penalty
  route-map  Route-map to specify criteria for dampening
  <cr>

R3(config-router)#bgp dampening 30 ?
  <1-20000>  Value to start reusing a route
  <cr>

R3(config-router)#bgp dampening 30 1500 ?
  <1-20000>  Value to start suppressing a route

R3(config-router)#bgp dampening 30 1500 3000 ?
  <1-255>  Maximum duration to suppress a stable route

R3(config-router)#bgp dampening 30 1500 3000 120 ?
  <cr>

R3(config-router)#bgp dampening 30 1500 3000 120 
% Maximum penalty is more than allowed maximum
R3(config-router)#
*Feb 16 23:55:53.101: %BGP-5-DAMPENING_HIGH_MAX_PENALTY: Maximum penalty (24000) is more than allowed maximum (20000). Dampening is OFF 
R3#show ip bgp dampening flap-statistics 
% dampening not enabled for base
R3(config-router)#no bgp dampening 30 1500 20000 120
R3(config-router)#bgp dampening 30 1500 20000 120   
% Maximum penalty is more than allowed maximum
R3(config-router)#do sh run | s bgp
router bgp 20
 bgp log-neighbor-changes
 neighbor 10.3.4.4 remote-as 20
 neighbor 10.3.4.4 next-hop-self
 neighbor 100.2.3.2 remote-as 10
R3(config-router)#no bgp dampening 30 1500 20000 120
R3(config-router)#^Z
R3#show ip bgp dampening flap-statistics 
*Feb 16 23:59:12.100: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip bgp dampening flap-statistics 
% dampening not enabled for base
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router bgp 20
R3(config-router)#bgp dampe
R3(config-router)#bgp dampening 3 400 800 9
R3(config-router)#no bgp dampening 3 400 800 9
R3(config-router)#do show ip bgp dampening flap-statistics
% dampening not enabled for base
R3(config-router)#bgp damep                               
R3(config-router)#bgp dampe
R3(config-router)#bgp dampening ? 
  <1-45>     Half-life time for the penalty
  route-map  Route-map to specify criteria for dampening
  <cr>

R3(config-router)#bgp dampening 3 400 800 9
R3(config-router)#^Z
R3#
*Feb 17 05:18:45.536: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip bgp dampening flap-statistics 
% dampening reconfiguration in progress
R3#show ip bgp dampening flap-statistics 
R1(config-if)#no shut
R1(config-if)#
*Feb 17 05:20:03.841: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
*Feb 17 05:20:04.842: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#
*Feb 17 05:20:07.040: %BGP-5-NBR_RESET: Neighbor 10.1.2.2 active reset (BGP Notification sent)
*Feb 17 05:20:07.041: %BGP-5-ADJCHANGE: neighbor 10.1.2.2 Up 
R1(config-if)#
R1(config-if)#shut
R1(config-if)#
*Feb 17 05:20:41.465: %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to administratively down
*Feb 17 05:20:42.465: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
R1(config-if)#
*Feb 17 05:23:07.375: %BGP-3-NOTIFICATION: sent to neighbor 10.1.2.2 4/0 (hold time expired) 0 bytes 
R1(config-if)#
*Feb 17 05:23:07.376: %BGP-5-NBR_RESET: Neighbor 10.1.2.2 reset (BGP Notification sent)
*Feb 17 05:23:07.378: %BGP-5-ADJCHANGE: neighbor 10.1.2.2 Down BGP Notification sent
*Feb 17 05:23:07.379: %BGP_SESSION-5-ADJCHANGE: neighbor 10.1.2.2 IPv4 Unicast topology base removed from session  BGP Notification sent
R1(config-if)#
R3#show ip bgp dampening flap-statistics 
R3#sh ip bgp
BGP table version is 11, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.1.0.0/16       100.2.3.2                              0 10 i
 *>i 4.4.0.0/16       10.3.4.4                 0    100      0 i
R3#
R3#sh ip bgp
BGP table version is 12, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
  h  1.1.0.0/16       100.2.3.2                              0 10 i
 *>i 4.4.0.0/16       10.3.4.4                 0    100      0 i
R3#show ip bgp dampening flap-statistics 
BGP table version is 12, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
 h  1.1.0.0/16       100.2.3.2       1     00:01:03          10 
R3#
R4#sh ip bgp
BGP table version is 12, local router ID is 4.4.0.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  4.4.0.0/16       0.0.0.0                  0         32768 i
R1(config-if)#no shut
R1(config-if)#
*Feb 17 05:24:50.391: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
*Feb 17 05:24:51.392: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#
*Feb 17 05:24:54.220: %BGP-5-ADJCHANGE: neighbor 10.1.2.2 Up 
R3#sh ip bgp                             
BGP table version is 13, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.1.0.0/16       100.2.3.2                              0 10 i
 *>i 4.4.0.0/16       10.3.4.4                 0    100      0 i
R3#show ip bgp dampening flap-statistics 
BGP table version is 13, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*>  1.1.0.0/16       100.2.3.2       1     00:02:38          10 

shut, no shut, shut, no shut, …

R3#show ip bgp dampening flap-statistics 
BGP table version is 13, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*>  1.1.0.0/16       100.2.3.2       1     00:05:22          10 
R3#

no, no, do clear ip bgp reset *

R3#show ip bgp 1.1.0.0                   
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1267, flapped 6 times in 00:20:29, reuse in 00:05:00
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1195, flapped 6 times in 00:20:46, reuse in 00:04:40
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1195, flapped 6 times in 00:20:49, reuse in 00:04:40
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1172, flapped 6 times in 00:20:54, reuse in 00:04:40
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1172, flapped 6 times in 00:20:57, reuse in 00:04:40
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1149, flapped 6 times in 00:20:59, reuse in 00:04:30
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1149, flapped 6 times in 00:21:00, reuse in 00:04:30
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 1149, flapped 6 times in 00:21:02, reuse in 00:04:30
      rx pathid: 0, tx pathid: 0
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:06 00:04:30 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:09 00:04:30 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:12 00:04:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:14 00:04:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:16 00:04:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:22 00:04:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:26 00:04:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:28 00:04:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:30 00:04:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:31 00:04:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:39 00:04:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:40 00:04:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:41 00:04:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:41 00:04:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:21:42 00:04:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:22:16 00:03:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:22:18 00:03:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:22:19 00:03:20 10 
R3#show ip bgp 1.1.0.0                   
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 858, flapped 6 times in 00:22:21, reuse in 00:03:20
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0                   
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 779, flapped 6 times in 00:22:46, reuse in 00:02:50
      rx pathid: 0, tx pathid: 0
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:22:54 00:02:50 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:22:58 00:02:50 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:23:00 00:02:40 10 
R3#show ip bgp 1.1.0.0                   
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 734, flapped 6 times in 00:23:05, reuse in 00:02:40
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 641, flapped 6 times in 00:23:40, reuse in 00:02:00
      rx pathid: 0, tx pathid: 0
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:23:50 00:01:50 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:04 00:01:40 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:11 00:01:40 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:25 00:01:30 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:31 00:01:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:37 00:01:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:39 00:01:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:40 00:01:20 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:42 00:01:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:43 00:01:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:45 00:01:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:46 00:01:10 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:48 00:01:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:49 00:01:00 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:24:51 00:01:00 10 
R3#show ip bgp 1.1.0.0                   
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 504, flapped 6 times in 00:24:53, reuse in 00:01:00
      rx pathid: 0, tx pathid: 0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 16
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 1
  10, (suppressed due to dampening)
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external
      Dampinfo: penalty 494, flapped 6 times in 00:24:59, reuse in 00:00:50
      rx pathid: 0, tx pathid: 0
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:25:03 00:00:50 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 16, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*d  1.1.0.0/16       100.2.3.2       6     00:25:08 00:00:50 10 
R3#show ip bgp dampening flap-statistics 
BGP table version is 17, local router ID is 100.2.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network          From            Flaps Duration Reuse    Path
*>  1.1.0.0/16       100.2.3.2       6     00:26:38          10 
R3#show ip bgp 1.1.0.0                   
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 341, flapped 6 times in 00:26:42
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 334, flapped 6 times in 00:26:47
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 334, flapped 6 times in 00:26:48
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 334, flapped 6 times in 00:26:49
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 334, flapped 6 times in 00:26:50
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 334, flapped 6 times in 00:26:51
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 327, flapped 6 times in 00:26:52
      rx pathid: 0, tx pathid: 0x0
R3#show ip bgp 1.1.0.0
BGP routing table entry for 1.1.0.0/16, version 17
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2         
  Refresh Epoch 1
  10
    100.2.3.2 from 100.2.3.2 (100.2.3.2)
      Origin IGP, localpref 100, valid, external, best
      Dampinfo: penalty 327, flapped 6 times in 00:26:52
      rx pathid: 0, tx pathid: 0x0
R3#

References

tech/network/cisco/bgp/bgp/route-flap-dampening/route-flap-dampening.txt · Last modified: 2019/02/17 15:12 by wnoguchi