User Tools

Site Tools


tech:network:cisco:bgp:bgp:no-auto-summary:no-auto-summary

BGP: no auto-summary

Topology

IP

Project name: ccna-bgp32-no-auto-summary

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 100.10.1.1 255.255.255.0
no shutdown
exit
interface Loopback 2
ip address 100.10.2.1 255.255.255.0
no shutdown
exit
interface Loopback 3
ip address 100.10.3.1 255.255.255.0
no shutdown
exit
interface Loopback 4
ip address 100.10.4.1 255.255.255.0
no shutdown
exit
interface Loopback 5
ip address 100.10.5.1 255.255.255.0
no shutdown
exit
interface Loopback 6
ip address 100.10.6.1 255.255.255.0
no shutdown
exit
interface Loopback 7
ip address 100.10.7.1 255.255.255.0
no shutdown
exit
interface Loopback 8
ip address 100.10.8.1 255.255.255.0
no shutdown
exit
interface Loopback 9
ip address 100.10.9.1 255.255.255.0
no shutdown
exit
interface Loopback 10
ip address 100.10.10.1 255.255.255.0
no shutdown
exit
interface Loopback 11
ip address 100.10.11.1 255.255.255.0
no shutdown
exit
interface Loopback 12
ip address 100.10.12.1 255.255.255.0
no shutdown
exit
interface Loopback 13
ip address 100.10.13.1 255.255.255.0
no shutdown
exit
interface Loopback 14
ip address 100.10.14.1 255.255.255.0
no shutdown
exit
interface Loopback 15
ip address 100.10.15.1 255.255.255.0
no shutdown
exit
interface Loopback 16
ip address 100.10.16.1 255.255.255.0
no shutdown
exit
interface Loopback 17
ip address 100.10.17.1 255.255.255.0
no shutdown
exit
interface Loopback 18
ip address 100.10.18.1 255.255.255.0
no shutdown
exit
interface Loopback 19
ip address 100.10.19.1 255.255.255.0
no shutdown
exit
interface Loopback 20
ip address 100.10.20.1 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 101.1.2.1 255.255.255.0
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 102.20.1.2 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 101.1.2.2 255.255.255.0
no shutdown
exit
!
end
write

Basic BGP Configuration

  • R1
configure terminal
!
router bgp 10
neighbor 101.1.2.2 remote-as 20
exit
!
end
  • R2
configure terminal
!
router bgp 20
network 102.20.1.0 mask 255.255.255.0
neighbor 101.1.2.1 remote-as 10
exit
!
end
R1#show running-config all | section router bgp 10
router bgp 10
 no synchronization
 bgp fast-external-fallover
 bgp route-map-cache
 no bgp asnotation dot
 no bgp consistency-checker
 bgp client-to-client reflection
 bgp client-to-client reflection intra-cluster cluster-id any
 bgp transport path-mtu-discovery
 bgp enforce-first-as
 bgp log-neighbor-changes
 bgp dynamic-med-interval 600
 bgp listen limit 100
 bgp update-delay 120
 bgp refresh stalepath-time 0
 bgp refresh max-eor-time 0
 bgp regexp deterministic
 bgp default ipv4-unicast
 bgp default ipv6-nexthop
 bgp default local-preference 100
 bgp default route-target filter
 bgp aggregate-timer 30
 bgp update-group split as-override
 bgp nexthop trigger enable
 bgp nexthop trigger delay 5
 bgp scan-time 60
 network 100.10.1.0 mask 255.255.255.0
 timers bgp 60 180 0
 neighbor 101.1.2.2 remote-as 20
 distance bgp 20 200 200
 distance mbgp 20 200 200
 no auto-summary

auto-summary Configuration

  • R1
configure terminal
!
router bgp 10
auto-summary
redistribute connected
exit
!
end

Verification

show ip bgp
show ip route bgp
ping 100.10.9.1 source 102.20.1.2
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 10
R1(config-router)#auto-summ
R1(config-router)#auto-summary 
R1(config-router)#redi
R1(config-router)#redistribute ?
  application  Application
  bgp          Border Gateway Protocol (BGP)
  connected    Connected
  eigrp        Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis         ISO IS-IS
  iso-igrp     IGRP for OSI networks
  lisp         Locator ID Separation Protocol (LISP)
  mobile       Mobile routes
  odr          On Demand stub Routes
  ospf         Open Shortest Path First (OSPF)
  ospfv3       OSPFv3
  rip          Routing Information Protocol (RIP)
  static       Static routes
  vrf          Specify a source VRF

R1(config-router)#redistribute 
% Incomplete command.

R1(config-router)#redistribute conne
R1(config-router)#redistribute connected 
R1(config-router)#^Z
R1#
*Feb 20 23:03:10.441: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip bgp
BGP table version is 4, local router ID is 100.10.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.0.0.0        0.0.0.0                  0         32768 ?
 *>  101.0.0.0        0.0.0.0                  0         32768 ?
 *>  102.20.1.0/24    101.1.2.2                0             0 20 i
R1#show ip bgp
BGP table version is 4, local router ID is 100.10.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.0.0.0        0.0.0.0                  0         32768 ?
 *>  101.0.0.0        0.0.0.0                  0         32768 ?
 *>  102.20.1.0/24    101.1.2.2                0             0 20 i
R1#show ip bgp
BGP table version is 4, local router ID is 100.10.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.0.0.0        0.0.0.0                  0         32768 ?
 *>  101.0.0.0        0.0.0.0                  0         32768 ?
 *>  102.20.1.0/24    101.1.2.2                0             0 20 i
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      100.0.0.0/8 is variably subnetted, 40 subnets, 2 masks
C        100.10.1.0/24 is directly connected, Loopback1
L        100.10.1.1/32 is directly connected, Loopback1
C        100.10.2.0/24 is directly connected, Loopback2
L        100.10.2.1/32 is directly connected, Loopback2
C        100.10.3.0/24 is directly connected, Loopback3
L        100.10.3.1/32 is directly connected, Loopback3
C        100.10.4.0/24 is directly connected, Loopback4
L        100.10.4.1/32 is directly connected, Loopback4
C        100.10.5.0/24 is directly connected, Loopback5
L        100.10.5.1/32 is directly connected, Loopback5
C        100.10.6.0/24 is directly connected, Loopback6
L        100.10.6.1/32 is directly connected, Loopback6
C        100.10.7.0/24 is directly connected, Loopback7
L        100.10.7.1/32 is directly connected, Loopback7
C        100.10.8.0/24 is directly connected, Loopback8
L        100.10.8.1/32 is directly connected, Loopback8
C        100.10.9.0/24 is directly connected, Loopback9
L        100.10.9.1/32 is directly connected, Loopback9
C        100.10.10.0/24 is directly connected, Loopback10
L        100.10.10.1/32 is directly connected, Loopback10
C        100.10.11.0/24 is directly connected, Loopback11
L        100.10.11.1/32 is directly connected, Loopback11
C        100.10.12.0/24 is directly connected, Loopback12
L        100.10.12.1/32 is directly connected, Loopback12
C        100.10.13.0/24 is directly connected, Loopback13
L        100.10.13.1/32 is directly connected, Loopback13
C        100.10.14.0/24 is directly connected, Loopback14
L        100.10.14.1/32 is directly connected, Loopback14
C        100.10.15.0/24 is directly connected, Loopback15
L        100.10.15.1/32 is directly connected, Loopback15
C        100.10.16.0/24 is directly connected, Loopback16
L        100.10.16.1/32 is directly connected, Loopback16
C        100.10.17.0/24 is directly connected, Loopback17
L        100.10.17.1/32 is directly connected, Loopback17
C        100.10.18.0/24 is directly connected, Loopback18
L        100.10.18.1/32 is directly connected, Loopback18
C        100.10.19.0/24 is directly connected, Loopback19
L        100.10.19.1/32 is directly connected, Loopback19
C        100.10.20.0/24 is directly connected, Loopback20
L        100.10.20.1/32 is directly connected, Loopback20
      101.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        101.1.2.0/24 is directly connected, GigabitEthernet0/0
L        101.1.2.1/32 is directly connected, GigabitEthernet0/0
      102.0.0.0/24 is subnetted, 1 subnets
B        102.20.1.0 [20/0] via 101.1.2.2, 00:01:25
R1#
R2#sh ip bg
BGP table version is 4, local router ID is 102.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.0.0.0        101.1.2.1                0             0 10 ?
 *>  101.0.0.0        101.1.2.1                0             0 10 ?
 *>  102.20.1.0/24    0.0.0.0                  0         32768 i
R2#sh ip ro bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

B     100.0.0.0/8 [20/0] via 101.1.2.1, 00:01:43
      101.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
B        101.0.0.0/8 [20/0] via 101.1.2.1, 00:01:43
R2#ping 100.10.9.1 source 102.20.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.9.1, timeout is 2 seconds:
Packet sent with a source address of 102.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
R2#

References

tech/network/cisco/bgp/bgp/no-auto-summary/no-auto-summary.txt · Last modified: 2019/02/21 08:07 by wnoguchi