PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:bgp:bgp:mp-bgp:mp-bgp

MP-BGP

MP-BGP(Multi Protocol BGP)

Topology

IP

Project name: ccna-ipv6-0013-mp-bgp

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:2::1/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::1 link-local
ipv6 address 2001:0:1:3::1/64
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::2 link-local
ipv6 address 2001:0:1:2::2/64
no shutdown
exit
interface GigabitEthernet 0/1
ipv6 address fe80::2 link-local
ipv6 address 2001:0:2:4::2/64
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::3 link-local
ipv6 address 2001:0:1:3::3/64
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
ipv6 unicast-routing 
!
interface GigabitEthernet 0/0
ipv6 address fe80::4 link-local
ipv6 address 2001:0:2:4::4/64
no shutdown
exit
!
end
write

Configure MP-BGP

  • R1
configure terminal
!
router bgp 13
no bgp default ipv4-unicast
bgp router-id 13.13.13.13
neighbor 2001:0:1:2::2 remote-as 24
address-family ipv6 unicast
neighbor 2001:0:1:2::2 activate
network 2001:0:1:3::/64
exit-address-family
exit
!
end
  • R2
configure terminal
!
router eigrp 24
no bgp default ipv4-unicast
bgp router-id 24.24.24.24
neighbor 2001:0:1:2::1 remote-as 13
address-family ipv6 unicast
neighbor 2001:0:1:2::1 activate
network 2001:0:2:4::/64
exit-address-family
exit
!
end
  • R3
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::1
!
end
  • R4
configure terminal
!
ipv6 route ::/0 GigabitEthernet 0/0 fe80::2
!
end
R3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 13
R1(config-router)#
*Mar 21 08:51:18.742: %BGP-4-NORTRID: BGP could not pick a router-id. Please configure manually.
R1(config-router)#no bg
R1(config-router)#no bgp de
R1(config-router)#no bgp defa
R1(config-router)#no bgp default ipv
R1(config-router)#no bgp default ipv4-u
R1(config-router)#no bgp default ipv4-unicast 
R1(config-router)#bgp router
R1(config-router)#bgp router-id 13.13.13.13
R1(config-router)#nei
R1(config-router)#neighbor 2001:0:1:2::2 remote
R1(config-router)#neighbor 2001:0:1:2::2 remote-as 24
R1(config-router)#add
R1(config-router)#address-family ipv6 u
R1(config-router)#address-family ipv6 unicast 
R1(config-router-af)#nei
R1(config-router-af)#neighbor 2001:0:1:2::2 ac
R1(config-router-af)#neighbor 2001:0:1:2::2 activate 
R1(config-router-af)#netwo
R1(config-router-af)#network 2001:0:1:3::/64
R1(config-router-af)#exi
R1(config-router-af)#exit-address-family 
R1(config-router)#^Z
R1#
*Mar 21 08:53:15.460: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar 21 08:54:31.337: %BGP-5-ADJCHANGE: neighbor 2001:0:1:2::2 Up 
R1#
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 24
R2(config-router)#
*Mar 21 08:51:23.119: %BGP-4-NORTRID: BGP could not pick a router-id. Please configure manually.
R2(config-router)#router bgp
R2(config-router)#no bgp defau
R2(config-router)#no bgp default ipv
R2(config-router)#no bgp default ipv4-uni
R2(config-router)#no bgp default ipv4-unicast 
R2(config-router)#bgp route
R2(config-router)#bgp router-id 24.24.24.24
R2(config-router)#nei
R2(config-router)#neighbor 2001:0:1:2::1 remote
R2(config-router)#neighbor 2001:0:1:2::1 remote-as 13
R2(config-router)#add
R2(config-router)#address-family ipv
R2(config-router)#address-family ipv6
R2(config-router)#address-family ipv6 unica
R2(config-router)#address-family ipv6 unicast 
R2(config-router-af)#nei
R2(config-router-af)#neighbor 2001:0:1:2::1 acti
R2(config-router-af)#neighbor 2001:0:1:2::1 activate 
R2(config-router-af)#netwo
R2(config-router-af)#network 
*Mar 21 08:54:30.960: %BGP-5-ADJCHANGE: neighbor 2001:0:1:2::1 Up 
R2(config-router-af)#network 2001:0:2:4::/64
R2(config-router-af)#ex
R2(config-router-af)#exit-address-family 
R2(config-router)#^Z
R2#
*Mar 21 08:54:56.002: %SYS-5-CONFIG_I: Configured from console by console
R2#
RR3#ping 2001:0:2:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:2:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/18 ms
R1#show bgp ipv6 unicast neighbors 2001:0:1:2::2 advertised-routes 
BGP table version is 5, local router ID is 13.13.13.13
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2001:0:1:3::/64  ::                       0         32768 i

Total number of prefixes 1 
R1#show ip bgp ipv6 unicast summary 
BGP router identifier 13.13.13.13, local AS number 13
BGP table version is 5, main routing table version 5
2 network entries using 336 bytes of memory
2 path entries using 208 bytes of memory
2/2 BGP path/bestpath attribute entries using 304 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 872 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2001:0:1:2::2   4           24      11      12        5    0    0 00:06:21        1
R1#show ip bgp ipv6 unicast 
BGP table version is 5, local router ID is 13.13.13.13
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2001:0:1:3::/64  ::                       0         32768 i
 *>  2001:0:2:4::/64  2001:0:1:2::2            0             0 24 i
R1#show ipv6 route bgp
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
B   2001:0:2:4::/64 [20/0]
     via FE80::2, GigabitEthernet0/0
R1#show ipv6 route    
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:0:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:0:1:2::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:0:1:3::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:0:1:3::1/128 [0/0]
     via GigabitEthernet0/1, receive
B   2001:0:2:4::/64 [20/0]
     via FE80::2, GigabitEthernet0/0
L   FF00::/8 [0/0]
     via Null0, receive
R2#show ipv6 route bgp
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
B   2001:0:1:3::/64 [20/0]
     via FE80::1, GigabitEthernet0/0
R2#show ipv6 route 
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
C   2001:0:1:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:0:1:2::2/128 [0/0]
     via GigabitEthernet0/0, receive
B   2001:0:1:3::/64 [20/0]
     via FE80::1, GigabitEthernet0/0
C   2001:0:2:4::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001:0:2:4::2/128 [0/0]
     via GigabitEthernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive

References

tech/network/cisco/bgp/bgp/mp-bgp/mp-bgp.txt · Last modified: 2019/03/21 18:04 by wnoguchi