User Tools

Site Tools


tech:network:cisco:bgp:bgp:maximum-prefix:maximum-prefix

BGP: maximum-prefix

Topology

IP

Project name: ccna-bgp31-maximum-prefix

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 100.10.1.1 255.255.255.0
no shutdown
exit
interface Loopback 2
ip address 100.10.2.1 255.255.255.0
no shutdown
exit
interface Loopback 3
ip address 100.10.3.1 255.255.255.0
no shutdown
exit
interface Loopback 4
ip address 100.10.4.1 255.255.255.0
no shutdown
exit
interface Loopback 5
ip address 100.10.5.1 255.255.255.0
no shutdown
exit
interface Loopback 6
ip address 100.10.6.1 255.255.255.0
no shutdown
exit
interface Loopback 7
ip address 100.10.7.1 255.255.255.0
no shutdown
exit
interface Loopback 8
ip address 100.10.8.1 255.255.255.0
no shutdown
exit
interface Loopback 9
ip address 100.10.9.1 255.255.255.0
no shutdown
exit
interface Loopback 10
ip address 100.10.10.1 255.255.255.0
no shutdown
exit
interface Loopback 11
ip address 100.10.11.1 255.255.255.0
no shutdown
exit
interface Loopback 12
ip address 100.10.12.1 255.255.255.0
no shutdown
exit
interface Loopback 13
ip address 100.10.13.1 255.255.255.0
no shutdown
exit
interface Loopback 14
ip address 100.10.14.1 255.255.255.0
no shutdown
exit
interface Loopback 15
ip address 100.10.15.1 255.255.255.0
no shutdown
exit
interface Loopback 16
ip address 100.10.16.1 255.255.255.0
no shutdown
exit
interface Loopback 17
ip address 100.10.17.1 255.255.255.0
no shutdown
exit
interface Loopback 18
ip address 100.10.18.1 255.255.255.0
no shutdown
exit
interface Loopback 19
ip address 100.10.19.1 255.255.255.0
no shutdown
exit
interface Loopback 20
ip address 100.10.20.1 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 100.1.2.1 255.255.255.0
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 100.20.1.2 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 100.1.2.2 255.255.255.0
no shutdown
exit
!
end
write

Basic BGP Configuration

  • R1
configure terminal
!
router bgp 10
network 100.10.1.0 mask 255.255.255.0
neighbor 100.1.2.2 remote-as 20
exit
!
end
  • R2
configure terminal
!
router bgp 20
network 100.20.1.0 mask 255.255.255.0
neighbor 100.1.2.1 remote-as 10
exit
!
end

maximum-prefix Configuration

  • R1
configure terminal
!
router bgp 10
network 100.10.1.0 mask 255.255.255.0
network 100.10.2.0 mask 255.255.255.0
network 100.10.3.0 mask 255.255.255.0
network 100.10.4.0 mask 255.255.255.0
network 100.10.5.0 mask 255.255.255.0
network 100.10.6.0 mask 255.255.255.0
network 100.10.7.0 mask 255.255.255.0
network 100.10.8.0 mask 255.255.255.0
network 100.10.9.0 mask 255.255.255.0
network 100.10.10.0 mask 255.255.255.0
network 100.10.11.0 mask 255.255.255.0
network 100.10.12.0 mask 255.255.255.0
network 100.10.13.0 mask 255.255.255.0
network 100.10.14.0 mask 255.255.255.0
network 100.10.15.0 mask 255.255.255.0
network 100.10.16.0 mask 255.255.255.0
network 100.10.17.0 mask 255.255.255.0
network 100.10.18.0 mask 255.255.255.0
network 100.10.19.0 mask 255.255.255.0
network 100.10.20.0 mask 255.255.255.0
exit
!
end
  • R2 (Pattern 1)
configure terminal
!
router bgp 20
neighbor 100.1.2.1 maximum-prefix 10
exit
!
end
  • R2 (Pattern 2)
configure terminal
!
router bgp 20
neighbor 100.1.2.1 maximum-prefix 10 50
exit
!
end
  • R2 (Pattern 3)
configure terminal
!
router bgp 20
neighbor 100.1.2.1 maximum-prefix 19 warning-only
exit
!
end
  • R2 (Pattern 4)
configure terminal
!
router bgp 20
neighbor 100.1.2.1 maximum-prefix 19 restart 3
exit
!
end

Verification

do ping 100.10.1.1 source 100.20.1.2
do ping 100.10.4.1 source 100.20.1.2
do show ip bgp
do show ip bgp neighbors | include BGP state
  • Pattern 1
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 10
R1(config-router)#network 100.10.2.0 mask 255.255.255.0
R1(config-router)#network 100.10.3.0 mask 255.255.255.0
R1(config-router)#network 100.10.4.0 mask 255.255.255.0
R1(config-router)#network 100.10.5.0 mask 255.255.255.0
R1(config-router)#network 100.10.6.0 mask 255.255.255.0
R1(config-router)#network 100.10.7.0 mask 255.255.255.0
R1(config-router)#network 100.10.8.0 mask 255.255.255.0
R1(config-router)#network 100.10.9.0 mask 255.255.255.0
R1(config-router)#network 100.10.10.0 mask 255.255.255.0
R1(config-router)#network 100.10.11.0 mask 255.255.255.0
R1(config-router)#
*Feb 17 23:25:39.280: %BGP-5-NBR_RESET: Neighbor 100.1.2.2 reset (Peer closed the session)
*Feb 17 23:25:39.284: %BGP-5-ADJCHANGE: neighbor 100.1.2.2 Down Peer closed the session
*Feb 17 23:25:39.285: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.2 IPv4 Unicast topology base removed from session  Peer closed the session
R1(config-router)#
*Feb 17 23:25:45.836: %BGP-5-NBR_RESET: Neighbor 100.1.2.2 active reset (BGP Notification received)
*Feb 17 23:25:45.839: %BGP-5-ADJCHANGE: neighbor 100.1.2.2 active Down BGP Notification received
*Feb 17 23:25:45.839: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.2 IPv4 Unicast topology base removed from session  BGP Notification received
R1(config-router)#
R2(config-router)#
*Feb 17 23:22:28.389: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 8, max 10
R2(config-router)#
*Feb 17 23:24:15.128: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 9, max 10
R2(config-router)#do sh ip bgp
BGP table version is 11, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.10.7.0/24    100.1.2.1                0             0 10 i
 *>  100.10.8.0/24    100.1.2.1                0             0 10 i
 *>  100.10.9.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#
*Feb 17 23:24:56.774: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 10, max 10
R2(config-router)#do sh ip bgp
BGP table version is 12, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.10.7.0/24    100.1.2.1                0             0 10 i
 *>  100.10.8.0/24    100.1.2.1                0             0 10 i
 *>  100.10.9.0/24    100.1.2.1                0             0 10 i
 *>  100.10.10.0/24   100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do sh ip bgp neigh | i BGP state
  BGP state = Established, up for 00:23:14
R2(config-router)#
*Feb 17 23:25:38.892: %BGP-3-MAXPFXEXCEED: Number of prefixes received from 100.1.2.1 (afi 0): 11 exceeds limit 10
*Feb 17 23:25:38.894: %BGP-3-NOTIFICATION: sent to neighbor 100.1.2.1 6/1 (Maximum Number of Prefixes Reached) 7 bytes 00010100 00000A
R2(config-router)#
*Feb 17 23:25:38.894: %BGP-5-NBR_RESET: Neighbor 100.1.2.1 reset (Peer over prefix limit)
*Feb 17 23:25:38.899: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 Down Peer over prefix limit
*Feb 17 23:25:38.900: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.1 IPv4 Unicast topology base removed from session  Peer over prefix limit
R2(config-router)#
*Feb 17 23:25:49.610: %BGP-5-NBR_RESET: Neighbor 100.1.2.1 passive reset (BGP Notification sent)
*Feb 17 23:25:49.615: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 passive Down AFI/SAFI not supported
R2(config-router)#do sh ip bgp neigh | i BGP state
  BGP state = Idle
R2(config-router)#do sh ip bgp                    
BGP table version is 22, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#
*Feb 17 23:26:44.915: %BGP-3-NOTIFICATION: sent to neighbor 100.1.2.1 passive 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer expired)
R2(config-router)#
  • Pattern 2
R1#sh ip bgp
BGP table version is 3, local router ID is 100.10.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    0.0.0.0                  0         32768 i
 *>  100.20.1.0/24    100.1.2.2                0             0 20 i
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 10
R1(config-router)#network 100.10.2.0 mask 255.255.255.0
R1(config-router)#network 100.10.3.0 mask 255.255.255.0
R1(config-router)#network 100.10.4.0 mask 255.255.255.0
R1(config-router)#network 100.10.5.0 mask 255.255.255.0
R1(config-router)#network 100.10.6.0 mask 255.255.255.0
R1(config-router)#network 100.10.7.0 mask 255.255.255.0
R1(config-router)#network 100.10.8.0 mask 255.255.255.0
R1(config-router)#network 100.10.9.0 mask 255.255.255.0
R1(config-router)#network 100.10.10.0 mask 255.255.255.0
R1(config-router)#network 100.10.11.0 mask 255.255.255.0
R1(config-router)#
*Feb 17 23:47:50.908: %BGP-5-NBR_RESET: Neighbor 100.1.2.2 reset (Peer closed the session)
*Feb 17 23:47:50.913: %BGP-5-ADJCHANGE: neighbor 100.1.2.2 Down Peer closed the session
*Feb 17 23:47:50.914: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.2 IPv4 Unicast topology base removed from session  Peer closed the session
R1(config-router)#
*Feb 17 23:47:57.098: %BGP-5-NBR_RESET: Neighbor 100.1.2.2 active reset (BGP Notification received)
*Feb 17 23:47:57.101: %BGP-5-ADJCHANGE: neighbor 100.1.2.2 active Down BGP Notification received
*Feb 17 23:47:57.102: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.2 IPv4 Unicast topology base removed from session  BGP Notification received
R1(config-router)#
*Feb 17 23:48:57.502: %BGP-3-NOTIFICATION: received from neighbor 100.1.2.2 active 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer expired)
R1(config-router)#
R2#sh ip bgp
BGP table version is 3, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 20
R2(config-router)#neigh
R2(config-router)#neighbor 100.1.2.1 maxi
R2(config-router)#neighbor 100.1.2.1 maximum-prefix 10 50
R2(config-router)#do pingdo ping 100.10.4.1 source 100.20.1.2
                         ^
% Invalid input detected at '^' marker.

R2(config-router)#do ping 100.10.4.1 source 100.20.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.4.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
.....
Success rate is 0 percent (0/5)
R2(config-router)#do ping 100.10.1.1 source 100.20.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.1.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
R2(config-router)#show ip bgp
                   ^
% Invalid input detected at '^' marker.

R2(config-router)#do show ip bgp
BGP table version is 3, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp neighbors | include BGP state
  BGP state = Established, up for 00:11:49
R2(config-router)#do show ip bgp                              
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 4, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 6, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp                       
BGP table version is 7, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 7, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
BGP table version is 7, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
*Feb 17 23:44:47.243: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 6, max 10
R2(config-router)#do show ip bgp
BGP table version is 8, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp
*Feb 17 23:45:18.016: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 7, max 10
R2(config-router)#do show ip bgp
BGP table version is 12, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.10.7.0/24    100.1.2.1                0             0 10 i
 *>  100.10.8.0/24    100.1.2.1                0             0 10 i
 *>  100.10.9.0/24    100.1.2.1                0             0 10 i
 *>  100.10.10.0/24   100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do ping 100.10.1.1 source 100.20.1.2        
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.1.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/7 ms
R2(config-router)#do ping 100.10.5.1 source 100.20.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.5.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms
R2(config-router)#do ping 100.10.10.1 source 100.20.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
R2(config-router)#
*Feb 17 23:47:50.584: %BGP-3-MAXPFXEXCEED: Number of prefixes received from 100.1.2.1 (afi 0): 11 exceeds limit 10
*Feb 17 23:47:50.586: %BGP-3-NOTIFICATION: sent to neighbor 100.1.2.1 6/1 (Maximum Number of Prefixes Reached) 7 bytes 00010100 00000A
*Feb 17 23:47:50.586: %BGP-5-NBR_RESET: Neighbor 100.1.2.1 reset (Peer over prefix limit)
*Feb 17 23:47:50.592: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 Down Peer over prefix limit
*Feb 17 23:47:50.592: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.1 IPv4 Unicast topology base removed from session  Peer over prefix limit
R2(config-router)#
*Feb 17 23:48:01.643: %BGP-5-NBR_RESET: Neighbor 100.1.2.1 passive reset (BGP Notification sent)
*Feb 17 23:48:01.646: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 passive Down AFI/SAFI not supported
R2(config-router)#do show ip bgp                       
BGP table version is 22, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp neighbors | include BGP state
  BGP state = Idle
R2(config-router)#do ping 100.10.10.1 source 100.20.1.2       
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
.....
Success rate is 0 percent (0/5)
R2(config-router)#
*Feb 17 23:48:57.020: %BGP-3-NOTIFICATION: sent to neighbor 100.1.2.1 passive 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer expired)
R2(config-router)#
  • Pattern 3
R1(config-router)#
*Feb 17 23:51:08.444: %BGP-5-ADJCHANGE: neighbor 100.1.2.2 Up 
R1(config-router)#network 100.10.12.0 mask 255.255.255.0
R1(config-router)#network 100.10.13.0 mask 255.255.255.0
R1(config-router)#network 100.10.14.0 mask 255.255.255.0
R1(config-router)#network 100.10.15.0 mask 255.255.255.0
R1(config-router)#network 100.10.16.0 mask 255.255.255.0
R1(config-router)#network 100.10.17.0 mask 255.255.255.0
R1(config-router)#network 100.10.18.0 mask 255.255.255.0
R1(config-router)#network 100.10.19.0 mask 255.255.255.0
R1(config-router)#network 100.10.20.0 mask 255.255.255.0
R1(config-router)#
R2(config-router)#neighbor 100.1.2.1 maximum-prefix 19 warning-only 
R2(config-router)#do
*Feb 17 23:51:08.174: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 Up 
R2(config-router)#do ping 100.10.10.1 source 100.20.1.2             
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/4 ms
R2(config-router)#do show ip bgp neighbors | include BGP state      
  BGP state = Established, up for 00:00:17
R2(config-router)#do show ip bgp                                    
BGP table version is 33, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.10.7.0/24    100.1.2.1                0             0 10 i
 *>  100.10.8.0/24    100.1.2.1                0             0 10 i
 *>  100.10.9.0/24    100.1.2.1                0             0 10 i
 *>  100.10.10.0/24   100.1.2.1                0             0 10 i
 *>  100.10.11.0/24   100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#
*Feb 17 23:52:08.674: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 15, max 19
R2(config-router)#
*Feb 17 23:52:08.676: %BGP-3-MAXPFXEXCEED: Number of prefixes received from 100.1.2.1 (afi 0): 20 exceeds limit 19
R2(config-router)#do show ip bgp
BGP table version is 42, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.10.7.0/24    100.1.2.1                0             0 10 i
 *>  100.10.8.0/24    100.1.2.1                0             0 10 i
 *>  100.10.9.0/24    100.1.2.1                0             0 10 i
 *>  100.10.10.0/24   100.1.2.1                0             0 10 i
 *>  100.10.11.0/24   100.1.2.1                0             0 10 i
 *>  100.10.12.0/24   100.1.2.1                0             0 10 i
 *>  100.10.13.0/24   100.1.2.1                0             0 10 i
 *>  100.10.14.0/24   100.1.2.1                0             0 10 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.15.0/24   100.1.2.1                0             0 10 i
 *>  100.10.16.0/24   100.1.2.1                0             0 10 i
 *>  100.10.17.0/24   100.1.2.1                0             0 10 i
 *>  100.10.18.0/24   100.1.2.1                0             0 10 i
 *>  100.10.19.0/24   100.1.2.1                0             0 10 i
 *>  100.10.20.0/24   100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do ping 100.10.20.1 source 100.20.1.2       
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.20.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms
R2(config-router)#
  • Pattern 4
R1(config-router)#
*Feb 17 23:55:59.501: %BGP-3-NOTIFICATION: received from neighbor 100.1.2.2 active 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer expired)
R1(config-router)#no network 100.10.20.0 mask 255.255.255.0
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1(config-router)#no network 100.10.20.0 mask 255.255.255.0
R1(config-router)#sh clock
                   ^
% Invalid input detected at '^' marker.

R1(config-router)#do sh clock
*23:57:49.697 UTC Sun Feb 17 2019
R1(config-router)#
*Feb 18 00:04:50.306: %BGP-5-ADJCHANGE: neighbor 100.1.2.2 Up 
R1(config-router)#
R2(config-router)#neighbor 100.1.2.1 maximum-prefix 19 restart ?
  <1-65535>  Restart interval in minutes

R2(config-router)#neighbor 100.1.2.1 maximum-prefix 19 restart 10
R2(config-router)#
*Feb 17 23:54:52.929: %BGP-3-MAXPFXEXCEED: Number of prefixes received from 100.1.2.1 (afi 0): 20 exceeds limit 19
*Feb 17 23:54:52.931: %BGP-3-NOTIFICATION: sent to neighbor 100.1.2.1 6/1 (Maximum Number of Prefixes Reached) 7 bytes 00010100 000013
R2(config-router)#
*Feb 17 23:54:52.945: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 Down Peer over prefix limit
*Feb 17 23:54:52.946: %BGP_SESSION-5-ADJCHANGE: neighbor 100.1.2.1 IPv4 Unicast topology base removed from session  Peer over prefix limit
R2(config-router)#do sh clo
*Feb 17 23:55:02.898: %BGP-5-NBR_RESET: Neighbor 100.1.2.1 passive reset (BGP Notification sent)
*Feb 17 23:55:02.902: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 passive Down AFI/SAFI not supported
R2(config-router)#do sh clock
*23:55:04.679 UTC Sun Feb 17 2019
R2(config-router)#do sh clock
*23:55:18.513 UTC Sun Feb 17 2019
R2(config-router)#do show ip bgp                                 
BGP table version is 62, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do show ip bgp                                 
*Feb 17 23:55:58.206: %BGP-3-NOTIFICATION: sent to neighbor 100.1.2.1 passive 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer expired)
R2(config-router)#do show ip bgp neighbors | include BGP state
  BGP state = Idle
R2(config-router)#do sh clock                                 
*23:56:15.498 UTC Sun Feb 17 2019
R2(config-router)#do ping 100.10.20.1 source 100.20.1.2          
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.20.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
....
Success rate is 0 percent (0/4)
R2(config-router)#do ping 100.10.15.1 source 100.20.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.15.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
.....
Success rate is 0 percent (0/5)
R2(config-router)#do sh clock                          
*23:57:54.086 UTC Sun Feb 17 2019
R2(config-router)#
*Feb 18 00:04:49.854: %BGP-5-ADJCHANGE: neighbor 100.1.2.1 Up 
R2(config-router)#
*Feb 18 00:04:49.877: %BGP-4-MAXPFX: Number of prefixes received from 100.1.2.1 (afi 0) reaches 15, max 19
R2(config-router)#do sh clock                          
*00:06:04.003 UTC Mon Feb 18 2019
R2(config-router)#do show ip bgp neighbors | include BGP state
  BGP state = Established, up for 00:01:25
R2(config-router)#do show ip bgp                              
BGP table version is 81, local router ID is 100.20.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.1.0/24    100.1.2.1                0             0 10 i
 *>  100.10.2.0/24    100.1.2.1                0             0 10 i
 *>  100.10.3.0/24    100.1.2.1                0             0 10 i
 *>  100.10.4.0/24    100.1.2.1                0             0 10 i
 *>  100.10.5.0/24    100.1.2.1                0             0 10 i
 *>  100.10.6.0/24    100.1.2.1                0             0 10 i
 *>  100.10.7.0/24    100.1.2.1                0             0 10 i
 *>  100.10.8.0/24    100.1.2.1                0             0 10 i
 *>  100.10.9.0/24    100.1.2.1                0             0 10 i
 *>  100.10.10.0/24   100.1.2.1                0             0 10 i
 *>  100.10.11.0/24   100.1.2.1                0             0 10 i
 *>  100.10.12.0/24   100.1.2.1                0             0 10 i
 *>  100.10.13.0/24   100.1.2.1                0             0 10 i
 *>  100.10.14.0/24   100.1.2.1                0             0 10 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>  100.10.15.0/24   100.1.2.1                0             0 10 i
 *>  100.10.16.0/24   100.1.2.1                0             0 10 i
 *>  100.10.17.0/24   100.1.2.1                0             0 10 i
 *>  100.10.18.0/24   100.1.2.1                0             0 10 i
 *>  100.10.19.0/24   100.1.2.1                0             0 10 i
 *>  100.20.1.0/24    0.0.0.0                  0         32768 i
R2(config-router)#do ping 100.10.15.1 source 100.20.1.2       
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.15.1, timeout is 2 seconds:
Packet sent with a source address of 100.20.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/5 ms
R2(config-router)#

References

tech/network/cisco/bgp/bgp/maximum-prefix/maximum-prefix.txt · Last modified: 2019/02/18 09:21 by wnoguchi