PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:bgp:bgp:aggregate-address:aggregate-address

BGP: aggregate-address

Topology

Project name: ccna-bgp18-aggregate-address-topology

IP

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 0
ip address 1.1.1.1 255.255.255.0
no shutdown
exit
interface Loopback 1
ip address 1.1.2.1 255.255.255.0
no shutdown
exit
interface Loopback 2
ip address 1.1.3.1 255.255.255.0
no shutdown
exit
interface Loopback 3
ip address 1.1.4.1 255.255.255.0
no shutdown
exit
interface Loopback 4
ip address 1.1.5.1 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 100.1.2.1 255.255.255.0
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface GigabitEthernet 0/0
ip address 100.1.2.2 255.255.255.0
no shutdown
exit
!
end
write

BGP

Project name: ccna-bgp18-aggregate-address

  • R1
enable
configure terminal
!
router bgp 1
neighbor 100.1.2.2 remote-as 2
network 1.1.1.0 mask 255.255.255.0
network 1.1.2.0 mask 255.255.255.0
network 1.1.3.0 mask 255.255.255.0
network 1.1.4.0 mask 255.255.255.0
network 1.1.5.0 mask 255.255.255.0
exit
!
end
write
  • R2
enable
configure terminal
!
router bgp 2
neighbor 100.1.2.1 remote-as 1
exit
!
end
write

aggregate-address

  • R1
enable
configure terminal
!
router bgp 1
aggregate-address 1.1.0.0 255.255.0.0
exit
!
end

aggregate-address summary-only

  • R1
enable
configure terminal
!
router bgp 1
aggregate-address 1.1.0.0 255.255.0.0 summary-only
exit
!
end

Topology

Project name: ccna-bgp19-aggregate-address-topology-star

IP

  • R1
enable
configure terminal
!
hostname R1
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 50.1.1.1 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 100.1.3.1 255.255.255.0
no shutdown
exit
!
end
write
  • R2
enable
configure terminal
!
hostname R2
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 50.1.2.2 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 100.2.3.2 255.255.255.0
no shutdown
exit
!
end
write
  • R3
enable
configure terminal
!
hostname R3
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface GigabitEthernet 0/0
ip address 100.1.3.3 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/1
ip address 100.2.3.3 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/2
ip address 100.3.4.3 255.255.255.0
no shutdown
exit
!
end
write
  • R4
enable
configure terminal
!
hostname R4
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synchronous
exit
!
interface Loopback 1
ip address 40.0.0.4 255.255.255.0
no shutdown
exit
interface GigabitEthernet 0/0
ip address 100.3.4.4 255.255.255.0
no shutdown
exit
!
end
write

BGP

Project name: ccna-bgp19-aggregate-address-star

  • R1
enable
configure terminal
!
router bgp 10
neighbor 100.1.3.3 remote-as 30
network 50.1.1.0 mask 255.255.255.0
exit
!
end
write
  • R2
enable
configure terminal
!
router bgp 20
neighbor 100.2.3.3 remote-as 30
network 50.1.2.0 mask 255.255.255.0
exit
!
end
write
  • R3
enable
configure terminal
!
router bgp 30
neighbor 100.1.3.1 remote-as 10
neighbor 100.2.3.2 remote-as 20
neighbor 100.3.4.4 remote-as 40
exit
!
end
write
  • R4
enable
configure terminal
!
router bgp 40
neighbor 100.3.4.3 remote-as 30
network 40.0.0.0 mask 255.255.255.0
exit
!
end
write

aggregate-address as-set summary-only lab

Compare following three configuration results.

  • R3
enable
configure terminal
!
router bgp 30
aggregate-address 50.1.0.0 255.255.0.0
exit
!
end
  • R3
enable
configure terminal
!
router bgp 30
aggregate-address 50.1.0.0 255.255.0.0 summary-only
exit
!
end
  • R3
enable
configure terminal
!
router bgp 30
aggregate-address 50.1.0.0 255.255.0.0 as-set summary-only
exit
!
end

References

tech/network/cisco/bgp/bgp/aggregate-address/aggregate-address.txt · Last modified: 2019/01/14 16:35 by wnoguchi