PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:advanced-rip-config:advanced-rip-config

Advanced RIP configuration

GNS3 Virtual Lab.

Key Feature

  • no auto-summary
  • passive-interface gig0/0
  • maximum-paths 2
  • default-information originate

Disable Auto Summarization

Topology

Initial Config

  • R1
conf t
!
hostname R1
!
int gig0/0
ip addr 172.16.1.1 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.1.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
conf t
!
hostname R2
!
int gig0/0
ip addr 192.168.1.2 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.2.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
conf t
!
hostname R3
!
int gig0/0
ip addr 192.168.2.3 255.255.255.0
no shut
exit
int gig0/1
ip addr 172.16.2.3 255.255.255.0
no shut
exit
!
end
wr
  • PC-1
ip 172.16.1.254 255.255.255.0 172.16.1.1
save
  • PC-2
ip 172.16.2.254 255.255.255.0 172.16.2.3
save

Configuration without no auto-summary

  • R1
conf t
!
router rip
network 172.16.0.0
network 192.168.1.0
version 2
exit
!
end
  • R2
conf t
!
router rip
network 192.168.1.0
network 192.168.2.0
version 2
exit
!
end
  • R3
conf t
!
router rip
network 172.16.0.0
network 192.168.2.0
version 2
exit
!
end

Verification without no auto-summary

  • R1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
R        172.16.0.0/16 [120/2] via 192.168.1.2, 00:01:51, GigabitEthernet0/1
C        172.16.1.0/24 is directly connected, GigabitEthernet0/0
L        172.16.1.1/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1
R     192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:07, GigabitEthernet0/1
  • R2
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:13, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:20, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
  • R3
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.2.0/24 is directly connected, GigabitEthernet0/1
L        172.16.2.3/32 is directly connected, GigabitEthernet0/1
R     192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:18, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.3/32 is directly connected, GigabitEthernet0/0
PC-1>  ping 172.16.2.254
*172.16.1.1 icmp_seq=1 ttl=255 time=3.007 ms (ICMP type:3, code:1, Destination host unreachable)
*172.16.1.1 icmp_seq=2 ttl=255 time=2.431 ms (ICMP type:3, code:1, Destination host unreachable)
*172.16.1.1 icmp_seq=3 ttl=255 time=2.510 ms (ICMP type:3, code:1, Destination host unreachable)
*172.16.1.1 icmp_seq=4 ttl=255 time=2.138 ms (ICMP type:3, code:1, Destination host unreachable)
*172.16.1.1 icmp_seq=5 ttl=255 time=2.223 ms (ICMP type:3, code:1, Destination host unreachable)

PC-1> ping 192.168.2.3
192.168.2.3 icmp_seq=1 timeout
192.168.2.3 icmp_seq=2 timeout
192.168.2.3 icmp_seq=3 timeout
192.168.2.3 icmp_seq=4 timeout
192.168.2.3 icmp_seq=5 timeout
R1#ping 192.168.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/8 ms
R2#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/9 ms
R2#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
R2#ping 172.16.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
R2#ping 172.16.2.3 rep
R2#ping 172.16.2.3 repeat 1000
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (1000/1000), round-trip min/avg/max = 2/3/23 ms
R2#ping 172.16.1.1 repeat 1000
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (1000/1000), round-trip min/avg/max = 2/3/6 ms
R2#cle
R2#clear ar
R2#clear arp
R2#clear ar
R2#clear arp
R2#clear arp-cache
R2#ping 172.16.1.1 repeat 1000
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (1000/1000), round-trip min/avg/max = 2/3/22 ms
R2#ping 172.16.1.1 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 2/3/6 ms
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 3/3/6 ms
R2#sh ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.1             0   5267.24af.d301  ARPA   GigabitEthernet0/0
Internet  192.168.1.2             -   5267.245f.bf00  ARPA   GigabitEthernet0/0
Internet  192.168.2.2             -   5267.245f.bf01  ARPA   GigabitEthernet0/1
Internet  192.168.2.3             0   5267.24eb.ff00  ARPA   GigabitEthernet0/1
R2#clear arp-cache
R2#sh ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.1             0   5267.24af.d301  ARPA   GigabitEthernet0/0
Internet  192.168.1.2             -   5267.245f.bf00  ARPA   GigabitEthernet0/0
Internet  192.168.2.2             -   5267.245f.bf01  ARPA   GigabitEthernet0/1
Internet  192.168.2.3             0   5267.24eb.ff00  ARPA   GigabitEthernet0/1
R2#clear ip ?
  access-list             Clear access list statistical information
  access-template         Access-template
  accounting              Clear IP accounting database
  admission               Clear Network Admission Control information
  arp                     IP ARP table
  auth-proxy              Clear the auth-proxy info
  bgp                     Clear BGP connections
  cache                   Delete cache table entries
  cef                     Cisco Express Forwarding info
  cgmp                    Cisco Group Management Protocol (CGMP)
  device                  Clear IP Device
  dhcp                    Delete items from the DHCP database
  dns-cache               Clear addresses in DNS cache
  dns-snoop-cache         Clear addresses in DNS cache
  drp                     Clear director responder counters
  eigrp                   Clear IPv4 EIGRP
  flow                    Clear flow information
  http                    Clear HTTP parameters
  icmp                    ICMP information
  igmp                    IGMP clear commands
  inspect                 Clear commands for IOS firewall
  ips                     Clear IPS information

R2#clear ip ar
R2#clear ip arp
% Incomplete command.

R2#clear ip arp *
                ^
% Invalid input detected at '^' marker.

R2#clear ip arp ?
  A.B.C.D  IP address of dynamic ARP entry

R2#clear ip ro *
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:06, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:06, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#clear ip ro *
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:01, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:01, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:02, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:02, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#clear ip ro ?
  *          Delete all routes
  A.B.C.D    Destination network route to delete
  dhcp       Delete route added by DHCP Server or Relay
  multicast  Multicast global information
  topology   Clear routes for a topology instance
  vrf        Clear routes for a VPN Routing/Forwarding instance

R2#clear ip ro *
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:01, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:01, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:03, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:03, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:03, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:03, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#ping 172.16.1.1 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip ro *
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     172.16.0.0/16 [120/1] via 192.168.2.3, 00:00:03, GigabitEthernet0/1
                    [120/1] via 192.168.1.1, 00:00:02, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip ro *
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip ro *
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip ro *
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip arp *
                ^
% Invalid input detected at '^' marker.

R2#clear ar
R2#clear arp-ca
R2#clear arp-cache
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear arp-cache
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear arp-cache
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip arp *
                ^
% Invalid input detected at '^' marker.

R2#clear ip arp *
                ^
% Invalid input detected at '^' marker.

R2#clear ip ro *
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip ro *
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)
R2#clear ip ro *
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
UUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Success rate is 0 percent (0/100)

after clear all ip routes, fails ping. but I don't know why success routing before clear route…

Configuration with no auto-summary

  • R1-3
conf t
!
router rip
no auto-summary
exit
!
end

Verification without no auto-summary

Must be end-to-end ping between different major networks.

  • PC-1
PC-1> ping 172.16.2.254
172.16.2.254 icmp_seq=1 timeout
172.16.2.254 icmp_seq=2 timeout
84 bytes from 172.16.2.254 icmp_seq=3 ttl=61 time=4.045 ms
84 bytes from 172.16.2.254 icmp_seq=4 ttl=61 time=6.061 ms
84 bytes from 172.16.2.254 icmp_seq=5 ttl=61 time=3.963 ms
  • PC-2
PC-2> ping 172.16.2.3
172.16.2.3 icmp_seq=1 timeout
84 bytes from 172.16.2.3 icmp_seq=2 ttl=255 time=2.101 ms
84 bytes from 172.16.2.3 icmp_seq=3 ttl=255 time=1.942 ms
84 bytes from 172.16.2.3 icmp_seq=4 ttl=255 time=2.850 ms
84 bytes from 172.16.2.3 icmp_seq=5 ttl=255 time=2.035 ms
  • R1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.16.1.0/24 is directly connected, GigabitEthernet0/0
L        172.16.1.1/32 is directly connected, GigabitEthernet0/0
R        172.16.2.0/24 [120/2] via 192.168.1.2, 00:00:05, GigabitEthernet0/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1
R     192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:05, GigabitEthernet0/1
  • R2
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R        172.16.0.0/16 [120/1] via 192.168.2.3, 00:02:11, GigabitEthernet0/1
                       [120/1] via 192.168.1.1, 00:01:59, GigabitEthernet0/0
R        172.16.1.0/24 [120/1] via 192.168.1.1, 00:00:08, GigabitEthernet0/0
R        172.16.2.0/24 [120/1] via 192.168.2.3, 00:00:18, GigabitEthernet0/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R2#ping 172.16.1.1 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 2/3/6 ms
R2#ping 172.16.2.3 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.2.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/3/7 ms
  • R3
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R        172.16.1.0/24 [120/2] via 192.168.2.2, 00:00:09, GigabitEthernet0/0
C        172.16.2.0/24 is directly connected, GigabitEthernet0/1
L        172.16.2.3/32 is directly connected, GigabitEthernet0/1
R     192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:09, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.3/32 is directly connected, GigabitEthernet0/0

specific route exist in R1-R3. in this case R2 show specific no summarize route below:

R        172.16.1.0/24 [120/1] via 192.168.1.1, 00:00:08, GigabitEthernet0/0
R        172.16.2.0/24 [120/1] via 192.168.2.3, 00:00:18, GigabitEthernet0/1

Routing update control: passive-interface

Topology

Initial Config

  • R1
conf t
!
hostname R1
!
int gig0/0
ip addr 192.168.0.1 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.1.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
conf t
!
hostname R2
!
int gig0/0
ip addr 192.168.1.2 255.255.255.0
no shut
exit
int gig0/1
ip addr 172.16.1.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
conf t
!
hostname R3
!
int gig0/0
ip addr 172.16.1.3 255.255.255.0
no shut
exit
int gig0/1
ip addr 172.16.2.3 255.255.255.0
no shut
exit
!
end
wr
  • PC-1
ip 192.168.0.254 255.255.255.0 192.168.0.1
save
  • PC-2
ip 172.16.2.254 255.255.255.0 172.16.2.3
save

Configuration

  • R1
conf t
!
router rip
network 192.168.0.0
network 192.168.1.0
version 2
exit
!
end
  • R2
conf t
!
router rip
network 192.168.1.0
network 172.16.0.0
version 2
exit
!
end
  • R3
conf t
!
router rip
network 172.16.0.0
version 2
exit
!
end

Verification without passive-interface

  • PC-1-R1

  • R1-R2

  • R3-PC-2

  • PC-1
PC-1> ping 172.16.2.254
84 bytes from 172.16.2.254 icmp_seq=1 ttl=61 time=7.279 ms
84 bytes from 172.16.2.254 icmp_seq=2 ttl=61 time=4.042 ms
84 bytes from 172.16.2.254 icmp_seq=3 ttl=61 time=3.536 ms
84 bytes from 172.16.2.254 icmp_seq=4 ttl=61 time=7.543 ms
84 bytes from 172.16.2.254 icmp_seq=5 ttl=61 time=5.171 ms

Configuration: Passive Interface

  • R1
conf t
!
router rip
passive-interface gig0/0
exit
!
end
  • R3
conf t
!
router rip
passive-interface gig0/1
exit
!
end

Verification wit passive-interface

  • PC-1-R1

  • R1-R2

  • R3-PC-2

  • PC-1
PC-1> ping 172.16.2.254
84 bytes from 172.16.2.254 icmp_seq=1 ttl=61 time=5.696 ms
84 bytes from 172.16.2.254 icmp_seq=2 ttl=61 time=4.255 ms
84 bytes from 172.16.2.254 icmp_seq=3 ttl=61 time=6.066 ms
84 bytes from 172.16.2.254 icmp_seq=4 ttl=61 time=4.511 ms
84 bytes from 172.16.2.254 icmp_seq=5 ttl=61 time=6.357 ms

Above shows stopped sending routing update from R1, R3. still exchange RIP update R1-R2 link.

but routing successful normally.

Change Load balancing count

Topology

Initial Config

  • R1
conf t
!
hostname R1
!
int gig0/0
ip addr 192.168.0.1 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.13.1 255.255.255.0
no shut
exit
int gig0/2
ip addr 192.168.14.1 255.255.255.0
no shut
exit
int gig0/3
ip addr 192.168.15.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
conf t
!
hostname R2
!
int gig0/0
ip addr 192.168.1.2 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.32.2 255.255.255.0
no shut
exit
int gig0/2
ip addr 192.168.42.2 255.255.255.0
no shut
exit
int gig0/3
ip addr 192.168.52.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
conf t
!
hostname R3
!
int gig0/0
ip addr 192.168.32.3 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.13.3 255.255.255.0
no shut
exit
!
end
wr
  • R4
conf t
!
hostname R4
!
int gig0/0
ip addr 192.168.42.4 255.255.255.0
no shut
exit
int gig0/2
ip addr 192.168.14.4 255.255.255.0
no shut
exit
!
end
wr
  • R5
conf t
!
hostname R5
!
int gig0/0
ip addr 192.168.52.5 255.255.255.0
no shut
exit
int gig0/3
ip addr 192.168.15.5 255.255.255.0
no shut
exit
!
end
wr
  • PC-1
ip 192.168.0.254 255.255.255.0 192.168.0.1
save
  • PC-2
ip 192.168.1.254 255.255.255.0 192.168.1.2
save

Verify

  • R1
R1#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.0.1     YES manual up                    up
GigabitEthernet0/1         192.168.13.1    YES manual up                    up
GigabitEthernet0/2         192.168.14.1    YES manual up                    up
GigabitEthernet0/3         192.168.15.1    YES manual up                    up
R1#ping 192.168.13.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 3/4/5 ms
R1#ping 192.168.14.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.14.4, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/5/6 ms
R1#ping 192.168.15.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.15.5, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/4/5 ms
  • R2
R2#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.2     YES manual up                    up
GigabitEthernet0/1         192.168.32.2    YES manual up                    up
GigabitEthernet0/2         192.168.42.2    YES manual up                    up
GigabitEthernet0/3         192.168.52.2    YES manual up                    up
R2#ping 192.168.1.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 192.168.32.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.32.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 3/5/8 ms
R2#ping 192.168.42.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.42.4, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 2/3/6 ms
R2#ping 192.168.52.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.52.5, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 3/4/5 ms
  • R3
R3#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.32.3    YES manual up                    up
GigabitEthernet0/1         192.168.13.3    YES manual up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
  • R4
R4#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.42.4    YES manual up                    up
GigabitEthernet0/1         unassigned      YES manual up                    up
GigabitEthernet0/2         192.168.14.4    YES manual up                    up
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
  • R5
R5#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.52.5    YES manual up                    up
GigabitEthernet0/1         unassigned      YES manual up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         192.168.15.5    YES manual up                    up
  • PC-1
PC-1> ping 192.168.0.1
84 bytes from 192.168.0.1 icmp_seq=1 ttl=255 time=12.116 ms
84 bytes from 192.168.0.1 icmp_seq=2 ttl=255 time=2.790 ms
84 bytes from 192.168.0.1 icmp_seq=3 ttl=255 time=2.438 ms
84 bytes from 192.168.0.1 icmp_seq=4 ttl=255 time=2.585 ms
84 bytes from 192.168.0.1 icmp_seq=5 ttl=255 time=2.883 ms
  • PC-2
PC-2> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=255 time=4.063 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=255 time=2.026 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=255 time=2.116 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=255 time=2.276 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=255 time=2.897 ms

Configuration without maximum-paths

  • R1
conf t
!
router rip
network 192.168.0.0
network 192.168.13.0
network 192.168.14.0
network 192.168.15.0
version 2
exit
!
end
  • R2
conf t
!
router rip
network 192.168.1.0
network 192.168.32.0
network 192.168.42.0
network 192.168.52.0
version 2
exit
!
end
  • R3
conf t
!
router rip
network 192.168.13.0
network 192.168.32.0
version 2
exit
!
end
  • R4
conf t
!
router rip
network 192.168.14.0
network 192.168.42.0
version 2
exit
!
end
  • R5
conf t
!
router rip
network 192.168.15.0
network 192.168.52.0
version 2
exit
!
end

Verification without maximum-paths

  • PC1
PC-1> ping 192.168.1.254
84 bytes from 192.168.1.254 icmp_seq=1 ttl=61 time=22.852 ms
84 bytes from 192.168.1.254 icmp_seq=2 ttl=61 time=4.065 ms
84 bytes from 192.168.1.254 icmp_seq=3 ttl=61 time=9.231 ms
84 bytes from 192.168.1.254 icmp_seq=4 ttl=61 time=3.288 ms
84 bytes from 192.168.1.254 icmp_seq=5 ttl=61 time=10.388 ms
  • PC2
PC-2> ping 192.168.0.254
84 bytes from 192.168.0.254 icmp_seq=1 ttl=61 time=5.167 ms
84 bytes from 192.168.0.254 icmp_seq=2 ttl=61 time=5.075 ms
84 bytes from 192.168.0.254 icmp_seq=3 ttl=61 time=7.719 ms
84 bytes from 192.168.0.254 icmp_seq=4 ttl=61 time=5.554 ms
84 bytes from 192.168.0.254 icmp_seq=5 ttl=61 time=7.630 ms
  • R1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
R     192.168.1.0/24 [120/2] via 192.168.15.5, 00:00:06, GigabitEthernet0/3
                     [120/2] via 192.168.14.4, 00:00:13, GigabitEthernet0/2
                     [120/2] via 192.168.13.3, 00:00:17, GigabitEthernet0/1
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, GigabitEthernet0/1
L        192.168.13.1/32 is directly connected, GigabitEthernet0/1
      192.168.14.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.14.0/24 is directly connected, GigabitEthernet0/2
L        192.168.14.1/32 is directly connected, GigabitEthernet0/2
      192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.15.0/24 is directly connected, GigabitEthernet0/3
L        192.168.15.1/32 is directly connected, GigabitEthernet0/3
R     192.168.32.0/24 [120/1] via 192.168.13.3, 00:00:17, GigabitEthernet0/1
R     192.168.42.0/24 [120/1] via 192.168.14.4, 00:00:13, GigabitEthernet0/2
R     192.168.52.0/24 [120/1] via 192.168.15.5, 00:00:06, GigabitEthernet0/3
R1#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.1.0/24 [120/2] via 192.168.15.5, 00:00:10, GigabitEthernet0/3
                     [120/2] via 192.168.14.4, 00:00:17, GigabitEthernet0/2
                     [120/2] via 192.168.13.3, 00:00:19, GigabitEthernet0/1
R     192.168.32.0/24 [120/1] via 192.168.13.3, 00:00:19, GigabitEthernet0/1
R     192.168.42.0/24 [120/1] via 192.168.14.4, 00:00:17, GigabitEthernet0/2
R     192.168.52.0/24 [120/1] via 192.168.15.5, 00:00:10, GigabitEthernet0/3
  • R2
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/2] via 192.168.52.5, 00:00:13, GigabitEthernet0/3
                     [120/2] via 192.168.42.4, 00:00:15, GigabitEthernet0/2
                     [120/2] via 192.168.32.3, 00:00:19, GigabitEthernet0/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.32.3, 00:00:19, GigabitEthernet0/1
R     192.168.14.0/24 [120/1] via 192.168.42.4, 00:00:15, GigabitEthernet0/2
R     192.168.15.0/24 [120/1] via 192.168.52.5, 00:00:13, GigabitEthernet0/3
      192.168.32.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.32.0/24 is directly connected, GigabitEthernet0/1
L        192.168.32.2/32 is directly connected, GigabitEthernet0/1
      192.168.42.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.42.0/24 is directly connected, GigabitEthernet0/2
L        192.168.42.2/32 is directly connected, GigabitEthernet0/2
      192.168.52.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.52.0/24 is directly connected, GigabitEthernet0/3
L        192.168.52.2/32 is directly connected, GigabitEthernet0/3
R2#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/2] via 192.168.52.5, 00:00:23, GigabitEthernet0/3
                     [120/2] via 192.168.42.4, 00:00:27, GigabitEthernet0/2
                     [120/2] via 192.168.32.3, 00:00:17, GigabitEthernet0/1
R     192.168.13.0/24 [120/1] via 192.168.32.3, 00:00:17, GigabitEthernet0/1
R     192.168.14.0/24 [120/1] via 192.168.42.4, 00:00:27, GigabitEthernet0/2
R     192.168.15.0/24 [120/1] via 192.168.52.5, 00:00:23, GigabitEthernet0/3
  • R3
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.13.1, 00:00:29, GigabitEthernet0/1
R     192.168.1.0/24 [120/1] via 192.168.32.2, 00:00:28, GigabitEthernet0/0
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, GigabitEthernet0/1
L        192.168.13.3/32 is directly connected, GigabitEthernet0/1
R     192.168.14.0/24 [120/1] via 192.168.13.1, 00:00:29, GigabitEthernet0/1
R     192.168.15.0/24 [120/1] via 192.168.13.1, 00:00:29, GigabitEthernet0/1
      192.168.32.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.32.0/24 is directly connected, GigabitEthernet0/0
L        192.168.32.3/32 is directly connected, GigabitEthernet0/0
R     192.168.42.0/24 [120/1] via 192.168.32.2, 00:00:28, GigabitEthernet0/0
R     192.168.52.0/24 [120/1] via 192.168.32.2, 00:00:28, GigabitEthernet0/0
R3#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.13.1, 00:00:19, GigabitEthernet0/1
R     192.168.1.0/24 [120/1] via 192.168.32.2, 00:00:11, GigabitEthernet0/0
R     192.168.14.0/24 [120/1] via 192.168.13.1, 00:00:19, GigabitEthernet0/1
R     192.168.15.0/24 [120/1] via 192.168.13.1, 00:00:19, GigabitEthernet0/1
R     192.168.42.0/24 [120/1] via 192.168.32.2, 00:00:11, GigabitEthernet0/0
R     192.168.52.0/24 [120/1] via 192.168.32.2, 00:00:11, GigabitEthernet0/0
  • R4
R4#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.14.1, 00:00:05, GigabitEthernet0/2
R     192.168.1.0/24 [120/1] via 192.168.42.2, 00:00:04, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.14.1, 00:00:05, GigabitEthernet0/2
      192.168.14.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.14.0/24 is directly connected, GigabitEthernet0/2
L        192.168.14.4/32 is directly connected, GigabitEthernet0/2
R     192.168.15.0/24 [120/1] via 192.168.14.1, 00:00:05, GigabitEthernet0/2
R     192.168.32.0/24 [120/1] via 192.168.42.2, 00:00:04, GigabitEthernet0/0
      192.168.42.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.42.0/24 is directly connected, GigabitEthernet0/0
L        192.168.42.4/32 is directly connected, GigabitEthernet0/0
R     192.168.52.0/24 [120/1] via 192.168.42.2, 00:00:04, GigabitEthernet0/0
R4#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.14.1, 00:00:13, GigabitEthernet0/2
R     192.168.1.0/24 [120/1] via 192.168.42.2, 00:00:26, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.14.1, 00:00:13, GigabitEthernet0/2
R     192.168.15.0/24 [120/1] via 192.168.14.1, 00:00:13, GigabitEthernet0/2
R     192.168.32.0/24 [120/1] via 192.168.42.2, 00:00:26, GigabitEthernet0/0
R     192.168.52.0/24 [120/1] via 192.168.42.2, 00:00:26, GigabitEthernet0/0
  • R5
R5#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.15.1, 00:00:06, GigabitEthernet0/3
R     192.168.1.0/24 [120/1] via 192.168.52.2, 00:00:05, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.15.1, 00:00:06, GigabitEthernet0/3
R     192.168.14.0/24 [120/1] via 192.168.15.1, 00:00:06, GigabitEthernet0/3
      192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.15.0/24 is directly connected, GigabitEthernet0/3
L        192.168.15.5/32 is directly connected, GigabitEthernet0/3
R     192.168.32.0/24 [120/1] via 192.168.52.2, 00:00:05, GigabitEthernet0/0
R     192.168.42.0/24 [120/1] via 192.168.52.2, 00:00:05, GigabitEthernet0/0
      192.168.52.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.52.0/24 is directly connected, GigabitEthernet0/0
L        192.168.52.5/32 is directly connected, GigabitEthernet0/0
R5#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.15.1, 00:00:13, GigabitEthernet0/3
R     192.168.1.0/24 [120/1] via 192.168.52.2, 00:00:14, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.15.1, 00:00:13, GigabitEthernet0/3
R     192.168.14.0/24 [120/1] via 192.168.15.1, 00:00:13, GigabitEthernet0/3
R     192.168.32.0/24 [120/1] via 192.168.52.2, 00:00:14, GigabitEthernet0/0
R     192.168.42.0/24 [120/1] via 192.168.52.2, 00:00:14, GigabitEthernet0/0

display filter

rip or icmp
PC-1> ping 192.168.1.254 -t
PC-3> ping 192.168.1.254 -t
PC-5> ping 192.168.0.254 -t
PC-7> ping 192.168.0.254 -t
PC-8> ping 192.168.0.254 -t

view capture

balanced.

Configuration maximum-paths

  • R1
conf t
!
router rip
maximum-paths 2
exit
!
end
  • R2
conf t
!
router rip
maximum-paths 2
exit
!
end

Verification maximum-paths

  • R1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
R     192.168.1.0/24 [120/2] via 192.168.15.5, 00:00:08, GigabitEthernet0/3
                     [120/2] via 192.168.14.4, 00:00:15, GigabitEthernet0/2
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, GigabitEthernet0/1
L        192.168.13.1/32 is directly connected, GigabitEthernet0/1
      192.168.14.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.14.0/24 is directly connected, GigabitEthernet0/2
L        192.168.14.1/32 is directly connected, GigabitEthernet0/2
      192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.15.0/24 is directly connected, GigabitEthernet0/3
L        192.168.15.1/32 is directly connected, GigabitEthernet0/3
R     192.168.32.0/24 [120/1] via 192.168.13.3, 00:00:25, GigabitEthernet0/1
R     192.168.42.0/24 [120/1] via 192.168.14.4, 00:00:15, GigabitEthernet0/2
R     192.168.52.0/24 [120/1] via 192.168.15.5, 00:00:08, GigabitEthernet0/3
R1#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.1.0/24 [120/2] via 192.168.15.5, 00:00:05, GigabitEthernet0/3
                     [120/2] via 192.168.14.4, 00:00:10, GigabitEthernet0/2
R     192.168.32.0/24 [120/1] via 192.168.13.3, 00:00:28, GigabitEthernet0/1
R     192.168.42.0/24 [120/1] via 192.168.14.4, 00:00:10, GigabitEthernet0/2
R     192.168.52.0/24 [120/1] via 192.168.15.5, 00:00:05, GigabitEthernet0/3
  • R2
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/2] via 192.168.42.4, 00:00:01, GigabitEthernet0/2
                     [120/2] via 192.168.32.3, 00:00:13, GigabitEthernet0/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.32.3, 00:00:13, GigabitEthernet0/1
R     192.168.14.0/24 [120/1] via 192.168.42.4, 00:00:01, GigabitEthernet0/2
R     192.168.15.0/24 [120/1] via 192.168.52.5, 00:00:28, GigabitEthernet0/3
      192.168.32.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.32.0/24 is directly connected, GigabitEthernet0/1
L        192.168.32.2/32 is directly connected, GigabitEthernet0/1
      192.168.42.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.42.0/24 is directly connected, GigabitEthernet0/2
L        192.168.42.2/32 is directly connected, GigabitEthernet0/2
      192.168.52.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.52.0/24 is directly connected, GigabitEthernet0/3
L        192.168.52.2/32 is directly connected, GigabitEthernet0/3
R2#sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/2] via 192.168.42.4, 00:00:21, GigabitEthernet0/2
                     [120/2] via 192.168.32.3, 00:00:17, GigabitEthernet0/1
R     192.168.13.0/24 [120/1] via 192.168.32.3, 00:00:17, GigabitEthernet0/1
R     192.168.14.0/24 [120/1] via 192.168.42.4, 00:00:21, GigabitEthernet0/2
R     192.168.15.0/24 [120/1] via 192.168.52.5, 00:00:25, GigabitEthernet0/3

routing table reduced to 2 path.

change filter

DisplayFilters - The Wireshark Wiki

ip.src == 192.168.0.0/24

reduced 2 paths in Wireshark capture

Connect GNS3 to the Internet

In this case I assume GNS3 2.1.4.

Choose cloud. No appliance necessary.

connect to eth1.

*May 14 23:01:59.647: %DHCP-6-ADDRESS_ASSIGN: Interface GigabitEthernet0/1 assigned DHCP address 192.168.200.139, mask 255.255.255.0, hostname R3

this seems to be used NAT Internet access.

Default route advertisement

Topology

Initial Config

  • R1
conf t
!
hostname R1
!
int gig0/0
ip addr 192.168.0.1 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.1.1 255.255.255.0
no shut
exit
!
end
wr
  • R2
conf t
!
hostname R2
!
int gig0/0
ip addr 192.168.1.2 255.255.255.0
no shut
exit
int gig0/1
ip addr 192.168.2.2 255.255.255.0
no shut
exit
!
end
wr
  • R3
conf t
!
hostname R3
!
int gig0/0
ip addr 192.168.2.3 255.255.255.0
no shut
exit
int gig0/1
ip addr dhcp
no shut
exit
!
end
wr
  • PC-1
ip 192.168.0.254 255.255.255.0 192.168.0.1
save

Configuration without default-information originate

  • R1
conf t
!
router rip
network 192.168.0.0
network 192.168.1.0
version 2
exit
!
end
  • R2
conf t
!
router rip
network 192.168.1.0
network 192.168.2.0
version 2
exit
!
end
  • R3
conf t
!
router rip
network 192.168.2.0
version 2
exit
!
end

Verification without default-information originate

  • R1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1
R     192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:01, GigabitEthernet0/1
  • R2
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.0.0/24 [120/1] via 192.168.1.1, 00:00:02, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
  • R3
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.200.2 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 192.168.200.2
R     192.168.0.0/24 [120/2] via 192.168.2.2, 00:00:27, GigabitEthernet0/0
R     192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:27, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.3/32 is directly connected, GigabitEthernet0/0
      192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.200.0/24 is directly connected, GigabitEthernet0/1
L        192.168.200.139/32 is directly connected, GigabitEthernet0/1
  • ping from PC-1 to R3
PC-1> ping 192.168.2.3
84 bytes from 192.168.2.3 icmp_seq=1 ttl=253 time=5.475 ms
84 bytes from 192.168.2.3 icmp_seq=2 ttl=253 time=5.733 ms
84 bytes from 192.168.2.3 icmp_seq=3 ttl=253 time=5.365 ms
84 bytes from 192.168.2.3 icmp_seq=4 ttl=253 time=6.568 ms
84 bytes from 192.168.2.3 icmp_seq=5 ttl=253 time=5.520 ms
  • ping from PC-1 to World
PC-1> ping 8.8.8.8
*192.168.0.1 icmp_seq=1 ttl=255 time=2.919 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=2 ttl=255 time=2.384 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=3 ttl=255 time=2.520 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=4 ttl=255 time=3.473 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.0.1 icmp_seq=5 ttl=255 time=4.768 ms (ICMP type:3, code:1, Destination host unreachable)

Configuration default-information originate

Now, time to configure default route advertisement.

  • R3
conf t
!
router rip
default-information originate
passive-interface gig0/1
exit
!
end

Verification default-information originate

  • R1
R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

R*    0.0.0.0/0 [120/2] via 192.168.1.2, 00:00:03, GigabitEthernet0/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet0/0
L        192.168.0.1/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1
R     192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:03, GigabitEthernet0/1
R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
  • R2
R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.2.3 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 192.168.2.3, 00:00:19, GigabitEthernet0/1
R     192.168.0.0/24 [120/1] via 192.168.1.1, 00:00:09, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1
L        192.168.2.2/32 is directly connected, GigabitEthernet0/1
R1#ping 8.8.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 14/15/17 ms
  • R3
R3#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.200.2 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 192.168.200.2
R     192.168.0.0/24 [120/2] via 192.168.2.2, 00:00:07, GigabitEthernet0/0
R     192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:07, GigabitEthernet0/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.3/32 is directly connected, GigabitEthernet0/0
      192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.200.0/24 is directly connected, GigabitEthernet0/1
L        192.168.200.139/32 is directly connected, GigabitEthernet0/1
  • ping from PC-1 to World
PC-1> ping 8.8.8.8
84 bytes from 8.8.8.8 icmp_seq=1 ttl=125 time=18.759 ms
84 bytes from 8.8.8.8 icmp_seq=2 ttl=125 time=13.421 ms
84 bytes from 8.8.8.8 icmp_seq=3 ttl=125 time=13.838 ms
84 bytes from 8.8.8.8 icmp_seq=4 ttl=125 time=16.313 ms
84 bytes from 8.8.8.8 icmp_seq=5 ttl=125 time=13.905 ms

You know, gateway of last resort is set, and RIP advertised default route in routing table.
Of course, ping to world successful.

References

tech/network/cisco/advanced-rip-config/advanced-rip-config.txt · Last modified: 2018/05/15 08:31 by wnoguchi