PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco:advanced-rip-config-2:advanced-rip-config-2

Advanced Configuration 2

R1#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.0.1     YES NVRAM  up                    up
GigabitEthernet0/1         192.168.1.1     YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
R1#
R1#
R1#
R1#
R1#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.0.1     YES NVRAM  up                    up
GigabitEthernet0/1         192.168.1.1     YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#acc
R1(config)#access-list 1 per
R1(config)#access-list 1 permit 172.16.1.0 0.0.0.255
R1(config)#route
R1(config)#router
R1(config)#router ri
R1(config)#router rip
R1(config-router)#off
R1(config-router)#offset-list 1 o
R1(config-router)#offset-list 1 out 3 gig0/1
R1(config-router)#offset-list 1 in 3 gig0/1
R1(config-router)#no offset-list 1 out 3 gig0/1
R1(config-router)#do sh ip ro rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R1(config-router)#exit
R1(config)#int gig0/0
R1(config-if)#ip su
R1(config-if)#ip summary-address ri
R1(config-if)#ip summary-address rip 172.0.0.0 255.0.0.0
 Summary mask must be greater or equal to major net
R1(config-if)#ip summary-address rip 172.16.0.0 255.255.0.0
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#tim
R1(config-router)#timers basi
R1(config-router)#timers basic ?
  <1-2147483>  Interval between updates for RIP

R1(config-router)#timers basic 30 30 30 30
R1(config-router)#exit
R1(config)#int gig0/1
R1(config-if)#p rip trigg
% Ambiguous command:  "p rip trigg"
R1(config-if)#p rip trigge
% Ambiguous command:  "p rip trigge"
R1(config-if)#p rip trigger
% Ambiguous command:  "p rip trigger"
R1(config-if)#p rip triggered
                ^
% Invalid input detected at '^' marker.

R1(config-if)#ip rip triggered
                     ^
% Invalid input detected at '^' marker.

R1(config-if)#ip rip
R1(config-if)#ip rip
R1(config-if)#ip rip ?
  advertise       Specify update interval
  authentication  Authentication control
  initial-delay   Specify initial delay interval
  receive         advertisement reception
  send            advertisement transmission
  v2-broadcast    send ip broadcast v2 update

R1(config-if)#exit
R1(config)#router rip
R1(config-router)#ip rip tri
R1(config-router)#ip rip trig
R1(config-router)#ip rip trig
R1(config-router)#ip rip trig
R1(config-router)#ip rip trig
R1(config-router)#ip rip trig
R1(config-router)#ip rip trig
R1(config-router)#ip rip ?
% Unrecognized command
R1(config-router)#exit
R1(config)#router rip
R1(config-router)#no valida
R1(config-router)#no validate-update-source
R1(config-router)#exit
R1(config)#router rip
R1(config-router)#ou
R1(config-router)#output-delay 50
R1(config-router)#exit
R1(config)#router rip
R1(config-router)#neigh
R1(config-router)#neighbo
R1(config-router)#neighbor 192.168.1.2
R1(config-router)#passsi
R1(config-router)#passiv
R1(config-router)#passive-interface gig0/1
R1(config-router)#exit
R1(config)#key chain
R1(config)#key chain RIPKEY
R1(config-keychain)#key ?
  <0-2147483647>  Key identifier

R1(config-keychain)#key 123
R1(config-keychain-key)#key-st
R1(config-keychain-key)#key-string rip-secure
R1(config-keychain-key)#exit
R1(config-keychain)#int gig0/1
R1(config-if)#ip rip auth
R1(config-if)#ip rip authentication mode md5
R1(config-if)#ip rip
R1(config-if)#ip rip auth
R1(config-if)#ip rip authentication ke
R1(config-if)#ip rip authentication key-chain RIPKEY
R1(config-if)#exit
R1(config)#access-list 101 permi
R1(config)#access-list 101 permit ud
R1(config)#access-list 101 permit udp hos
R1(config)#access-list 101 permit udp host 192.168.1.2 an
R1(config)#access-list 101 permit udp host 192.168.1.2 any eq
R1(config)#access-list 101 permit udp host 192.168.1.2 any eq rip
R1(config)#acc
R1(config)#access-list 101 deny udp any any eq ri
R1(config)#access-list 101 deny udp any any eq rip
R1(config)#acc
R1(config)#access-list 101 permit ip any any
R1(config)#int gig0/1
R1(config-if)#ip acc
R1(config-if)#ip acce
R1(config-if)#ip access-group 101 in
R1(config-if)#exit

References

tech/network/cisco/advanced-rip-config-2/advanced-rip-config-2.txt · Last modified: 2018/05/15 09:13 by wnoguchi