PG1X WIKI

My Knowledge Base

User Tools

Site Tools


tech:network:cisco-equipment-convenient-startup-config:cisco-equipment-convenient-startup-config

Cisco Equipment Convenient startup-config

Initial Configuration

Router

enable
configure terminal
!
no service config
no ip domain-lookup
!
line console 0
 no login
 exec-timeout 0 0
 logging synchronous
 privilege level 15
exit
line vty 0 15
 no login
 privilege level 15
exit
!
hostname R1
!
interface FastEthernet 0/1
 ip addr 172.17.1.5 255.255.255.0
 no shutdown
exit
!
ip route 0.0.0.0 0.0.0.0 172.17.1.254
!
ntp source FastEthernet 0/0
ntp server 10.0.128.254
ntp update-calendar
!
end
copy running-config startup-config

Catalyst Switch

en
conf t
no service config
no setup express
no ip domain-lookup
!
line console 0
exec-timeout 0 0
logging synchronous
exit
hostname SW4
int vlan 1
ip addr 172.17.1.5 255.255.255.0
no shut
exit
ip default-gateway 172.16.1.1
enable secret password
line vty 0 15
exec-timeout 0 0
password password
login
exit
ntp source f0/0
ntp server 10.0.128.254
end
write

Internet!!!!

en
conf t
!
no service config
no ip domain-lookup
!
line console 0
exec-timeout 0 0
logging synchronous
exit
!
hostname R1
!
int fa0/0
ip addr 172.16.2.1 255.255.255.0
ip nat inside
no shut
exit
int fa0/1
ip addr dhcp
ip nat outside
no shut
exit
!
line vty 0 15
exec-timeout 0 0
exit
!
access-list 1 permit 172.16.2.0 0.0.0.255
!
ip nat inside source list 1 interface f0/1 overload
!
end
write

Clear Setting

Router

enable
erase startup-config
reload

Catalyst Switch

enable
erase startup-config
delete flash:vlan.dat
reload

References

tech/network/cisco-equipment-convenient-startup-config/cisco-equipment-convenient-startup-config.txt · Last modified: 2020/04/20 11:40 by wnoguchi